<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"def25c5cff","applicationID":"282811705,282811706","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":904,"agent":""}</script>
<script>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</script>
<script src='https://cdn.rivals.com/production/assets/window_name-426a8929f8d33048988258b1fc9ba7fa371d790b3661496339ffb6f2b1141c3f.js'></script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='stage.guce.rivals.com' name='oath:guce:consent-host'>
<meta content='true' name='oath:guce:report-only'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-81764304-1', 'auto');
</script>

<script>
dataLayer = [];
</script>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PHNjcmlwdD4KICAoZnVuY3Rpb24odyxkLHMsbCxpKXsKICAgICAgICBpZiAo
d2luZG93Ll9kaWRBc3luY0luamVjdEdvb2dsZVRhZ01hbmFnZXIpIHJldHVy
bjsKICAgICAgICB3W2xdPXdbbF18fFtdO3dbbF0ucHVzaCh7J2d0bS5zdGFy
dCc6CiAgICAgICAgbmV3IERhdGUoKS5nZXRUaW1lKCksZXZlbnQ6J2d0bS5q
cyd9KTt2YXIgZj1kLmdldEVsZW1lbnRzQnlUYWdOYW1lKHMpWzBdLAogICAg
ICAgIGo9ZC5jcmVhdGVFbGVtZW50KHMpLGRsPWwhPSdkYXRhTGF5ZXInPycm
bD0nK2w6Jyc7ai5hc3luYz10cnVlO2ouc3JjPQogICAgICAgICdodHRwczov
L3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNvbS9ndG0uanM/aWQ9JytpK2RsKycm
Z3RtX2F1dGg9JysnS2hINmhlQ3BvV0pVSG5xVnpkRWE3dycrCiAgICAgICAg
JyZndG1fcHJldmlldz0nKydlbnYtMScrJyZndG1fY29va2llc193aW49eCc7
Zi5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLGYpOwogICAgICAgIHdpbmRv
dy5fZGlkQXN5bmNJbmplY3RHb29nbGVUYWdNYW5hZ2VyID0gdHJ1ZTsKICAg
ICAgfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCdkYXRhTGF5ZXInLCdH
VE0tTUY2UFhYQycpOwo8L3NjcmlwdD4KPG5vc2NyaXB0Pgo8aWZyYW1lIGhl
aWdodD0nMCcgc3JjPSdodHRwczovL3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNv
bS9ucy5odG1sP2lkPUdUTS1NRjZQWFhDJmFtcDtndG1fYXV0aD1LaEg2aGVD
cG9XSlVIbnFWemRFYTd3JmFtcDtndG1fcHJldmlldz1lbnYtMSZhbXA7Z3Rt
X2Nvb2tpZXNfd2luPXgnIHN0eWxlPSdkaXNwbGF5Om5vbmU7dmlzaWJpbGl0
eTpoaWRkZW4nIHdpZHRoPScwJz48L2lmcmFtZT4KPC9ub3NjcmlwdD4KCgo=

</div>
</div>
<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-17665c085dfaf620c961e1c0ddea354a20565cd5002add288461398e9f21d1eb.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansCondFonts-74c0340099b3ec93e18951b2b059a74493c5db2e72ef7acd1cf1c42a6e4a523d.css' rel='stylesheet'>
<title>ArizonaVarsity  -  Gridiron Arizona&#39;s 2022 Recruiting Update: 10/6</title>
<meta content='ArizonaVarsity  -  Gridiron Arizona&#39;s 2022 Recruiting Update: 10/6' property='og:title'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2022 class' name='description'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-3e35aed6375aafe36358d97418c7b1a761e93998da858c6d39683883c8789ba8.css" />


<script src="https://cdn.rivals.com/production/assets/lib-6c022b93a90b8980b59dc8365df99c024fc31b928721a316b58736a1fa13e26e.js"></script>
<script src='/javascript/config.js'></script>
<script src="https://cdn.rivals.com/production/assets/application-ddd0c0835158676b613d1b156c9c688ba94bb5423133886d378d905ffc51da5e.js"></script>

<script src='/javascript/url_factory.js'></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="hPNFukUfKLcrdSZtXl4CKGZFSzvBj8GW3Mwgea1zrhv+T0JGTgejctNDlLgHyeVNrxtFI5snA3xsMxD6zGhnCA==" />
<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-fdff72b91f19d75cf51d8bdb22cf7f1c7435213329db92847ab8cd17911cc566.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-171b5725637bfa4769cee9b7c9352a74b2ba24d525be5b720e267e8adf48012c.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2022-recruiting-update-10-6' property='og:url'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/hmfhv6t3vx76rwd3zd3r' property='og:image'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2022 class' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2021-10-07 00:42:54 -0500' property='article:published_time'>
<meta content='2021-10-07 00:59:30 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-79d2adbade85e1e68905ea1a26278770384c72769e302a0dae0424b3991cb8c0.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-fad0448de054b018c1fb496c82e4d147e36e025324f6097d939a6223773c6408.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-d83a481672df92fa565a3c3e4490fe8538a8cca8f2f6c8bc04b4e003da9c1f95.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-dde27fd6889cda35c548e8f311394eb5ad38fd060061150fb984469c56db0a8d.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-1b293697db4809dca023fcaee39f7266c5278095067b8f6c8edb1bcc1cf9029a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-160b06011cecdf794bd4037752e257bf4272d38e105b58b8b63ff4e510d25a7a.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-b53ef0fb1afaa6ee435ba26728402dd43f9f2853b6a2932fa7d9fb70fc5e35ce.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-95c2973fbaef93d4c790667ba039b95898451bb04f5b2b399071e6483347812d.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-a223232b426f12e2f04f4a3aecf49f46b9e0a79cd886e7a210e0cdf5ad5bd024.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-a217ac85d423e19cbde56dcf9b01630789a023d0509d6fa0880bd5da15cc22d1.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-894aa91cf9d624f18d121145468a0bb30395f01d70de0dbf67742b95de46cfd2.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-b0f9dfc4ee4c3780ac01665cf518b0b20ec78f58b81349f7cbcf715820137ac3.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-8ab5e15036ae6a8e5c073b018e034b9e1d8b57c0445d930c005e3bbd54bdf23e.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-c5cfe3c55f53109b71f4a7ed03d0ff07134dc883a367e64241c5c595468da9bb.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-4bf9998442db4c04360a1612c42ca4e1aeff88b16510ab66fc9275af3e694668.json' rel='manifest'>
<rv-chartbeat-config-header ng-hide subdomain='arizonavarsity.rivals.com'></rv-chartbeat-config-header>

</head>
<body class='arizonavarsity contents-show' ng-app='rivals'>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PHNjcmlwdD4KICAoZnVuY3Rpb24odyxkLHMsbCxpKXsKICAgICAgICBpZiAo
d2luZG93Ll9kaWRBc3luY0luamVjdEdvb2dsZVRhZ01hbmFnZXIpIHJldHVy
bjsKICAgICAgICB3W2xdPXdbbF18fFtdO3dbbF0ucHVzaCh7J2d0bS5zdGFy
dCc6CiAgICAgICAgbmV3IERhdGUoKS5nZXRUaW1lKCksZXZlbnQ6J2d0bS5q
cyd9KTt2YXIgZj1kLmdldEVsZW1lbnRzQnlUYWdOYW1lKHMpWzBdLAogICAg
ICAgIGo9ZC5jcmVhdGVFbGVtZW50KHMpLGRsPWwhPSdkYXRhTGF5ZXInPycm
bD0nK2w6Jyc7ai5hc3luYz10cnVlO2ouc3JjPQogICAgICAgICdodHRwczov
L3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNvbS9ndG0uanM/aWQ9JytpK2RsKycm
Z3RtX2F1dGg9JysnS2hINmhlQ3BvV0pVSG5xVnpkRWE3dycrCiAgICAgICAg
JyZndG1fcHJldmlldz0nKydlbnYtMScrJyZndG1fY29va2llc193aW49eCc7
Zi5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLGYpOwogICAgICAgIHdpbmRv
dy5fZGlkQXN5bmNJbmplY3RHb29nbGVUYWdNYW5hZ2VyID0gdHJ1ZTsKICAg
ICAgfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCdkYXRhTGF5ZXInLCdH
VE0tTUY2UFhYQycpOwo8L3NjcmlwdD4KPG5vc2NyaXB0Pgo8aWZyYW1lIGhl
aWdodD0nMCcgc3JjPSdodHRwczovL3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNv
bS9ucy5odG1sP2lkPUdUTS1NRjZQWFhDJmFtcDtndG1fYXV0aD1LaEg2aGVD
cG9XSlVIbnFWemRFYTd3JmFtcDtndG1fcHJldmlldz1lbnYtMSZhbXA7Z3Rt
X2Nvb2tpZXNfd2luPXgnIHN0eWxlPSdkaXNwbGF5Om5vbmU7dmlzaWJpbGl0
eTpoaWRkZW4nIHdpZHRoPScwJz48L2lmcmFtZT4KPC9ub3NjcmlwdD4KCgo=

</div>
</div>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-81764304-1', 'auto');
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .arizonavarsity #programming > h1 {
      background-color: #000000 !important; } }
  
  .arizonavarsity .wrapper-container .team-colors-line {
    background-color: #b87333; }
  
  @media screen and (min-width: 768px) {
    .arizonavarsity .solid-team-line {
      width: 100%;
      height: 8px;
      display: flex;
      background-color: #b87333; } }
  
  .arizonavarsity .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #000000; }
    .arizonavarsity .team-colors-line .color {
      width: 33.33%; }
    .arizonavarsity .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .arizonavarsity .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .arizonavarsity .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .arizonavarsity .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .arizonavarsity .team-colors-line.header {
      height: 6px; }
  
  .arizonavarsity > header .notification-link .count-container {
    background-color: #000000 !important; }
  
  .arizonavarsity > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
  
  .arizonavarsity > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .arizonavarsity > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .arizonavarsity > header .invalid-email-banner a:hover {
      color: #b87333; }
  
  @media screen and (max-width: 767px) {
    .arizonavarsity > header .mobile-header {
      background-color: #b87333 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  
  .arizonavarsity > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  
  .arizonavarsity > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  
  .arizonavarsity > header .second-nav {
    background-color: white !important; }
  
  @media screen and (max-width: 1023px) {
    .arizonavarsity > header .nav-row > ul,
    .arizonavarsity > header .third-nav {
      background-color: white !important; }
    .arizonavarsity > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  
  .arizonavarsity > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #b87333; }
  
  .site-secondary-background-color {
    background-color: #b87333; }
  
  :root {
    --primary-color: #000000;
    --primary-color-overlay: rgba(0, 0, 0, .4);
    --secondary-color: #b87333;
    --accent-color: #000000;
    --button-color: #000000;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init("arizonavarsity")' role='navigation'>
<div class='wrapper-container'>
<a class='cta-header-banner' ng_href='{{ctrl.subscribePath}}' style='display: none;'>
Enjoying ArizonaVarsity? Get a yearly subscription for $99.95/year or $9.95/month
</a>
<div class='wrapper logo-row'>
<a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-black'></div>
</a><a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
<a alt="Arizona HS Sports" class="site-header logo-image-wrapper" href="https://arizonavarsity.rivals.com/"><img src="https://images.rivals.com/image/upload/f_auto,q_auto/jfx2ba0nx7j1blby9bv1" />
</a><div class='nav-right-controls'>
<div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
<span class='upsell-text'>
Join the team!
</span>
<div class='subscribe-button' ng-click='ctrl.subscribeEvent()'>
Subscribe
</div>
</div>
<rv-universal-search></rv-universal-search>
<rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
<rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
</div>
</div>
<div class='solid-team-line header'></div>
</div>
<div class='mobile-header'></div>
<rv-header-alert class='alert-nav'></rv-header-alert>
<hr>
<div class='nav-row-container'>
<div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="8"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="4"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
<a ng-href='{{ctrl.userProfileEditPath}}'>
Your account has an invalid email address. Please update it here.
</a>
</div>
</div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid3.js"></script>
<script src='/javascript/ad_beacon.js?path=content&space_id=2022719646' type='text/javascript'></script>

<rv-content-title content-title='Gridiron Arizona&#39;s 2022 Recruiting Update: 10/6' ng-hide='true'></rv-content-title>
<meta content='summary_large_image' name='twitter:card'>
<meta content='ArizonaVarsity' name='twitter:site'>
<meta content='Gridiron Arizona&#39;s 2022 Recruiting Update: 10/6' name='twitter:title'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2022 class' name='twitter:description'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_large/hmfhv6t3vx76rwd3zd3r' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {&quot;id&quot;:6,&quot;legacy_id&quot;:1128,&quot;name&quot;:&quot;ArizonaVarsity&quot;,&quot;friendly_name&quot;:&quot;Arizona HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;arizonavarsity&quot;,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;arizonavarsity&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;}, true, 161, nil, {&quot;id&quot;:92,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;commitment_module_football&quot;:true,&quot;rivals_module_football&quot;:true,&quot;header_name&quot;:&quot;ArizonaVarsity.com&quot;,&quot;header_logo_cloudinary&quot;:&quot;jfx2ba0nx7j1blby9bv1&quot;,&quot;mobile_header_logo_cloudinary&quot;:&quot;lt4xm3i1vhxzczdsev3e&quot;,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;,&quot;logo_background_shading&quot;:&quot;black&quot;,&quot;football_content&quot;:true,&quot;basketball_content&quot;:true,&quot;baseball_content&quot;:true,&quot;other_content&quot;:true,&quot;site_id&quot;:6,&quot;created_at&quot;:&quot;2016-11-23T13:38:43.400-06:00&quot;,&quot;updated_at&quot;:&quot;2021-08-27T11:07:08.773-05:00&quot;,&quot;max_trending_articles&quot;:6,&quot;enrichments&quot;:[{&quot;active&quot;:true,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:1},{&quot;active&quot;:false,&quot;type&quot;:&quot;TeamRankings&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Rivals&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardScores&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Commitment&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Schedule&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardPhotos&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;FanFuturecastLeaderboard&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;RecentForecasts&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null}],&quot;footer_text&quot;:null,&quot;sections&quot;:[],&quot;supplied_domain&quot;:null,&quot;forums_link_url&quot;:&quot;https://arizonavarsity.forums.rivals.com&quot;,&quot;scoreboard_scores_id&quot;:15081,&quot;scoreboard_photos_id&quot;:15082,&quot;aol_player_id&quot;:null,&quot;aol_company_id&quot;:null,&quot;ad_frequency&quot;:5,&quot;display_twitter_follow&quot;:true,&quot;display_fb_follow&quot;:true,&quot;follow_twitter_handle&quot;:&quot;ArizonaVarsity&quot;,&quot;follow_fb_handle&quot;:&quot;arizonavarsity&quot;,&quot;forum_id&quot;:null,&quot;premium_forum_id&quot;:null,&quot;facebook_page_id&quot;:null,&quot;max_ticker_articles&quot;:12,&quot;schedule_header_on&quot;:false,&quot;promo_popup_on&quot;:false,&quot;facebook_developer_id&quot;:null,&quot;customized_tos&quot;:[],&quot;show_survey_popup&quot;:false,&quot;survey_popup_link&quot;:null,&quot;header_bottom_border_style&quot;:null,&quot;customized_upsell_banner_text&quot;:null,&quot;email_logo_cloudinary&quot;:null,&quot;target_list_on&quot;:null,&quot;gifting_banner_content&quot;:&quot;Give a Rivals gift subscription this holiday season&quot;,&quot;gifting_banner_title&quot;:&quot;The perfect gift for football recruiting fans!&quot;,&quot;gifting_banner_button_text&quot;:&quot;Give a gift subscription&quot;,&quot;navigation_key&quot;:&quot;arizonavarsity&quot;},
&quot;58e686759efa8936610b8215&quot;, &quot;58e68374c7480e728bcc385f&quot;, &quot;rivals&quot;, 15000,
false, {&quot;id&quot;:1967,&quot;user_id&quot;:2798272,&quot;site_id&quot;:6,&quot;updated_at&quot;:&quot;2018-06-24T21:51:58.853-05:00&quot;,&quot;publisher_name&quot;:&quot;Chris Eaton&quot;,&quot;first_name&quot;:&quot;Chris&quot;,&quot;last_name&quot;:&quot;Eaton&quot;,&quot;site_title&quot;:&quot;Staff&quot;,&quot;bio&quot;:null,&quot;twitter_handle&quot;:null,&quot;image_url&quot;:null,&quot;publisher_name_and_title&quot;:&quot;Chris Eaton, Staff&quot;,&quot;site_name&quot;:&quot;ArizonaVarsity&quot;,&quot;site_short_name&quot;:&quot;arizonavarsity&quot;,&quot;has_edited_profile&quot;:false}, null)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{&quot;no-ad-padding&quot;: &quot;#{@display_ldrb_top}&quot;}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode' site_name='ArizonaVarsity'></rv-news-ticker>
</div>

<rv-forums ad-referer='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2022-recruiting-update-10-6' base-api-url='https://arizonavarsity.forums.rivals.com/' forums-url='https://arizonavarsity.forums.rivals.com' homepage='false' pub-ad='null' size='size' space-id='2022719646' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='article-display-wrapper'>
<div class='mobile-ad native-ad-ccc25e1a-d33c-46c9-a14a-96144b7a8b28'></div>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2022-recruiting-update-10-6/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo(&#39;2021-10-07 00:42:54 -0500&#39;) }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2322902/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h1 class='article-title'>Gridiron Arizona&#39;s 2022 Recruiting Update: 10/6</h1>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/nkwxsvflttn52my4hspq&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/nkwxsvflttn52my4hspq&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Photo Courtesy of Jacob Holmes" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/nkwxsvflttn52my4hspq" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Photo Courtesy of Jacob Holmes</figcaption>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<div>
<span class='author-name'>
Chris Eaton
&bull;
<span class='type-sm'>ArizonaVarsity</span>
</span>
<div>
<span class='author-name'>Staff</span>
</div>
</div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>

<div class='mobile-ad'>
<div class='native-ad-50d38545-0eeb-4c35-9393-b22cf70b9e3d'></div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><h3 class='article-heading'>Chandler defensive line prospect Holmes adds Tulane offer</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>UPDATED: 10/6/21</b></p><p>Colleges across the nation continue to take notice of the prep talent in Arizona each season. More than 360 players from the Class of 2021 signed with schools to advance their football careers, and receive an education.</p><p>Times for games are given in Arizona time.</p><p>Chandler defensive tackle <a href="https://n.rivals.com/content/prospects/2022/jacob-holmes-271659">Jacob Holmes</a> has been waiting to get back on the field for a long time. The former Cesar Chavez lineman transferred to the Wolves after the 2020 season and will be eligible to play this Friday when Chandler (5-0) begins its sixth game of the season at Perry. Holmes (6-3, 285) received an offer on Tuesday from Tulane. He was limited to just three games in 2020 because that's all Chavez was allowed to play in. As a sophomore, Holmes had 68 tackles for the Champions. Tulane takes to the big stage on Thursday night as the Green Wave will host Houston (4-1) in an American Athletic Conference game. This will be the first appearance for Tulane (1-4) on ESPN's Thursday night showcase. The game from Yulman Stadium kicks off at 4:30 p.m.</p><p>Here's the rest of the offers over the past week:</p><p>Brophy quarterback Elijah Warner received an offer from Hawaii.<br>Cactus wide receiver Chris Thomas Jr. received an offer from Morehead State (Ky.).<br>Arete Prep quarterback/defensive back Matthew McClelland received an offer from Morehead State.<br>Salpointe linebacker Joey Sumlin received his first offer from Morgan State (Md.).<br>Mountain Ridge offensive guard Alexis Sanchez received an offer from Eastern Washington.<br>Verrado wide receiver Trey Nelson received offers from Arizona Christian and Juniata (Pa.).<br>Florence linebacker Victor Aguirre received an offer from Rose-Hulman (Ind.).<br>Pusch Ridge running back Javier Grajeda Jr. received an offer from Rose-Hulman.<br>Pusch Ridge quarterback Ryan Fontaine received an offer from Oberlin (Ohio).<br>Sahuaro defensive end Jordan Pfeiffer received an offer from Luther (Iowa).<br>Queen Creek long snapper Mack Taylor received an offer from Luther.<br>Casa Grande cornerback Dematris Azcueta received an offer from Luther.<br>Hamilton cornerback Joel Gant recieved an offer from Montana State-Northern.<br>Paradise Valley offensive tackle Armando Nieves received his first offer from Arizona Christian.<br>Valley Vista center Jaden Lay received an offer from Mount Mary (S. Dak.).<br>O'Connor kicker Christian Makanoeich received his first offer from Ottawa (Kans.).<br>Desert View offensive guard Jose Roman received an offer from Bethany College (Kans.).<br>Sabino defensive tackle Sam Franco received his first offer from Clarke (Iowa).<br>Salpointe linebacker Davian Carrasco received his first offer from Clarke.<br>Benjamin Franklin offensive tackle Brigham Alexander received an offer from Clarke.<br>Basha safety Jordan Anderson received an offer from Clarke.<br></p><p>This list shows four-year college offers received by seniors throughout the state. It's not limited to just 6A and 5A. It will be constantly updated as we approach the Early Signing Period from December 15-17. Those are the first days that high school seniors can sign a letter of intent to agree to attend an institution.</p><p>Verbal commitments are shown in bold.</p>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p> <b>CLASS OF 2022 OFFERS</b></p><p>Quaron Adams - Chandler (WR): Arizona, Arizona State, California, Hawaii, Howard, Idaho, <b>IOWA STATE</b>, Kansas, New Mexico, Northern Arizona, Oregon</p><p>Raul Aguilar - Saguaro (OG): Concordia Coll. (Minn.), Mayville State, Ripon<br></p><p>Victor Aguirre - Florence (LB): Concordia Coll. (Minn.), Rose-Hulman<br></p><p>Emmanuel Ajala - Chandler (OT): Lake Forest, Wisconsin-River Falls<br></p><p>Brigham Alexander - Benjamin Franklin (OT): Clarke, Graceland, Lyon, Morehead State, Northern Arizona<br></p><p>Carson Allen - Highland (LB): Lewis &amp; Clark<br></p><p>Carter Allen - Central (WR): Rose-Hulman</p><p>Diego Alvarez - Estrella Foothills (K): St. Francis (Ill.)<br></p><p>Christian Anaya - Hamilton (WR): Montana State, Northern Arizona, Northern Colorado</p><p>Jordan Anderson - Basha (FS): Allegheny, Arizona Christian, Benedictine Univ. (Ill.), Clarke, Concordia Coll. (Minn.), Lake Forest, Puget Sound, Ripon, Wisconsin-River Falls<br></p><p>Milo Apodaca - Greenway (LB): Arizona Christian, Kansas Wesleyan, Lewis &amp; Clark, Wisconsin-River Falls</p><p>Jamarei Ashby-Phan - Chaparral (ATH): St. Thomas (Minn.)<br></p><p>Dematris Azcueta - Casa Grande (CB): Abilene Christian, Arizona, Arizona Christian, Clarke, Finlandia, Luther, Mercer, San Diego, Western Carolina, Wisconsin-River Falls<br></p><p>Rson Baker - Goldwater (TE): Lewis &amp; Clark<br></p><p>Payton Barlow - Queen Creek (RB): South Dakota School of Mines</p><p>Zach Bauer - Greenway (OG): Arizona Christian, Carroll Univ. (Wisc.), Lake Forest, Wisconsin-River Falls<br></p><p>Johnny Bellino - ALA-Gilbert North (WR): Concordia Coll. (Minn.), Minot State, Montana Tech, Wisconsin-River Falls</p><p>Jack Bellomy - Arete Prep (RB): Puget Sound<br></p><p>Joshua Berg-Nabors - Sierra Linda (RB): Mayville State</p><p>Jeremy Blassingame - Campo Verde (WR): Allegheny<br></p><p>Bryan Bogardus - Saguaro (RB): Allegheny, Arizona Christian, Bethany Coll. (Kans.), Bethel Coll. (Kans.), Catholic, Clarke, Crown, Culver-Stockton, Kansas Wesleyan, Lewis &amp; Clark, Luther, Montana State-Northern, Puget Sound, Ripon, Rochester (N.Y.), Rose-Hulman, St. Norbert, Willamette, Wisconsin-River Falls</p><p>Noah Borchard - Campo Verde (FS): St. Olaf<br></p><p>Charles Borowsky - Chaparral (WR): Puget Sound, Wisconsin-River Falls<br></p><p>Treyson Bourguet - Salpointe (QB): Arizona, BYU, Columbia, Idaho, Portland State, Vanderbilt</p><p>Shakaun Bowser - Casteel (LB): Arizona, Arizona State, <b>COLORADO</b>, Colorado State, Fresno State, Iowa State, Kansas, Kansas State, Michigan, New Mexico, Oregon State, Southern Mississippi, Utah, Utah State</p><p>Amier Boyd - Mountain Pointe (ATH): Arizona Christian, Lake Forest, Northern Arizona<br></p><p>Parker Brailsford - Saguaro (OG): Air Force, Arizona, Boise State, BYU, Colorado, Colorado State, Hawaii, Kansas State, Michigan State, New Mexico, Northern Arizona, Oregon State, San Diego State, USC, <b>WASHINGTON</b>, Washington State</p><p>Jacob Brooks - Campo Verde (QB): Allegheny<br></p><p>Gavin Broscious - Desert Edge (OG): Arizona, Arizona State, BYU, California, Colorado, Idaho, Kansas, <b>MICHIGAN STATE</b>, Minnesota, Nebraska, Nevada, New Mexico, UNLV, Utah, Vanderbilt</p><p>Breshaun Brown - Desert Edge (CB): Minot State, Northern State, Wisconsin-River Falls</p><p>Davondre Bucannon - Chaparral (CB): Idaho, Northern Arizona</p><p>Vincent Burgo - Cactus (DE): Carroll Univ. (Wisc.), Lake Forest, St. Olaf<br></p><p>Jake Burrow - Notre Dame (C): St. Norbert, Whittier<br></p><p>Ethan Bush - Notre Dame (LB): Lewis &amp; Clark, St. Norbert</p><p>Fisher Camac - Highland (DE): Southwest Minnesota State, <b>UNLV</b><br></p><p>Tommy Carberry - Florence (WR): Allegheny, Bethany Coll. (Kans.), Greenville, Nichols, Puget Sound, Willamette</p><p>Davian Carrasco - Salpointe (LB): Clarke<br></p><p>Mikey Castro - Seton Catholic (RB): Arizona Christian<br></p><p>Malik Charles - Heritage Academy Maricopa (WR): Arizona Christian</p><p>Bryce Chen - Arizona College Prep (WR): Allegheny, Concordia Coll. (Minn.), Grinnell, Lake Forest, Lewis &amp; Clark, Rose-Hulman, St. Norbert, Washington &amp; Lee<br></p><p>Augustin Chiang - Coolidge (CB): Arizona Christian, Luther, St. Norbert</p><p>Matthew Clark - Mesa Mountain View (FS): Air Force<br></p><p>Will Clark - Campo Verde (WR): Jamestown<br></p><p>Connor Clinton - Casteel (FS): Arizona, Arizona State, <b>Army</b>, Dartmouth, Fordham, Navy, Northern Arizona<br></p><p>Kaden Cloud - Williams Field (RB): Air Force, Army, Columbia, Navy, Oregon State</p><p>Nason Coleman - Chandler (TE): Arizona, Arizona State, Arkansas, BYU, Colorado State, Dartmouth, Idaho, Iowa State, Nebraska, New Mexico, <b>PRINCETON</b>, UCF, UNLV, Utah, Utah State, Yale</p><p>Cris Contreras - Desert Edge (DE): Wisconsin-River Falls</p><p>KJ Cooper - Chandler (QB): Eastern Kentucky<br></p><p>Brandon Craddock - O'Connor (LB): Arizona (preferred walk-on), Arizona State (preferred walk-on), Georgetown, Marist, Michigan State (preferred walk-on), Morgan State, Southwest Minnesota State</p><p>Michael Cromer - Walden Grove (OT): Bethany Coll. (Kans.), Concordia Coll. (Minn.), Hamline, Wisconsin-River Falls<br></p><p>Miles Crutchley - Saguaro (LB): Army</p><p>Mason Cullop - Cactus (C): Arizona Christian, Concordia Coll. (Minn.), Northern Michigan<br></p><p>Kolton Cunningham - Perry (LB): Allegheny, Lewis &amp; Clark, Rochester (N.Y.), St. Norbert, Wisconsin-River Falls<br></p><p>Brevin Czosnyka - O'Connor (LB): Army, Eastern Washington, Idaho, Montana State, Navy, <b>NORTHERN ARIZONA</b><br></p><p>Russell Davis II - Hamilton (DE): <b>ARIZONA</b>, Boston College, Colorado State, Duke, East Carolina, Fresno State, Idaho, Iowa State, Nevada, San Diego State, Utah State</p><p>Thomas DeChesaro - Saguaro (FS): Lake Forest</p><p>Grant DeGraffenreid - Hamilton (DE): Lewis &amp; Clark, Millikin<br></p><p>Tavian Dennis - Desert Vista (SS): San Diego State</p><p>Brok Determan - Benson (QB): Bethany Coll. (Kans.), Clarke, Crown<br></p><p>Ridge Docekal - Saguaro (QB): Appalachian State, Bucknell, Columbia, Fordham, Furman, Houston, <b>IDAHO</b></p><p>Carlos Dominguez - Brophy (WR): La Verne</p><p>Devin Dunn - Chandler (LB): Lewis &amp; Clark</p><p>CJ Eastwood - Chaparral (LB): Rose-Hulman<br></p><p>Skylar Edmonds - Red Mountain (LB): Minot State<br></p><p>Amar Elmore - Chandler (DE): Benedictine Coll. (Kans.), Dartmouth</p><p>Mason Ennen - Mesa (DE): Arizona Christian<br></p><p>Owen Faulkner - O'Connor (DT): Arizona Christian, St. Norbert</p><p>Ryan Finch - Mountain Ridge (QB): Arizona Christian<br></p><p>Angel Flores - Casa Grande (QB): Columbia, Eastern Washington, Georgetown, Morgan State, Northern Arizona, Portland State, Rice<br></p><p>Ryan Fontaine - Pusch Ridge (QB): Allegheny, Bethel Univ. (Tenn.), Ithaca, Lyon, Oberlin<br></p><p>Camren Foster - Desert Edge (CB): Black Hills State, Wisconsin-River Falls</p><p>Sam Franco - Sabino (DT): Clarke<br></p><p>Cole Franklin - Pinnacle (LB): Bowdoin<br></p><p>Jacob Franze - Chaparral (SS): Chicago, Johns Hopkins, Saint Anselm<br></p><p>Duke Frye - Notre Dame (DT/OG): Allegheny, Arizona Christian, Bowdoin, Concordia Coll. (Minn.), Grinnell, Lewis &amp; Clark, Puget Sound, Rose-Hulman, Washington (Mo.), Wisconsin-River Falls</p><p>Joel Gant - Hamilton (CB): Arizona Christian, Montana State-Northern<br></p><p>Reilly Garcia - Campo Verde (QB): Carleton<br></p><p>Josiah Gardner - Willow Canyon (DT): Allegheny, Arizona Christian, Concordia Coll. (Minn.)</p><p>Carson Gazeley - Casteel (OG): Lewis &amp; Clark<br></p><p>Valentin Gbafore - Liberty (WR): Idaho<br></p><p>Xander Georgoulis - Sunnyslope (RB): Lewis &amp; Clark, Wisconsin-River Falls<br></p><p>Amari Gilmore - Poston Butte (FS): Idaho, Southwest Minnesota State</p><p>Denzel Glass - Coolidge (OT): Wisconsin-River Falls</p><p>Nathan Goerke - Sahuaro (LB): Clarke, Lyon<br></p><p>Carlos Gonzalez - Salpointe (C): Clarke<br></p><p>Jeremiah Gossett - Peoria (CB): Allegheny, Arizona Christian, Benedictine Coll. (Kans.), Culver-Stockton, Northern Michigan, St. Norbert</p><p>Javier Grajeda Jr. - Pusch Ridge (RB): Lyon, Rose-Hulman<br></p><p>Kyion Grayes - Chandler (WR): Arizona, Arizona State, Auburn, Iowa State, Kansas, Miami (Fla.), Michigan State, Nebraska, Northern Arizona, <b>OHIO STATE</b>, Oregon, Oregon State, Penn State, Tennessee, Texas, USC, Utah</p><p>Devon Grubbs - Desert Vista (DB): Air Force, Arizona, Arizona State, <b>NORTHERN ARIZONA</b><br></p><p>Donovan Guyton - Williams Field (FS): Air Force</p><p>Camden Haggard - Hamilton (S): Morningside, Northern State, Southwest Minnesota State<br></p><p>Hayden Hallett - Pusch Ridge (QB): Puget Sound, Wisconsin-River Falls</p><p>Zach Hammett - River Valley (RB): Lake Forest, Wisconsin-River Falls</p><p>Johnny Hart - Sunrise Mountain (TE): Lyon, South Dakota School of Mines<br></p><p>Kaden Hicks - Mountain Ridge (OT): Allegheny, Arizona Christian, Concordia Coll. (Minn.), Culver-Stockton, Kansas Wesleyan, Lake Forest, Mayville State, Morehead State, Morningside, Puget Sound, Southwest Minnesota State, Valparaiso, Whittier, Wisconsin-River Falls</p><p>Gavin Higley - Chaparral (WR): Arizona Christian<br></p><p>Ashton Hill - Deer Valley (RB): Allegheny, Arizona Christian, Lake Forest, Lewis &amp; Clark</p><p>Joseph Hill - Willow Canyon (OG): Lyon<br></p><p>Andrew Hinojos - Campo Verde (OT): Concordia Coll. (Minn.), St. Norbert, Wisconsin-River Falls<br></p><p>Blaine Hipa - Chandler (QB): Hawaii, Tennessee<br></p><p>Jacob Holmes - Chandler (DT): Arizona, Arizona State, Colorado State, Fresno State, Idaho, Indiana, Northern Arizona, Oregon State, San Diego State, San Jose State, Tulane, Utah State, Washington State, West Virginia<br></p><p>Lance Holtzclaw - Desert Ridge (DE): Air Force, Arizona, Boise State, Boston College, Colorado, Idaho, Iowa State, Kansas State, Michigan, Northern Arizona, Oregon State, San Diego State, Vanderbilt, <b>WASHINGTON</b></p><p>Dawson Hubbard - Hamilton (DT): Butler, Drake<br></p><p>Logan Hubler - ALA-Queen Creek (QB): Bethany Coll. (Kans.), Lake Forest<br></p><p>Jordan Huff - Mountain Pointe (WR): Arizona Christian<br></p><p>Taj Hughes - Brophy (WR): Presbyterian, South Dakota School of Mines<br></p><p>Jayden Hurst - Red Mountain (DT): Concordia Coll. (Minn.), Lake Forest, Mayville State<br></p><p>Javen Jacobs - Saguaro (RB): Air Force, Arizona State, Army, Colorado, Colorado State, Idaho, New Mexico, Northern Arizona, Portland State, Yale</p><p>Andrew James - Mesa (LB): Arizona Christian<br></p><p>Aziya Jamison - Williams Field (RB): Arizona State, BYU, Idaho, New Mexico, Northern Arizona</p><p>Kevin Johanson - Greenway (SS): Grinnell<br></p><p>Isaiah Johnson - Chandler (DT): <b>ARIZONA</b>, Colorado, Colorado State, Idaho, Utah State</p><p>Lloyd Johnson - Marana Mountain View (LB): Clarke<br></p><p>Luke Johnson - Northwest Christian (LB): College of Idaho<br></p><p>Quinton Johnson - Centennial (DE): CSU-Pueblo<br></p><p>Brooks Jones - ALA-Queen Creek (TE/DE): <b>BYU</b><br></p><p>Dillon Jones - Notre Dame (DE): Wisconsin-River Falls<br></p><p>Brody Kallman - Cienega (DE): Culver-Stockton, Southwest Minnesota State</p><p>Steven Kennedy Jr. - Perry (DE): Arizona Christian, Benedictine Coll. (Kans.)<br></p><p>Bryan King - Queen Creek (FS): Northern Arizona, Southern Mississippi</p><p>Cameron Knight - Hamilton (CB): Lewis &amp; Clark<br></p><p>Adam Knowles - Perry (DT): Concordia Coll. (Minn.), Lake Forest, Wisconsin-River Falls</p><p>Dane Kohl - Perry (SS): Lewis &amp; Clark<br></p><p>Joseph Lagafuaina - Cactus (FS): Arizona Christian, Benedictine Coll. (Kans.), Black Hills State, Northern Michigan, South Dakota School of Mines, Southwest Minnesota State, St. Olaf, Wisconsin-River Falls<br></p><p>Jeff Lambert - Corona del Sol (LB): Lewis &amp; Clark, New Mexico, Northern Arizona<br></p><p>Adryan Lara - Desert Edge (QB): Arizona, Iowa State, Kansas, Oregon State, <b>WASHINGTON STATE</b>, William &amp; Mary</p><p>Jaden Lay - Valley Vista (C): Arizona Christian, Concordia Coll. (Minn.), Lake Forest, Mayville State, Mount Marty, Wisconsin-River Falls<br></p><p>Ethan Lee - Brophy (RB): La Verne</p><p>Gage Lentz - Veritas Prep (QB): Dordt</p><p>Jimmy Lerblance - Benson (CB): Crown, Rose-Hulman<br></p><p>Anthony Lucas - Chaparral (DT): Alabama, Arizona, Arizona State, Auburn, California, Colorado, Florida State, Georgia, Iowa State, LSU, Miami (Fla.), Michigan, Michigan State, Nebraska, Notre Dame, Oklahoma, Oregon, Penn State, Texas, Texas A&amp;M, UCLA, USC, Utah, Vanderbilt, Washington, Wisconsin</p><p>Micah Lutu - Saguaro (OG): Arizona State, New Mexico</p><p>Marcus Lye - Brophy (K/P): Presbyterian</p><p>Christian Makanoeich (K): Ottawa (Kans.)<br></p><p>Nicco Marchiol - Hamilton (QB): Arizona, Arizona State, Arkansas, Charlotte, Colorado, Colorado State, Florida, Florida Atlantic, Florida State, Georgia, Georgia Tech, Kentucky, Liberty, LSU, Louisville, Michigan, Michigan State, Mississippi, Mississippi State, Nebraska, Penn State, Rutgers, South Florida, TCU, USC, Utah, Washington State, <b>WEST VIRGINIA</b><br></p><p>Damien Marquez - Deer Valley (C): Arizona Christian<br></p><p>Ivan Martin - Saguaro (CB): Allegheny, Army, Concordia Coll. (Minn.), Grand View, Lake Forest, Lewis &amp; Clark, Minot State, Navy, Northern State, St. Olaf, Wisconsin-River Falls</p><p>Antonio Martinez - Salpointe (WR): St. Norbert</p><p>Jesse Martinez - Goldwater (QB/DB): Bethany Coll. (Kans.)<br></p><p>Nick Martinez - St. Mary's (QB): Anderson, Jamestown, St. Norbert</p><p>Michael Masunas - Hamilton (TE): Air Force, Arizona, Army, Florida State, Maryland, <b>MICHIGAN STATE</b>, New Mexico, Northern Arizona, Pennsylvania, San Diego State, Tennessee, UNLV, Utah</p><p>Ryan Matteson - River Valley (LB): Bethany Coll. (Kans.)<br></p><p>Matthew McClelland - Arete Prep (QB/DB): Concordia Coll. (Minn.), Morehead State, St. Olaf, Willamette<br></p><p>Parker McClure - Red Mountain (LB): Black Hills State, Minot State<br></p><p>Jeryll McIntosh - Desert Edge (RB): Morgan State, Southwest Minnesota State, Wisconsin-River Falls<br></p><p>Jonathan Melgar - Apollo (DT): Wisconsin-River Falls</p><p>Ryan Meloche - Pinnacle (FS): Bowdoin, Carnegie Mellon, Chicago, Johns Hopkins<br></p><p>Anthony Mendez - Sierra Linda (DT): Mayville State<br></p><p>Keaton Messerole - Arizona College Prep (OT): Concordia Coll. (Minn.), Grinnell, Lewis &amp; Clark, Ripon, Sewanee, St. Norbert, Wisconsin-River Falls<br></p><p>Kane Metts-Terrell - Liberty (WR): Morehead State</p><p>Djevon Miles - Deer Valley (FS): Arizona Christian<br></p><p>KJ Miniefield - Desert Ridge (CB): Air Force, Idaho, Nevada</p><p>Josh Minton - Brophy (SS): Allegheny, Luther<br></p><p>Roger Miranda-Mora - Brophy (OG): La Verne, Luther<br></p><p>Tristan Monday - Saguaro (DE): <b>ARIZONA</b>, Baylor, Colorado, Florida State, Idaho, Iowa State, New Mexico</p><p>Jeremiah Moore - Chandler (RB): Southwest Minnesota State<br></p><p>Franky Morales - Chandler (FS): Arizona Christian, Benedictine Coll. (Kans.), Lake Forest, Wisconsin-River Falls<br></p><p>Andrew Morris - Mesquite (LB): Idaho, <b>MARSHALL</b>, New Mexico, Northern Arizona</p><p>Jordan Morris - Red Mountain (TE): Colorado State, Fresno State, Nevada, New Mexico State, Northern Arizona, <b>SAN DIEGO STATE</b>, UNLV, Utah State, Yale</p><p>Benjamin Morrison - Brophy (CB): Alabama, Arizona, Arizona State, Auburn, Boston College, Colorado, Duke, Florida State, Indiana, Iowa State, LSU, Michigan, Michigan State, Minnesota, Nebraska, Nevada, Northwestern, <b>NOTRE DAME</b>, Oklahoma, Oregon, Oregon State, Penn State, UCLA, UNLV, Washington, Washington State <br></p><p>Ethan Morrison - Ironwood Ridge (LB): Carthage, Whittier<br></p><p>Nick Morrow - Flagstaff (DE): Baylor, <b>CALIFORNIA</b>, Northern Arizona, UNLV<br></p><p>Dylan Murray - Horizon (SS): Bryant</p><p>Trey Nelson - Verrado (WR): Arizona Christian, Juniata, Wisconsin-River Falls<br></p><p>Ian Nieto - Perry (WR): Lewis &amp; Clark</p><p>Armando Nieves - Paradise Valley (OT): Arizona Christian<br></p><p>Oliver Ocampos - Centennial (OG): Wisconsin-River Falls</p><p>Cordell Outridge - Moon Valley (DT): Wisconsin-River Falls</p><p>Rivelino Pacheco - River Valley (ATH): Carthage, Clarke<br></p><p>Skyler Partridge - Horizon (QB): Whittier<br></p><p>Jace Patton - Highland (TE): Lewis &amp; Clark, Luther, Morningside, Southwest Minnesota State, Wisconsin-River Falls<br></p><p>Pablo Pena - Marana Mountain View (OT): Clarke<br></p><p>Elijah Peters - ALA-Queen Creek (WR): Anderson, South Dakota School of Mines<br></p><p>Andrew Petersen - Casteel (DT): Southern Mississippi</p><p>Jordan Pfeiffer - Sahuaro (DE): Bethany Coll. (Kans.), Clarke, Hastings, Luther, Lyon, Wisconsin-River Falls<br></p><p>Fabian Pina - Sierra Linda (OG): Mayville State<br></p><p>Jack Plote - Mountain Pointe (OT): Arizona Christian, Wisconsin-River Falls<br></p><p>Tyler Powell - Brophy (TE): <b>ARIZONA</b>, Arizona State, Auburn, Florida State, Idaho, Iowa State, New Mexico State, UCLA, UNLV</p><p>Xavier Quintanilla - Sierra Linda (CB): Mayville State</p><p>Cody Raetzman - Salpointe (SS): Allegheny, Minot State, Wisconsin-River Falls</p><p>Ricky Randall - Canyon View (OG): Dickinson State<br></p><p>Caleb Richardson - Perry (DT): Allegheny, Lake Forest, Lewis &amp; Clark, Ripon, Wisconsin-River Falls<br></p><p>Josh Richardson - Perry (LB): Lewis &amp; Clark, Ripon, Wisconsin-River Falls<br></p><p>Alex Rivera - Trevor Browne (QB): Allegheny, Mayville State</p><p>Leon Roberts - Carl Hayden (CB): Mayville State, Wisconsin-River Falls<br></p><p>Ty Robinson - Basha (DE): Allegheny, Arizona Christian, Concordia Coll. (Minn.), Lake Forest, Mayville State, Puget Sound, Ripon, Wisconsin-River Falls<br></p><p>Jai Rodriquez - Desert Vista (OT): Arizona State, Idaho, <b>NORTHERN ARIZONA</b>, Portland State<br></p><p>Jose Roman - Desert View (OG): Arizona Christian, Bethany Coll. (Kans.), Clarke<br></p><p>Jacob Romero - Mountain Pointe (LB): Arizona Christian</p><p>Cole Rood - Highland (CB): Northern State<br></p><p>Cooper Ross - Heritage Academy Mesa (TE): <b>BYU</b>, Lake Forest, New Mexico Highlands, Northern Arizona, Southwest Minnesota State</p><p>Dwayne Quentin Ross - Hamilton (WR): Lewis &amp; Clark<br></p><p>Terryon Rowe - Mountain Pointe (WR): Arizona Christian, Southwest Minnesota State, Wisconsin-River Falls<br></p><p>Andy Ruiz - Coconino (CB): Northern Arizona, Wisconsin-River Falls<br></p><p>John Ruvo - Notre Dame (CB): Bowdoin, South Dakota School of Mines<br></p><p>Alexis Sanchez - Mountain Ridge (OG): Drake, Eastern Washington, Georgetown, Lehigh, Morehead State, Northern Arizona, San Diego<br></p><p>Andy Sanchez - Mountain Ridge (DT): Drake<br></p><p>Deven Sanchez - Marana Mountain View (S/SB): Arizona Christian, Ripon<br></p><p>Isaac Sandoval - Florence (WR): Wisconsin-River Falls</p><p>Daniel Santiago - Horizon (DT): Air Force, Arizona, Army, Buffalo, Colgate, Colorado State, San Diego State, Yale<br></p><p>Cy Schmaltz - Mesa (QB): New Mexico Highlands<br></p><p>James Scott - Centennial (RB): Benedictine Coll. (Kans.), Drake, Lewis &amp; Clark, San Diego, Southwest Minnesota State</p><p>Hunter Seelye - Campo Verde (OG): Drake<br></p><p>Tony Servin - Centennial (OG): Arizona Christian, Mayville State</p><p>Justin Shehow - Walden Grove (OT): Muskingum<br></p><p>Cannen Siegel - Saguaro (LB): Lake Forest<br></p><p>Brayten Silbor - Chaparral (QB): Columbia, <b>NEW MEXICO</b>, Northern Arizona, Pennsylvania</p><p>Aiden Simonton - O'Connor (OT): Minot State<br></p><p>Alfred Smith - Chandler (CB): Army, Benedictine Coll. (Kans.), Navy, South Dakota School of Mines, Southwest Minnesota State, St. Norbert, Western New Mexico<br></p><p>Gavin Smith - Notre Dame (WR): Arizona (preferred walk-on), Arizona State, Idaho, North Dakota, San Diego<br></p><p>Devon Sparks - Mountain Pointe (RB): Arizona Christian</p><p>Elijah Sports-Trott - Centennial (WR): Allegheny<br></p><p>Lance St. Louis - Williams Field (LS): <b>TEXAS</b><br></p><p>Jax Stam - Liberty (FS): Arizona (preferred walk-on), Army, Georgetown, New Mexico, Pennsylvania, Southwest Minnesota State</p><p>Braden Starmer - Desert Ridge (LS): Mayville State</p><p>Cade Stenson - Florence (WR): Concordia Coll. (Minn.), Luther, Nichols, Willamette, Wisconsin-River Falls<br></p><p>Jason Stevens - Walden Grove (QB): Saint Mary<br></p><p>Grayson Stovall - Hamilton (OG): <b>ARIZONA</b>, Arizona State, Charlotte, Colorado State, Idaho, Indiana, Kansas, Michigan State, Oregon State, Utah</p><p>Joey Sumlin - Salpointe (LB): Morgan State<br></p><p>Zac Swanson - Brophy (DE): Arizona, Arizona State, Auburn, California, Colorado, Florida State, Indiana, Iowa State, Kentucky, Michigan State, Oklahoma, Oregon, Oregon State, <b>TEXAS</b>, UCLA, USC, Utah</p><p>Trevor Swan - Perry (OG): Arizona State</p><p>Malaki Ta'ase - Mesa Mountain View (DE): Idaho, Nevada, Southern Utah, Utah State</p><p>Tre Tate - Hamilton (WR): Colorado School of Mines<br></p><p>Mack Taylor - Queen Creek (LS): Colorado School of Mines, Concordia Coll (Minn.), Lake Forest, Luther, Morningside, South Dakota School of Mines, Willamette<br></p><p>Myllen Terameau - Saguaro (CB): Northern Arizona</p><p>Ata Teutupe - Cactus (LB): Concordia Coll. (Minn.), Southwest Minnesota State<br></p><p>Chris Thomas Jr. - Cactus (WR): Allegheny, Lake Forest, Lewis &amp; Clark, Morehead State, Morgan State</p><p>Kiko Trejo - Amphitheater (RB): Arizona Christian<br></p><p>Keiyon Turner - Desert Ridge (WR): Arizona Christian</p><p>Ilya Uvaydov - Gilbert (K): Dixie State<br></p><p>Rudy Varela - Casteel (C): <b>AIR FORCE</b>, Army, Navy, Northern Arizona, Valparaiso</p><p>Frankie Viera - Desert Vista (LB): Allegheny<br></p><p>Josiah Villanueva - Red Mountain (RB): Allegheny, Lewis &amp; Clark<br></p><p>Max Ware - Brophy (WR): South Dakota School of MInes<br></p><p>Elijah Warner - Brophy (QB): Ball State, Colorado State, Eastern Kentucky, Hawaii, Marshall, Northern Colorado, Presbyterian, Tennessee-Martin</p><p>Kolten Warner - O'Connor (SS): Arizona Christian, Central (Iowa), Concordia Coll. (Minn.), Minot State, St. Norbert</p><p>Gabriel Watkins-Daigle - Walden Grove (OG): Morningside<br></p><p>Braden Wells - Notre Dame (QB): Puget Sound, St. Norbert<br></p><p>John West - Deer Valley (DB): Allegheny, Arizona Christian, Mayville State, St. Norbert, Wisconsin-River Falls<br></p><p>Tucker Wilburn - Marcos de Niza (DE): Arizona State</p><p>Etwood Williams - Mesa (CB): Arizona Christian, Ottawa<br></p><p>Matthew Willis - Desert Edge (TE): Concordia Coll. (Minn.), Southwest Minnesota State, Wisconsin-River Falls</p><p>Zach Wren - Pinnacle (QB): Benedictine Coll. (Kans.)<br></p><p>Merhauti Xepera - Higley (TE): <b>FRESNO STATE</b><br></p><p>Isaac Yates - Shadow Ridge (WR): Southwest Minnesota State</p><p>Ethan Young - O'Connor (QB): Kansas Wesleyan<br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/dg9uqxbhyzaihutfjz2r&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/dg9uqxbhyzaihutfjz2r&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Photo Courtesy of Jai Rodriquez" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/dg9uqxbhyzaihutfjz2r" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Photo Courtesy of Jai Rodriquez</figcaption>
</div>
</figure>
<h3 class='article-heading'>Desert Vista offensive lineman Rodriquez commits to Northern Arizona</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>UPDATED: 10/6/21</b></p><p>Northern Arizona added an in-state offensive lineman to its class on Sunday as the Lumberjacks landed a commitment from <a href="https://n.rivals.com/content/prospects/2022/jai-rodriquez-257643">Jai Rodriquez</a> out of Desert Vista.<br></p><p>The 6-6, 275-pound tackled picked NAU over offers from a pair of other Big Sky schools - Idaho and Portland State.<br></p><p>"It was just overall how they recruited me," Rodriquez said in a text message. "They made me feel very welcome and at home. They didn't just make me feel like I was just any other recruit."<br></p><p>Rodriquez also mentioned the bonds he has created with the NAU coaching staff since it offered him back in January. He is the 2nd DVHS player to pledge to Northern Arizona joining defensive back Devon Grubbs.<br></p><p>Desert Vista has been on the come up this year. After going winless in 2020, the Thunder carries a 2-2 record into a home game with Basha this Friday.<br></p><p>Northern Arizona celebrated Family Weekend last Saturday in Flagstaff with a 48-17 victory over Idaho State. The Lumberjacks generated 649 yards of total offense. The game marked the first time since 2014 that NAU had a pair of 100-yard receivers as well as a 100-yard rusher. Two of those players have a hometown feel as Coleman Owen (Higley) had 137 yards receiving and Kevin Daniels (Glendale) rushed for 118 yards. The Lumberjacks are in their bye week and will host Southern Utah on Oct. 16 with the Grand Canyon Trophy on the line.<br></p><p><br>On Saturday, Saguaro signal caller Ridge Docekal became the fourth senior quarterback to announce his college destination as he will go to Idaho.</p><p>Docekal is in his third year on the Sabercats' varsity team and second as a starter. He shared snaps as a junior, but is taking the bulk of them in 2021. Docekal went on an official visit to UI back on Sept. 4 when the Vandals defeated Simon Fraser.<br></p><p>"They really made me feel wanted," Docekal said in a text message. "I have heard from all of the coaches there a lot. When I visited there, they had a great presentation for me and told me I was the No. 1 prospect on their board. The area is great and I feel I can compete to be the starter in Year One."<br></p><p>Docekal selected Idaho over six other schools, including Houston.</p><p>This season, Docekal has passed for 619 yards and thrown six touchdowns while leading the Sabercats to a 3-1 record. In last week's win over Salpointe, he was 10-of-13 for 165 yards and two TDs. SHS hosts Maricopa on Friday night.<br></p><p>Last Saturday, Idaho outgained No. 8 UC Davis by more than 100 yards, but came up short in a 27-20 game on the road. It was the Vandals' first loss in Big Sky Conference play. Idaho (1-3) will have just its second home game of the year this Saturday against Portland State (2-2) at the Kibbie Dome.</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/g4qj5fzhodyahihtowxk&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/g4qj5fzhodyahihtowxk&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Saguaro QB Ridge Docekal  (Photo by Andy Silvas Photography)" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/g4qj5fzhodyahihtowxk" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Saguaro QB Ridge Docekal  (Photo by Andy Silvas Photography)</figcaption>
</div>
</figure>
<h3 class='article-heading'>CLASS OF 2022 COMMITMENTS



</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>AIR FORCE FALCONS</b></p><p>Rudy Varela (C) - Casteel<b><br></b></p><p><b>ARIZONA WILDCATS<br></b></p><p>Russell Davis II (DE) - Hamilton<br>Isaiah Johnson (DT) - Chandler<br>Tristan Monday (DE) - Saguaro<br>Tyler Powell (TE) - Brophy<br>Grayson Stovall (OG) - Hamilton</p><p><b>ARMY BLACK KNIGHTS</b></p><p>Connor Clinton (FS) - Casteel<br></p><p><b>BYU COUGARS</b></p><p>Brooks Jones (TE/DE) - ALA-Queen Creek<br>Cooper Ross (TE) - Heritage Academy Mesa</p><p><b>CALIFORNIA GOLDEN BEARS</b></p><p>Nick Morrow (DE) - Flagstaff</p><p><b>COLORADO BUFFALOES</b></p><p>Shakaun Bowser (LB) - Casteel<br></p><p><b>FRESNO STATE BULLDOGS</b></p><p>Merhauti Xepera (TE) - Higley</p><p><b>IDAHO VANDALS</b></p><p>Ridge Docekal (QB) - Saguaro<br></p><p><b>IOWA STATE CYCLONES</b></p><p>Quaron Adams (WR) - Chandler<br></p><p><b>MARSHALL THUNDERING HERD</b></p><p>Andrew Morris (LB) - Mesquite<br></p><p><b>MICHIGAN STATE SPARTANS</b></p><p>Gavin Broscious (OG) - Desert Edge<br>Michael Masunas (TE) - Hamilton</p><p><b>NEW MEXICO LOBOS</b></p><p>Brayten Silbor (QB) - Chaparral</p><p><b>NORTHERN ARIZONA LUMBERJACKS</b></p><p>Brevin Czosnyka (LB) - O'Connor<br>Devon Grubbs (DB) - Desert Vista<br>Jai Rodriquez (OT) - Desert Vista<br></p><p><b>NOTRE DAME FIGHTING IRISH</b></p><p>Benjamin Morrison (CB) - Brophy<br></p><p><b>OHIO STATE BUCKEYES</b></p><p>Kyion Grayes (WR) - Chandler</p><p><b>PRINCETON TIGERS</b></p><p>Nason Coleman (TE) - Chandler<br></p><p><b>SAN DIEGO STATE AZTECS</b></p><p>Jordan Morris (TE) - Red Mountain<br></p><p><b>TEXAS LONGHORNS</b></p><p>Lance St. Louis (LS) - Williams Field<br>Zac Swanson (DE) - Brophy</p><p><b>UNLV REBELS</b></p><p>Fisher Camac (DE) - Highland<br></p><p><b>WASHINGTON HUSKIES</b></p><p>Parker Brailsford (OG) - Saguaro<br>Lance Holtzclaw (DE) - Desert Ridge<br></p><p><b>WASHINGTON STATE COUGARS</b></p><p>Adryan Lara (QB) - Desert Edge</p><p><b>WEST VIRGINIA MOUNTAINEERS</b></p><p>Nicco Marchiol (QB) - Hamilton<br></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2022-recruiting-update-10-6/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === &quot;premium&quot;'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>

<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' display-lrec1-rightrail='true' display-lrec2-rightrail='true' display-lrec3-rightrail='true' enrichments='[{&quot;active&quot;:true,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:1}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2021' ncaaf-schedule-year='2021' scoreboard-photos-id='15082' scoreboard-scores-id='15081' site='{&quot;id&quot;:6,&quot;legacy_id&quot;:1128,&quot;name&quot;:&quot;ArizonaVarsity&quot;,&quot;friendly_name&quot;:&quot;Arizona HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;arizonavarsity&quot;,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;arizonavarsity&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;}' twitter-feed='{&quot;id&quot;:6,&quot;site_id&quot;:6,&quot;handle&quot;:&quot;ArizonaVarsity&quot;,&quot;list_name&quot;:&quot;TeamAZV&quot;,&quot;created_at&quot;:&quot;2016-02-01T12:24:39.964-06:00&quot;,&quot;updated_at&quot;:&quot;2020-04-28T02:17:51.614-05:00&quot;,&quot;hashtags&quot;:[],&quot;usernames&quot;:[&quot;AZHSFB&quot;,&quot;ArizonaVarsity&quot;],&quot;max_number&quot;:5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2022-recruiting-update-10-6/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
</div>
</div>
<script src='/javascript/ad?ad_referrer=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fgridiron-arizona-s-2022-recruiting-update-10-6&amp;space_id=2022719646' type='text/javascript'></script>

<rv-chartbeat-config-body ng-hide sections='content,content-football,content-football-free,content-article' title='Gridiron Arizona&#39;s 2022 Recruiting Update: 10/6'></rv-chartbeat-config-body>

<script>
dataLayer = [{"u15":"arizonavarsity","u16":2322902}];

</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if='showLRECad(&#39;footer&#39;)'>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
</div>

</div>
</main>
<script src='/javascript/pencil_ad.js'></script>
<script src='/javascript/stream_ad.js'></script>
<script src='/javascript/moments_ad.js'></script>
<footer>
<div class='flexible-links'>
<a class='link' href='/news/about-us'>About</a>
<a class='link' href='/news/member-services'>Help</a>
<a class='link' href='/news/contact-us-5'>Contact Us</a>
<a class='link' href='/tos'>Terms of Service</a>
<a class='link' href='/gifts/purchase'>Gift Subscription</a>
</div>
<div class='flexible-links'>
<a class='link' href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
</div>
<div class='logo-container'>
<div class='footer-logo'><?xml version="1.0" encoding="UTF-8"?>
<svg width="159px" height="96px" viewbox="0 0 159 96" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 58 (84663) - https://sketch.com -->
    <title>logo_yahoo_sports_gray</title>
    <desc>Created with Sketch.</desc>
    <g id="Logos" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="logo-/-yahoo-sports-/-grayscale">
            <g id="logo-/-yahoo-sports-MASTER-/-black-on-white" transform="translate(0.000000, 36.000000)">
                <g id="yahoo-sports-logo-white">
                    <path d="M24.0702452,5.83111111 L24.0702452,7.06666667 C23.2097927,6.0367158 21.9427054,5.46606759 20.6261035,5.51555556 C17.1389101,5.51555556 14.5428883,8.69333333 14.5428883,12.4222222 C14.5428883,16.2577778 17.1259946,19.3333333 20.6261035,19.3333333 C21.9510266,19.3980812 23.2277754,18.8131965 24.0702452,17.7555556 L24.0702452,18.9911111 L28.4184741,18.9911111 L28.4184741,5.83111111 L24.0702452,5.83111111 Z M29.9209809,0 L29.9209809,18.9911111 L34.4241962,18.9911111 L34.4241962,11.9777778 C34.4241962,10.6088889 35.0613624,9.79555556 36.0773842,9.79555556 C37.093406,9.79555556 37.6315531,10.5066667 37.6315531,11.8177778 L37.6315531,18.9911111 L42.1347684,18.9911111 L42.1347684,10.7155556 C42.1347684,7.51111111 40.4557493,5.51555556 37.7564033,5.51555556 C36.4540592,5.4661141 35.2068557,6.0603675 34.3983651,7.11555556 L34.3983651,0.00444444444 L29.9209809,0 Z M71.1129155,12.4444444 C71.1129155,16.3866667 68.1897003,19.3555556 64.293515,19.3555556 C60.3973297,19.3555556 57.4741144,16.3866667 57.4741144,12.4444444 C57.4741144,8.50222222 60.4016349,5.53777778 64.293515,5.53777778 C68.1853951,5.53777778 71.1129155,8.50666667 71.1129155,12.4444444 Z M56.7120981,12.4444444 C56.7120981,16.3866667 53.7845777,19.3555556 49.8926975,19.3555556 C46.0008174,19.3555556 43.073297,16.3866667 43.073297,12.4444444 C43.073297,8.50222222 46.0008174,5.53777778 49.8926975,5.53777778 C53.7845777,5.53777778 56.7120981,8.50666667 56.7120981,12.4444444 Z M5.68434189e-14,5.85333333 L5.44174387,19.1155556 L3.48288828,23.8977778 L8.26594005,23.8977778 L15.5201635,5.85333333 L10.7844687,5.85333333 L7.83111717,13.5733333 L4.90359673,5.85333333 L5.68434189e-14,5.85333333 Z M21.5258856,15.1511111 C20.0778762,15.1511111 18.9040327,13.9392952 18.9040327,12.4444444 C18.9040327,10.9495937 20.0778762,9.73777778 21.5258856,9.73777778 C22.9738949,9.73777778 24.1477384,10.9495937 24.1477384,12.4444444 C24.1582975,13.1655836 23.8854595,13.8603865 23.3914592,14.3703671 C22.8974589,14.8803478 22.2244277,15.1620118 21.5258856,15.1511111 L21.5258856,15.1511111 Z M52.4155313,12.4444444 C52.3942095,10.9991882 51.2457931,9.84329333 49.8457334,9.85791214 C48.4456737,9.87253095 47.3201395,11.0521694 47.3271064,12.4975752 C47.3341381,13.942981 48.4710404,15.1109435 49.8711717,15.1111111 C50.5556752,15.1211114 51.2144344,14.8420408 51.6948283,14.3385545 C52.1752222,13.8350681 52.4355617,13.150859 52.4155313,12.4444444 Z M66.8163488,12.4444444 C66.795027,10.9991882 65.6466105,9.84329333 64.2465509,9.85791214 C62.8464912,9.87253095 61.720957,11.0521694 61.7279238,12.4975752 C61.7349555,13.942981 62.8718578,15.1109435 64.2719891,15.1111111 C64.9564926,15.1211114 65.6152519,14.8420408 66.0956458,14.3385545 C66.5760396,13.8350681 66.8363791,13.150859 66.8163488,12.4444444 Z M71.6510627,16.2266667 C71.6417293,17.0311249 71.9471656,17.80545 72.4982184,18.3743287 C73.0492712,18.9432074 73.7993326,19.2585242 74.5785831,19.2488889 C76.2429617,19.2488889 77.5922071,17.855997 77.5922071,16.1377778 C77.6063278,15.3326284 77.3030257,14.5560964 76.7518547,13.9862577 C76.2006837,13.416419 75.4489316,13.102163 74.6689918,13.1155556 C73.0046133,13.1155556 71.6553678,14.5084474 71.6553678,16.2266667 L71.6510627,16.2266667 Z M78.0657766,0.0222222222 L73.2999455,11.9244444 L78.6469755,11.9244444 L83.4300272,0 L78.0657766,0.0222222222 Z" id="Shape" fill="#000000"></path>
                    <path d="M134.510954,5.48444444 C134.287017,5.41042851 134.052932,5.37440508 133.81782,5.37777778 C132.285501,5.33345562 130.885901,6.2707681 130.30049,7.73333333 L130.30049,5.69333333 L125.681035,5.69333333 L125.681035,18.9466667 L130.326322,18.9466667 L130.326322,14.12 C130.326322,11.6577778 131.432752,10.28 133.382997,10.28 C133.766741,10.2725198 134.148703,10.3357311 134.510954,10.4666667 L134.510954,5.48444444 Z M157.586703,14.7066667 C157.586703,12.56 156.174605,11.3911111 153.328883,10.5688889 L152.584087,10.36 C151.529319,10.0666667 151.120327,9.96 151.120327,9.64444444 C151.120327,9.32888889 151.400163,9.08888889 152.093297,9.08888889 C153.450345,9.14730589 154.776143,9.52749663 155.967956,10.2 L157.405886,6.72888889 C155.762922,5.84513411 153.941481,5.37314042 152.088992,5.35111111 C148.778311,5.35111111 146.522398,7.07111111 146.522398,9.85333333 C146.522398,12.2133333 147.981853,13.3511111 150.883542,14.04 L151.550845,14.2 C152.52812,14.44 152.962943,14.5733333 152.962943,14.9422222 C152.962943,15.3866667 152.532425,15.5244444 151.860817,15.5244444 C150.346116,15.4741491 148.867045,15.0374509 147.55564,14.2533333 L145.911063,17.6977778 C147.686591,18.7932991 149.72378,19.3537124 151.791935,19.3155556 C155.180109,19.3155556 157.565177,17.6444444 157.565177,14.7066667 L157.586703,14.7066667 Z M99.466812,23.8755556 L99.466812,17.5422222 C100.358,18.7173685 101.741926,19.3788009 103.186485,19.32 C106.677984,19.32 109.213733,16.2088889 109.213733,12.3244444 C109.213733,8.44 106.69951,5.32888889 103.186485,5.32888889 C101.733545,5.28164108 100.348025,5.96204577 99.466812,7.15555556 L99.466812,5.69777778 L94.7913896,5.69777778 L94.7913896,23.88 L99.466812,23.8755556 Z M99.3376567,12.32 C99.3271861,11.213905 99.9645436,10.210698 100.951431,9.77990287 C101.938319,9.34910772 103.079494,9.57595163 103.84086,10.3542665 C104.602227,11.1325813 104.833158,12.3083876 104.425573,13.3313811 C104.017988,14.3543747 103.052522,15.0221694 101.981035,15.0222222 C101.279555,15.0391913 100.60157,14.760828 100.102982,14.251141 C99.6043938,13.7414539 99.3281085,13.0443046 99.3376567,12.32 L99.3376567,12.32 Z M117.380654,5.32444444 C113.351008,5.32444444 110.3503,8.34666667 110.3503,12.32 C110.3503,16.2933333 113.363924,19.3155556 117.380654,19.3155556 C121.397384,19.3155556 124.389482,16.2933333 124.389482,12.32 C124.389482,8.34666667 121.375858,5.32444444 117.380654,5.32444444 Z M119.925028,12.32 C119.926756,13.3827901 119.307948,14.3419313 118.357325,14.7498901 C117.406702,15.1578489 116.311622,14.9342208 115.583048,14.1833503 C114.854473,13.4324797 114.635998,12.3023557 115.029563,11.3202919 C115.423128,10.338228 116.351165,9.69774364 117.380654,9.69774364 C118.055765,9.6942178 118.704284,9.9692005 119.182069,10.4616073 C119.659855,10.954014 119.927319,11.6230453 119.925028,12.32 L119.925028,12.32 Z M137.378202,1.58666667 L137.378202,5.69333333 L135.656131,5.69333333 L135.656131,9.61333333 L137.378202,9.61333333 L137.378202,14.3288889 C137.378202,17.4844444 139.17346,19.3111111 142.113896,19.3111111 C143.108761,19.3245868 144.098636,19.1637885 145.041417,18.8355556 L145.041417,14.7555556 C144.601078,14.9003846 144.142996,14.9797003 143.680981,14.9911111 C142.600381,14.9911111 142.036403,14.4888889 142.036403,13.2133333 L142.036403,9.65777778 L145.050027,9.65777778 L145.050027,5.76 L142.036403,5.76 L142.036403,1.65333333 L137.378202,1.58666667 Z M93.5342779,14.7066667 C93.5342779,12.56 92.1221798,11.3911111 89.2764578,10.5688889 L88.5316621,10.36 C87.4768937,10.0666667 87.0679019,9.96 87.0679019,9.64444444 C87.0679019,9.32888889 87.3477384,9.08888889 88.0408719,9.08888889 C89.3979195,9.14730589 90.7237182,9.52749663 91.9155313,10.2 L93.3534605,6.72888889 C91.7104967,5.84513411 89.8890562,5.37314042 88.0365668,5.35111111 C84.7258856,5.35111111 82.4699728,7.07111111 82.4699728,9.85333333 C82.4699728,12.2133333 83.9294278,13.3511111 86.8311172,14.04 L87.4984196,14.2 C88.4756948,14.44 88.9105177,14.5733333 88.9105177,14.9422222 C88.9105177,15.3866667 88.48,15.5244444 87.8083924,15.5244444 C86.2936909,15.4741491 84.81462,15.0374509 83.5032153,14.2533333 L81.8586376,17.6977778 C83.6341658,18.7932991 85.6713546,19.3537124 87.7395095,19.3155556 C91.1276839,19.3155556 93.512752,17.6444444 93.512752,14.7066667 L93.5342779,14.7066667 Z" id="Shape" fill="#999999"></path>
                </g>
            </g>
        </g>
    </g>
</svg></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC</div>
<div class='copyright-notice'>© 2021 Verizon Media. All rights reserved.</div>
</footer>
<script src="https://cdn.rivals.com/production/assets/basicFooter-f52cf31faa2fb51e14b7d11944f0f0d0be3da6cd4353a61c24a499b6101be6e7.js"></script>

</body>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PCEtLSBCZWdpbiBjb21TY29yZSBUYWcgLS0+Cgo8c2NyaXB0PgogIHZhciBf
Y29tc2NvcmUgPSBfY29tc2NvcmUgfHwgW107CiAgX2NvbXNjb3JlLnB1c2go
ewogICAgYzE6ICIyIiwKICAgIGMyOiAiNzI0MTQ2OSIsCiAgICBjNTogIjIw
MjI3MTk2NDYiLAogICAgYzc6ICJodHRwczovL2FyaXpvbmF2YXJzaXR5LnJp
dmFscy5jb20vbmV3cy9ncmlkaXJvbi1hcml6b25hLXMtMjAyMi1yZWNydWl0
aW5nLXVwZGF0ZS0xMC02IgogIH0pOwogIChmdW5jdGlvbigpIHsKICAgIHZh
ciBzID0gZG9jdW1lbnQuY3JlYXRlRWxlbWVudCgic2NyaXB0IiksIGVsID0g
ZG9jdW1lbnQuZ2V0RWxlbWVudHNCeVRhZ05hbWUoInNjcmlwdCIpWzBdOyBz
LmFzeW5jID0gdHJ1ZTsKICAgIC8vIGxvYWRpbmcgdGhlIGV2ZXJncmVlbiB2
ZXJzaW9uIG9mIGNzLmpzIHNvIHdlIGFsd2F5cyBoYXZlIHRoZSBsYXN0IHZl
cnNpb24KICAgIHMuc3JjID0gImh0dHBzOi8vcy55aW1nLmNvbS9jeC92em0v
Y3MuanMiOwogICAgZWwucGFyZW50Tm9kZS5pbnNlcnRCZWZvcmUocywgZWwp
OwogIH0pKCk7Cjwvc2NyaXB0PgoKPG5vc2NyaXB0PgogIDxpbWcgc3JjPSJo
dHRwczovL3NiLnNjb3JlY2FyZHJlc2VhcmNoLmNvbS9wP2MxPTImYzI9NzI0
MTQ2OSZjNz1odHRwcyUzQSUyRiUyRmFyaXpvbmF2YXJzaXR5LnJpdmFscy5j
b20lMkZuZXdzJTJGZ3JpZGlyb24tYXJpem9uYS1zLTIwMjItcmVjcnVpdGlu
Zy11cGRhdGUtMTAtNiZjNT0yMDIyNzE5NjQ2JmN2PTIuMCZjaj0xJmNzX3Vj
ZnI9MCIgLz4KPC9ub3NjcmlwdD4KPCEtLSBFbmQgY29tU2NvcmUgVGFnIC0t
PgoKCg==

</div>
</div>
</html>
