<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":7,"applicationTime":880,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81764304-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<script src="https://cdn.rivals.com/production/packs/js/application-1f5483b4dac8beced1ed.js"></script>
<link rel="stylesheet" media="screen" href="https://cdn.rivals.com/production/packs/css/application-d5220c95.css" />
<title>ArizonaVarsity  -  Checking in on the Champs</title>
<meta content='ArizonaVarsity  -  Checking in on the Champs' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-02eb9b5f2c94db113dfb318987ff62b83675833797c26696434b80eefa9d2109.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-542efce215d958ef91e57c7d3eeab26b0a8635016479253b92381a79e420d228.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="ui2+/rTMmikSVWxD+IM0/CJ+aShaVCQ/BlQGZD27UmvPAw8ui54Tf5zBkKm8RzOq8IHpGgX9ozDFMcVkmWn3+w==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      return {
        getPremiumIcon: getPremiumIcon
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://arizonavarsity.rivals.com/news/checking-in-on-the-champs' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/fmgio8hc8ovclfs1garx' property='og:image'>
<meta content="Many of the big names from last year are gone, but Chandler simply reloads and has it's eye on the first Open title" property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-06-30 23:58:21 -0500' property='article:published_time'>
<meta content='2019-06-30 23:58:22 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "arizonavarsity.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='arizonavarsity contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .arizonavarsity #programming > h1 {
      background-color: #000000 !important; } }
  .arizonavarsity .wrapper-container .team-colors-line {
    background-color: #edbe00; }
  .arizonavarsity .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #000000; }
    .arizonavarsity .team-colors-line .color {
      width: 33.33%; }
    .arizonavarsity .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .arizonavarsity .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .arizonavarsity .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .arizonavarsity .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .arizonavarsity .team-colors-line.header {
      height: 6px; }
  .arizonavarsity > header .notification-link .count-container {
    background-color: #000000 !important; }
  .arizonavarsity > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .arizonavarsity > header .wrapper-container {
        border-bottom: 6px solid #edbe00 !important; } }
  .arizonavarsity > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .arizonavarsity > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .arizonavarsity > header .invalid-email-banner a:hover {
      color: #edbe00; }
  @media screen and (max-width: 767px) {
    .arizonavarsity > header .mobile-header {
      background-color: #edbe00 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .arizonavarsity > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .arizonavarsity > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .arizonavarsity > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .arizonavarsity > header .nav-row > ul,
    .arizonavarsity > header .third-nav {
      background-color: white !important; }
    .arizonavarsity > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .arizonavarsity > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #edbe00; }
  
  .site-secondary-background-color {
    background-color: #edbe00; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(0, 0, 0, 0.4), rgba(0, 0, 0, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #000000;
    --secondary-color: #edbe00;
    --accent-color: #000000;
    --button-color: #000000; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false)' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Arizona HS Sports" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://arizonavarsity.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/zcfxozfifkhrsxmluop3" alt="Zcfxozfifkhrsxmluop3" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;arizonavarsity&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;arizonavarsity&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719646,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Checking in on the Champs"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='azhsfb' name='twitter:site'>
<meta content='Checking in on the Champs' name='twitter:title'>
<meta content="Many of the big names from last year are gone, but Chandler simply reloads and has it's eye on the first Open title" name='twitter:description'>
<meta content='https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/fmgio8hc8ovclfs1garx' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":6,"legacy_id":1128,"name":"ArizonaVarsity","friendly_name":"Arizona HS Sports","annual_discount":null,"subdomain":"arizonavarsity","primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","short_name":"arizonavarsity","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81764304-1"}, true, 161, nil, {"id":92,"primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"ArizonaVarsity.com","header_logo_cloudinary":"zcfxozfifkhrsxmluop3","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81764304-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":false,"other_content":true,"site_id":6,"created_at":"2016-11-23T13:38:43.400-06:00","updated_at":"2019-01-14T18:59:58.121-06:00","max_trending_articles":6,"enrichments":[{"active":false,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://arizonavarsity.forums.rivals.com","scoreboard_scores_id":15081,"scoreboard_photos_id":15082,"aol_player_id":null,"aol_company_id":null,"ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":10,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000, false, {"id":1967,"user_id":2798272,"site_id":6,"updated_at":"2018-06-24T21:51:58.853-05:00","publisher_name":"Chris Eaton","first_name":"Chris","last_name":"Eaton","site_title":"Staff","bio":null,"twitter_handle":null,"image_url":null,"publisher_name_and_title":"Chris Eaton, Staff","site_name":"ArizonaVarsity","site_short_name":"arizonavarsity","has_edited_profile":false})'>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>


<rv-message-boards ad-referer='https://arizonavarsity.rivals.com/news/checking-in-on-the-champs' base-api-url='https://arizonavarsity.forums.rivals.com/' homepage='false' message-board-url='https://arizonavarsity.forums.rivals.com' pub-ad='null' size='size' space-id='2022719646' subscribed-user='subscribedUser'></rv-message-boards>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://arizonavarsity.rivals.com/news/checking-in-on-the-champs/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-06-30 23:58:21 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2056202/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Checking in on the Champs</h2>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/poxq3xc1mudlbqpx1zxm','https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto/poxq3xc1mudlbqpx1zxm')">
<div class='blurred-image image-with-caption'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/poxq3xc1mudlbqpx1zxm)'></div>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/poxq3xc1mudlbqpx1zxm" alt="Poxq3xc1mudlbqpx1zxm" />
<div class='zoom-image'></div>
</div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Chandler linebacker Jaheim Brown-Taylor makes a move during the Wolves' semfinal playoff game last season.  He rushed for 755 yards as a junior for CHS.</figcaption>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='author-name'>
Chris Eaton
&bull;
</span>
<span class='type-sm'>ArizonaVarsity</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>Staff</span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><h3 class='article-heading'>Defending 6A state champion Chandler hits reset</h3>
<div class='st__content-block st__content-block--text article-text'>
<p> <b>WEEKLY BLOG: 6/30/19</b> </p><p>When we last saw the Chandler Wolves under the bright lights of the playoffs, it was DeCarlos Brooks rushing for six touchdowns in a 65-28 victory over district rival Perry. In the round before that, it was the gutsy decision by head coach Shaun Aguano to go for two in overtime against Highland. When Jacob Conover completed the conversion attempt to Brayden Liebrock, it raised the three-year starting QB's record to 34-4 (he added one more to that win total in the title game).</p><p>And now, as we look forward to the 2019 season. . . . all those guys are gone.</p><p>Brooks will be suiting up for Cal as part of a six-pack of recruits the Golden Bears secured from the '19 class. Conover, currently on a church mission, will be at BYU when he returns. Liebrock, who finished with 11 touchdowns, joins Notre Dame's Jake Smith as Texas won out for two of Arizona's biggest recruits. Even Aguano has moved on, and is already making a big impact. As Arizona State's new running backs coach, he secured a commitment from Ohio's top back, DeaMonte Trayanum, earlier this week.</p><p>So, after three consecutive state titles (and four in five years), is this the break everyone else has been waiting for? A chance to catch the Wolves in a down year?</p><p>Don't go writing off Chandler quite yet.</p><p>"We have a lot of players and a lot of talent," new head coach Rick Garretson said. "This will be the fastest and most talented team since I've been at Chandler."</p><p>That's saying something, because Garretson has been with the Wolves' program since 2010. He began working with the quarterbacks and was the passing game coordinator and co-offensive coordinator the past three seasons.</p><p>Chandler returns five players on defense and four on offense. Three of the offensive returners are linemen, an area of the team in which consistency is the key. Moving from the inside out, center <b>Tevainui Neher</b> started as a sophomore last year. He'll be joined by seniors <a href="https://n.rivals.com/content/prospects/2020/nehemiah-magalei-211148">Nehemiah Magalei</a> (OG) and <b>Alexis Castro</b> (OT).</p><p><a href="https://n.rivals.com/content/prospects/2021/mikey-keene-255589">Mikey Keene</a> is the Wolves' new starting quarterback. Those that check MaxPreps will see that he attempted just 10 varsity passes last year (completing nine). But, he had a year to learn while watching Conover. Plus, the last time he was taking the snaps, Keene had a lot of success. As the starter of the 2017 freshman team, he threw 32 touchdown passes and led the Wolves to a 9-0 record while averaging 44.8 points per game.</p><p>"He's got a very good pocket awareness," Garretson said. "He's the best thrower on the run that we've had since I've been at Chandler."</p><p>Keene had a very good summer. He was named the MVP for the passing tournament at Northern Arizona in June. Chandler employs the same playbook for 7-on-7 that it will use for 11-on-11 when the season starts.</p><p>Here's Keene completing a pass to fellow junior <b>Jalen Richmond</b> in the Scottsdale Tournament last May.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Chandler Class of 2021 QB <a href="https://twitter.com/MikeyKeene1?ref_src=twsrc%5Etfw">@MikeyKeene1</a> tosses a dime to his WR right at the pylon for a <a href="https://twitter.com/FTBL_Boosters?ref_src=twsrc%5Etfw">@FTBL_Boosters</a> TD in today’s 7 on 7 tournament <a href="https://twitter.com/GarretsonRick?ref_src=twsrc%5Etfw">@GarretsonRick</a> <a href="https://t.co/hLUDKxi0Ya">pic.twitter.com/hLUDKxi0Ya</a></p>&mdash; Cody Cameron (@CodyTCameron) <a href="https://twitter.com/CodyTCameron/status/1132401700118024192?ref_src=twsrc%5Etfw">May 25, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>One constant in Chandler's state championship run has been production at the running back position. Brooks rushed for 2,229 yards making it the third straight year that one of the team's backs broke the 2,000-yard barrier (along with TJ Green and Drake Anderson). <a href="https://n.rivals.com/content/prospects/2020/jaheim-brown-taylor-216162">Jaheim Brown-Taylor</a> gained 755 yards in just 86 carries (8.8 yds/attempt) as the backup running back. He has offers from six schools including New Mexico State, San Diego State, and Wyoming.</p><p>"He's a 10.4 100-meter guy," Garretson said of Brown-Taylor. "You can tell he's a weight room guy. His film shows his explosive speed."</p><p>Brooks toted the rock on 57 percent of the Wolves' running plays last year. Brown-Taylor may have to share the load a little more, particularly in the second half of the season.</p><p>The deep backfield also includes <b>Nicolas Nesbitt</b>, who averaged 8.6 yards per carry in his 39 attempts and scored seven touchdowns. Nesbitt was the state runner up in the long jump last spring as a sophomore. <b>Rodney Clement</b> is another junior that will get opportunities. Finally, a big transfer moved over to Chandler with <b>Eli Sanders</b>. Sanders rushed for 878 yards and nine touchdowns as a sophomore at Mountain Pointe last season. He'll have to sit the first five games due to the AIA transfer rule, but will then have a season and a half to shine for the Wolves.</p><p>A total of 70 percent of the pass receptions last season were caught by seniors. More speed is present in this area led by <a href="https://n.rivals.com/content/prospects/2022/quaron-adams-248197">Quaron Adams</a>, who starred for the freshman team last year (which went 9-0 and flat out dominated). Adams also won the Division I title in the 100-meters last May.</p><p>"He's a Tyreke Hill of high school ball," Garretson said. "You can put him anywhere. Quaron is electric with the ball in his hands."</p><p>Another one of the go-to guys this summer was Richmond. There is depth at this position as well with <a href="https://n.rivals.com/content/prospects/2022/kyion-grayes-234890">Kyion Grayes</a>, who already has four offers after his freshman year, including both Arizona and Arizona State. Another player from the '22 class is <a href="https://n.rivals.com/content/prospects/2022/nason-coleman-248196">Nason Coleman</a>, who holds offers from ASU and BYU. Junior <b>Eli Swope</b> plays H-back and recently had a solid performance at a Vanderbilt camp. Senior tight end <b>Jay McEuen</b> (who is 6-4) rounds out the group.</p><p>The defense has two players that have already committed to Big Ten schools. <a href="https://n.rivals.com/content/prospects/2020/gunner-maldonado-211080">Gunner Maldonado</a> will be going to Northwestern and <a href="https://n.rivals.com/content/prospects/2020/malik-reed-225502">Malik Reed</a> is headed for Wisconsin following his senior season.</p><p>Maldonado was the rare Chandler player that saw time on both sides of the ball last year. He had a big season with 782 receiving yards and eight touchdowns in just eight games. His year ended a couple weeks before the playoffs with a labrum tear. Garretson said Maldonado will definitely be on the defensive side of the ball (as a safety), but time will tell if he's used on offense again. As noted above, there is a lot of depth at the receiving positions.</p><p>The secondary will include junior <b>Kentrell Williams Jr.</b> and senior <a href="https://n.rivals.com/content/prospects/2020/ramone-robinson-237816">Ramone Robinson</a>. Both saw significant playing time last year.</p><p>And another of those '22 kids is already making plays as <b>Franky Morales</b> picked off a pass in the Wolves' San Diego State tournament earlier this month.<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr"><a href="https://twitter.com/AZHSFB?ref_src=twsrc%5Etfw">@AZHSFB</a> Chandler DB F Morales reading the QB and snatchin this pass in the SDSU passing tournament.. <a href="https://t.co/CEh8lsDVZZ">pic.twitter.com/CEh8lsDVZZ</a></p>&mdash; Chilly Batson (@JUSTCHILLY) <a href="https://twitter.com/JUSTCHILLY/status/1140087356965310464?ref_src=twsrc%5Etfw">June 16, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Chandler had success over the summer with their linemen winning the <a href="https://arizonavarsity.rivals.com/news/inaugural-makoa-big-man-challenge">Makoa Big Man Challenge</a>. The skill position players won the NAU tournament and reached the finals in San Diego.</p><p>"We always tell the kids that this is a way to evaluate and see how we compete," Garretson said of the June non-padded events. "We saw very good improvement in each tournament."</p><p>It's also worth noting that Chandler defeated Chaparral three times over the summer after getting eliminated by the Firebirds in the Scottsdale tournament. Also, CHS took all four of its meetings with Pinnacle, one of the state's top contenders for the new Open Division championship.</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/akzvobcrv1aobpi3fe0y','https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto/akzvobcrv1aobpi3fe0y')">
<div class='blurred-image image-with-caption'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/akzvobcrv1aobpi3fe0y)'></div>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/akzvobcrv1aobpi3fe0y" alt="Akzvobcrv1aobpi3fe0y" />
<div class='zoom-image'></div>
</div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>From left to right, Chandler offensive linemen Micah Lutu, Tevainui Neher, and Alexis Castro competed in the Makoa Big Man Challenge in Chandler earlier in June.  Lutu and Neher are guards and Castro is a tackle. (Photo by Ralph Amsden)</figcaption>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>There aren't any 4-year starters on the Wolves as the team opts to keep their freshmen together and then call some up for the playoffs. Magalei, Maldonado, and linebacker <a href="https://n.rivals.com/content/prospects/2020/tate-romney-211079">Tate Romney</a> will all be three-year starters this season. Romney is the team's returning leader in tackles with 92 last year.<br></p><p>Chandler will head back to Flagstaff from July 8-11 for a camp. They'll practice three times a day (one is special teams) and have high-tempo competitions, which will be light on the 7-on-7 work after the busy summer.</p><p>For the seventh year in a row, Chandler will take on out-of-state competition. The Wolves open the season on Aug. 23 just outside Las Vegas when they travel to take on Liberty. The Patriots may be familiar to fans of high school football in Arizona. They defeated Saguaro each of the past two years. Chandler will also play in California on Sept. 14 against Capital Christian, a school in Sacramento that went 13-1 and played in a CIF bowl game last season.</p><p>So when the dust settles, we'll see if the younger players at Chandler are ready to carry on what has been laid before them. The postseason competition will be ramped up as the best teams in 5A and 4A will likely be represented in the new Open tournament.<br></p><p>"It's a great program to be associated with," Garretson said. "Shaun has built it up and we just want to keep it going from there."<br></p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Solid work ALL DAY... NAU PASS CHAMPS! <a href="https://twitter.com/hashtag/WORRYABOUTUS?src=hash&amp;ref_src=twsrc%5Etfw">#WORRYABOUTUS</a> <a href="https://twitter.com/hashtag/WEATTACKSUCCESS?src=hash&amp;ref_src=twsrc%5Etfw">#WEATTACKSUCCESS</a> <a href="https://t.co/0AI74IWzU7">pic.twitter.com/0AI74IWzU7</a></p>&mdash; Coach G (@GarretsonRick) <a href="https://twitter.com/GarretsonRick/status/1137557129219284992?ref_src=twsrc%5Etfw">June 9, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://arizonavarsity.rivals.com/news/checking-in-on-the-champs/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' scoreboard-photos-id='15082' scoreboard-scores-id='15081' site='{"id":6,"legacy_id":1128,"name":"ArizonaVarsity","friendly_name":"Arizona HS Sports","annual_discount":null,"subdomain":"arizonavarsity","primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","short_name":"arizonavarsity","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81764304-1"}' twitter-feed='{"id":6,"site_id":6,"handle":"azhsfb","list_name":"Arizona-Varsity","created_at":"2016-02-01T12:24:39.964-06:00","updated_at":"2018-08-16T01:52:12.473-05:00","hashtags":[],"usernames":["AZHSFB","ArizonaVarsity","GreggRosenberg1"],"max_number":5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://arizonavarsity.rivals.com/news/checking-in-on-the-champs/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719646', 'https://arizonavarsity.rivals.com/news/checking-in-on-the-champs');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Checking in on the Champs";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("arizonavarsity", 2056202, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
</div>
</div>

</div>
</main>
<div data-react-class="Footer/container" data-react-props="{}"></div>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719646",
    c7: "https://arizonavarsity.rivals.com/news/checking-in-on-the-champs"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fchecking-in-on-the-champs&c5=2022719646&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
