<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","errorBeacon":"bam-cell.nr-data.net","licenseKey":"def25c5cff","applicationID":"282811705,282811706","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":1058,"agent":""}</script>
<script>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</script>
<script src='https://cdn.rivals.com/production/assets/window_name-426a8929f8d33048988258b1fc9ba7fa371d790b3661496339ffb6f2b1141c3f.js'></script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='stage.guce.rivals.com' name='oath:guce:consent-host'>
<meta content='true' name='oath:guce:report-only'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<rv-google-analytics google-analytics-id='UA-81764304-1' ng-hide></rv-google-analytics>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-17665c085dfaf620c961e1c0ddea354a20565cd5002add288461398e9f21d1eb.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansCondFonts-74c0340099b3ec93e18951b2b059a74493c5db2e72ef7acd1cf1c42a6e4a523d.css' rel='stylesheet'>
<title>ArizonaVarsity  -  Gridiron Arizona&#39;s 2021 Recruiting Update: 1/30</title>
<meta content='ArizonaVarsity  -  Gridiron Arizona&#39;s 2021 Recruiting Update: 1/30' property='og:title'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2021 class' name='description'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-218e41258ee18a40f5345df930e873d31d877c0356339993bdbdc548c034196c.css" />


<script src="https://cdn.rivals.com/production/assets/lib-6c022b93a90b8980b59dc8365df99c024fc31b928721a316b58736a1fa13e26e.js"></script>
<script src='/javascript/config.js'></script>
<script src="https://cdn.rivals.com/production/assets/application-06f28590aea85dfffdaf49d43c4b17b494bf7ac111a2691dd0eeb86a296d5ffc.js"></script>

<script src='/javascript/url_factory.js'></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="Y1VkvULgI7ka4pXeBg5VEVwTmbEpnXp2DrseJNL04d1aC6A2FRse2+q4ZEkuHF0oHQ5dwuzXDCa0rOo54C1ikw==" />
<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-fdff72b91f19d75cf51d8bdb22cf7f1c7435213329db92847ab8cd17911cc566.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-171b5725637bfa4769cee9b7c9352a74b2ba24d525be5b720e267e8adf48012c.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-1-30' property='og:url'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/iiyac1fove9ypewf21r2' property='og:image'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2021 class' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2021-01-31 01:29:07 -0600' property='article:published_time'>
<meta content='2021-01-31 01:29:08 -0600' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-79d2adbade85e1e68905ea1a26278770384c72769e302a0dae0424b3991cb8c0.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-fad0448de054b018c1fb496c82e4d147e36e025324f6097d939a6223773c6408.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-d83a481672df92fa565a3c3e4490fe8538a8cca8f2f6c8bc04b4e003da9c1f95.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-dde27fd6889cda35c548e8f311394eb5ad38fd060061150fb984469c56db0a8d.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-1b293697db4809dca023fcaee39f7266c5278095067b8f6c8edb1bcc1cf9029a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-160b06011cecdf794bd4037752e257bf4272d38e105b58b8b63ff4e510d25a7a.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-b53ef0fb1afaa6ee435ba26728402dd43f9f2853b6a2932fa7d9fb70fc5e35ce.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-95c2973fbaef93d4c790667ba039b95898451bb04f5b2b399071e6483347812d.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-a223232b426f12e2f04f4a3aecf49f46b9e0a79cd886e7a210e0cdf5ad5bd024.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-a217ac85d423e19cbde56dcf9b01630789a023d0509d6fa0880bd5da15cc22d1.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-894aa91cf9d624f18d121145468a0bb30395f01d70de0dbf67742b95de46cfd2.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-b0f9dfc4ee4c3780ac01665cf518b0b20ec78f58b81349f7cbcf715820137ac3.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-8ab5e15036ae6a8e5c073b018e034b9e1d8b57c0445d930c005e3bbd54bdf23e.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-c5cfe3c55f53109b71f4a7ed03d0ff07134dc883a367e64241c5c595468da9bb.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-4bf9998442db4c04360a1612c42ca4e1aeff88b16510ab66fc9275af3e694668.json' rel='manifest'>
<rv-chartbeat-config-header ng-hide subdomain='arizonavarsity.rivals.com'></rv-chartbeat-config-header>

</head>
<body class='arizonavarsity contents-show' ng-app='rivals'>
<rv-google-analytics google-analytics-id='UA-81764304-1' ng-hide></rv-google-analytics>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .arizonavarsity #programming > h1 {
      background-color: #000000 !important; } }
  
  .arizonavarsity .wrapper-container .team-colors-line {
    background-color: #b87333; }
  
  .arizonavarsity .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #000000; }
    .arizonavarsity .team-colors-line .color {
      width: 33.33%; }
    .arizonavarsity .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .arizonavarsity .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .arizonavarsity .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .arizonavarsity .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .arizonavarsity .team-colors-line.header {
      height: 6px; }
  
  .arizonavarsity > header .notification-link .count-container {
    background-color: #000000 !important; }
  
  .arizonavarsity > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .arizonavarsity > header .wrapper-container {
        border-bottom: 6px solid #b87333 !important; } }
  
  .arizonavarsity > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .arizonavarsity > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .arizonavarsity > header .invalid-email-banner a:hover {
      color: #b87333; }
  
  @media screen and (max-width: 767px) {
    .arizonavarsity > header .mobile-header {
      background-color: #b87333 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  
  .arizonavarsity > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  
  .arizonavarsity > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  
  .arizonavarsity > header .second-nav {
    background-color: white !important; }
  
  @media screen and (max-width: 1023px) {
    .arizonavarsity > header .nav-row > ul,
    .arizonavarsity > header .third-nav {
      background-color: white !important; }
    .arizonavarsity > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  
  .arizonavarsity > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #b87333; }
  
  .site-secondary-background-color {
    background-color: #b87333; }
  
  :root {
    --primary-color: #000000;
    --primary-color-overlay: rgba(0, 0, 0, .4);
    --secondary-color: #b87333;
    --accent-color: #000000;
    --button-color: #000000;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init("arizonavarsity")' role='navigation'>
<div class='wrapper-container'>
<div class='wrapper logo-row'>
<a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-black'></div>
</a><a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
<a alt="Arizona HS Sports" class="site-header logo-image-wrapper" href="https://arizonavarsity.rivals.com/"><img src="https://images.rivals.com/image/upload/f_auto,q_auto/jfx2ba0nx7j1blby9bv1" />
</a><div class='nav-right-controls'>
<div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
<span class='upsell-text'>
Join the team!
</span>
<div class='subscribe-button' ng-click='ctrl.subscribeEvent()'>
Subscribe
</div>
</div>
<rv-universal-search></rv-universal-search>
<rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
<rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
</div>
</div>
</div>
<div class='mobile-header'></div>
<rv-header-alert class='alert-nav'></rv-header-alert>
<hr>
<div class='nav-row-container'>
<div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="8"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="4"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
<a ng-href='{{ctrl.userProfileEditPath}}'>
Your account has an invalid email address. Please update it here.
</a>
</div>
</div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script src='/javascript/ad_beacon.js?path=content&space_id=2022719646' type='text/javascript'></script>

<rv-content-title content-title='Gridiron Arizona&#39;s 2021 Recruiting Update: 1/30' ng-hide='true'></rv-content-title>
<meta content='summary_large_image' name='twitter:card'>
<meta content='ArizonaVarsity' name='twitter:site'>
<meta content='Gridiron Arizona&#39;s 2021 Recruiting Update: 1/30' name='twitter:title'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2021 class' name='twitter:description'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_large/iiyac1fove9ypewf21r2' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {&quot;id&quot;:6,&quot;legacy_id&quot;:1128,&quot;name&quot;:&quot;ArizonaVarsity&quot;,&quot;friendly_name&quot;:&quot;Arizona HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;arizonavarsity&quot;,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;arizonavarsity&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;}, true, 161, nil, {&quot;id&quot;:92,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;commitment_module_football&quot;:true,&quot;rivals_module_football&quot;:true,&quot;header_name&quot;:&quot;ArizonaVarsity.com&quot;,&quot;header_logo_cloudinary&quot;:&quot;jfx2ba0nx7j1blby9bv1&quot;,&quot;mobile_header_logo_cloudinary&quot;:&quot;lt4xm3i1vhxzczdsev3e&quot;,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;,&quot;logo_background_shading&quot;:&quot;black&quot;,&quot;football_content&quot;:true,&quot;basketball_content&quot;:true,&quot;baseball_content&quot;:true,&quot;other_content&quot;:true,&quot;site_id&quot;:6,&quot;created_at&quot;:&quot;2016-11-23T13:38:43.400-06:00&quot;,&quot;updated_at&quot;:&quot;2020-06-25T15:45:51.480-05:00&quot;,&quot;max_trending_articles&quot;:6,&quot;enrichments&quot;:[{&quot;active&quot;:false,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;TeamRankings&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Rivals&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardScores&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Commitment&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Schedule&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardPhotos&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;FanFuturecastLeaderboard&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;RecentForecasts&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null}],&quot;footer_text&quot;:null,&quot;sections&quot;:[],&quot;supplied_domain&quot;:null,&quot;forums_link_url&quot;:&quot;https://arizonavarsity.forums.rivals.com&quot;,&quot;scoreboard_scores_id&quot;:15081,&quot;scoreboard_photos_id&quot;:15082,&quot;aol_player_id&quot;:null,&quot;aol_company_id&quot;:null,&quot;ad_frequency&quot;:5,&quot;display_twitter_follow&quot;:true,&quot;display_fb_follow&quot;:true,&quot;follow_twitter_handle&quot;:&quot;ArizonaVarsity&quot;,&quot;follow_fb_handle&quot;:&quot;arizonavarsity&quot;,&quot;forum_id&quot;:null,&quot;premium_forum_id&quot;:null,&quot;facebook_page_id&quot;:null,&quot;max_ticker_articles&quot;:12,&quot;schedule_header_on&quot;:false,&quot;promo_popup_on&quot;:false,&quot;facebook_developer_id&quot;:null,&quot;customized_tos&quot;:[],&quot;show_survey_popup&quot;:false,&quot;survey_popup_link&quot;:null,&quot;header_bottom_border_style&quot;:null,&quot;customized_upsell_banner_text&quot;:null,&quot;email_logo_cloudinary&quot;:null,&quot;target_list_on&quot;:null,&quot;gifting_banner_content&quot;:&quot;Give a Rivals gift subscription this holiday season&quot;,&quot;gifting_banner_title&quot;:&quot;The perfect gift for football recruiting fans!&quot;,&quot;gifting_banner_button_text&quot;:&quot;Give a gift subscription&quot;},
&quot;58e686759efa8936610b8215&quot;, &quot;58e68374c7480e728bcc385f&quot;, &quot;rivals&quot;, 15000,
false, {&quot;id&quot;:1967,&quot;user_id&quot;:2798272,&quot;site_id&quot;:6,&quot;updated_at&quot;:&quot;2018-06-24T21:51:58.853-05:00&quot;,&quot;publisher_name&quot;:&quot;Chris Eaton&quot;,&quot;first_name&quot;:&quot;Chris&quot;,&quot;last_name&quot;:&quot;Eaton&quot;,&quot;site_title&quot;:&quot;Staff&quot;,&quot;bio&quot;:null,&quot;twitter_handle&quot;:null,&quot;image_url&quot;:null,&quot;publisher_name_and_title&quot;:&quot;Chris Eaton, Staff&quot;,&quot;site_name&quot;:&quot;ArizonaVarsity&quot;,&quot;site_short_name&quot;:&quot;arizonavarsity&quot;,&quot;has_edited_profile&quot;:false}, null)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{&quot;no-ad-padding&quot;: &quot;#{@display_ldrb_top}&quot;}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode' site_name='ArizonaVarsity'></rv-news-ticker>
</div>

<rv-forums ad-referer='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-1-30' base-api-url='https://arizonavarsity.forums.rivals.com/' forums-url='https://arizonavarsity.forums.rivals.com' homepage='false' pub-ad='null' size='size' space-id='2022719646' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='article-display-wrapper'>
<div class='mobile-ad native-ad-ccc25e1a-d33c-46c9-a14a-96144b7a8b28'></div>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-1-30/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo(&#39;2021-01-31 01:29:07 -0600&#39;) }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2244248/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h1 class='article-title'>Gridiron Arizona&#39;s 2021 Recruiting Update: 1/30</h1>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/iipreqx44dat5uux25hx&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/iipreqx44dat5uux25hx&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Photo Courtesy of 5 Hive Photo/David McBee" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/iipreqx44dat5uux25hx" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Photo Courtesy of 5 Hive Photo/David McBee</figcaption>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<div>
<span class='author-name'>
Chris Eaton
&bull;
<span class='type-sm'>ArizonaVarsity</span>
</span>
<div>
<span class='author-name'>Staff</span>
</div>
</div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>

<div class='mobile-ad'>
<div class='native-ad-50d38545-0eeb-4c35-9393-b22cf70b9e3d'></div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><h3 class='article-heading'>Bethany offers offensive guard Corniea from Alhambra</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>UPDATED: 1/30/21</b></p><p>Colleges across the nation continue to take notice of the prep talent in Arizona each season. More than 350 players from the Class of 2020 signed with schools to advance their football careers, and receive an education.</p><p>Bethany College in Kansas continues to reach out to Arizona for future players. On Saturday, it was to Alhambra and offensive guard <b>Thomas Corniea</b>. It is the third offer for the 5-10, 257-pound lineman, who is a hard worker and made the most of limited opportunities as a senior. He was only able to get film in on two games last season as AHS is in the Phoenix Union District and was not able to start as early as much of the Valley. Bethany played five games last fall (1-4 record) and will have five more in the spring. The Swedes are in the Kansas Collegiate Athletic Conference (NAIA) and have a new offensive coordinator. Chris Snyder returns to Bethany after serving as the offensive coordinator at Saint Mary (Kans.). He was previously with the Swedes for four years.<br></p><p>Here's the rest of the offers from Saturday:</p><p>Marcos de Niza center Enrique Ruiz received an offer from Concordia College (Minnesota).<br>Tucson linebacker Martin Barreras received an offer from Ottawa.<br></p><p>This list shows four-year college offers received by seniors throughout the state. It's not limited to just 6A and 5A. It will be constantly updated as we approach National Signing Day on February 3. That is the next day that high school seniors can sign a letter of intent to agree to attend an institution.</p><p>Verbal commitments are shown in bold.</p>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p> <b>CLASS OF 2021 OFFERS</b></p><p>Oscar Abundis Jr. - Centennial (OT): Benedictine (Kans.), Colorado Mesa, Concordia Coll. (Minn.), Concordia Univ. (Ill.), Eastern New Mexico, Jamestown, Simpson, Wisconsin-River Falls<br></p><p>Rashon Adams - Centennial (CB): Abilene Christian, <b>GEORGETOWN</b>, South Dakota State<br></p><p>Sebastian Adamski - Walden Grove (LB): Beloit, Concordia Coll. (Minn.), Cornell Coll. (Iowa), <b>DRAKE</b>, Lake Forest, Luther, Pacific, Southwestern, St. Olaf, Whittier</p><p>Jayden Ahboah - Desert Edge (OG): Arizona Christian, Benedictine (Kans.), Concordia Coll. (Minn.), Culver-Stockton, <b>FORT LEWIS</b>, Livingstone, Mayville State, MidAmerican Nazarene, Morgan State, Ottawa, Ripon, Simpson, St. Olaf, Western New Mexico, Whittier</p><p>Eman Alaniz - Parker (RB): Buena Vista, Western New Mexico<br></p><p>Ammon Allen - Highland (FS): Air Force, Arizona, Army, Eastern Michigan, Idaho, Morehead State, Navy, New Mexico State, Northern Arizona, South Dakota State<br></p><p>Adrian Alvarado - Walden Grove (K/P): Clarke, Concordia Coll. (Minn.), Cornell Coll. (Iowa), Culver-Stockton, Luther, McPherson, MidAmerica Nazarene, Millikin, Nebraska Wesleyan, New Mexico Highlands, Otterbein, Saint John's (Minn.), Simpson, Southwest Minnesota State, Trine, Western New Mexico<br></p><p>Anthony Ament - Pinnacle (RB): <b>OREGON (PREFERRED WALK-ON)</b>, Wisconsin-River Falls</p><p>Braxton Anderson - Williams Field (CB): Buena Vista, Concordia Coll. (Minn.), Hamline, Jamestown, Nebraska Wesleyan, Puget Sound, Simpson<br></p><p>Elijah Anderson - Sunrise Mountain (CB): Arizona Christian, Benedictine (Kans.), Culver-Stockton, <b>EASTERN NEW MEXICO</b>, Nebraska Wesleyan, Simpson, Wisconsin-River Falls</p><p>Brian Angeles - Trevor Browne (K/P): Clarke, Missouri Valley<br></p><p>Raife Anthony - Canyon del Oro (CB): Aurora, Hamline, Luther, Nebraska Wesleyan, Simpson, Wooster<br></p><p>Joseph Armstrong - Walden Grove (CB): Albright, <b>CARROLL</b>, Concordia Univ. (Ill.), Culver-Stockton</p><p>Tommy Arnold - Sunrise Mountain (LB): Arizona Christian, Benedictine Coll. (Kans.), McPherson, Presentation, Simpson<br></p><p>Albin Arulanandu - Mountain Ridge (CB): Bowdoin, Carleton, Concordia Coll. (Minn.), Grinnell, Kenyon, <b>LAKE FOREST</b>, Nebraska Wesleyan, Puget Sound, Washington &amp; Lee, Wisconsin-River Falls, Wooster</p><p>Jace Atkins - Lake Havasu (LB): Avila<br></p><p>AJ Auau - Agua Fria (DT): Arizona Christian, Benedictine (Kans.), Luther, Ohio Northern<br></p><p>Dominic Avant - Buena (OT): Avila, Dakota State, McPherson, MidAmerica Nazarene, <b>SIOUX FALLS (PREFERRED WALK-ON)</b>, Tabor, Trine</p><p>Sardar Azeez - Chaparral (OG): Benedictine Coll. (Kans.), Ottawa<br></p><p>Carson Bachmann - Basha (WR): Buena Vista, Concordia Coll. (Minn.), Concordia Univ. (Ill.), Dakota State, Nebraska Wesleyan, Northern State (preferred walk-on), Southwest Minnesota State, <b>WESTERN NEW MEXICO</b><br></p><p>Trae Baker - San Tan Charter (WR): Arizona Christian, Avila, Bethany (Kans.), Southwestern (Kans.)<br></p><p>Ethan Ball - San Tan Charter (C): La Verne, Lake Forest<br></p><p>Damirion Barber - Sierra Linda (WR): Dickinson State, Peru State, Rocky Mountain<br></p><p>Heriberto Barnett - Nogales (CB): Beloit, Culver-Stockton, Kalamazoo, Luther, McPherson, Millikin, St. Norbert, Trinity International, Westminster (Mo.)<br></p><p>Andrell Barney - Basha (CB): Hawaii, Montana State-Northern, Nevada, Nebraska Wesleyan, <b>NEW MEXICO</b>, New Mexico State, Northern Arizona, Southern Utah, Washburn</p><p>Martin Barreras - Tucson (LB): Bethany Coll. (Kans.), Culver-Stockton, Ottawa<br></p><p>Hunter Barth - Queen Creek (FS): Arizona, Boise State, <b>CALIFORNIA</b>, Duke, Idaho, Iowa State, Northern Arizona, Oklahoma State, Oregon, Pittsburgh, San Diego State, Tulane, UCLA, UNLV, USC, Utah, Virginia, Washington State, Yale</p><p>Derek Bass - Basha (K): Culver-Stockton, Hamline, McPherson, Southwestern, Whittier</p><p>William Bastman - Brophy (DE): Bowdoin<br></p><p>Josh Baxter - Saguaro (RB): Concordia Coll. (Minn.), Lake Forest</p><p>Daniel Becerra - Tucson (WR): Chardron State, Dakota State, Hamline, Southwest Minnesota State, Wagner (preferred walk-on), Western New Mexico, Wisconsin-River Falls<br></p><p>Jaquel Bell - Glendale (WR): Arizona Christian, Mayville State, Wisconsin-River Falls</p><p>John Beltran - Cibola (RB): Albright, Arizona Christian</p><p>Zach Bennett - Coconino (RB): Adams State, Arizona Christian, Bethany Coll. (Kans), Carroll Univ. (Wisc.), Clarke, Culver-Stockton, DePauw, Friends, Hiram, Luther, McPherson, Minnesota Morris, Pacific Lutheran, Simpson, St. Norbert, Whittier, Wooster<br></p><p>Isaac Benoit - Buena (RB): Arizona Christian, Carthage, Concordia Univ. (Ill.), Cornell Coll. (Iowa), Culver-Stockton, Lewis &amp; Clark, Oberlin, Simpson, <b>SIOUX FALLS (PREFERRED WALK-ON)</b>, St. Olaf, Trinity International, Whittier</p><p>Skyler Bergen - Carl Hayden (OT): VMI (preferred walk-on)<br></p><p>Cade Berger - Perry (WR): <b>AIR FORCE</b>, Northern Arizona</p><p>Alec Bernardo - Pinnacle (OG): Buena Vista, Carthage, Concordia Coll. (Minn.), George Fox, Graceland, Heidelberg, Lake Forest, Lewis &amp; Clark, Oberlin, Ottawa, Ripon, Simpson, St. Norbert, Wheaton, Whittier, Whitworth, Wisconsin-River Falls</p><p>Austin Bilski - Verrado (S): Concordia Coll. (Minn.), Puget Sound, Saint John's (Minn.), Trine, Willamette</p><p>Zach Blackwood - Desert Edge (DE): <b>NORTHERN ARIZONA</b>, Valparaiso</p><p>Jackson Boersma - O'Connor (K): Gustavus Adolphus<br></p><p>Desmond Bohannon - North Canyon (FS): Carthage, Clarke, La Verne, Ottawa<br></p><p>Cannon Booker - Highland (LB): Arizona Christian, Brevard, Buena Vista, Jamestown, Nebraska Wesleyan, Presentation, Sterling, Tabor, Whittier<br></p><p>Alex Boyle - Centennial (LB): Culver-Stockton, Puget Sound, <b>SIMPSON</b><br></p><p>Joseph Boyle - Arcadia (DT): Concordia Coll. (Minn.), Ottawa<br></p><p>Bubba Brandel - Lake Havasu (LB): St. Francis (Ill.)<br></p><p>Zeke Branham - Skyline (LB): Abilene Christian, Air Force, Army, Ball State, Columbia, Dartmouth, Eastern Michigan, <b>FRESNO STATE</b>, Georgetown, Holy Cross, Lehigh, Montana State, New Mexico, New Mexico State, Northern Arizona, Oregon (preferred walk-on), Penn, Princeton, UC Davis, UNLV, Valparaiso, Washington (preferred walk-on), Yale</p><p>Adam Brauer - Sabino (DT): Benedictine (Kans.)<br></p><p>Austin Brenn - Perry (OG): Buena Vista, <b>JAMESTOWN</b><br></p><p>Tony Brewer - Chandler (FS): Benedictine (Kans.), Colorado School of Mines, <b>DRAKE</b>, St. Thomas (Minn.), Western New Mexico</p><p>Diamonte Bright - Desert Ridge (SS): Benedictine (Kans.), Mayville State, Ottawa, <b>SIOUX FALLS</b>, Whittier</p><p>Dom Brister - Centennial (CB): Eastern New Mexico</p><p>Jimmy Brooks - Poston Butte (WR): Carthage, Southwest Minnesota State<br></p><p>Alfonzo Brown - Gila Ridge (LB): <b>TABOR</b><br></p><p>Cooper Brown - Highland (DE): Black Hills State, Eastern New Mexico, Southwest Baptist<br></p><p>Dalton Brown - Williams Field (DT): Mary<br></p><p>Derrick Brown - Queen Creek (OT): Idaho, Incarnate Word, <b>SOUTH DAKOTA STATE</b>, Tarleton State</p><p>Dylan Brown - Cactus Shadows (DE): Mayville State, Ottawa<br></p><p>Trey Brown - Arcadia (LB): Colorado State, Delaware State, <b>DUKE</b>, Eastern Washington, Georgetown, Hawaii, Montana State, Nevada, New Mexico, Northern Arizona, San Diego State, Tulane, UNLV, Utah State, Washington State</p><p>Yani Brown - Empire (WR): Ottawa<br></p><p>Ron Bruce - Mountain View (CB): Rocky Mountain<br></p><p>Rocco Bruney - Glendale (QB): Arizona Christian, Heidelberg, Ottawa<br></p><p>Alexander Bruns - Hamilton (OT): <b>COLORADO MESA</b>, Erskine, Mary, Northwestern Oklahoma State, Southwest Minnesota State, William Jewell</p><p>Naz Bryant - Red Mountain (RB): Eastern New Mexico, Northern State, Western Colorado<br></p><p>Brandon Buckner - Chandler (DE): Arizona, Arizona State, Colorado, Fresno State, Iowa State, Maryland, Michigan State, Middle Tennessee, Northern Arizona, <b>OREGON</b>, Oregon State, San Diego State, UNLV, Washington State</p><p>Denzel Burke - Saguaro (CB/WR): Arizona, Arizona State, Auburn, Colorado, Idaho, Iowa State, Louisville, LSU, Michigan State, Mississippi State, Nebraska, Northern Arizona, <b>OHIO STATE</b>, Oklahoma State, Oregon, San Diego State, Tennessee, Texas, UCLA, UNLV, USC, Utah, Washington</p><p>Zion Burns - Poston Butte (RB/DB): Abilene Christian, Austin Peay State, <b>NEVADA</b></p><p>Michael Bustin - Marana Mountain View (WR): McPherson</p><p>Lucas Caccavale - Desert Vista (P): Arizona Christian, Culver-Stockton<br></p><p>Jayden Calderon - Marcos de Niza (RB): Luther<br></p><p>Caden Calloway - Campo Verde (RB): Dakota State, Lake Forest, Wisconsin-River Falls</p><p>Cayden Camacho - Basha (FS): Chadron State, Clarke, Dakota State, Judson, Mayville State, Northern State, Simpson, <b>SIOUX FALLS</b><br></p><p>Jackson Camarata - Brophy (WR): Allegheny, Bates, Benedictine (Kans.), Bowdoin, Carleton, Concordia Coll. (Minn.), DePauw, Kenyon, La Verne, Oberlin</p><p>Mateo Campos - Marana (LB): Clarke, Culver-Stockton<br></p><p>Jacob Carpenter - Verrado (DE): Arizona Christian, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Mayville State, Monmouth (Ill.), Northwestern Coll. (Iowa), Simpson, Wisconsin-River Falls</p><p>Andrew Carreon - Arcadia (OG): North Park, Pacific</p><p>Anthony Carrington - Red Mountain (WR): Wisconsin-River Falls<br></p><p>Chandler Carter - Valley Christian (DE): Bethel (Tenn.), Concordia Coll. (Minn.), Hope, Jamestown, Mary, Rocky Mountain, Simpson, <b>SOUTH DAKOTA STATE</b>, Tennessee Tech, Trine, Wheaton, Wisconsin-River Falls</p><p>Chase Cassel - Ironwood Ridge (QB): <b>ST. NORBERT</b><br></p><p>Victor Castellano - Red Mountain (OG): Whittier</p><p>Nathan Cender - Horizon (OT): Wisconsin-River Falls</p><p>Aiden Cerullo - Desert Mountain (QB): Ottawa, Western New Mexico<br></p><p>Jack Chappelle - Shadow Ridge (OT): Buena Vista, Colorado Mesa, Jamestown, <b>NORTHERN MICHIGAN</b>, Simpson<br></p><p>Mark Chavez - Arizona College Prep (QB): Hope, Lake Forest, Olivet, Simpson, St. Francis, St. Norbert, Trine</p><p>Mister Chavis - Maricopa (RB): Western New Mexico<br></p><p>Peter Chawki - Horizon (DE): Concordia Coll. (Minn.), Ottawa<br></p><p>Dane Christensen - Casteel (QB): Drake</p><p>Giovanni Ciaccio - Marana Mountain View (QB): Arizona Christian, Ottawa<br></p><p> Jacob Cisneros - Boulder Creek (RB): Colorado School of Mines, Dartmouth, Georgetown, Northern Arizona, <b>PENNSYLVANIA</b>, San Diego, Southwest Minnesota State, West Virginia State, Yale <br></p><p>Jaden Clark - Desert Vista (CB): Western New Mexico<br></p><p>Chaz Clemons - Desert Edge (SS): Cornell, Navy, Valparaiso</p><p>John Coleman - Estrella Foothills (LB): Puget Sound<br></p><p>Blake Comstock - Mountain Ridge (K): Whittier</p><p>Jackson Condie - Desert Ridge (C): Concordia Coll. (Minn.), Hamline, Trine</p><p>Amaro Contreras - River Valley (CB): Carthage, St. Francis (Ill.)<br></p><p>Dylan Cook - Ironwood Ridge (FS): Carroll, <b>MOREHEAD STATE</b>, Northern State, South Dakota School of Mines</p><p>Bryce Cord - Sunrise Mountain (SS): Arizona Christian<br></p><p>David Cordero - Salpointe (RB): Chadron State, Hamline, Morehead State, Ottawa, Southwest Minnesota State, Western New Mexico<br></p><p>Logan Corfield - Desert Edge (OT): Benedictine (Kans.), Concordia Coll. (Minn.), Lake Forest, Montana Tech, Morehead State, San Diego, Southeast Missouri, Southwest Minnesota State, Wisconsin-River Falls</p><p>Marquise Corley - Liberty (RB): Ottawa<br></p><p>Damen Cornett - Queen Creek (FB): <b>OTTAWA</b><br></p><p>Thomas Corniea - Alhambra (OG): Bethany Coll. (Kans.), Clarke, McPherson<br></p><p>Marzion Cosby - Centennial (WR): Eastern Illinois, Missouri State, Northeastern State, <b>NORTHERN ARIZONA</b>, Roosevelt, Tennessee-Martin, Washburn, Western Illinois</p><p>Linwood Crawford - Cesar Chavez (RB): Arizona Christian, Ottawa<br></p><p>Jaden Crockett - Mountain Pointe (S): Hamline, Simpson, <b>SOUTH DAKOTA STATE</b>, Whittier</p><p>Quinton Crosby - Higley (LB): Bethany Coll. (Kans.), Buena Vista, Carroll, Dakota State, <b>NEBRASKA WESLEYAN</b>, Presentation, Waldorf<br></p><p>Alex Culbertson - Walden Grove (WR): Culver-Stockton, <b>SIMPSON</b>, St. Francis (Ill.), Trine</p><p>Kam Cullimore - Highland (LB): Dakota State, Southern Utah (preferred walk-on)<br></p><p>Brody Curtner - Gilbert Christian (RB): Arizona Christian, St. Norbert</p><p>Darrion Dalton - Saguaro (DT): Air Force, Army, Fordham, Idaho, Lehigh, Navy, Northern Arizona, Northern Colorado, <b>SAN DIEGO STATE</b>, UNLV</p><p>Shane Davenport - Fountain Hills (QB): Ottawa, Puget Sound</p><p>Mason Davies - Saguaro (WR): Adams State, Army, Eastern New Mexico, Morehead State, San Diego<br></p><p>Riley Davies - Cactus (LB): Concordia Univ. (Minn.)</p><p>Max Davis - Highland (RB): Arizona Christian<br></p><p>Traivian Denetso - Cienega (CB): Defiance, Wooster<br></p><p>Connor DePrez - Hamilton (OG): Eastern New Mexico, Heidelberg, Idaho, San Diego, Southwest Minnesota State<br></p><p>Joel Diaz - Arizona College Prep (FS): Arizona Christian, Benedictine (Kans.), Carnegie Mellon, Carroll, Chicago, Colorado School of Mines, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Grand View, Johns Hopkins, Montana Tech, Morehead State, Olivet Nazarene, Rose-Hulman, St. Francis, St. Thomas (Minn.), Trinity International, Washington &amp; Lee, Whitworth, Wisconsin-River Falls</p><p>Brock Dieu - Casteel (OT): Air Force, Arizona State, Army, Boise State, Columbia, Cornell, Harvard, Nevada, New Mexico, Northern Arizona, Oregon, Penn, Princeton, San Jose State, UC Davis, Utah State, <b>WASHINGTON STATE</b>, Yale</p><p>Dom Digian - Casteel (WR): Mary, Western New Mexico<br></p><p>Tanner Dimond - Cactus Shadows (FS): Simpson</p><p>Bryan Dyson - Arizona College Prep (WR): Briar Cliff, Concordia Coll. (Minn.), Olivet, Rocky Mountain, Simpson, St. Francis (Ill.), Trine, Trinity International, Wisconsin-River Falls</p><p>Hunter Dzugas - Higley (DT): Dakota State, McPherson, Monmouth Coll (Ill.), Mount Marty, Peru State, Southwest Minnesota State, Trine, Westminster<br></p><p>Christian Earls - Basha (TE): Arizona Christian, Avila, Black Hills State, Eastern New Mexico, Southern Virginia, Trine</p><p>Amani El-Nawal - Mountain Pointe (DB): Avila<br></p><p>Da Marcus Ellis-Dennard - Brophy (LB): <b>NEW MEXICO STATE</b>, Northeastern State, Washburn</p><p>Colton Ellsworth - Highland (TE): Southwest Minnesota State</p><p>Zayden Ennis - Centennial (OT): <b>BENEDICTINE COLL. (KANS.)</b>, Dakota State, Graceland, Jamestown<br></p><p>Molimau Esene - Centennial (DT): Eastern New Mexico</p><p>Alan Esquivel - Cibola (LB): Friends<br></p><p>Nathan Eubank - Northwest Christian (LB): Arizona Christian, Culver-Stockton, Hamline, Ottawa, Simpson, Trine, Whittier</p><p>Connor Faust - Payson (DT): St. Ambrose, Whittier</p><p>Luis Felix - Trevor Browne (LB): <b>MAYVILLE STATE</b>, Ottawa<br></p><p> Sebastian Felix - Cienega (SS): <b>DRAKE</b>, Morehead State, South Dakota School of Mines, Southwest Minnesota State, Valparaiso, Washburn <br></p><p>Seth Felts - O'Connor (QB): Puget Sound<br></p><p>John Ferlmann - Boulder Creek (LS): Air Force, Arizona, <b>ARIZONA STATE</b><br></p><p>Micah Ferrin - ALA-Queen Creek (DE): Sioux Falls, Utah (preferred walk-on)<br></p><p>Sebastian Fiery-Hardimon - Ironwood (CB): Allegheny, Arizona Christian, Concordia Coll. (Minn.), Culver-Stockton, Lake Forest, Olivet, Puget Sound, Simpson, St. Olaf, Trine, Wisconsin-River Falls</p><p>Adrian Fleming - Phoenix Christian (QB): Ottawa<br></p><p>Brit Fleming - Higley (FS): Concordia Coll. (Minn.)<br></p><p>CJ Flores - Cienega (SS): Arizona Christian, Carleton, Concordia Coll. (Minn.), Concordia Univ. (Ill.), Culver-Stockton, Iowa Wesleyan, Jamestown, Lewis &amp; Clark, Monmouth, Nebraska Wesleyan, Presentation, Puget Sound, Rose-Hulman, Sewanee, Simpson, St. Francis (Ill.), St. Olaf, Trine, Trinity International, Wayland Baptist, Whittier<br></p><p>Josiah Flores - Cienega (LB): Bethany Coll. (Kans.), Clarke, Culver-Stockton, Fort Lewis (preferred walk-on), La Verne, Trine, Wooster</p><p>Donavin Fontaine - O'Connor (RB): Friends, Lake Forest, Nebraska Wesleyan, Simpson, St. Olaf<br></p><p>Jordan Forbes - Desert Ridge (WR): Concordia Coll. (Minn.), McPherson<br></p><p>Steven Forester - Maricopa (RB): Arizona Christian, Culver-Stockton, Graceland<br></p><p>Anthony Franklin - Pinnacle (DE): Air Force, Arizona, Army, Ball State, Brown, Colorado State, Columbia, Cornell, Duke, Harvard, Idaho, Indiana, Kansas State, Lehigh, Michigan State, Montana State, Navy, Northern Arizona, Penn, Princeton, South Dakota State, <b>STANFORD</b>, Tulane, UNLV, Yale</p><p>Xander Franquero - Desert Vista (FS): Allegheny, Clarke, Culver-Stockton, Graceland, Luther, Nebraska Wesleyan, Puget Sound, Simpson<br></p><p>Rogan Freeburg - Desert Mountain (WR): <b>EASTERN NEW MEXICO</b>, Simpson, Southern Nazarene, Wisconsin-River Falls</p><p>Scott French - Ironwood Ridge (DT): Concordia Univ. (Wisc.), Culver-Stockton, Dakota State, Hamline, Nebraska Wesleyan, Oberlin, Simpson</p><p>Tanner-James Friend - Sahuarita (CB): Concordia Coll. (Minn.), Wisconsin-River Falls</p><p>Mikaele Fuamatu - Millennium (OG): Benedictine (Kans.), Eastern New Mexico, <b>MARY</b>, Minot State, Nebraska Wesleyan, Ottawa</p><p>Darrell Fuertes - Trevor Browne (OG): Mayville State<br></p><p>Daniel Fulton - Chandler (LB): Albright, Bates, Carleton, Carnegie Mellon, Carthage, Concordia Coll. (Minn.), Hamline, Kalamazoo, Lake Forest, Occidental, <b>RHODES</b>, Simpson, Trine, Whittier, Wisconsin-River Falls</p><p>Jake Gaines - O'Connor (WR): Simpson</p><p>Anthony Galvez - Sunnyside (WR): Graceland, Nebraska Wesleyan, Norwich, Ottawa, Simpson</p><p>Travis Gammage - South Mountain (WR): Benedictine (Kans.), Concordia Coll. (Minn.), Simpson</p><p>Max Garcia - Desert Edge (DT): Arizona Christian, Concordia Coll. (Minn.), Mayville State, <b>ROCKY MOUNTAIN</b>, Simpson, Southwest Minnesota State, Wisconsin-River Falls<br></p><p>Bobby Gardea - Dysart (CB): Wisconsin-River Falls</p><p>Colby Garvin - Queen Creek (WR): <b>ARIZONA STATE (PREFERRED WALK-ON)</b>, Utah (preferred walk-on)<br></p><p>Joshua Gasca - Centennial (QB): Hamline, <b>LAKE FOREST</b>, Simpson<br></p><p>Aaron Gerle - Greenway (DT): Abilene Christian, Augustana, Harding, Houston Baptist, Idaho, Lehigh, <b>MONTANA STATE</b>, Northern Arizona, Northern State, Southern Utah, Southwest Minnesota State, Tarleton State, Washburn</p><p>Kellen Gibson - Arizona College Prep (LB): Arizona Christian, Bates, Carleton, Carnegie Mellon, Claremont Mudd Scripps, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Hamline, Johns Hopkins, Kalamazoo, Kenyon, Macalester, Monmouth (Ill.), Montana Tech, Oberlin, Rochester, St. Francis, St. Olaf, Washington (Mo.), Whitworth, Wisconsin-River Falls</p><p>Logan Gingg - Verrado (RB): Abilene Christian, Bucknell, Cornell, Lehigh, <b>SAN DIEGO</b>, Yale</p><p>Isaia Glass - Queen Creek (OT): Arizona, <b>ARIZONA STATE</b>, Army, Colorado, Fresno State, Hawaii, Idaho, Indiana, Iowa State, Kansas State, Nevada, New Mexico, Northern Arizona, Oklahoma State, Oregon State, San Diego State, Tulane, UNLV, Utah, Utah State, Washington State</p><p>DJ Gleash - Centennial (DE): Drake, Northern State, Valparaiso</p><p>Johvany Gomez - Apollo (TE): Arizona Christian<br></p><p>Tony Gomez Jr. - Valley Christian (RB): Arizona Christian, Carleton, Colorado School of Mines, Culver-Stockton, Grinnell, Wisconsin-River Falls</p><p>Anthony Gonzales - Saguaro (FS): <b>ARIZONA (PREFERRED WALK-ON)</b>, New Mexico Highlands, Southwest Minnesota State</p><p>Andrew Gonzalez - Sunnyside (LB): Bethany Coll. (Kans.), Buena Vista, Culver-Stockton, Muskingum, Presentation<br></p><p>Collin Gordon - Marcos de Niza (LB): Arizona Christian, Culver-Stockton, Luther<br></p><p>Gavin Goulette - Gilbert (QB): <b>MAYVILLE STATE</b>, Monmouth Coll. (Ill.), St. Ambrose</p><p>Carter Gourd - Perry (CB): Jamestown<br></p><p>Markiy Grasty - Higley (OG): Arizona Christian<br></p><p>James Groff - O'Connor (WR): Yale</p><p>Gavin Guarino - Pinnacle (OT): Benedictine (Kans.), Carleton, Concordia Univ. (Ill.), Lake Forest, Ottawa, Western New Mexico, Wesleyan, Whittier</p><p>Aydan Guenther - Sunrise Mountain (LB): Buena Vista</p><p>Jett Hale - Casa Grande (SS): McPherson<br></p><p>Capri Hamilton - Chaparral (WR): Arizona Christian, Benedictine (Kans.), Hamline, Trine</p><p>Charles Hamm - Cienega (CB): Culver-Stockton, <b>JAMESTOWN</b>, St. Olaf<br></p><p>Anthony Hanger - Chandler (DT): <b>AUGUSTANA UNIV. (S. DAK.)</b>, Southwest Minnesota State, Washburn</p><p>Ricky Hanlan IV - Nogales (WR): Bethany Coll. (Kans.), Concordia Univ. (Ill.), Culver-Stockton, Presentation, St. Norbert, Trine, <b>WESTERN NEW MEXICO</b><br></p><p>Andrew Hanzal - Valley Christian (WR): Avila, Hope, Rocky Mountain, <b>SIOUX FALLS (PREFERRED WALK-ON)</b>, Trine<br></p><p>Jadon Hanzal - Valley Christian (QB): Hope, <b>MARY</b></p><p>Jayden Harrington - Verrado (CB): Arizona Christian, Benedictine (Kans.), Carthage, Concordia Coll. (Minn.), Concordia Univ. (Minn.), Culver-Stockton, Graceland, Hamline, Lake Forest, Mayville State, Mount Marty, Northwestern Coll. (Iowa), Simpson, <b>SIOUX FALLS</b>, Southwest Minnesota State, Trine, Western New Mexico, Wisconsin-River Falls</p><p>Isaiah Harris - Saguaro (CB): Concordia Univ. (Ill.), Nebraska Wesleyan<br></p><p>Evan Harvey - Ironwood Ridge (LB): Clarke<br></p><p>Will Haskell - Ironwood (QB): Akron, Duke, Fresno State, Iowa State, Northern Arizona, <b>SAN DIEGO STATE</b></p><p>Marlon Hauck - Desert Vista (K): Arizona Christian<br></p><p>Jaylen Hawkins - Millennium (RB): Bethany Coll. (Kans.), McPherson, <b>OTTAWA</b>, Tabor<br></p><p>Zach Hay - Mountain Pointe (DE): San Diego<br></p><p>Mason Hays - Pinnacle (DE): Arizona Christian</p><p>Brendan Heard - Peoria (RB): Mayville State <br></p><p>Dax Heggie - Casteel (LB): Concordia Coll. (Minn.)<br></p><p>Heath Henderson - Desert Mountain (OT): Arizona Christian, Avila, Concordia Coll. (Minn.), Dakota State, McPherson, Ottawa, Simpson, <b>WESTERN NEW MEXICO</b>, Wisconsin-River Falls</p><p>Josh Hendrickson - Marana (DT): Ottawa<br></p><p>Trey Hendrix - Peoria (OG): Southwest Minnesota State, Whittier</p><p>Angel Hernandez - Gilbert (DE): St. Francis<br></p><p>Justin Hernandez - Shadow Ridge (OT): Southern Oregon</p><p>Branson Heywood - Higley (WR): Benedictine (Kans.)</p><p>Skyler Higdon - Vista Grande (OT): Augustana Coll. (Ill.), Aurora, Buena Vista, <b>COE</b>, Dakota State, Hamline, Knox, Nebraska Wesleyan, Simpson, Whittier<br></p><p>Sione Hingano - Chandler (OT): <b>BYU</b>, Idaho, Northern Arizona, Southern Utah, Weber State, Western Illinois<br></p><p>Myles Hobbs - Desert Edge (LB): Bowdoin, Carleton, Simpson</p><p>Anthony Hodges - Buena (OT): Carthage, Norwich</p><p>Liam Hoffmeyer - Cibola (TE): <b>AIR FORCE</b>, Fordham, Idaho, South Dakota State, Valparaiso</p><p>Desmon Holton - Casteel (WR): Allegheny, Buena Vista, Concordia Coll. (Minn.), Concordia Univ. (Ill.), Crown, Culver-Stockton, Gustavus Adolphus, Hamline, Jamestown, Lakeland, <b>LEWIS &amp; CLARK</b>, Luther, Nebraska Wesleyan, Ripon, Simpson<br></p><p>Jack Howell - Hamilton (FS): Ball State, <b>COLORADO STATE</b>, Montana, New Mexico, New Mexico State, North Dakota, Northern Arizona, South Dakota State</p><p>Joseph Hoyt - Chandler (DT): Abilene Christian, South Dakota State, Southwest Minnesota State</p><p>August Hubbard - Trivium Prep (WR): Fort Lewis, Ottawa, St. Olaf<br></p><p>Nate Hull - Pinnacle (WR): Wisconsin-River Falls</p><p>Ethan Hunt - Casteel (DE): <b>BLACK HILLS STATE</b>, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Whittier</p><p>Andrew Husfelt - Cienega (C): Culver-Stockton, Eastern New Mexico, Morehead State, Simpson, <b>WASHBURN</b></p><p>Cess Ibarra - Chandler (OG): Buena Vista, Carthage, Catholic, Clarke, Concordia Coll. (Minn.), Concordia Univ. (Wisc.), Culver-Stockton, Dakota State, Lake Forest, Lakeland, Millikin, Nebraska Wesleyan, Peru State, Ripon, <b>ROCKY MOUNTAIN</b>, Simpson, St. Olaf, Trine, Trinity International</p><p>Jacob Irick - Marcos de Niza (LB): Benedictine Coll. (Kans.), Lake Forest, Luther</p><p>Brandon Jackson - North Canyon (CB): Ottawa, Wisconsin-River Falls<br></p><p>Krew Jackson - Queen Creek (FS): Air Force, Arizona, Arizona State, Boise State, Boston College, BYU, Idaho, Iowa State, <b>KANSAS STATE</b>, Michigan State, Navy, Northern Arizona, Pittsburgh, San Diego State, Tulane, UNLV, Virginia, Washington State, Yale</p><p>Anton Jamero - Desert View (LB): Culver-Stockton, Ripon<br></p><p>James Jaquint - Notre Dame (SS): Benedictine (Kans.), <b>SAN DIEGO</b>, Valparaiso<br></p><p>Luis Jaramillo - Flagstaff (RB): Arizona Christian, Carthage, Concordia Coll. (Minn.), Mayville State, Northern Arizona (preferred walk-on), Puget Sound, Simpson, Western New Mexico</p><p>Joey Jensen - Combs (SS): Concordia Univ. (Ill.), Dakota State, Kansas Wesleyan, Ottawa, Saint Mary (Kans.), Southern Virginia, Southwest Minnesota State, St. Norbert</p><p>Kannon Jewell - Pusch Ridge (LB): Arizona Christian, Buena Vista, Carthage, Concordia Coll. (Minn.), Dakota State, Luther, Trine, Trinity International<br></p><p>Christian Johnson - Greenway (RB): Concordia Coll. (Minn.), Hamline, <b>LAKE FOREST</b><br></p><p>Elias Johnson - Tucson (LB): Southwest Minnesota State<br></p><p>Isaak Johnson - Shadow Mountain (LB): <b>FERRUM</b>, Whittier</p><p>Tanner Johnson - Mesa Mountain View (WR): Dakota State, Nebraska Wesleyan<br></p><p>Caleb Jones - Basha (RB): <b>SOUTH DAKOTA SCHOOL OF MINES (PREFERRED WALK-ON)</b>, Whittier</p><p>Dylan Jones - Shadow Ridge (OG): Buena Vista, McPherson, Nebraska Wesleyan, Simpson<br></p><p>Yufiel Jones - Sequoia Pathway (DE): Southwestern (Kans.)<br></p><p>Jace Judd - Combs (LB): Ottawa<br></p><p>Jonathan Justice - Lake Havasu (DE): Arizona Christian, Benedictine Coll. (Kans.), Concordia Coll. (Minn.), Monmouth (Ill.), Nebraska Wesleyan, Northwestern (Iowa), Presentation, St. Francis, Wisconsin-River Falls<br></p><p>Mikey Keene - Chandler (QB): Coastal Carolina, Colorado State, Columbia, Eastern Michigan, Harvard, Hawaii, Iowa State, Middle Tennessee, Nevada, New Mexico, Northern Arizona, Penn, San Jose State, Tulane, <b>UCF</b>, Utah State, Western Kentucky, Yale</p><p>Ned Kennedy - Centennial (OG): Jamestown, Ripon</p><p>Brent Kenyon - Greenway (C): Simpson</p><p>Gavin Keppel - Perry (WR): Jamestown<br></p><p>Josiah Kidd - Desert Ridge (RB): Hope, Lake Forest, Wisconsin-River Falls</p><p>Caleb Kidney - Cienega (WR): Culver-Stockton, Trine</p><p>Logan Kingsford - Highland (WR): Buena Vista, Mount Union<br></p><p>Clayton Kinkel - Arcadia (LB): Culver-Stockton <br></p><p>Christian Kirkman - Saguaro (LB): Arizona Christian, Concordia Coll. (Minn.).<br></p><p>Colby Kitson - Boulder Creek (LB): La Verne</p><p>Jayce Knutsen - Casteel (RB): Arizona State (preferred walk-on)</p><p>Jake Kostoryz - Desert Ridge (TE): Buena Vista, Carleton, Concordia Coll. (Minn.), Lake Forest, St. Scholastica, Wisconsin-River Falls <br></p><p>Garrick Krautz - Catalina Foothills (TE): Chadron State, Concordia Coll. (Minn.), Hamline, Lake Forest, <b>MOREHEAD STATE</b>, Nebraska Wesleyan<br></p><p>Richard Kwete - Sunnyslope (DT): Idaho, <b>NORTHERN ARIZONA</b><br></p><p>Avery Lambert - Horizon (WR): Adams State, Benedictine (Kans.), Buena Vista, Ottawa, Simpson, Southern Nazarene, Southwest Baptist, St. Olaf, Trine, Wisconsin-River Falls</p><p>Maximus LaVoy - Notre Dame (OT): <b>CONCORDIA COLL. (MINN.)</b><br></p><p>Maddox Lawien - Valley Vista (WR): <b>CROWN</b>, La Verne<br></p><p>Jake LeBlanc - Pinnacle (C): Allegheny, Ave Maria, Benedictine Coll. (Kans.), Concordia Coll. (Minn.), Culver-Stockton, Lewis &amp; Clark, Minnesota Morris, Ottawa, Pacific, Sewanee, Simpson, Trine, Whittier</p><p>Sean Lehman - Notre Dame (CB): Wisconsin-River Falls</p><p>Jake Leighty - Campo Verde (OG): Bethel Coll. (Kans.), Nebraska Wesleyan, Simpson<br></p><p>Jonah Leon - Yuma Catholic (WR): Arizona Christian, Benedictine Coll. (Kans.), Culver-Stockton, Gustavus Adolphus, Jamestown, Lewis &amp; Clark, Ottawa, Southwest Baptist<br></p><p>Deryk Leverage - Mountain Ridge (LB): Concordia Coll. (Minn.), Luther, Simpson</p><p>Gabe Levy - Cienega (RB): Black Hills State, <b>MARY</b>, Sioux Falls, Washburn, Western New Mexico</p><p>Elijah Lewis - Millennium (WR): Ottawa<br></p><p>Michael Lewis - Florence (OT): Clarke, Ripon<br></p><p>Zachary Lewis - Hamilton (CB): Army, <b>NEVADA</b>, Northern Arizona, Washington State</p><p>Mark Liano - Campo Verde (LB): Concordia Coll. (Minn.), Hamline, Lake Forest, Oberlin, St. Olaf</p><p>Terrance Liddile - Kellis (CB): <b>DAKOTA STATE</b>, Peru State<br></p><p>Daxon Lindholm - Centennial (RB): <b>ARMY</b></p><p>Eric Lira - Mesquite (WR): St. Francis (Ill.), <b>SOUTHWEST MINNESOTA STATE</b>, Trine, Wisconsin-River Falls</p><p>Benjamin Lisk - Paradise Valley (LS): Carleton, George Fox, Hamline, Pacific, <b>TOLEDO</b></p><p>Colby Littleton - Queen Creek (LB): <b>SOUTH DAKOTA STATE</b>, Trine<br></p><p>Qwestin Litz - Cienega (CB): Concordia Coll. (Minn.), McPherson, Muskingum, Nebraska Wesleyan, Texas Wesleyan<br></p><p>Gavin Lloyd - Poston Butte (QB): Hamline, Iowa Wesleyan, Simpson</p><p>PJ London - Blue Ridge (QB): Fort Lewis, <b>NORTHERN ARIZONA</b><br></p><p>Tanor Loosle - Mountain Ridge (SS): Hamline</p><p>Robert Lopez - Carl Hayden (DE): Arizona Christian, Mayville State, Tabor</p><p>Dylan Lorenzen - Mesquite (DB): Coe, Finlandia, Whitworth<br></p><p>Stephen Louis - Higley (DE): Allegheny, Arizona Christian, Culver-Stockton<br></p><p>Evan Lovett - Pusch Ridge (RB): Eastern New Mexico, <b>MINOT STATE</b>, Western New Mexico</p><p>Angel Lydon - Trevor Browne (QB): Clarke, Dakota State, Ottawa<br></p><p>Alani Ma'afu - Saguaro (DT): Iowa State, Liberty, Memphis, Montana State, New Mexico, <b>NORTHERN ARIZONA</b>, San Diego State, Tulane, Washington State</p><p>Joseph MacDonald - O'Connor (CB): <b>BUTLER</b>, Culver-Stockton, Fort Lewis (preferred walk-on), Gustavus Adolphus, Kalamazoo, Lake Forest, Nebraska Wesleyan, St. Olaf, Valparaiso<br></p><p>Fernando Macias - Trevor Browne (OG): <b>MAYVILLE STATE</b>, Ottawa<br></p><p>Eli Mackowski - Desert Mountain (LB): Buena Vista, Concordia Coll. (Minn.), Concordia Univ. (Ill.), Luther, Nebraska Wesleyan, Ottawa, Simpson, St. Olaf<br></p><p>Zion Magalei - Chandler (DE): Air Force, Arizona, Army, Brown, <b>COLORADO</b>, Kansas State, Navy, Nevada, Northern Arizona, Northern Colorado, San Diego State, Washburn, Yale</p><p>Troy Mann - Tucson (DE): Buena Vista, Dakota State, McPherson, Simpson, Whittier<br></p><p>Wyatt Manning - Florence (DE): Arizona Christian, Carthage, Clarke, Concordia Univ. (Wisc.), Graceland, La Verne, Monmouth (Ill.), Puget Sound, Simpson<br></p><p>Mekhi Mannino-Faison - Ironwood (TE): Augustana (S. Dak.), Findlay, Mary, Ottawa, Southwest Minnesota State</p><p>Kaleb Markley - Sabino (SS): Culver-Stockton</p><p>Ezekiel Marshall - Sunrise Mountain (WR): Eastern New Mexico<br></p><p>Andrew Mason - Perry (OT): <b>NORTHERN ARIZONA</b>, San Diego<br></p><p>Brock Mast - Liberty (QB): Buena Vista, Concordia Coll. (Minn.), Hamline, Mayville State, Puget Sound, <b>ROCKY MOUNTAIN</b>, Simpson, Wisconsin-River Falls</p><p>Christian McCook - Hamilton (C): Eastern New Mexico<br></p><p>Sam McCracken - Notre Dame (LB): Buena Vista, Concordia Univ. (Ill.), Simpson, St. Olaf<br></p><p>Brees McCraren - Salpointe (DT): Arizona (preferred walk-on), Concordia Coll. (Minn.), Culver-Stockton, Fort Lewis (preferred walk-on), Hamline, Millikin, Nebraska Wesleyan, Presentation, St. Norbert, Trine, Whittier, Wisconsin-River Falls</p><p>Ty McDermott - Walden Grove (WR): Benedictine (Kans.), Carleton, Concordia Coll. (Minn.), Culver-Stockton, Kalamazoo, Millikin, Otterbein, Pacific, Simpson, St. Norbert, St. Olaf, Trine, Western New Mexico<br></p><p>Cliffonte McDowell - Desert Edge (CB): Livingstone<br></p><p>James Mcelhenny - Ironwood (QB): Arizona Christian, Heidelberg, Ottawa, Presentation, Wisconsin-River Falls</p><p>Carson McNutt - Shadow Ridge (DT): Jamestown<br></p><p>TJ McRae - Centennial (DT): <b>DIXIE STATE</b>, Memphis</p><p>Marcus McWilliams - Gilbert Christian (CB): St. Norbert. Wisconsin-River Falls</p><p>Lucas Meredith - Saguaro (RB): Ottawa<br></p><p>Bear Milacek - Boulder Creek (QB): <b>NEW MEXICO</b>, San Diego, Valparaiso, Western Kentucky</p><p>Caiden Miles - Centennial (OT): Abilene Christian, Air Force, Columbia, New Mexico State, <b>NORTHERN ARIZONA</b>, UNLV<b>,</b> Yale</p><p>Jonah Miller - Salpointe (OT): Arizona, Arizona State, Colorado, Florida, Missouri, Nebraska, Nevada, Oklahoma State, <b>OREGON</b>, Penn State, Tennessee, Texas, USC, Utah, Washington, Washington State</p><p>Marques Miller - Desert Edge (SS): Livingstone</p><p>Max Miller - Pinnacle (K): Lake Forest, Puget Sound<br></p><p>Kai Millner - Higley (QB): Arizona, Arizona State, Boise State, <b>CALIFORNIA</b>, Colorado, Hawaii, Indiana, Iowa State, Miami (Fla.), Michigan State, North Carolina State, Northern Arizona, Syracuse, UCF, Washington State<br></p><p>Max Minor - Chaparral (WR): <b>AUGUSTANA UNIV. (S. DAK.)</b>, Sioux Falls, Southwest Minnesota State</p><p>Miles Molander - Queen Creek (WR): Adams State, Chadron State, Dakota State, Doane, Ottawa<br></p><p>Gabriel Monaco - O'Connor (DE): Arizona Christian, Culver-Stockton</p><p>Chris Montelongo - Cesar Chavez (LB): Arizona Christian</p><p>Cross Moojen - Centennial (DT): Arizona Christian, Buena Vista, Dakota State, Jamestown, Rocky Mountain, Simpson<br></p><p>Jacob Moore - Boulder Creek (OG): Southwest Minnesota State, UTEP, Valparaiso, Washburn</p><p>Zion Morgan - Maricopa (WR): Crown, Graceland<br></p><p>Trae Moshier - ALA-Queen Creek (RB): Bethany Coll. (Kans.), Tabor, Waldorf<br></p><p>Daveun Moton - Horizon (CB): Arizona Christian<br></p><p>Landon Mumford - Horizon (LB): Ottawa</p><p>Dimitry Muncy - Blue Ridge (OG): Mayville State, Ottawa<br></p><p>Dominic Murrieta - Sunnyside (SS): Dakota State, Defiance, Hamline, Nebraska Wesleyan, Ottawa, Wooster<br></p><p>Caiden Myers - Williams Field (FB): Friends, Saint Mary (Kans.)<br></p><p>Luke Nash - Notre Dame (RB): Culver-Stockton, Denison, Puget Sound, Whittier</p><p>Zeth Nastal - Mesa (LB): Culver-Stockton, <b>MINOT STATE</b>, Simpson</p><p>Lil-Mike Neasman - Basha (FS) - Bendectine Coll. (Kans.), Saint Mary<br></p><p>Isaiah Negron - Verrado (WR): Trine</p><p>Tevainui Neher - Chandler (OG): <b>DRAKE</b>, Georgetown, Lamar</p><p>Cooper Nemeth - Chaparral (WR): Whittier<br></p><p>Daivon Nelson - Marcos de Niza (CB): Benedictine (Kans.), Culver-Stockton, Saint John's (Minn.), Wisconsin-River Falls</p><p>Jack Nelson - Skyline (QB): Eastern New Mexico, George Fox, Montana State Northern</p><p>Moses Nelson - Cholla (RB): Hamline<br></p><p>Nicolas Nesbitt - Chandler (RB): Brown, Bucknell, <b>COLUMBIA</b>, Dartmouth, Lafayette, Morehead State, Penn, San Diego, Valparaiso</p><p>Montana Neustadter - Canyon del Oro (QB): Aurora, Presentation</p><p>Jared NeVille - San Tan Charter (FS): Avila<br></p><p>Myles Newble - Brophy (RB): Allegheny, Culver-Stockton, Hamline, La Verne, Rochester, Saint John's (Minn.)</p><p>Isaiah Newcombe - Casteel (WR): Abilene Christian, Air Force, Army, Boise State, BYU, Colorado State, Columbia, Fresno State, Hawaii, Idaho, New Mexico, New Mexico State, Northern Arizona, Southern Utah, Tulane, <b>UCLA</b>, Utah, Washington, Yale</p><p>Blake Nguyen - Brophy (WR): Brevard<br></p><p>Jared Nichols - Desert Ridge (SS): Concordia Coll. (Minn.), Concordia Univ. (Minn.)</p><p>Eduardo Ogaz - Safford (RB): <b>ST. OLAF</b><br></p><p>Hunter Ogle - Santa Cruz (RB): Arizona Christian, Buena Vista<br></p><p>Kollins Opoku-Appoh - Marana Mountain View (RB): Eastern New Mexico<br></p><p>Ali'i Kai Ormita - Chandler (OG): Benedictine (Kans.), Concordia Coll. (Minn.), Dakota State, Lake Forest, Mary, <b>ROCKY MOUNTAIN</b><br></p><p>Kyler Orr - Chandler (LB): Abilene Christian, <b>AIR FORCE</b>, Idaho, Morehead State</p><p>Anthony Ortiz - Mountain Pointe (OG): South Dakota School of Mines, <b>SOUTHWEST MINNESOTA STATE</b>, Trine</p><p>Mikey Ortiz - Desert Edge (FS): Allegheny, Arizona Christian, Lake Forest, Ottawa, Simpson, Trine</p><p>Steven Ortiz Jr. - Desert Edge (CB): Arizona, California, Duke, Houston, Idaho, Iowa State, Kansas, Kansas State, Louisiana, <b>MINNESOTA</b>, Mississippi State, Nebraska, Northern Arizona, Oregon, Oregon State, Penn State, Rutgers, San Diego State, Syracuse, UNLV, Washington, Washington State, William &amp; Mary</p><p>Mason Osborn - Chaparral (OT): Montana Tech, Morgan State, <b>NORTHERN STATE</b>, Ohio Dominican, Sioux Falls, Southwest Minnesota State, Washburn</p><p>Damien Owens - Notre Dame (WR): Abilene Christian, Idaho, <b>NORTH DAKOTA</b>, South Dakota State, Southern Utah</p><p>Angelo Palacios - Coolidge (OG): Arizona Christian, Simpson<br></p><p>Caleb Parker - Casteel (CB): Buena Vista, Concordia Coll. (Minn.), Nebraska Wesleyan, Simpson</p><p>Mason Parker - Mesa Mountain View (LB): Concordia Coll. (Minn.), Dakota State, <b>JAMESTOWN</b><br></p><p>Hayden Parson - Marana Mountain View (WR): Eastern New Mexico<br></p><p>Andrew Patterson - Desert Edge (WR): Abilene Christian, Fordham, Gardner-Webb, Idaho, <b>MONTANA STATE</b>, New Mexico, New Mexico State, North Dakota, Northern Arizona, Northern Colorado, Southern Utah, Valparaiso, Washburn, Weber State, Western New Mexico</p><p>Parker Pelletier - Salpointe (CB): Chadron State (preferred walk-on), Clarke, Concordia Coll. (Minn.), Culver-Stockton, Doane, Graceland, Greenville, Hamline, Kalamazoo, Lake Forest, Monmouth (Ill.), Norwich, Sewanee, Simpson, St. Norbert, Trine, Wagner (preferred walk-on), Western New Mexico, Wisconsin-River Falls</p><p>Peyton Pelletier - Ironwood Ridge (QB): Clarke, Concordia Coll. (Minn.), Culver-Stockton, Finlandia, Greenville, Hamline, Kalamazoo, Lake Forest, Millikin, Norwich, Olivet, Sacred Heart, Simpson, St. Norbert, Trine, Wagner (preferred walk-on), Western New Mexico<br></p><p>Trent Pennington - Basha (WR): Adams State, Culver-Stockton, Dakota State, Fort Hays State, Hamline, South Dakota School of Mines, <b>VALPARAISO</b>, Western New Mexico<br></p><p>Ryan Peplinski - Horizon (SS): Arizona Christian, Ottawa, Southern Virginia<br></p><p>Hank Pepper - Chandler (LS/LB): <b>MICHIGAN STATE</b>, San Diego State, Southwest Minnesota State, Western New Mexico</p><p>Ty Perry - Estrella Foothills (QB): Benedictine (Kans.), Fort Lewis, Jamestown, MidAmerica Nazarene, Oklahoma Panhandle State, Ottawa<br></p><p>Caden Petersen - Higley (WR): <b>LAKE FOREST</b><br></p><p>Ethan Peterson - Red Mountain (FS): Western Colorado<br></p><p>Logan Petit - Gilbert (DE): Bethany Coll. (Kans.), Clarke, Judson, Luther, Nebraska Wesleyan, Ripon, Saint Mary (Kans.)<br></p><p>Mason Phillips - Casteel (LB): Carthage, Clarke, Concordia Coll. (Minn.), Connecticut (walk-on), Culver-Stockton, Graceland, Hamline, Lake Forest, <b>MARY</b>, Mayville State, Millikin, Monmouth (Ill.), Puget Sound, Ripon, Simpson, St. Olaf, Trine, Whittier, Wisconsin-River Falls</p><p>Matthew Phillips - Centennial (LB): Arizona Christian, Culver-Stockton</p><p>Jacob Pickett - Saguaro (RB): Lake Forest<br></p><p>Zamir Pierce - Marana Mountain View (WR): Arizona Christian<br></p><p>Shane Pitts - Liberty (FS): Chadron State, Mary<br></p><p>Jayloni Pizarro - Gilbert (RB): Bethany (Kans.), Wisconsin-River Falls</p><p>Bryson Plueger - Willow Canyon (DE): Mayville State<br></p><p>Alex Pobloske - Sabino (DE): Arizona Christian, Benedictine Coll. (Kans.), Hastings, Nebraska Wesleyan<br></p><p>Kyle Pointer - Casteel (LB): <b>ABILENE CHRISTIAN</b>, Northern State, Whittier, Wisconsin-River Falls</p><p>Hayden Preston - Campo Verde (OT): Concordia Coll. (Minn.), Concordia Univ. (Ill.), Culver-Stockton, Hamline, <b>LAKE FOREST</b>, Ohio Northern, Whittier</p><p>Brandon Price - Peoria (RB): Graceland, Wisconsin-River Falls<br></p><p>Ethan Price - Cactus (DT): Benedictine (Kans.), Culver-Stockton, Graceland, Hamline, <b>OBERLIN</b>, Simpson, Southwest Minnesota State, Valparaiso, Whittier<br></p><p>Jadon Prince - Desert Ridge (RB): Hamline, Ottawa, Trine</p><p>Hunter Ramage - Mountain Ridge (DT): Hamline</p><p>Chris Ramirez - Marcos de Niza (OG): McPherson<br></p><p>George Ramirez - Red Mountain (SS): Chadron State, Colorado School of Mines, Mary, Northern Arizona, Northern Colorado, Northern State, Southern Utah (preferred walk-on), Southwest Minnesota State, Washburn</p><p>Jacob Ramirez - Desert View (RB): Culver-Stockton, Lyon, McPherson, Saint Mary, Whittier</p><p>Jason Ramirez-Corpuz - Mountain Pointe (CB): Arizona Christian, Baldwin Wallace, Carthage, Culver-Stockton, <b>MARY</b>, North Park, Olivet, Simpson, St. Norbert, St. Thomas (Minn.)</p><p>Junior Ramos - San Tan Charter (WR): Bethany Coll. (W. Va.), Southwestern (Kans.)<br></p><p>Chase Randall - Canyon del Oro (DE): <b>SIOUX FALLS</b><br></p><p>Jackson Ray - Highland (P): <b>COLORADO STATE</b></p><p>Daniel Redmond - Willow Canyon (WR): Allegheny, Juniata, Simpson<br></p><p>Jeremiah Reed - Westwood (SS): <b>PERU STATE</b><br></p><p>Amarey Reid - Alhambra (C): McPherson, Muskingum , Nebraska Wesleyan, Whittier<br></p><p>Trey Reynolds - Queen Creek (LB): Air Force, Arizona, Boise State, BYU, Colorado, Duke, Fresno State, Illinois, Indiana, Iowa State, Kansas State, Michigan State, Northern Arizona, Oklahoma State, Oregon, San Diego State, UCLA, UNLV, <b>UTAH</b>, Utah State, Virginia, Washington, Washington State, Wisconsin, Yale</p><p>Tyler Reynolds - Cactus Shadows (QB): Concordia Coll. (Minn.), Hamline, Ottawa, Whittier, Wooster</p><p>Jordan Richardson - Moon Valley (CB): Ottawa, Wisconsin-River Falls</p><p>Dominik Richie - Combs (LB): Culver-Stockton, Ottawa<br></p><p>Jalen Richmond - Chandler (WR): Abilene Christian, <b>BOISE STATE</b>, Eastern Michigan, Georgetown, Idaho, Missouri State, Navy, Nevada, New Mexico State, North Dakota, Northern Arizona, Northern Colorado, Rice, San Jose State, South Dakota State, Southern Utah</p><p>Nik Rieck - Higley (FS): Buena Vista, Central (Iowa), Dakota State, Jamestown, Lake Forest, Simpson, Wisconsin-River Falls</p><p>Tage Rigby - Centennial (RB): Benedictine (Kans.), Bethel (Kans.), Central Washington, Hamline, <b>NORTHERN ARIZONA (PREFERRED WALK-ON)</b>, San Diego<br></p><p>Cavan Riggs - Queen Creek (CB): Benedictine (Kans.), Saint Anselm, St. Thomas (Minn.), Wagner (preferred walk-on), Wisconsin-River Falls</p><p>TJ Ritter - Chaparral (OG): Ottawa, Trine</p><p>JD Roberts - Notre Dame (LB/FB): <b>NEW MEXICO</b>, Northern Arizona</p><p>Truitt Robinson - Higley (WR): Lake Forest, Nebraska Wesleyan, Simpson<br></p><p>Taryn Robles - Centennial (LB): Carleton, Culver-Stockton<br></p><p>Stevie Rocker - Canyon del Oro (RB): <b>ARIZONA</b>, BYU, California, Nevada</p><p>Greg Rodriguez - Coolidge (RB): Simpson</p><p>Malachi Rodriguez - Coolidge (LB): Oklahoma Panhandle State, Simpson<br></p><p>Isaiah Roebuck - Marana (WR): Arizona (preferred walk-on), Hastings, Jamestown, Ottawa<br></p><p>Jason Rogers - Glendale (DE): Arizona Christian<br></p><p>Julian Rohan - Mountain Pointe (CB): UNLV, Utah</p><p>Justin Romo - Casa Grande (CB): Nebraska Wesleyan</p><p>Enrique Ruiz - Marcos de Niza (C): Buena Vista, Concordia Coll. (Minn.), Culver-Stockton, Luther<br></p><p>Jan Ruiz - Sierra Linda (WR): <b>DICKINSON STATE</b>, Ottawa, Peru State, Southwest Minnesota State</p><p>Howard Russell - Phoenix Christian (RB): Arizona Christian, Black Hills State, <b>EASTERN NEW MEXICO</b>, Ottawa<br></p><p>Ethan Saldana - Desert Edge (OG): Ottawa<br></p><p>Andy Salome - Brophy (WR): Benedictine (Kans.)</p><p>Nickolas Samaniego - Marcos de Niza (OT): Mary<br></p><p>Alex Sanchez - Skyline (LB): Culver-Stockton</p><p>Devin Sanchez - Centennial (LB): Allegheny, Bethel (Kans.), Colorado Mesa (preferred walk-on), Concordia Coll. (Minn.), Concordia Univ. (Ill.), Hamline, Lake Forest, Rocky Mountain, <b>SIMPSON</b><br></p><p>Eli Sanders - Chandler (RB): Arizona, Arizona State, Boise State, Dartmouth, Hawaii, Idaho, Iowa, <b>IOWA STATE</b>, Nevada, New Mexico State, Northern Arizona, San Diego State, Tulane</p><p>Elijah Sanders - Ironwood (WR): Mary, <b>SIOUX FALLS</b> <br></p><p>Grant Sands - Perry (LS): Weber State</p><p>Koby Sarna - Red Mountain (DE): Culver-Stockton, Southern (preferred walk-on)<br></p><p>Mo Sarnowski - Hamilton (LB): Benedictine (Kans.), <b>NORTHERN ARIZONA</b><br></p><p>Xavier Saucedo - Tolleson (WR): Arizona Christian<br></p><p>Kevin Sawitzke - Mountain Pointe (TE): Augustana (S. Dak.), Colorado Mesa, Idaho, Iowa State (preferred walk-on), Southwest Minnesota State</p><p>Joshua Schenks - Highland (WR): <b>JAMESTOWN</b><br></p><p>Hunter Schlagel - Cienega (DT): Augustana, Northern Arizona, Southwest Minnesota State, Tarleton State, Washburn, <b>WESTERN NEW MEXICO</b><br></p><p>Noah Schmidt - Hamilton (RB): College of Idaho, <b>COLORADO STATE (PREFERRED WALK-ON)</b>, Fresno State (preferred walk-on)<br></p><p>Jake Schmitt - Corona del Sol (LB): Colorado State, Idaho, New Mexico, New Mexico State, <b>NORTHERN ARIZONA</b>, Southern Utah. Weber State</p><p>Jack Schrieber - Desert Mountain (WR): Culver-Stockton, Hamline, Kalamazoo, Ottawa, Southwest Minnesota State, St. Norbert, Wisconsin-River Falls</p><p>Brandon Schwartz - Deer Valley (OG): Southwest Minnesota State, Wisconsin-River Falls<br></p><p>Tyler Schweigert - Notre Dame (QB): Allegheny, Carroll, Hamline, Monmouth Coll. (Ill.), Simpson, Whittier, <b>WISCONSIN-RIVER FALLS</b><br></p><p>Micah Scott - Sunrise Mountain (SS): Arizona Christian, Benedictine Coll. (Kans.), Nebraska Wesleyan<br></p><p>CJ Scrivner - Safford (RB): <b>CSU-PUEBLO</b>, Culver-Stockton<br></p><p>Jackson Sebastiani - Horizon (C): Arizona Christian, Culver-Stockton, Mayville State, Ottawa, Wisconsin-River Falls<br></p><p>Joseph Semien - Willow Canyon (DE): Whittier</p><p>Ethan Seppala - Canyon del Oro (FS): Concordia Coll. (Minn.), Hamline, Nebraska Wesleyan, Wisconsin-River Falls</p><p>Ryan Severson - Perry (OG): Dakota State, Jamestown, <b>WESTERN NEW MEXICO</b><br></p><p>Kyle Sfarcioc - Liberty (OT): Abilene Christian, Morehead State, San Diego, Southern Utah<br></p><p>Brayden Shambaugh - Casteel (RB): Whittier</p><p>Dustin Sheeley - Canyon del Oro (LB): Simpson</p><p>Jaxson Sherwood - Casteel (LB): Lake Forest<br></p><p>Junior Shima - Ironwood (RB): Carthage, Clarke, Culver-Stockton, Hamline, North Park, Puget Sound, Trine, Whittier<br></p><p>Brady Shough - Hamilton (ATH): <b>NORTHERN ARIZONA</b><br></p><p>Dillon Silva - Cienega (LB): Simpson, Western New Mexico, Wisconsin-River Falls<br></p><p>Corvel Simmons - Central (LB): Wisconsin-River Falls</p><p>Sean Simmons - Basha (WR): Hamline<br></p><p>Dorian Singer - Pinnacle (WR/S): Air Force, Eastern Michigan, Howard, Illinois State, Iowa State, Montana State, North Dakota State, Northern Arizona, Northern Iowa, Ohio, South Dakota, South Dakota State, Southern Illinois, Texas, Utah, Western Michigan<br></p><p>Taylor Siren - Highland (FS): Dakota State, Ottawa, Southwest Minnesota State, Trine, Wisconsin-River Falls<br></p><p>Sean Sisco - Mountain Ridge (OG): Bethel Univ. (Minn.), Carleton, Concordia Coll. (Minn.), Hamline, Kenyon, Lake Forest, Oberlin, Occidental, Pacific, Puget Sound, Rose-Hulman, Simpson, St. Olaf, Wheaton</p><p>Dallas Sitzler - Centennial (LB): <b>SIMPSON</b><br></p><p>AJ Skaggs - Sabino (QB): Augustana, Sioux Falls, Whittier</p><p>Kenny Slade - Cienega (CB): Culver-Stockton, Whittier<br></p><p>Dante Smith - Desert Ridge (DT): Abilene Christian, New Mexico, New Mexico State, North Dakota, <b>NORTHERN ARIZONA</b>, Northern Colorado, Sacramento State, South Dakota State, Tarleton State<br></p><p>Daylin Smith - Marana Mountain View (LB): Ripon, Western New Mexico, Wisconsin-River Falls</p><p>Seth Smith - Chandler (OT): <b>NORTHERN ARIZONA</b><br></p><p>Thomas Smith - Ironwood Ridge (WR): Kalamazoo, Simpson</p><p>Elijah Sobas - Hamilton (LB): Concordia Coll. (Minn.), Heidelberg<br></p><p>Quintin Somerville - Saguaro (DE): Arizona, Arizona State, Auburn, Florida, Florida State, Georgia, Georgia Tech, Idaho, Kansas State, LSU, Memphis, Michigan, Michigan State, Mississippi, Mississippi State, Nebraska, Northwestern, Ohio State, Oregon State, Stanford, <b>UCLA</b>, UNLV, Utah, Vanderbilt, Washington, Washington State</p><p>Colton Sopko - Paradise Honors (P): Benedictine (Ill.), Carthage, Kansas Wesleyan, Lyon, Nichols, Puget Sound, St. Ambrose, Tabor, Wisconsin Lutheran</p><p>Justice Sosnicki - Verrado (LB): Arizona Christian, <b>MAYVILLE STATE</b>, Southwestern (Kans.)<br></p><p>Tyler Speece - Skyline (SS): Arizona Christian, Concordia Coll. (Minn.), Dakota State, DePauw, Doane, George Fox, Hamline, Kalamazoo, Kenyon, Lake Forest, Luther, Nebraska Wesleyan, Northwestern Coll. (Iowa), Oberlin, Ottawa, Presentation, Puget Sound, Rhodes, Saint John's, Simpson, Southwest Minnesota State, St. Ambrose, St. Olaf, Trine, Wisconsin-River Falls</p><p>Kai Spencer - Marana (LB): Benedictine (Kans.), Concordia Coll. (Minn.), Millikin<br></p><p>Cameron Steele - Desert Edge (LB): Livingstone, <b>ROCKY MOUNTAIN</b><br></p><p>Jaden Stewart - Deer Valley (LB): Crown, <b>OTTAWA</b><br></p><p>Kaiden Stewart - Valley Vista (FS): Arizona Christian, Carroll Coll. (Mont.), <b>COLLEGE OF IDAHO</b>, Jamestown, La Verne, Nebraska Wesleyan, Rocky Mountain<br></p><p>Chris Stoica - Shadow Ridge (OG): Benedictine (Kans.), Carleton, Concordia Coll. (Minn.)., Culver-Stockton, Judson, Kalamazoo, Puget Sound, Sewanee, Trine</p><p>Kolton Stone - Florence (C): Clarke, Concordia Univ. (Wisc.), Culver-Stockton, <b>SIMPSON</b><br></p><p>Ben Strawn - Northwest Christian (DE): Ottawa, Whittier</p><p>TyKayden Surrell - Mountain Pointe (SS): Avila<br></p><p>Garrett Sutliffe - Valley Vista (OG): Benedictine Univ. (Ill.), Buena Vista, Hamline, Lake Forest, Mayville State, Nebraska Wesleyan, Pacific, Redlands, Whittier<br></p><p>Kayden Sutter - Higley (LB): Hamline, Simpson, Wisconsin-River Falls</p><p>Zachary Sutton - Shadow Ridge (WR): Adams State<br></p><p>Evan Svoboda - Red Mountain (QB): Abilene Christian, Illinois State, Marshall (preferred walk-on), Morehead State, Washburn</p><p>Davin Switzer - Williams Field (TE): Simpson<br></p><p>Ryan Swoger - Cienega (S): <b>SOUTH DAKOTA STATE</b><br></p><p>Eli Swope - Chandler (TE): Colorado School of Mines, <b>SAN DIEGO</b>, Southern Utah</p><p>Tyson Tapley - Desert Mountain (WR): Loras, Luther, Puget Sound, Whittier</p><p>Caleb Taylor - Desert Mountain (LB): Arizona Christian, Benedictine (Kans.), Ottawa<br></p><p>KJ Taylor - Chandler (WR): Concord, West Virginia (preferred walk-on)<br></p><p>Myles Taylor - Williams Field (WR/DB): Abilene Christian, Air Force, Army, Idaho, Navy, North Dakota, <b>SOUTH DAKOTA STATE</b>, Southern Utah</p><p>Filipo Teofilo - Centennial (OG): Simpson<br></p><p>Jacob Thomas - Casa Grande (LB): Benedictine Coll. (Kans.), Hamline, McPherson, Simpson<br></p><p>Justin Thomas - Casteel (OT): Abilene Christian, Air Force, Dartmouth, Idaho, <b>NORTHERN ARIZONA</b>, Southeast Missouri State, Washburn</p><p>Owen Thomas - Sunrise Mountain (LB): Whittier<br></p><p>Donovan Thomason - Saguaro (LB): Arizona Christian, Concordia Coll. (Minn.), Ottawa, Simpson<br></p><p>Luke Thompson - Sabino (LB): Concordia Univ. (Ill.)<br></p><p>Ty Thompson - Mesquite (QB): Arizona, Arizona State, Boise State, Boston College, California, Colorado, Duke, Iowa, Iowa State, Louisville, LSU, Miami (Fla.), Michigan State, North Carolina State, Northern Arizona, <b>OREGON</b>, Oregon State, Purdue, Utah, Wisconsin</p><p>Alex Ticala - Cactus (OT): Benedictine (Kans.)</p><p>Ben Tobin - Scottsdale Christian (QB): Arizona Christian, Chadron State, <b>NEW MEXICO STATE (PREFERRED WALK-ON)</b>, Ottawa<br></p><p>Derek Torres - Mountain Ridge (DE): Simpson</p><p>Fernando Torres - Salpointe (TE): <b>ST. OLAF</b><br></p><p>Daniel Tripp - Valley Lutheran (OT): Avila, Western New Mexico<br></p><p>Chris Trojan - Hamilton (FS): Arizona Christian, Benedictine Coll. (Kans.), Clarke, New Mexico, Northern Arizona (preferred walk-on), Olivet, Wisconsin-River Falls</p><p>Joshua Tsosie - Saguaro (DE): Concordia Coll. (Minn.), Nebraska Wesleyan<br></p><p>Gabe Tulo - Desert Ridge (CB): Hamline<br></p><p>Jeremiah Tyler - Chandler (DT): Air Force, Army, Ball State, Brown, Furman, Georgetown, Howard, Nevada, New Mexico, <b>WESTERN NEW MEXICO</b><br></p><p>Marcellous Urias - Saguaro (OT): Mary, Ottawa, Southwest Minnesota State, Western New Mexico<br></p><p>Rene Urias Jr. - Nogales (LB): <b>GRINNELL</b><br></p><p>Nico Vasko - Westview (QB): Mayville State</p><p>Isaiah Vega - Williams Field (OT): Livingstone<br></p><p>Andrew Vescova - Paradise Valley (DT): Arizona Christian, Culver-Stockton, La Verne, Monmouth Coll. (Ill.), Pacific, Puget Sound, Ripon, Simpson, Trine</p><p>Chris Villalobos - Campo Verde (CB): Wisconsin-River Falls</p><p>Bram Walden - Saguaro (OT): Arizona, Arizona State, Arkansas, Auburn, BYU, California, Colorado, Florida State, Iowa State, LSU, Memphis, Miami (Fla.), Michigan, Michigan State, Mississippi State, Missouri, Ohio State, Oklahoma State, <b>OREGON</b>, Oregon State, Stanford, Tennessee, Texas, Texas A&amp;M, UCLA, UNLV, USC, Utah, Washington, Washington State</p><p>Christopher Walter - Florence (QB): Clarke, Concordia Univ. (Wisc.), Graceland, Lewis &amp; Clark, Millikin, Monmouth (Ill.), Olivet, Wagner (preferred walk-on), Western New Mexico<br></p><p>Tory Walters - Buena (RB): Benedictine, Carthage, Culver-Stockton, Elmhurst, Friends, Millikin, Monmouth (Ill.), Puget Sound, Whitworth, Wooster<br></p><p>Brannon Weatherby - Yuma Catholic (C): Abilene Christian (preferred walk-on), Arizona Christian, Benedictine (Kans.), Culver-Stockton, Nebraska Wesleyan, Ottawa, Simpson, <b>SOUTHWEST BAPTIST</b>, Whittier</p><p>Sherome Weatherspoon - Valley Christian (WR): Avila, Graceland<br></p><p>Isaiah Webb - Cienega (LB): Southwest Minnesota State, <b>WESTERN NEW MEXICO</b><br></p><p>Matthew Weed - Deer Valley (WR): Carleton, Culver-Stockton, Grinnell, Hamline, <b>PUGET SOUND</b><br></p><p>Xander Werner - Saguaro (TE/QB): Air Force, Army, Bucknell, Fordham, Hawaii, Idaho, New Mexico, New Mexico State, <b>NORTHERN ARIZONA</b>, Southern Utah, Texas State</p><p>Dane White - Perry (QB): <b>JAMESTOWN</b><br></p><p>Jaden White - Cactus Shadows (QB): <b>ARIZONA (PREFERRED WALK-ON)</b>, Buena Vista, Hamline, Puget Sound, St. Olaf<br></p><p>Jack Whitten - Chaparral (SS): <b>BROWN</b>, Carnegie Mellon, Chicago</p><p>Case Wiggins - Saguaro (OG): Saint Anselm, San Diego</p><p>Syre Wilkerson - Arcadia (WR): Oklahoma Panhandle State<br></p><p>Caleb Wilkins - North Canyon (QB): Arizona Christian, Benedictine (Kans.), La Verne, Ottawa, St. Francis, Trine, Whittier, Wisconsin-River Falls</p><p>DJ Williams - Centennial (CB): Montana State, <b>NORTHERN ARIZONA</b>, Northern Colorado, Southern Utah<br></p><p>Jared Williams - Chaparral (RB): <b>MINOT STATE</b>, Northern Arizona, Ottawa<br></p><p>Kentrell Williams Jr. - Chandler (SS): <b>EASTERN WASHINGTON</b>, Furman, Northern Arizona, Northern Colorado, Southern Utah, Western New Mexico</p><p>Noah Williams - Dobson (LB): Bethel Coll. (Kans.)<br></p><p>Richie Williams - Arizona College Prep (RB): Hope, Kenyon, Lake Forest, Linfield, Livingstone, Olivet, Pacific, Saint John's, Simpson, St. Francis, Trine</p><p>Zereoue Williams - Mountain Pointe (OT): Arizona, Arizona State, Boston College, Florida State, Iowa State, Missouri, Northern Arizona, Oregon State, Tennessee, <b>UTAH</b><br></p><p>Ian Williamson - Notre Dame (RB): Whittier</p><p>Jaheim Wilson-Jones - Gila Ridge (CB/WR): McDaniel, Morgan State, <b>NORTHERN COLORADO</b><br></p><p>Mason Winkelmann - Chandler (C): Allegheny, Concordia Coll. (Minn.), Lake Forest, Mayville State, Trinity International<br></p><p>Ryan Wintermeyer - Cactus Shadows (LS): Air Force, Akron, <b>SAN DIEGO STATE (PREFERRED WALK-ON)</b><br></p><p>Alex Witt - Hamilton (DE): Olivet</p><p>Garrett Wojcik - Willow Canyon (FS): Juniata, Lake Forest, Marietta, Simpson, Willamette<br></p><p>Aaron Wolfcale-Holsten - Williams Field (DT): Benedictine (Kans.), Concordia Coll. (Minn.), Hamline, Livingstone, Mary, San Diego, <b>SOUTH DAKOTA STATE</b>, Valparaiso, Wisconsin-River Falls</p><p>Brandon Woodland - Greenway (K/P): Arizona Christian, Gustavus Adolphus, Mayville State, Tabor</p><p>Mark Wren - Thatcher (RB): Lake Forest<br></p><p>Dominic Wright - Boulder Creek (RB): La Verne, Simpson</p><p>Jonah Wright - Peoria (OT): Black Hills State, <b>SOUTHERN UTAH</b><br></p><p>Zachary Young - Casteel (LB): La Verne<br></p><p>Ashton Yurkiw - Sunnyslope (WR): Arizona Christian</p><p>Jesus Zayas - Glendale (OG): Arizona Christian</p><p>Victor Zayas - Hamilton (LB): Arizona<br></p><p>Wyatt Zellner - Gilbert (LB): Carleton, Concordia Coll. (Minn.), Linfield, Mayville State<br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/dldkchbuyjszr7z97awg&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/dldkchbuyjszr7z97awg&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Photo by Andy Silvas Photography" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/dldkchbuyjszr7z97awg" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Photo by Andy Silvas Photography</figcaption>
</div>
</figure>
<h3 class='article-heading'>Basha wide receiver Bachmann commits to Western New Mexico</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>UPDATED: 1/30/21</b></p><p>Basha senior wide receiver <b>Carson Bachmann</b> announced his commitment to Western New Mexico on Saturday afternoon.<br></p><p>Bachmann, a standout kick returner as well, caught 15 passes for 287 yards and scored three offensive touchdowns. His two other scores came on long kickoff runbacks of 80 and 95 yards.<br></p><p>The 5-10, 160-pounder totaled 372 yards in his seven kick returns. Bachmann also played some defensive back and had 12 tackles. He is the seventh senior from Arizona to commit to WNMU in this class.<br></p><p>Western New Mexico is a member of the Lone Star Conference (Div. II). The Mustangs were 2-10 in 2019, but weren't able to play in the fall. Fortunately, WNMU will get a chance in the spring with a four-game schedule. The Mustangs will begin it at home in Silver City on Feb. 27 against UT-Permian Basin (Tex.).<br></p><p><br>Casteel defensive end <b>Ethan Hunt</b> visited Black Hills State. He got to take in everything the school and the football program in South Dakota had to offer. On Saturday, he announced his commitment to the Yellow Jackets.<br></p><p>"The atmosphere of the university was amazing," Hunt said in a text message. "The culture that they are building there is unbelievable; everything from the coaching staff to the student athletes that were on campus. I knew from the minute I stepped onto the campus that I wanted to be a part of the amazing culture that they are building at Black Hills State University."<br></p><p>Last season, the 6-2, 235-pound lineman made 38 tackles and had a sack for the Colts. Hunt is a multi-sport athlete and also plays catcher for the baseball team.</p><p>Black Hills State is in the Rocky Mountain Athletic Conference (Div. II). The Yellow Jackets played in two games (0-2) in October and saw the rest of its abbreviated fall schedule canceled due to continued COVID-19 concerns. In its opener, BHSU played at home on a snowy field. In that game, junior running back Nolan Susel (a Florence alum) led the team with 24 rushing yards while also catching six passes for 93 yards against Colorado Mesa.<br></p><p><br>One of Hunt's teammates also announced his commitment on Saturday as <b>Desmon Holton</b> will be headed northwest to Lewis &amp; Clark College.</p><p>A meeting with one of the assistant coaches from the Pioneers helped cement the relationship.<br></p><p>"They were really interested in me early on and the Assistant Head Coach (Joe Bushman) was out here in Arizona a little while back and told me he'd like to meet me," Holton said in a text message. "We were at Raising Canes for about an hour talking about their school and football program. No one else did that for me."</p><p>Holton followed that up with a FaceTime visit of the campus in Portland. He also likes the offense the Pioneers run.</p><p>"Their football team likes to air it out and they just put in a spread package to their offense and that was big for me since we did a lot of that at Casteel," Holton said. "Their team is on the brink of something special and just needs a few more pieces to push it over the edge and I feel I'm one of those pieces they're looking for!"<br></p><p>The 6-foot, 175-pound wide receiver had eight catches for 51 yards on a Casteel team that was very deep at the position. Holton also excels in the classroom with a 4.2 GPA.<br></p><p>Lewis &amp; Clark, along with Willamette, canceled competition for high-risk sports football and basketball for the entire academic year. The Pioneers are in the Northwest Conference (Div. III) and the school is looking for meaningful ways to engage in athletic and physical activities this spring. In the 2019 season, Lewis &amp; Clark finished 4-5, which was its highest win total since 2012.<br></p><p><br><b>Isaak Johnson</b> played on both sides of the ball at Shadow Mountain. Following a December visit to Ferrum College in Virginia, he received an offer from the Panthers.</p><p>The center and linebacker acted on that and gave his commitment to Ferrum on Saturday.</p><p>"They were one of the only Division III schools that offered an Animal Science program and their team philosophy lines up exactly with my own," Johnson said in a text message. "They were also very active and supportive throughout the entire recruitment process."<br></p><p>The 5-11, 210-pound athlete was named to the All-Paradise Valley School District Defense Team. Johnson made 27 tackles in five games for the Matadors. In addition to football, Johnson wrestles at SMHS.<br></p><p>Ferrum is getting closer to kicking off its season. The Panthers and the rest of the Old Dominion Athletic Conference will play on Friday nights starting on Feb. 26 at home against Emory &amp; Henry (Va.). There will be five weeks of games followed by a championship week where eight of the nine schools will play another game. In 2019, the Panthers finished 4-6.<br></p><p><br>Two more commitments from Saturday:</p><p>Mesa Mountain View linebacker <b>Mason Parker</b> committed to Jamestown (N. Dak.) and Valley Vista wide receiver <b>Maddox Lawien</b> committed to Crown (Minn.).<br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/fw0p7gtch9jlkonyo0vp&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/fw0p7gtch9jlkonyo0vp&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Casteel DE Ethan Hunt" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/fw0p7gtch9jlkonyo0vp" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Casteel DE Ethan Hunt</figcaption>
</div>
</figure>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/rh9akqjy6dwh9jzjemjf&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/rh9akqjy6dwh9jzjemjf&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Casteel WR Desmon Holton  (Photo Courtesy of Desmon Holton)" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/rh9akqjy6dwh9jzjemjf" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Casteel WR Desmon Holton  (Photo Courtesy of Desmon Holton)</figcaption>
</div>
</figure>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/jabikzqpn1lkmogixbvr&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/jabikzqpn1lkmogixbvr&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Shadow Mountain C Isaak Johnson  (Photo Courtesy of Isaak Johnson)" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/jabikzqpn1lkmogixbvr" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Shadow Mountain C Isaak Johnson  (Photo Courtesy of Isaak Johnson)</figcaption>
</div>
</figure>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/ws0nm9y7wbkfipdgiqc4&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/ws0nm9y7wbkfipdgiqc4&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Mountain View LB Mason Parker" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/ws0nm9y7wbkfipdgiqc4" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Mountain View LB Mason Parker</figcaption>
</div>
</figure>
<h3 class='article-heading'>CLASS OF 2021 COMMITMENTS

</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>Players that have signed are in BOLD<br></b></p><p><b><br></b></p><p><b>ABILENE CHRISTIAN WILDCATS</b></p><p><b>Kyle Pointer (LB) - Casteel</b><b><br></b></p><p><b>AIR FORCE FALCONS</b></p><p>Cade Berger (WR) - Perry<b><br>Liam Hoffmeyer (TE) - Cibola<br>Kyler Orr (LB) - Chandler<br></b></p><p><b>ARIZONA WILDCATS</b></p><p>Anthony Gonzales (FS) - Saguaro (walk-on)<b><br>Stevie Rocker (RB) - Canyon del Oro<br></b>Jaden White (QB) - Cactus Shadows (walk-on)<b><br></b></p><p><b>ARIZONA STATE SUN DEVILS</b></p><p><b>John Ferlmann (LS) - Boulder Creek (walk-on)<br></b>Colby Garvin (WR) - Queen Creek (walk-on)<b><br>Isaia Glass (OT) - Queen Creek<br></b></p><p><b>ARMY BLACK KNIGHTS</b></p><p><b>Daxon Lindholm (RB) - Centennial<br></b></p><p><b>AUGUSTANA (S. DAK.) VIKINGS</b></p><p>Anthony Hanger (DT) - Chandler<b><br></b>Max Minor (WR) - Chaparral<b><br></b></p><p><b>BENEDICTINE (KANS.) RAVENS</b></p><p>Zayden Ennis (OT) - Centennial<b><br></b></p><p><b>BLACK HILLS STATE YELLOW JACKETS</b></p><p>Ethan Hunt (DE) - Casteel<b><br></b></p><p><b>BOISE STATE BRONCOS</b></p><p><b>Jalen Richmond (WR) - Chandler<br></b></p><p><b>BROWN BEARS</b></p><p><b>Jack Whitten (SS) - Chaparral</b></p><p><b>BUTLER BULLDOGS</b></p><p>Joseph MacDonald (CB) - O'Connor<b><br></b></p><p><b>BYU COUGARS</b></p><p><b>Sione Hingano (OT) - Chandler<br></b></p><p><b>CALIFORNIA GOLDEN BEARS<br></b></p><p><b>Hunter Barth (FS) - Queen Creek<br>Kai Millner (QB) - Higley</b></p><p><b>CARROLL PIONEERS</b></p><p>Joseph Armstrong (CB) - Walden Grove<b><br></b></p><p><b>COE KOHAWKS</b></p><p>Skyler Higdon (OT) - Vista Grande<b><br></b></p><p><b>COLLEGE OF IDAHO YOTES</b></p><p>Kaiden Stewart (FS) - Valley Vista<b><br></b></p><p><b>COLORADO BUFFALOES</b></p><p><b>Zion Magalei (DE) - Chandler</b></p><p><b>COLORADO MESA MAVERICKS</b></p><p>Alexander Bruns (OT) - Hamilton<b><br></b></p><p><b>COLORADO STATE RAMS</b></p><p><b>Jack Howell (FS) - Hamilton<br>Jackson Ray (P) - Highland (walk-on)<br></b>Noah Schmidt (RB) - Hamilton<b><br></b></p><p><b>COLUMBIA LIONS</b></p><p><b>Nicolas Nesbitt (RB) - Chandler</b></p><p><b>CONCORDIA COLLEGE (MINN.) COBBERS</b></p><p>Maximus LaVoy (OT) - Notre Dame<b><br></b></p><p><b>CROWN STORM</b></p><p>Maddox Lawien (WR) - Valley Vista<b><br></b></p><p><b>CSU-PUEBLO THUNDERWOLVES</b></p><p>CJ Scrivner (RB) - Safford<b><br></b></p><p><b>DAKOTA STATE TROJANS</b></p><p>Terrance Liddile - Kellis (CB)<b><br></b></p><p><b>DICKINSON STATE BLUE HAWKS</b></p><p>Jan Ruiz (WR ) - Sierra Linda<b><br></b></p><p><b>DIXIE STATE TRAILBLAZERS</b></p><p>TJ McRae (DT) - Centennial<b><br></b></p><p><b>DRAKE BULLDOGS</b></p><p><b>Sebastian Adamski (LB) - Walden Grove<br></b>Tony Brewer (FS) - Chandler<b><br></b>Sebastian Felix (SS) - Cienega<b><br>Tevainui Neher (C) - Chandler<br></b></p><p><b>DUKE BLUE DEVILS</b></p><p><b>Trey Brown (LB) - Arcadia</b></p><p><b>EASTERN NEW MEXICO GREYHOUNDS</b></p><p>Elijah Anderson (CB) - Sunrise Mountain<br>Rogan Freeburg (WR) - Desert Mountain<b><br></b>Howard Russell (RB) - Phoenix Christian<b><br></b></p><p><b>EASTERN WASHINGTON EAGLES</b></p><p><b>Kentrell Williams Jr. (SS) - Chandler</b></p><p><b>FERRUM PANTHERS</b></p><p><b>Isaak Johnson (LB) - Shadow Mountain<br></b></p><p><b>FORT LEWIS SKYHAWKS</b></p><p>Jayden Ahboah (OG) - Desert Edge<b><br></b></p><p><b>FRESNO STATE BULLDOGS</b></p><p>Zeke Branham (LB) - Skyline (blue shirt)<b><br></b></p><p><b>GEORGETOWN HOYAS</b></p><p><b>Rashon Adams (CB) - Centennial<br></b></p><p><b>GRINNELL PIONEERS</b></p><p>Rene Urias Jr. (LB) - Nogales<b><br></b></p><p><b>IOWA STATE CYCLONES</b></p><p>Eli Sanders (RB) - Chandler<b><br></b></p><p><b>JAMESTOWN JIMMIES</b></p><p>Austin Brenn (OG) - Perry<br>Charles Hamm (CB) - Cienega<br>Mason Parker (LB) - Mesa Mountain View<br>Joshua Schenks (WR) - Highland<br>Dane White (QB) - Perry<b><br></b></p><p><b>KANSAS STATE WILDCATS</b></p><p><b>Krew Jackson (FS) - Queen Creek<br></b></p><p><b>LAKE FOREST FORESTERS</b></p><p>Albin Arulanandu (CB) - Mountain Ridge<br>Joshua Gasca (QB) - Centennial<br>Christian Johnson (RB) - Greenway<b><br></b>Caden Petersen (WR) - Higley<b><br></b>Hayden Preston (OT) - Campo Verde<b><br></b></p><p><b>LEWIS &amp; CLARK PIONEERS</b></p><p>Desmon Holton (WR) - Casteel<b><br></b></p><p><b>MARY MARAUDERS</b></p><p>Mikaele Fuamatu (OG) - Millennium<br>Jadon Hanzal (QB) - Valley Christian<b><br></b>Gabe Levy (RB) - Cienega<b><br></b>Mason Phillips (LB) - Casteel<b><br></b>Jason Ramirez-Corpuz (CB) - Mountain Pointe<b><br></b></p><p><b>MAYVILLE STATE COMETS</b></p><p>Luis Felix (LB) - Trevor Browne<br>Gavin Goulette (QB) - Gilbert<br>Fernando Macias (OG) - Trevor Browne<b><br></b>Justice Sosnicki (LB) - Verrado<b><br></b></p><p><b>MICHIGAN STATE SPARTANS</b></p><p><b>Hank Pepper (LS/LB) - Chandler<br></b></p><p><b>MINNESOTA GOLDEN GOPHERS</b></p><p><b>Steven Ortiz Jr. (CB) - Desert Edge<br></b></p><p><b>MINOT STATE BEAVERS</b></p><p>Evan Lovett (RB) - Pusch Ridge<br>Zeth Nastal (LB) - Mesa<b><br></b>Jared Williams (RB) - Chaparral<b><br></b></p><p><b>MONTANA STATE BOBCATS</b></p><p><b>Aaron Gerle (DT) - Greenway<br>Andrew Patterson (WR) - Desert Edge<br></b></p><p><b>MOREHEAD STATE EAGLES</b></p><p><b>Dylan Cook (FS) - Ironwood Ridge<br>Garrick Krautz (TE) - Catalina Foothills</b></p><p><b>NEBRASKA WESLEYAN PRAIRIE WOLVES</b></p><p>Quinton Crosby (LB) - Higley<b><br></b></p><p><b>NEVADA WOLF PACK</b></p><p><b>Zion Burns (DB/RB) - Poston Butte<br>Zachary Lewis (CB) - Hamilton<br></b></p><p><b>NEW MEXICO LOBOS</b></p><p><b>Andrell Barney (CB) - Basha<br>Bear Milacek (QB) - Boulder Creek<br>JD Roberts (LB) - Notre Dame<br></b></p><p><b>NEW MEXICO STATE AGGIES</b></p><p><b>Da Marcus Ellis-Dennard (LB) - Brophy<br></b>Ben Tobin (QB) - Scottsdale Christian<b><br></b></p><p><b>NORTH DAKOTA FIGHTING HAWKS</b></p><p><b>Damien Owens (WR) - Notre Dame<br></b></p><p><b>NORTHERN ARIZONA LUMBERJACKS</b></p><p><b>Zach Blackwood (DE) - Desert Edge<br>Marzion Cosby (WR) - Centennial<br>Richard Kwete (DT) - Sunnyslope<br></b>PJ London (QB) - Blue Ridge<b><br>Alani Ma'afu (DT) - Saguaro<br>Andrew Mason (OT) - Perry<br>Caiden Miles (OT) - Centennial<br></b>Tage Rigby (RB) - Centennial (walk-on)<b><br></b>Mo Sarnowski (LB) - Hamilton<b><br>Jake Schmitt (LB) - Corona del Sol<br>Brady Shough (ATH) - Hamilton<br>Dante Smith (DT) - Desert Ridge<br>Seth Smith (OT) - Chandler<br>Justin Thomas (OT) - Casteel<br>Xander Werner (TE/QB) - Saguaro<br>DJ Williams (CB) - Centennial</b></p><p><b>NORTHERN COLORADO BEARS</b></p><p>Jaheim Wilson-Jones (CB/WR) - Gila Ridge<b><br></b></p><p><b>NORTHERN MICHIGAN WILDCATS</b></p><p>Jack Chappelle (OT) - Shadow Ridge<b><br></b></p><p><b>NORTHERN STATE WOLVES</b></p><p>Mason Osborn (OT) - Chaparral<b><br></b></p><p><b>OBERLIN YEOMEN <br></b></p><p>Ethan Price (DT) - Cactus<b><br></b></p><p><b>OHIO STATE BUCKEYES</b></p><p><b>Denzel Burke (CB/WR) - Saguaro<br></b></p><p><b>OREGON DUCKS</b></p><p><b>Anthony Ament (RB) - Pinnacle (walk-on)<br>Brandon Buckner (DE) - Chandler<br>Jonah Miller (OT) - Salpointe<br>Ty Thompson (QB) - Mesquite<br>Bram Walden (OT) - Saguaro</b></p><p><b>OTTAWA SPIRIT</b></p><p>Damen Cornett (FB) - Queen Creek<br>Jaylen Hawkins (RB) - Millennium<br>Jaden Stewart (LB) - Deer Valley</p><p><b>PENNSYLVANIA QUAKERS</b></p><p><b>Jacob Cisneros (RB) - Boulder Creek</b></p><p><b>PERU STATE BOBCATS</b></p><p>Jeremiah Reed (SS) - Westwood<br></p><p><b>PUGET SOUND LOGGERS</b></p><p>Matthew Weed (WR/DB) - Deer Valley</p><p><b>RHODES LYNX</b></p><p>Daniel Fulton (LB) - Chandler<br></p><p><b>ROCKY MOUNTAIN BATTLIN' BEARS</b></p><p>Max Garcia (DT) - Desert Edge<b><br></b>Cess Ibarra (OG) - Chandler<b><br>Brock Mast (QB) - Liberty<br></b>Ali'i Kai Ormita (OG) - Chandler<br>Cameron Steele (LB) - Desert Edge<br></p><p><b>SAN DIEGO TOREROS</b></p><p><b>Logan Gingg (RB) - Verrado<br>James Jaquint (SS) - Notre Dame<br>Eli Swope (TE) - Chandler</b><br></p><p><b>SAN DIEGO STATE AZTECS</b></p><p><b>Darrion Dalton (DT) - Saguaro<br>Will Haskell (QB) - Ironwood<br></b>Ryan Wintermeyer (LS) - Cactus Shadows (walk-on)<b><br></b></p><p><b>SIMPSON STORM</b></p><p>Alex Boyle (LB) - Centennial<br>Alex Culbertson (WR) - Walden Grove<br>Devin Sanchez (LB) - Centennial<br>Dallas Sitzler (LB) - Centennial<br>Kolton Stone (C) - Florence<br></p><p><b>SIOUX FALLS COUGARS</b></p><p>Dominic Avant (OT) - Buena (walk-on)<br>Isaac Benoit (RB) - Buena (walk-on)<br>Diamonte Bright (SS) - Desert Ridge<br>Cayden Camacho (FS) - Basha<br>Andrew Hanzal (WR) - Valley Christian (walk-on)<br>Jayden Harrington (CB) - Verrado<br>Chase Randall (DE) - Canyon del Oro<br>Elijah Sanders (WR) - Ironwood<br></p><p><b>SOUTH DAKOTA SCHOOL OF MINES</b></p><p>Caleb Jones (RB) - Basha (walk-on)<br></p><p><b>SOUTH DAKOTA STATE JACKRABBITS</b></p><p><b>Derrick Brown (OT) - Queen Creek<br></b>Chandler Carter (DE) - Valley Christian<b><br>Jaden Crockett (S) - Mountain Pointe<br>Colby Littleton (LB) - Queen Creek (walk-on)<br>Ryan Swoger (S) - Cienega (walk-on)<br>Myles Taylor (WR) - Williams Field<br>Aaron Wolfcale-Holsten (DT) - Williams Field</b></p><p><b>SOUTHERN UTAH THUNDERBIRDS</b></p><p><b>Jonah Wright (OT) - Peoria</b></p><p><b>SOUTHWEST BAPTIST BEARCATS</b></p><p>Brannon Weatherby (C) - Yuma Catholic<b><br></b></p><p><b>SOUTHWEST MINNESOTA STATE MUSTANGS</b></p><p>Eric Lira (WR) - Mesquite<br>Anthony Ortiz (OG) - Mountain Pointe<br></p><p><b>ST. NORBERT GREEN KNIGHTS</b></p><p>Chase Cassel (QB) - Ironwood Ridge<br></p><p><b>ST. OLAF OLES</b></p><p>Eduardo Ogaz (RB) - Safford<br>Fernando Torres (TE) - Salpointe<br></p><p><b>STANFORD CARDINAL</b></p><p><b>Anthony Franklin (DE) - Pinnacle</b></p><p><b>TABOR BLUEJAYS<br></b></p><p><b>Alfonzo Brown - Gila Ridge (LB)</b><br></p><p><b>TOLEDO ROCKETS</b></p><p><b>Benjamin Lisk (LS) - Paradise Valley</b></p><p><b>UCF KNIGHTS</b></p><p><b>Mikey Keene (QB) - Chandler</b><br></p><p><b>UCLA BRUINS</b></p><p><b>Isaiah Newcombe (WR) - Casteel<br>Quintin Somerville (DE) - Saguaro</b><br></p><p><b>UTAH UTES</b></p><p><b>Trey Reynolds (LB) - Queen Creek<br>Zereoue Williams (OT) - Mountain Pointe</b></p><p><b>VALPARAISO CRUSADERS</b></p><p>Trent Pennington (WR) - Basha<b><br></b></p><p><b>WASHBURN ICHABODS</b></p><p>Andrew Husfelt (C) - Cienega<br></p><p><b>WASHINGTON STATE COUGARS</b></p><p><b>Brock Dieu (OT): Casteel</b></p><p><b>WESTERN NEW MEXICO MUSTANGS</b></p><p>Carson Bachmann (WR) - Basha<br>Ricky Hanlan IV (WR) - Nogales<br>Heath Henderson (OT) - Desert Mountain<br>Hunter Schlagel (DT) - Cienega<br>Ryan Severson (OG) - Perry<br>Jeremiah Tyler (DT) - Chandler<br>Isaiah Webb (LB) - Cienega</p><p><b>WISCONSIN-RIVER FALLS FALCONS</b></p><p>Tyler Schweigert (QB) - Notre Dame<br></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-1-30/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === &quot;premium&quot;'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>

<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' display-lrec1-rightrail='true' display-lrec2-rightrail='true' display-lrec3-rightrail='true' enrichments='[]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2020' ncaaf-schedule-year='2020' scoreboard-photos-id='15082' scoreboard-scores-id='15081' site='{&quot;id&quot;:6,&quot;legacy_id&quot;:1128,&quot;name&quot;:&quot;ArizonaVarsity&quot;,&quot;friendly_name&quot;:&quot;Arizona HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;arizonavarsity&quot;,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;arizonavarsity&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;}' twitter-feed='{&quot;id&quot;:6,&quot;site_id&quot;:6,&quot;handle&quot;:&quot;ArizonaVarsity&quot;,&quot;list_name&quot;:&quot;TeamAZV&quot;,&quot;created_at&quot;:&quot;2016-02-01T12:24:39.964-06:00&quot;,&quot;updated_at&quot;:&quot;2020-04-28T02:17:51.614-05:00&quot;,&quot;hashtags&quot;:[],&quot;usernames&quot;:[&quot;AZHSFB&quot;,&quot;ArizonaVarsity&quot;],&quot;max_number&quot;:5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-1-30/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
</div>
</div>
<script src='/javascript/ad?ad_referrer=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fgridiron-arizona-s-2021-recruiting-update-1-30&amp;space_id=2022719646' type='text/javascript'></script>

<rv-chartbeat-config-body ng-hide sections='content,content-football,content-football-free,content-article' title='Gridiron Arizona&#39;s 2021 Recruiting Update: 1/30'></rv-chartbeat-config-body>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init(null, null, null, &quot;arizonavarsity&quot;, 2244248, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if='showLRECad(&#39;footer&#39;)'>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
</div>

</div>
</main>
<script src='/javascript/pencil_ad.js'></script>
<script src='/javascript/stream_ad.js'></script>
<script src='/javascript/moments_ad.js'></script>
<footer>
<div class='flexible-links'>
<a class='link' href='/news/about-us'>About</a>
<a class='link' href='/news/member-services'>Help</a>
<a class='link' href='/news/contact-us-5'>Contact Us</a>
<a class='link' href='/tos'>Terms of Service</a>
<a class='link' href='/gifts/purchase'>Gift Subscription</a>
</div>
<div class='flexible-links'>
<a class='link' href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
</div>
<div class='logo-container'>
<div class='footer-logo'><?xml version="1.0" encoding="UTF-8"?>
<svg width="159px" height="96px" viewbox="0 0 159 96" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 58 (84663) - https://sketch.com -->
    <title>logo_yahoo_sports_gray</title>
    <desc>Created with Sketch.</desc>
    <g id="Logos" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="logo-/-yahoo-sports-/-grayscale">
            <g id="logo-/-yahoo-sports-MASTER-/-black-on-white" transform="translate(0.000000, 36.000000)">
                <g id="yahoo-sports-logo-white">
                    <path d="M24.0702452,5.83111111 L24.0702452,7.06666667 C23.2097927,6.0367158 21.9427054,5.46606759 20.6261035,5.51555556 C17.1389101,5.51555556 14.5428883,8.69333333 14.5428883,12.4222222 C14.5428883,16.2577778 17.1259946,19.3333333 20.6261035,19.3333333 C21.9510266,19.3980812 23.2277754,18.8131965 24.0702452,17.7555556 L24.0702452,18.9911111 L28.4184741,18.9911111 L28.4184741,5.83111111 L24.0702452,5.83111111 Z M29.9209809,0 L29.9209809,18.9911111 L34.4241962,18.9911111 L34.4241962,11.9777778 C34.4241962,10.6088889 35.0613624,9.79555556 36.0773842,9.79555556 C37.093406,9.79555556 37.6315531,10.5066667 37.6315531,11.8177778 L37.6315531,18.9911111 L42.1347684,18.9911111 L42.1347684,10.7155556 C42.1347684,7.51111111 40.4557493,5.51555556 37.7564033,5.51555556 C36.4540592,5.4661141 35.2068557,6.0603675 34.3983651,7.11555556 L34.3983651,0.00444444444 L29.9209809,0 Z M71.1129155,12.4444444 C71.1129155,16.3866667 68.1897003,19.3555556 64.293515,19.3555556 C60.3973297,19.3555556 57.4741144,16.3866667 57.4741144,12.4444444 C57.4741144,8.50222222 60.4016349,5.53777778 64.293515,5.53777778 C68.1853951,5.53777778 71.1129155,8.50666667 71.1129155,12.4444444 Z M56.7120981,12.4444444 C56.7120981,16.3866667 53.7845777,19.3555556 49.8926975,19.3555556 C46.0008174,19.3555556 43.073297,16.3866667 43.073297,12.4444444 C43.073297,8.50222222 46.0008174,5.53777778 49.8926975,5.53777778 C53.7845777,5.53777778 56.7120981,8.50666667 56.7120981,12.4444444 Z M5.68434189e-14,5.85333333 L5.44174387,19.1155556 L3.48288828,23.8977778 L8.26594005,23.8977778 L15.5201635,5.85333333 L10.7844687,5.85333333 L7.83111717,13.5733333 L4.90359673,5.85333333 L5.68434189e-14,5.85333333 Z M21.5258856,15.1511111 C20.0778762,15.1511111 18.9040327,13.9392952 18.9040327,12.4444444 C18.9040327,10.9495937 20.0778762,9.73777778 21.5258856,9.73777778 C22.9738949,9.73777778 24.1477384,10.9495937 24.1477384,12.4444444 C24.1582975,13.1655836 23.8854595,13.8603865 23.3914592,14.3703671 C22.8974589,14.8803478 22.2244277,15.1620118 21.5258856,15.1511111 L21.5258856,15.1511111 Z M52.4155313,12.4444444 C52.3942095,10.9991882 51.2457931,9.84329333 49.8457334,9.85791214 C48.4456737,9.87253095 47.3201395,11.0521694 47.3271064,12.4975752 C47.3341381,13.942981 48.4710404,15.1109435 49.8711717,15.1111111 C50.5556752,15.1211114 51.2144344,14.8420408 51.6948283,14.3385545 C52.1752222,13.8350681 52.4355617,13.150859 52.4155313,12.4444444 Z M66.8163488,12.4444444 C66.795027,10.9991882 65.6466105,9.84329333 64.2465509,9.85791214 C62.8464912,9.87253095 61.720957,11.0521694 61.7279238,12.4975752 C61.7349555,13.942981 62.8718578,15.1109435 64.2719891,15.1111111 C64.9564926,15.1211114 65.6152519,14.8420408 66.0956458,14.3385545 C66.5760396,13.8350681 66.8363791,13.150859 66.8163488,12.4444444 Z M71.6510627,16.2266667 C71.6417293,17.0311249 71.9471656,17.80545 72.4982184,18.3743287 C73.0492712,18.9432074 73.7993326,19.2585242 74.5785831,19.2488889 C76.2429617,19.2488889 77.5922071,17.855997 77.5922071,16.1377778 C77.6063278,15.3326284 77.3030257,14.5560964 76.7518547,13.9862577 C76.2006837,13.416419 75.4489316,13.102163 74.6689918,13.1155556 C73.0046133,13.1155556 71.6553678,14.5084474 71.6553678,16.2266667 L71.6510627,16.2266667 Z M78.0657766,0.0222222222 L73.2999455,11.9244444 L78.6469755,11.9244444 L83.4300272,0 L78.0657766,0.0222222222 Z" id="Shape" fill="#000000"></path>
                    <path d="M134.510954,5.48444444 C134.287017,5.41042851 134.052932,5.37440508 133.81782,5.37777778 C132.285501,5.33345562 130.885901,6.2707681 130.30049,7.73333333 L130.30049,5.69333333 L125.681035,5.69333333 L125.681035,18.9466667 L130.326322,18.9466667 L130.326322,14.12 C130.326322,11.6577778 131.432752,10.28 133.382997,10.28 C133.766741,10.2725198 134.148703,10.3357311 134.510954,10.4666667 L134.510954,5.48444444 Z M157.586703,14.7066667 C157.586703,12.56 156.174605,11.3911111 153.328883,10.5688889 L152.584087,10.36 C151.529319,10.0666667 151.120327,9.96 151.120327,9.64444444 C151.120327,9.32888889 151.400163,9.08888889 152.093297,9.08888889 C153.450345,9.14730589 154.776143,9.52749663 155.967956,10.2 L157.405886,6.72888889 C155.762922,5.84513411 153.941481,5.37314042 152.088992,5.35111111 C148.778311,5.35111111 146.522398,7.07111111 146.522398,9.85333333 C146.522398,12.2133333 147.981853,13.3511111 150.883542,14.04 L151.550845,14.2 C152.52812,14.44 152.962943,14.5733333 152.962943,14.9422222 C152.962943,15.3866667 152.532425,15.5244444 151.860817,15.5244444 C150.346116,15.4741491 148.867045,15.0374509 147.55564,14.2533333 L145.911063,17.6977778 C147.686591,18.7932991 149.72378,19.3537124 151.791935,19.3155556 C155.180109,19.3155556 157.565177,17.6444444 157.565177,14.7066667 L157.586703,14.7066667 Z M99.466812,23.8755556 L99.466812,17.5422222 C100.358,18.7173685 101.741926,19.3788009 103.186485,19.32 C106.677984,19.32 109.213733,16.2088889 109.213733,12.3244444 C109.213733,8.44 106.69951,5.32888889 103.186485,5.32888889 C101.733545,5.28164108 100.348025,5.96204577 99.466812,7.15555556 L99.466812,5.69777778 L94.7913896,5.69777778 L94.7913896,23.88 L99.466812,23.8755556 Z M99.3376567,12.32 C99.3271861,11.213905 99.9645436,10.210698 100.951431,9.77990287 C101.938319,9.34910772 103.079494,9.57595163 103.84086,10.3542665 C104.602227,11.1325813 104.833158,12.3083876 104.425573,13.3313811 C104.017988,14.3543747 103.052522,15.0221694 101.981035,15.0222222 C101.279555,15.0391913 100.60157,14.760828 100.102982,14.251141 C99.6043938,13.7414539 99.3281085,13.0443046 99.3376567,12.32 L99.3376567,12.32 Z M117.380654,5.32444444 C113.351008,5.32444444 110.3503,8.34666667 110.3503,12.32 C110.3503,16.2933333 113.363924,19.3155556 117.380654,19.3155556 C121.397384,19.3155556 124.389482,16.2933333 124.389482,12.32 C124.389482,8.34666667 121.375858,5.32444444 117.380654,5.32444444 Z M119.925028,12.32 C119.926756,13.3827901 119.307948,14.3419313 118.357325,14.7498901 C117.406702,15.1578489 116.311622,14.9342208 115.583048,14.1833503 C114.854473,13.4324797 114.635998,12.3023557 115.029563,11.3202919 C115.423128,10.338228 116.351165,9.69774364 117.380654,9.69774364 C118.055765,9.6942178 118.704284,9.9692005 119.182069,10.4616073 C119.659855,10.954014 119.927319,11.6230453 119.925028,12.32 L119.925028,12.32 Z M137.378202,1.58666667 L137.378202,5.69333333 L135.656131,5.69333333 L135.656131,9.61333333 L137.378202,9.61333333 L137.378202,14.3288889 C137.378202,17.4844444 139.17346,19.3111111 142.113896,19.3111111 C143.108761,19.3245868 144.098636,19.1637885 145.041417,18.8355556 L145.041417,14.7555556 C144.601078,14.9003846 144.142996,14.9797003 143.680981,14.9911111 C142.600381,14.9911111 142.036403,14.4888889 142.036403,13.2133333 L142.036403,9.65777778 L145.050027,9.65777778 L145.050027,5.76 L142.036403,5.76 L142.036403,1.65333333 L137.378202,1.58666667 Z M93.5342779,14.7066667 C93.5342779,12.56 92.1221798,11.3911111 89.2764578,10.5688889 L88.5316621,10.36 C87.4768937,10.0666667 87.0679019,9.96 87.0679019,9.64444444 C87.0679019,9.32888889 87.3477384,9.08888889 88.0408719,9.08888889 C89.3979195,9.14730589 90.7237182,9.52749663 91.9155313,10.2 L93.3534605,6.72888889 C91.7104967,5.84513411 89.8890562,5.37314042 88.0365668,5.35111111 C84.7258856,5.35111111 82.4699728,7.07111111 82.4699728,9.85333333 C82.4699728,12.2133333 83.9294278,13.3511111 86.8311172,14.04 L87.4984196,14.2 C88.4756948,14.44 88.9105177,14.5733333 88.9105177,14.9422222 C88.9105177,15.3866667 88.48,15.5244444 87.8083924,15.5244444 C86.2936909,15.4741491 84.81462,15.0374509 83.5032153,14.2533333 L81.8586376,17.6977778 C83.6341658,18.7932991 85.6713546,19.3537124 87.7395095,19.3155556 C91.1276839,19.3155556 93.512752,17.6444444 93.512752,14.7066667 L93.5342779,14.7066667 Z" id="Shape" fill="#999999"></path>
                </g>
            </g>
        </g>
    </g>
</svg></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC</div>
<div class='copyright-notice'>© 2021 Verizon Media. All rights reserved.</div>
</footer>
<script src="https://cdn.rivals.com/production/assets/basicFooter-3354817297e893319b72187d3925028dbe228a45f06b1e68941019737a608dca.js"></script>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719646",
    c7: "https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-1-30"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    // loading the evergreen version of cs.js so we always have the last version
    s.src = "https://s.yimg.com/cx/vzm/cs.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fgridiron-arizona-s-2021-recruiting-update-1-30&c5=2022719646&cv=2.0&cj=1&cs_ucfr=0" />
</noscript>
<!-- End comScore Tag -->

</html>
