<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"282811705,282811706","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":1373,"agent":""}</script>
<script>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</script>
<script src='https://cdn.rivals.com/production/assets/window_name-426a8929f8d33048988258b1fc9ba7fa371d790b3661496339ffb6f2b1141c3f.js'></script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='stage.guce.rivals.com' name='oath:guce:consent-host'>
<meta content='true' name='oath:guce:report-only'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<rv-google-analytics google-analytics-id='UA-81764304-1' ng-hide></rv-google-analytics>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-17665c085dfaf620c961e1c0ddea354a20565cd5002add288461398e9f21d1eb.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansCondFonts-74c0340099b3ec93e18951b2b059a74493c5db2e72ef7acd1cf1c42a6e4a523d.css' rel='stylesheet'>
<title>ArizonaVarsity  -  Gridiron Arizona&#39;s 2021 Recruiting Update: 9/21</title>
<meta content='ArizonaVarsity  -  Gridiron Arizona&#39;s 2021 Recruiting Update: 9/21' property='og:title'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2021 class' name='description'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-3ff7a4df3e7096dcc2ba4a522eee663b162aad9c529207196841ac57b6bbfc8a.css" />


<script src="https://cdn.rivals.com/production/assets/lib-6c022b93a90b8980b59dc8365df99c024fc31b928721a316b58736a1fa13e26e.js"></script>
<script src='/javascript/config.js'></script>
<script src="https://cdn.rivals.com/production/assets/application-504d4ab7ef93a59413fc3d881f7aa2d0b3e10f376f15a12d902e5bfa22a6813f.js"></script>

<script src='/javascript/url_factory.js'></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="qY8gD7sDdQ7PHESBevp2RXi39GMGI1yAgjvax8RyF/sLCIM2zrUfdCKa8QUhnF3WUl7PdQuL07nGHiKIXvH62Q==" />
<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-fdff72b91f19d75cf51d8bdb22cf7f1c7435213329db92847ab8cd17911cc566.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-171b5725637bfa4769cee9b7c9352a74b2ba24d525be5b720e267e8adf48012c.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-9-21' property='og:url'>
<meta content='https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_headline_primary/jkq5y7gswry52olcnvhm' property='og:image'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2021 class' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2020-09-22 00:07:17 -0500' property='article:published_time'>
<meta content='2020-09-22 00:07:18 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-79d2adbade85e1e68905ea1a26278770384c72769e302a0dae0424b3991cb8c0.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-fad0448de054b018c1fb496c82e4d147e36e025324f6097d939a6223773c6408.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-d83a481672df92fa565a3c3e4490fe8538a8cca8f2f6c8bc04b4e003da9c1f95.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-dde27fd6889cda35c548e8f311394eb5ad38fd060061150fb984469c56db0a8d.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-1b293697db4809dca023fcaee39f7266c5278095067b8f6c8edb1bcc1cf9029a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-160b06011cecdf794bd4037752e257bf4272d38e105b58b8b63ff4e510d25a7a.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-b53ef0fb1afaa6ee435ba26728402dd43f9f2853b6a2932fa7d9fb70fc5e35ce.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-95c2973fbaef93d4c790667ba039b95898451bb04f5b2b399071e6483347812d.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-a223232b426f12e2f04f4a3aecf49f46b9e0a79cd886e7a210e0cdf5ad5bd024.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-a217ac85d423e19cbde56dcf9b01630789a023d0509d6fa0880bd5da15cc22d1.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-894aa91cf9d624f18d121145468a0bb30395f01d70de0dbf67742b95de46cfd2.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-b0f9dfc4ee4c3780ac01665cf518b0b20ec78f58b81349f7cbcf715820137ac3.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-8ab5e15036ae6a8e5c073b018e034b9e1d8b57c0445d930c005e3bbd54bdf23e.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-c5cfe3c55f53109b71f4a7ed03d0ff07134dc883a367e64241c5c595468da9bb.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-4bf9998442db4c04360a1612c42ca4e1aeff88b16510ab66fc9275af3e694668.json' rel='manifest'>
<rv-chartbeat-config-header ng-hide subdomain='arizonavarsity.rivals.com'></rv-chartbeat-config-header>

</head>
<body class='arizonavarsity contents-show' ng-app='rivals'>
<rv-google-analytics google-analytics-id='UA-81764304-1' ng-hide></rv-google-analytics>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .arizonavarsity #programming > h1 {
      background-color: #000000 !important; } }
  
  .arizonavarsity .wrapper-container .team-colors-line {
    background-color: #b87333; }
  
  .arizonavarsity .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #000000; }
    .arizonavarsity .team-colors-line .color {
      width: 33.33%; }
    .arizonavarsity .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .arizonavarsity .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .arizonavarsity .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .arizonavarsity .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .arizonavarsity .team-colors-line.header {
      height: 6px; }
  
  .arizonavarsity > header .notification-link .count-container {
    background-color: #000000 !important; }
  
  .arizonavarsity > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .arizonavarsity > header .wrapper-container {
        border-bottom: 6px solid #b87333 !important; } }
  
  .arizonavarsity > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .arizonavarsity > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .arizonavarsity > header .invalid-email-banner a:hover {
      color: #b87333; }
  
  @media screen and (max-width: 767px) {
    .arizonavarsity > header .mobile-header {
      background-color: #b87333 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  
  .arizonavarsity > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  
  .arizonavarsity > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  
  .arizonavarsity > header .second-nav {
    background-color: white !important; }
  
  @media screen and (max-width: 1023px) {
    .arizonavarsity > header .nav-row > ul,
    .arizonavarsity > header .third-nav {
      background-color: white !important; }
    .arizonavarsity > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  
  .arizonavarsity > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #b87333; }
  
  .site-secondary-background-color {
    background-color: #b87333; }
  
  :root {
    --primary-color: #000000;
    --primary-color-overlay: rgba(0, 0, 0, .4);
    --secondary-color: #b87333;
    --accent-color: #000000;
    --button-color: #000000;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init("arizonavarsity")' role='navigation'>
<div class='wrapper-container'>
<div class='wrapper logo-row'>
<a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-black'></div>
</a><a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
<a alt="Arizona HS Sports" class="site-header logo-image-wrapper" href="https://arizonavarsity.rivals.com/"><img src="https://images.rivals.com/rivals/image/upload/f_auto,q_auto/jfx2ba0nx7j1blby9bv1" />
</a><div class='nav-right-controls'>
<div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
<span class='upsell-text'>
Join the team!
</span>
<div class='subscribe-button' ng-click='ctrl.subscribeEvent()'>
Subscribe
</div>
</div>
<rv-universal-search></rv-universal-search>
<rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
<rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
</div>
</div>
</div>
<div class='mobile-header'></div>
<rv-header-alert class='alert-nav'></rv-header-alert>
<hr>
<div class='nav-row-container'>
<div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="8"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="4"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items></ul>
</div>
<div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
<a ng-href='{{ctrl.userProfileEditPath}}'>
Your account has an invalid email address. Please update it here.
</a>
</div>
</div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script src='/javascript/ad_beacon.js?path=content&space_id=2022719646' type='text/javascript'></script>

<rv-content-title content-title='Gridiron Arizona&#39;s 2021 Recruiting Update: 9/21' ng-hide='true'></rv-content-title>
<meta content='summary_large_image' name='twitter:card'>
<meta content='ArizonaVarsity' name='twitter:site'>
<meta content='Gridiron Arizona&#39;s 2021 Recruiting Update: 9/21' name='twitter:title'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2021 class' name='twitter:description'>
<meta content='https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/jkq5y7gswry52olcnvhm' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {&quot;id&quot;:6,&quot;legacy_id&quot;:1128,&quot;name&quot;:&quot;ArizonaVarsity&quot;,&quot;friendly_name&quot;:&quot;Arizona HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;arizonavarsity&quot;,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;arizonavarsity&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;}, true, 161, nil, {&quot;id&quot;:92,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;commitment_module_football&quot;:true,&quot;rivals_module_football&quot;:true,&quot;header_name&quot;:&quot;ArizonaVarsity.com&quot;,&quot;header_logo_cloudinary&quot;:&quot;jfx2ba0nx7j1blby9bv1&quot;,&quot;mobile_header_logo_cloudinary&quot;:&quot;lt4xm3i1vhxzczdsev3e&quot;,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;,&quot;logo_background_shading&quot;:&quot;black&quot;,&quot;football_content&quot;:true,&quot;basketball_content&quot;:true,&quot;baseball_content&quot;:true,&quot;other_content&quot;:true,&quot;site_id&quot;:6,&quot;created_at&quot;:&quot;2016-11-23T13:38:43.400-06:00&quot;,&quot;updated_at&quot;:&quot;2020-06-25T15:45:51.480-05:00&quot;,&quot;max_trending_articles&quot;:6,&quot;enrichments&quot;:[{&quot;active&quot;:false,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;TeamRankings&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Rivals&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardScores&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Commitment&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Schedule&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardPhotos&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;FanFuturecastLeaderboard&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;RecentForecasts&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null}],&quot;footer_text&quot;:null,&quot;sections&quot;:[],&quot;supplied_domain&quot;:null,&quot;forums_link_url&quot;:&quot;https://arizonavarsity.forums.rivals.com&quot;,&quot;scoreboard_scores_id&quot;:15081,&quot;scoreboard_photos_id&quot;:15082,&quot;aol_player_id&quot;:null,&quot;aol_company_id&quot;:null,&quot;ad_frequency&quot;:5,&quot;display_twitter_follow&quot;:true,&quot;display_fb_follow&quot;:true,&quot;follow_twitter_handle&quot;:&quot;ArizonaVarsity&quot;,&quot;follow_fb_handle&quot;:&quot;arizonavarsity&quot;,&quot;forum_id&quot;:null,&quot;premium_forum_id&quot;:null,&quot;facebook_page_id&quot;:null,&quot;max_ticker_articles&quot;:12,&quot;schedule_header_on&quot;:false,&quot;promo_popup_on&quot;:false,&quot;facebook_developer_id&quot;:null,&quot;customized_tos&quot;:[],&quot;show_survey_popup&quot;:false,&quot;survey_popup_link&quot;:null,&quot;header_bottom_border_style&quot;:null,&quot;customized_upsell_banner_text&quot;:null,&quot;email_logo_cloudinary&quot;:null,&quot;target_list_on&quot;:null,&quot;gifting_banner_content&quot;:&quot;Give a Rivals gift subscription this holiday season&quot;,&quot;gifting_banner_title&quot;:&quot;The perfect gift for football recruiting fans!&quot;,&quot;gifting_banner_button_text&quot;:&quot;Give a gift subscription&quot;},
&quot;58e686759efa8936610b8215&quot;, &quot;58e68374c7480e728bcc385f&quot;, &quot;rivals&quot;, 15000,
false, {&quot;id&quot;:1967,&quot;user_id&quot;:2798272,&quot;site_id&quot;:6,&quot;updated_at&quot;:&quot;2018-06-24T21:51:58.853-05:00&quot;,&quot;publisher_name&quot;:&quot;Chris Eaton&quot;,&quot;first_name&quot;:&quot;Chris&quot;,&quot;last_name&quot;:&quot;Eaton&quot;,&quot;site_title&quot;:&quot;Staff&quot;,&quot;bio&quot;:null,&quot;twitter_handle&quot;:null,&quot;image_url&quot;:null,&quot;publisher_name_and_title&quot;:&quot;Chris Eaton, Staff&quot;,&quot;site_name&quot;:&quot;ArizonaVarsity&quot;,&quot;site_short_name&quot;:&quot;arizonavarsity&quot;,&quot;has_edited_profile&quot;:false}, null)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{&quot;no-ad-padding&quot;: &quot;#{@display_ldrb_top}&quot;}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode' site_name='ArizonaVarsity'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if='showLRECad(&#39;leftrail-below-ticker&#39;)'>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-forums ad-referer='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-9-21' base-api-url='https://arizonavarsity.forums.rivals.com/' forums-url='https://arizonavarsity.forums.rivals.com' homepage='false' pub-ad='null' size='size' space-id='2022719646' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-9-21/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo(&#39;2020-09-22 00:07:17 -0500&#39;) }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2199117/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h1 class='article-title'>Gridiron Arizona&#39;s 2021 Recruiting Update: 9/21</h1>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/saz6wscjo0ixay6vum9w&#39;,&#39;https://images.rivals.com/rivals/image/upload/f_auto,q_auto/saz6wscjo0ixay6vum9w&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="" alt="" src="https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/saz6wscjo0ixay6vum9w" />
<div class='zoom-image'></div>
</div>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<div>
<span class='author-name'>
Chris Eaton
&bull;
<span class='type-sm'>ArizonaVarsity</span>
</span>
<div>
<span class='author-name'>Staff</span>
</div>
</div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>

<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><h3 class='article-heading'>Concordia College offers Basha wide receiver Bachmann</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>UPDATED: 9/21/20</b></p><p>Colleges across the nation continue to take notice of the prep talent in Arizona each season. More than 350 players from the Class of 2020 have signed with schools to advance their football careers, and receive an education.</p><p>Of course, everything in sports has been ground to a halt due to the worldwide coronavirus pandemic. Recruiting is not immune to that. The NCAA has extended its dead period for in-person recruiting through at least January 1. Schools are not permitted to host any official or unofficial on-campus visits during that time. Coaches are allowed to contact prospective student-athletes through phone calls, text messages, and in writing (but not in person). That continues to be in effect for every sport in Division I and Division II.</p><p>Concordia College in Minnesota extended offers to a pair of players in the Valley on Monday. <b>Carson Bachmann</b> and <b>Oscar Abundis Jr.</b> received them from the Cobbers. Bachmann is a 5-11, 170-pound wide receiver at Basha. In seven games, he caught 11 passes for 145 yards. Two of those were for touchdowns in a win at O'Connor. Bachmann is one of 22 seniors on this year's varsity team at BHS. Abundis Jr. is a 6-6, 320-pound offensive tackle at Centennial. He has monster size, can finish blocks, and was a Second Team All-5A Northwest Region performer last season. In the weight room, he can squat 455. In addition to that strength, Abundis also has flexibility and uses stretching in his routines. Concordia College is a member of the Minnesota Intercollegiate Athletic Conference (Div. III), which postponed football until the spring season. The conference is working to develop a spring schedule. Last year, the Cobbers won their final three games to finish 5-5. One of those was a stunning home upset against No. 4 St. John's (Minn.), 19-18 in overtime.</p><p> Arizona College Prep is coming off its first playoff appearance after just its third year as a varsity program. The Knights bring back quarterback <b>Mark Chavez</b>, who picked up an offer from Lake Forest College on Monday. The 6-1, 190-pound signal caller has been the starter in each of his three years on varsity. Chavez had his best season as a junior with 1,851 yards and 24 touchdown passes. Lake Forest has a proud tradition of recruiting the state of Arizona and one of its players from the Southwest Suburb is getting some preseason recognition. A.J. Jackson (Centennial) was named to the D3football.com 2020 Preseason All-America team as a kick returner. As a sophomore, he led the nation with 939 combined return yards. Jackson was also a First Team All-Midwest Conference wide receiver. Last year, the Foresters finished 7-3. As for this year, the conference has suspended competition through December. The football team is slated to compete in the spring. </p><p> Another Midwest Conference school offered an Arizona player this week. Ripon College made an offer to <a href="https://n.rivals.com/content/prospects/2021/daylin-smith-217109">Daylin Smith</a> on Monday. The 6-3, 230-pound linebacker plays at Marana Mountain View. Smith had 62 tackles and six sacks last year for the Mountain Lions. He started playing football at the age of seven and has been waiting a long time for his senior season. This MVHS team has several players that have been together on varsity since they were sophomores. Ripon, located in Wisconsin, recently hired its first strength and conditioning coach in school history. Brandon Zemke comes to Ripon from another Midwest Conference school, Lawrence (Wisc.). The Red Hawks started last year at 1-5, but rebounded to end up at 4-6. </p><p>Keeping it in Southern Arizona, but switching it over to Sahuarita, <b>Ty McDermott</b> obtained an offer on Monday from Pacific University in Oregon. The 6-3, 190-pound wide receiver led Walden Grove in catches last season with 40. Those went for 553 yards and McDermott scored five touchdowns. He also played some cornerback last year and tallied 25 tackles, two interceptions, and a blocked punt. In the classroom, McDermott carries a 4.2 GPA. Pacific has a new offensive coordinator as Jim Craft is returning to the Northwest Conference school. After helping start the Boxer program in 2010, Craft has been at Cal Poly for the last seven years as an assistant. Pacific, a Division III school, finished 4-6 last year. The NWC has postponed football and all of its conference competitions across all sports for this fall.<br></p><p>Coconino is coming off a season that ended with its first trip to the playoffs since 2005. The Panthers return running back <a href="https://n.rivals.com/content/prospects/2021/zach-bennett-269168">Zach Bennett</a>, who collected an offer from Minnesota Morris on Monday. The 5-8, 180-pound back put together his second straight 1,000-yard season (actually 1,753 yards) during a 9-2 season. Bennett scored 23 touchdowns and now has five offers. Minnesota Morris was finally able to take to its new turf for small-group workouts this week. The Cougars will have a short, four-game spring season in April. UMN Morris finished 1-9 last season and plays in the Upper Midwest Athletic Conference (Div. III).<br></p><p>This list shows four-year college offers received by seniors throughout the state. It's not limited to just 6A and 5A. It will be constantly updated as we approach the Early Signing Period from December 16-18. Those are the first days that high school seniors can sign a letter of intent to agree to attend an institution.</p><p>Verbal commitments are shown in bold.</p>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p> <b>CLASS OF 2021 OFFERS</b></p><p>Oscar Abundis Jr. - Centennial (OT): Benedictine (Kans.), Concordia Coll. (Minn.), Concordia Univ. (Ill.)<br></p><p>Rashon Adams - Centennial (WR): Abilene Christian, South Dakota State</p><p>Sebastian Adamski - Walden Grove (LB): Concordia Coll. (Minn.), Cornell Coll. (Iowa), Drake, Lake Forest, Luther, Pacific, Southwestern, Whittier</p><p>Jayden Ahboah - Desert Edge (OG): Benedictine (Kans.), Concordia Coll. (Minn.), Culver-Stockton, Livingstone, MidAmerican Nazarene, Morgan State, St. Olaf, Whittier</p><p>Ammon Allen - Highland (FS): Air Force, Army, Eastern Michigan, Idaho, Morehead State, Navy, New Mexico State, Northern Arizona</p><p>Adrian Alvarado - Walden Grove (K/P): Clarke, Concordia Coll. (Minn.), Cornell Coll. (Iowa), Culver-Stockton, Luther, Millikin, Otterbein, Saint John's (Minn.), Simpson, Trine</p><p>Braxton Anderson - Williams Field (CB): Hamline</p><p>Elijah Anderson - Sunrise Mountain (CB): Arizona Christian, Benedictine (Kans.), Culver-Stockton, Simpson, Wisconsin-River Falls</p><p>Joseph Armstrong - Walden Grove (CB): Albright, Concordia Univ. (Ill.), Culver-Stockton<br></p><p>Albin Arulanandu - Mountain Ridge (CB): Bowdoin, Carleton, Concordia Coll. (Minn.), Grinnell, Kenyon, Puget Sound, Washington &amp; Lee<br></p><p>AJ Auau - Agua Fria (DT): Benedictine (Kans.), Ohio Northern<br></p><p>Dominic Avant - Buena (OT): Trine</p><p>Carson Bachmann - Basha (WR): Concordia Coll. (Minn.), Concordia Univ. (Ill.)</p><p>Trae Baker - San Tan Charter (FS): Arizona Christian</p><p>Damirion Barber - Sierra Linda (WR): Peru State<br></p><p>Heriberto Barnett - Nogales (CB): Culver-Stockton, Kalamazoo, Luther, Millikin, St. Norbert, Trinity International<br></p><p>Andrell Barney - Basha (CB): Hawaii, Montana State-Northern, Nevada, <b>NEW MEXICO</b>, New Mexico State, Northern Arizona, Southern Utah, Washburn</p><p>Hunter Barth - Queen Creek (FS): Arizona, Boise State, <b>CALIFORNIA</b>, Duke, Idaho, Iowa State, Northern Arizona, Oklahoma State, Oregon, Pittsburgh, San Diego State, Tulane, UCLA, UNLV, USC, Utah, Virginia, Washington State, Yale</p><p>Derek Bass - Basha (K): Culver-Stockton, Hamline, Southwestern, Whittier</p><p>William Bastman - Brophy (DE): Bowdoin<br></p><p>Josh Baxter - Saguaro (RB): Concordia Coll. (Minn.), Lake Forest</p><p>Daniel Becerra - Tucson (WR): Hamline<br></p><p>Jaquel Bell - Glendale (WR): Mayville State, Wisconsin-River Falls</p><p>John Beltran - Cibola (RB): Albright, Arizona Christian</p><p>Zach Bennett - Coconino (RB): Culver-Stockton, DePauw, Friends, Minnesota Morris, Whittier<br></p><p>Isaac Benoit - Buena (RB): Arizona Christian, Carthage, Concordia Univ. (Ill.), Cornell Coll. (Iowa), Culver-Stockton, Oberlin, Simpson, St. Olaf, Whittier</p><p>Cade Berger - Perry (WR): Air Force, Northern Arizona</p><p>Alec Bernardo - Pinnacle (OG): Carthage, Concordia Coll. (Minn.), Graceland, Heidelberg, Oberlin, Simpson, Wheaton, Whittier, Whitworth, Wisconsin-River Falls</p><p>Austin Bilski - Verrado (S): Concordia Coll. (Minn.), Puget Sound, Saint John's (Minn.), Trine, Willamette</p><p>Zach Blackwood - Desert Edge (DE): <b>NORTHERN ARIZONA</b>, Valparaiso<br></p><p>Desmond Bohannon - North Canyon (FS): Carthage, Clarke<br></p><p>Alex Boyle - Centennial (LB): Culver-Stockton</p><p>Joseph Boyle - Arcadia (DT): Concordia Coll. (Minn.)</p><p>Bubba Brandel - Lake Havasu (LB): St. Francis (Ill.)<br></p><p>Zeke Branham - Skyline (SS): Abilene Christian, Air Force, Army, Ball State, Columbia, Dartmouth, Eastern Michigan, Fresno State, Holy Cross, Lehigh, Montana State, New Mexico, New Mexico State, Northern Arizona, Penn, Princeton, UC Davis, UNLV, Valparaiso, Yale</p><p>Adam Brauer - Sabino (DT): Benedictine (Kans.)<br></p><p>Tony Brewer - Chandler (FS): Benedictine (Kans.), Colorado School of Mines, Western New Mexico</p><p>Diamonte Bright - Desert Ridge (SS): Benedictine (Kans.), Whittier</p><p>Derrick Brown - Queen Creek (OT): Idaho<br></p><p>Trey Brown - Arcadia (LB): Colorado State, Delaware State, <b>DUKE</b>, Eastern Washington, Georgetown, Hawaii, Montana State, Nevada, New Mexico, Northern Arizona, San Diego State, Tulane, UNLV, Utah State, Washington State</p><p>Rocco Bruney - Glendale (QB): Heidelberg</p><p>Alexander Bruns - Hamilton (OT): Erskine, Northwestern Oklahoma State, William Jewell<br></p><p>Brandon Buckner - Chandler (DE): Arizona, Arizona State, Colorado, Fresno State, Iowa State, Maryland, Michigan State, Middle Tennessee, Northern Arizona, <b>OREGON</b>, Oregon State, San Diego State, UNLV, Washington State</p><p>Denzel Burke - Saguaro (CB/WR): Arizona, Arizona State, Auburn, Colorado, Idaho, Iowa State, Louisville, LSU, Michigan State, Mississippi State, Nebraska, Northern Arizona, <b>OHIO STATE</b>, Oklahoma State, Oregon, San Diego State, Tennessee, Texas, UCLA, UNLV, USC, Utah, Washington</p><p>Zion Burns - Poston Butte (RB/DB): Abilene Christian, Austin Peay State, <b>NEVADA</b></p><p>Caden Calloway - Campo Verde (RB): Lake Forest, Wisconsin-River Falls</p><p>Jackson Camarata - Brophy (WR): Allegheny, Bates, Benedictine (Kans.), Bowdoin, Carleton, Concordia Coll. (Minn.), DePauw, Kenyon, La Verne, Oberlin</p><p>Mateo Campos - Marana (LB): Culver-Stockton<br></p><p>Jacob Carpenter - Verrado (DE): Arizona Christian, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Mayville State, Monmouth (Ill.), Northwestern Coll. (Iowa), Simpson, Wisconsin-River Falls</p><p>Andrew Carreon - Arcadia (OG): Pacific<br></p><p>Chandler Carter - Valley Christian (TE): Bethel (Tenn.), Concordia Coll. (Minn.), Hope, Jamestown, Simpson, Trine, Wheaton, Wisconsin-River Falls</p><p>Chase Cassel - Ironwood Ridge (QB): St. Norbert</p><p>Victor Castellano - Red Mountain (OG): Whittier<br></p><p>Mark Chavez - Arizona College Prep (QB): Hope, Lake Forest, Olivet, Simpson, St. Francis, St. Norbert, Trine</p><p>Peter Chawki - Horizon (DE): Concordia Coll. (Minn.)</p><p>Dane Christensen - Casteel (QB): Drake<br></p><p> Jacob Cisneros - Boulder Creek (RB): Colorado School of Mines, Penn, Southwest Minnesota State, West Virginia State, Yale </p><p>Blake Comstock - Mountain Ridge (K): Whittier</p><p>Jackson Condie - Desert Ridge (C): Concordia Coll. (Minn.), Hamline, Trine<br></p><p>Dylan Cook - Ironwood Ridge (FS): Carroll, Morehead State, Northern State, South Dakota School of Mines</p><p>David Cordero - Salpointe (RB): Hamline, Morehead State, Southwest Minnesota State<br></p><p>Logan Corfield - Desert Edge (OT): Benedictine (Kans.), Concordia Coll. (Minn.), Lake Forest, Montana Tech, Morehead State, San Diego, Southeast Missouri, Southwest Minnesota State, Wisconsin-River Falls</p><p>Marzion Cosby - Centennial (WR): Eastern Illinois, Missouri State, Northeastern State, Northern Arizona, Roosevelt, Tennessee-Martin, Washburn, Western Illinois<br></p><p>Jaden Crockett - Mountain Pointe (QB): Hamline, Simpson, Whittier</p><p>Alex Culbertson - Walden Grove (WR): Culver-Stockton, Trine</p><p>Brody Curtner - Gilbert Christian (RB): Arizona Christian, St. Norbert</p><p>Darrion Dalton - Saguaro (DT): Air Force, Army, Fordham, Idaho, Lehigh, Navy, Northern Arizona, Northern Colorado, <b>SAN DIEGO STATE</b>, UNLV</p><p>Connor DePrez - Hamilton (OG): Eastern New Mexico, Heidelberg, Southwest Minnesota State<br></p><p>Joel Diaz - Arizona College Prep (FS): Arizona Christian, Benedictine (Kans.), Carnegie Mellon, Chicago, Colorado School of Mines, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Grand View, Johns Hopkins, Montana Tech, Rose-Hulman, St. Francis, St. Thomas (Minn.), Trinity International, Washington &amp; Lee, Whitworth, Wisconsin-River Falls</p><p>Brock Dieu - Casteel (OT): Air Force, Arizona State, Army, Boise State, Columbia, Cornell, Harvard, Nevada, New Mexico, Northern Arizona, Oregon, Penn, Princeton, San Jose State, UC Davis, Utah State, <b>WASHINGTON STATE</b>, Yale</p><p>Tanner Dimond - Cactus Shadows (FS): Simpson</p><p>Bryan Dyson - Arizona College Prep (WR): Briar Cliff, Concordia Coll. (Minn.), Olivet, Simpson, St. Francis (Ill.), Trine, Wisconsin-River Falls</p><p>Christian Earls - Basha (TE): Trine</p><p>Damarcus Ellis-Dennard - Brophy (LB): New Mexico State, Northeastern State, Washburn</p><p>Colton Ellsworth - Highland (TE): Southwest Minnesota State</p><p>Zayden Ennis - Centennial (OT): Graceland<br></p><p>Jovoni Ervin - Cesar Chavez (LB): St. Francis (Ill.)<br></p><p>Nathan Eubank - Northwest Christian (LB): Culver-Stockton, Hamline, Trine, Whittier</p><p>Connor Faust - Payson (DT): Whittier</p><p> Sebastian Felix - Cienega (SS): Morehead State, South Dakota School of Mines, Southwest Minnesota State, Valparaiso, Washburn </p><p>John Ferlmann - Boulder Creek (LS): Air Force, Arizona, <b>ARIZONA STATE</b><br></p><p>Micah Ferrin - ALA-Queen Creek (DE): Sioux Falls<br></p><p>Sebastian Fiery-Hardimon - Ironwood (CB): Concordia Coll. (Minn.), Culver-Stockton, Lake Forest, Olivet, Puget Sound, St. Olaf, Trine, Wisconsin-River Falls</p><p>Brit Fleming - Higley (FS): Concordia Coll. (Minn.)<br></p><p>CJ Flores - Cienega (SS): Arizona Christian, Carleton, Monmouth, Sewanee, Simpson, St. Francis (Ill.), St. Olaf, Trine, Trinity International, Whittier<br></p><p>Josiah Flores - Cienega (LB): Culver-Stockton, Trine</p><p>Jordan Forbes - Desert Ridge (WR): Concordia Coll. (Minn.)<br></p><p>Steven Forester - Maricopa (RB): Arizona Christian, Culver-Stockton<br></p><p>Anthony Franklin - Pinnacle (DE): Air Force, Arizona, Army, Ball State, Brown, Colorado State, Columbia, Cornell, Duke, Harvard, Idaho, Indiana, Kansas State, Lehigh, Michigan State, Montana State, Navy, Northern Arizona, Penn, Princeton, South Dakota State, Stanford, Tulane, UNLV, Yale</p><p>Xander Franquero - Desert Vista (FS): Allegheny, Clarke, Culver-Stockton, Puget Sound<br></p><p>Rogan Freeburg - Desert Mountain (WR): Simpson, Wisconsin-River Falls</p><p>Scott French - Ironwood Ridge (DT): Culver-Stockton, Hamline, Oberlin, Simpson</p><p>Tanner-James Friend - Sahuarita (CB): Concordia Coll. (Minn.), Wisconsin-River Falls</p><p>Mikaele Fuamatu - Millennium (OG): Benedictine (Kans.)</p><p>Daniel Fulton - Chandler (LB): Albright, Bates, Carleton, Carnegie Mellon, Carthage, Concordia Coll. (Minn.), Hamline, Kalamazoo, Lake Forest, Occidental, Simpson, Trine, Whittier, Wisconsin-River Falls</p><p>Jake Gaines - O'Connor (WR): Simpson</p><p>Anthony Galvez - Sunnyside (WR): Simpson</p><p>Travis Gammage - South Mountain (WR): Benedictine (Kans.), Concordia Coll. (Minn.), Simpson</p><p>Bobby Gardea - Dysart (CB): Wisconsin-River Falls</p><p>Joshua Gasca - Centennial (QB): Hamline</p><p>Aaron Gerle - Greenway (DT): Abilene Christian, Augustana, Harding, Houston Baptist, Idaho, Lehigh, <b>MONTANA STATE</b>, Northern Arizona, Northern State, Southern Utah, Southwest Minnesota State, Tarleton State, Washburn</p><p>Kellen Gibson - Arizona College Prep (LB): Arizona Christian, Bates, Carleton, Carnegie Mellon, Claremont Mudd Scripps, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Hamline, Kalamazoo, Kenyon, Macalester, Monmouth (Ill.), Montana Tech, Oberlin, Rochester, St. Francis, St. Olaf, Washington (Mo.), Whitworth, Wisconsin-River Falls</p><p>Logan Gingg - Verrado (RB): Abilene Christian, Bucknell, Cornell, Lehigh, San Diego, Yale</p><p>Isaia Glass - Queen Creek (OT): Arizona, <b>ARIZONA STATE</b>, Army, Colorado, Fresno State, Hawaii, Idaho, Indiana, Iowa State, Kansas State, Nevada, New Mexico, Northern Arizona, Oklahoma State, Oregon State, San Diego State, Tulane, UNLV, Utah, Utah State, Washington State</p><p>DJ Gleash - Centennial (DE): Drake, Northern State, Valparaiso</p><p>Johvany Gomez - Apollo (TE): Arizona Christian<br></p><p>Tony Gomez Jr. - Valley Christian (RB): Arizona Christian, Colorado School of Mines, Culver-Stockton, Grinnell, Wisconsin-River Falls</p><p>Anthony Gonzales - Saguaro (FS): New Mexico Highlands, Southwest Minnesota State</p><p>Andrew Gonzalez - Sunnyside (LB): Culver-Stockton<br></p><p>James Groff - O'Connor (WR): Yale</p><p>Gavin Guarino - Pinnacle (OT): Benedictine (Kans.), Carleton, Concordia Univ. (Ill.), Western New Mexico, Wesleyan, Whittier</p><p>Capri Hamilton - Chaparral (WR): Benedictine (Kans.), Hamline, Trine</p><p>Charles Hamm - Cienega (CB): Culver-Stockton, St. Olaf<br></p><p>Anthony Hanger - Chandler (DT): Augustana Univ. (S. Dak.), Southwest Minnesota State, Washburn</p><p>Ricky Hanlan IV - Nogales (WR): Concordia Univ. (Ill.), Culver-Stockton, St. Norbert, Trine</p><p>Andrew Hanzal - Valley Christian (WR): Hope, Trine<br></p><p>Jadon Hanzal - Valley Christian (QB): Hope, <b>MARY</b></p><p>Jayden Harrington - Verrado (CB): Arizona Christian, Benedictine (Kans.), Carthage, Concordia Coll. (Minn.), Concordia Univ. (Minn.), Culver-Stockton, Graceland, Hamline, Lake Forest, Mayville State, Mount Marty, Northwestern Coll. (Iowa), Simpson, <b>SIOUX FALLS</b>, Southwest Minnesota State, Trine, Western New Mexico, Wisconsin-River Falls</p><p>Evan Harvey - Ironwood Ridge (LB): Clarke<br></p><p>Will Haskell - Ironwood (QB): Akron, Duke, Fresno State, Iowa State, Northern Arizona, <b>SAN DIEGO STATE</b></p><p>Dax Heggie - Casteel (LB): Concordia Coll. (Minn.)<br></p><p>Heath Henderson - Desert Mountain (OT): Concordia Coll. (Minn.), Simpson, Wisconsin-River Falls</p><p>Trey Hendrix - Peoria (OG): Southwest Minnesota State, Whittier</p><p>Justin Hernandez - Shadow Ridge (OT): Southern Oregon</p><p>Branson Heywood - Higley (WR): Benedictine (Kans.)</p><p>Sione Hingano - Chandler (OT): Idaho, Northern Arizona, Southern Utah, Western Illinois<br></p><p>Myles Hobbs - Desert Edge (LB): Bowdoin, Carleton, Simpson</p><p>Anthony Hodges - Buena (OT): Carthage, Norwich</p><p>Liam Hoffmeyer - Cibola (TE): Idaho, South Dakota State, Valparaiso</p><p>Desmon Holton - Casteel (WR): Concordia Coll. (Minn.), Culver-Stockton, Ripon<br></p><p>Jack Howell - Hamilton (FS): Ball State, <b>COLORADO STATE</b>, Montana, New Mexico, New Mexico State, North Dakota, Northern Arizona, South Dakota State</p><p>Joseph Hoyt - Chandler (DT): Abilene Christian, South Dakota State, Southwest Minnesota State</p><p>August Hubbard - Trivium Prep (WR): St. Olaf<br></p><p>Nate Hull - Pinnacle (WR): Wisconsin-River Falls</p><p>Ethan Hunt - Casteel (DE): Concordia Coll. (Minn.), Culver-Stockton, Graceland, Whittier</p><p>Andrew Husfelt - Cienega (C): Culver-Stockton, Morehead State, Simpson, Washburn</p><p>Cess Ibarra - Chandler (OT): Carthage, Catholic, Concordia Coll. (Minn.), Culver-Stockton, Millikin, Ripon, Trinity International<br></p><p>Krew Jackson - Queen Creek (FS): Air Force, Arizona, Arizona State, Boise State, Boston College, BYU, Idaho, Iowa State, <b>KANSAS STATE</b>, Michigan State, Navy, Northern Arizona, Pittsburgh, San Diego State, Tulane, UNLV, Virginia, Washington State, Yale</p><p>Anton Jamero - Desert View (LB): Culver-Stockton, Ripon<br></p><p>James Jaquint - Notre Dame (SS): Benedictine (Kans.), <b>SAN DIEGO</b>, Valparaiso<br></p><p>Luis Jaramillo - Flagstaff (RB): Carthage, Concordia Coll. (Minn.), Mayville State, Puget Sound, Simpson, Western New Mexico</p><p>Christian Johnson - Greenway (RB): Concordia Coll. (Minn.), Hamline, Lake Forest</p><p>Elias Johnson - Tucson (LB): Southwest Minnesota State<br></p><p>Isaak Johnson - Shadow Mountain (C): Whittier</p><p>Caleb Jones - Basha (RB): Whittier</p><p>Jonathan Justice - Lake Havasu (DE): Concordia Coll. (Minn.), Monmouth (Ill.), St. Francis</p><p>Mikey Keene - Chandler (QB): Coastal Carolina, Colorado State, Columbia, Eastern Michigan, Harvard, Hawaii, Middle Tennessee, Nevada, New Mexico, Northern Arizona, Penn, San Jose State, Tulane, <b>UCF</b>, Utah State, Western Kentucky, Yale</p><p>Josiah Kidd - Desert Ridge (RB): Hope, Lake Forest, Wisconsin-River Falls</p><p>Caleb Kidney - Cienega (WR): Culver-Stockton, Trine</p><p>Clayton Kinkel - Arcadia (LB): Culver-Stockton <br></p><p>Christian Kirkman - Saguaro (LB): Concordia Coll. (Minn.).<br></p><p>Colby Kitson - Boulder Creek (LB): La Verne</p><p>Garrick Krautz - Catalina Foothills (TE): Concordia Coll. (Minn.), Hamline</p><p>Richard Kwete - Sunnyslope (DT): Idaho, <b>NORTHERN ARIZONA</b><br></p><p>Avery Lambert - Horizon (WR): Benedictine (Kans.), Simpson, St. Olaf, Trine, Wisconsin-River Falls</p><p>Maximus LaVoy - Notre Dame (OT): Concordia Coll. (Minn.)</p><p>Jake LeBlanc - Pinnacle (C): Concordia Coll. (Minn.), Culver-Stockton, Minnesota Morris, Pacific, Sewanee, Simpson, Trine, Whittier</p><p>Sean Lehman - Notre Dame (CB): Wisconsin-River Falls</p><p>Deryk Leverage - Mountain Ridge (LB): Concordia Coll. (Minn.), Simpson</p><p>Gabe Levy - Cienega (RB): Sioux Falls, Washburn, Western New Mexico</p><p>Michael Lewis - Florence (OT): Clarke, Ripon<br></p><p>Zachary Lewis - Hamilton (CB): Army, <b>NEVADA</b>, Northern Arizona, Washington State</p><p>Mark Liano - Campo Verde (LB): Concordia Coll. (Minn.), Hamline, Oberlin, St. Olaf<br></p><p>Daxon Lindholm - Centennial (RB): <b>ARMY</b></p><p>Eric Lira - Mesquite (WR): St. Francis (Ill.), Trine, Wisconsin-River Falls</p><p>Benjamin Lisk - Paradise Valley (LS): Carleton, George Fox, Hamline, Pacific, <b>TOLEDO</b></p><p>Colby Littleton - Queen Creek (LB): Trine<br></p><p>Qwestin Litz - Cienega (CB): Concordia Coll. (Minn.)</p><p>Gavin Lloyd - Poston Butte (QB): Hamline<br></p><p>Tanor Loosle - Mountain Ridge (SS): Hamline</p><p>Alani Ma'afu - Saguaro (DT): Iowa State, Liberty, Memphis, Montana State, New Mexico, <b>NORTHERN ARIZONA</b>, San Diego State, Tulane, Washington State</p><p>Joseph MacDonald - O'Connor (CB): Culver-Stockton, Kalamazoo, St. Olaf<br></p><p>Eli Mackowski - Desert Mountain (LB): Concordia Coll. (Minn.)</p><p>Zion Magalei - Chandler (DE): Air Force, Arizona, Army, Brown, Colorado, Kansas State, Navy, Nevada, Northern Arizona, Northern Colorado, San Diego State, Washburn, Yale</p><p>Wyatt Manning - Florence (DE): Clarke, Graceland, Monmouth (Ill.), Puget Sound<br></p><p>Mekhi Mannino-Faison - Ironwood (TE): Augustana (S. Dak.), Southwest Minnesota State</p><p>Saia Mapakaitolo - Red Mountain (OT): Arizona, Arizona State, BYU, Oregon State, UCLA, <b>USC</b>, Utah, Washington State<br></p><p>Kaleb Markley - Sabino (SS): Culver-Stockton</p><p>Ezekiel Marshall - Sunrise Mountain (WR): Eastern New Mexico<br></p><p>Andrew Mason - Perry (OT): Northern Arizona</p><p>Brock Mast - Liberty (QB): Concordia Coll. (Minn.), Hamline, Mayville State, Puget Sound, Wisconsin-River Falls</p><p>Sam McCracken - Notre Dame (LB): Concordia Univ. (Ill.), St. Olaf<br></p><p>Brees McCraren - Salpointe (DT): Concordia Coll. (Minn.), Culver-Stockton, Hamline, Millikin, St. Norbert, Trine, Whittier, Wisconsin-River Falls</p><p>Ty McDermott - Walden Grove (WR): Benedictine (Kans.), Carleton, Concordia Coll. (Minn.), Culver-Stockton, Kalamazoo, Millikin, Otterbein, Pacific, Simpson, St. Norbert, St. Olaf, Trine</p><p>Cliffonte McDowell - Desert Edge (CB): Livingstone<br></p><p>James Mcelhenny - Tolleson (QB): Heidelberg, Wisconsin-River Falls</p><p>TJ McRae - Centennial (C): Memphis</p><p>Marcus McWilliams - Gilbert Christian (CB): St. Norbert. Wisconsin-River Falls</p><p>Bear Milacek - Boulder Creek (QB): <b>NEW MEXICO</b>, San Diego, Valparaiso, Western Kentucky</p><p>Caiden Miles - Centennial (OT): Abilene Christian, Air Force, Columbia, New Mexico State, Northern Arizona, <b>UNLV</b>, Yale</p><p>Jonah Miller - Salpointe (OT): Arizona, Arizona State, Colorado, Florida, Missouri, Nebraska, Nevada, Oklahoma State, <b>OREGON</b>, Penn State, Tennessee, Texas, USC, Utah, Washington, Washington State</p><p>Marques Miller - Desert Edge (SS): Livingstone</p><p>Max Miller - Pinnacle (K): Lake Forest, Puget Sound<br></p><p>Kai Millner - Higley (QB): Arizona, Arizona State, Boise State, <b>CALIFORNIA</b>, Colorado, Hawaii, Indiana, Iowa State, Miami (Fla.), Michigan State, North Carolina State, Northern Arizona, Syracuse, UCF, Washington State<br></p><p>Max Minor - Chaparral (WR): Augustana, Sioux Falls, Southwest Minnesota State</p><p>Gabriel Monaco - O'Connor (DE): Culver-Stockton<br></p><p>Jacob Moore - Boulder Creek (OG): Southwest Minnesota State, Washburn</p><p>Luke Nash - Notre Dame (RB): Culver-Stockton, Puget Sound, Whittier</p><p>Zeth Nastal - Mesa (LB): Culver-Stockton, Minot State, Simpson</p><p>Isaiah Negron - Verrado (WR): Trine</p><p>Tevainui Neher - Chandler (C): Drake, Georgetown, Lamar</p><p>Daivon Nelson - Marcos de Niza (CB): Benedictine (Kans.), Culver-Stockton, Saint John's (Minn.), Wisconsin-River Falls</p><p>Jack Nelson - Skyline (QB): George Fox, Montana State Northern</p><p>Moses Nelson - Cholla (RB): Hamline<br></p><p>Nicolas Nesbitt - Chandler (RB): Brown, Columbia, Dartmouth, Lafayette, Morehead State, Penn, San Diego, Valparaiso</p><p>Myles Newble - Brophy (RB): Allegheny, Culver-Stockton, Hamline, La Verne, Rochester, Saint John's (Minn.)</p><p>Isaiah Newcombe - Casteel (WR): Abilene Christian, Air Force, Army, Boise State, BYU, Colorado State, Columbia, Fresno State, Hawaii, Idaho, New Mexico, New Mexico State, Northern Arizona, Southern Utah, Tulane, <b>UCLA</b>, Utah, Washington, Yale</p><p>Blake Nguyen - Brophy (WR): Brevard<br></p><p>Jared Nichols - Desert Ridge (SS): Concordia Coll. (Minn.), Concordia Univ. (Minn.)</p><p>Eduardo Ogaz - Safford (RB): <b>ST. OLAF</b><br></p><p>Ali'i Kai Ormita - Chandler (OT): Benedictine (Kans.), Concordia Coll. (Minn.), Lake Forest</p><p>Kyler Orr - Chandler (LB): Abilene Christian, Air Force, Idaho, Morehead State</p><p>Anthony Ortiz - Mountain Pointe (TE): South Dakota School of Mines, Southwest Minnesota State, Trine</p><p>Mikey Ortiz - Desert Edge (FS): Arizona Christian, Lake Forest, Simpson, Trine</p><p>Steven Ortiz Jr. - Desert Edge (CB): Arizona, California, Duke, Houston, Idaho, Iowa State, Kansas, Kansas State, Louisiana, <b>MINNESOTA</b>, Mississippi State, Nebraska, Northern Arizona, Oregon, Oregon State, Penn State, Rutgers, San Diego State, Syracuse, UNLV, Washington, Washington State, William &amp; Mary</p><p>Mason Osborn - Chaparral (OT): Montana Tech, Morgan State, Ohio Dominican, Sioux Falls, Southwest Minnesota State, Washburn</p><p>Damien Owens - Notre Dame (WR): Abilene Christian, Idaho, <b>NORTH DAKOTA</b>, South Dakota State, Southern Utah</p><p>Caleb Parker - Casteel (CB): Concordia Coll. (Minn.)</p><p>Andrew Patterson - Desert Edge (WR): Abilene Christian, Fordham, Gardner-Webb, Idaho, <b>MONTANA STATE</b>, New Mexico, New Mexico State, North Dakota, Northern Arizona, Northern Colorado, Southern Utah, Valparaiso, Washburn, Weber State, Western New Mexico</p><p>Parker Pelletier - Salpointe (CB): Clarke, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Greenville, Hamline, Kalamazoo, Lake Forest, Monmouth (Ill.), Norwich, Sewanee, Simpson, St. Norbert, Trine, Wisconsin-River Falls</p><p>Peyton Pelletier - Ironwood Ridge (QB): Clarke, Concordia Coll. (Minn.), Culver-Stockton, Finlandia, Greenville, Hamline, Kalamazoo, Lake Forest, Millikin, Norwich, Olivet, Simpson, St. Norbert, Trine</p><p>Trent Pennington - Basha (WR): Culver-Stockton, Hamline</p><p>Hank Pepper - Chandler (LS): <b>SAN DIEGO STATE</b>, Southwest Minnesota State, Western New Mexico</p><p>Logan Petit - Gilbert (DE): Ripon<br></p><p>Mason Phillips - Casteel (C): Clarke, Concordia Coll. (Minn.), Culver-Stockton, Graceland, Hamline, Lake Forest, Mayville State, Millikin, Monmouth (Ill.), Puget Sound, Ripon, Simpson, St. Olaf, Trine, Whittier, Wisconsin-River Falls</p><p>Matthew Phillips - Centennial (LB): Arizona Christian, Culver-Stockton<br></p><p>Jayloni Pizarro - Gilbert (RB): Wisconsin-River Falls</p><p>Kyle Pointer - Casteel (DE): Abilene Christian, Northern State, Wisconsin-River Falls</p><p>Hayden Preston - Campo Verde (OT): Concordia Coll. (Minn.), Concordia Univ. (Ill.), Culver-Stockton, Hamline, Lake Forest, Ohio Northern, Whittier</p><p>Ethan Price - Cactus (DT): Benedictine (Kans.), Culver-Stockton, Graceland, Hamline, Oberlin, Simpson, Southwest Minnesota State, Valparaiso, Whittier<br></p><p>Jadon Prince - Desert Ridge (RB): Hamline, Trine</p><p>Hunter Ramage - Mountain Ridge (DT): Hamline</p><p>George Ramirez - Red Mountain (SS): Colorado School of Mines, Northern Arizona, Northern Colorado, Southwest Minnesota State, Washburn</p><p>Jacob Ramirez - Desert View (RB): Culver-Stockton, Whittier</p><p>Jason Ramirez-Corpuz - Mountain Pointe (S): Arizona Christian, Baldwin Wallace, Carthage, Culver-Stockton, North Park, Olivet, Simpson, St. Norbert, St. Thomas (Minn.)<br></p><p>Chase Randall - Canyon del Oro (DE): <b>SIOUX FALLS</b><br></p><p>Jackson Ray - Highland (P): <b>COLORADO STATE</b></p><p>Jeremiah Reed - Westwood (SS): Peru State<br></p><p>Trey Reynolds - Queen Creek (LB): Air Force, Arizona, Boise State, BYU, Colorado, Duke, Fresno State, Illinois, Indiana, Iowa State, Kansas State, Michigan State, Northern Arizona, Oklahoma State, Oregon, San Diego State, UCLA, UNLV, <b>UTAH</b>, Utah State, Virginia, Washington, Washington State, Wisconsin, Yale</p><p>Tyler Reynolds - Cactus Shadows (QB): Concordia Coll. (Minn.), Hamline, Whittier, Wooster</p><p>Jordan Richardson - Moon Valley (CB): Wisconsin-River Falls</p><p>Dominik Richie - Combs (LB): Culver-Stockton<br></p><p>Jalen Richmond - Chandler (WR): Abilene Christian, <b>BOISE STATE</b>, Eastern Michigan, Georgetown, Idaho, Missouri State, Navy, Nevada, New Mexico State, North Dakota, Northern Arizona, Northern Colorado, Rice, San Jose State, South Dakota State, Southern Utah</p><p>Nik Rieck - Higley (FS): Lake Forest, Simpson, Wisconsin-River Falls</p><p>Tage Rigby - Centennial (RB): Benedictine (Kans.), Bethel (Kans.), Central Washington, Hamline, San Diego<br></p><p>Cavan Riggs - Queen Creek (CB): Benedictine (Kans.), Wisconsin-River Falls</p><p>TJ Ritter - Chaparral (OG): Trine</p><p>JD Roberts - Notre Dame (LB/FB): <b>NEW MEXICO</b>, Northern Arizona</p><p>Taryn Robles - Centennial (LB): Carleton, Culver-Stockton<br></p><p>Stevie Rocker - Canyon del Oro (RB): <b>ARIZONA</b>, BYU, California, Nevada</p><p>Julian Rohan - Mountain Pointe (CB): UNLV, Utah<br></p><p>Jan Ruiz - Sierra Linda (WR): Peru State, Southwest Minnesota State</p><p>Enrique Ruiz - Marcos de Niza (C): Culver-Stockton</p><p>Andy Salome - Brophy (WR): Benedictine (Kans.)<br></p><p>Alex Sanchez - Skyline (LB): Culver-Stockton</p><p>Devin Sanchez - Centennial (LB): Bethel (Kans.), Concordia Coll. (Minn.), Concordia Univ. (Ill.)<br></p><p>Eli Sanders - Chandler (RB): Arizona, Arizona State, <b>BOISE STATE</b>, Dartmouth, Idaho, Nevada, New Mexico State, Northern Arizona, Tulane</p><p>Mo Sarnowski - Hamilton (LB): Benedictine (Kans.)</p><p>Kevin Sawitzke - Mountain Pointe (TE): Idaho<br></p><p>Hunter Schlagel - Cienega (DT): Augustana, Northern Arizona, Southwest Minnesota State, Tarleton State, Washburn, Western New Mexico</p><p>Noah Schmidt - Hamilton (RB): College of Idaho</p><p>Jake Schmitt - Corona del Sol (LB): Colorado State, Idaho, New Mexico, New Mexico State, Northern Arizona, Southern Utah. Weber State</p><p>Jack Schrieber - Desert Mountain (WR): Culver-Stockton, Hamline, Kalamazoo, St. Norbert, Wisconsin-River Falls</p><p>Brandon Schwartz - Deer Valley (OG): Wisconsin-River Falls<br></p><p>Tyler Schweigert - Notre Dame (QB): Hamline, Whittier</p><p>CJ Scrivner - Safford (RB): Culver-Stockton<br></p><p>Jackson Sebastiani - Horizon (C): Culver-Stockton, Mayville State</p><p>Joseph Semien - Willow Canyon (DE): Whittier</p><p>Ethan Seppala - Canyon del Oro (FS): Concordia Coll. (Minn.), Hamline, Wisconsin-River Falls<br></p><p>Brayden Shambaugh - Casteel (RB): Whittier</p><p>Junior Shima - Ironwood (RB): Carthage, Clarke, Culver-Stockton, Hamline, North Park, Puget Sound, Trine, Whittier<br></p><p>Brady Shough - Hamilton (WR): Northern Arizona</p><p>Dillon Silva - Cienega (LB): Simpson</p><p>Corvel Simmons - Central (LB): Wisconsin-River Falls<br></p><p>Dorian Singer - Pinnacle (WR/S): Air Force, Eastern Michigan, Howard, Illinois State, Iowa State, Montana State, North Dakota State, Northern Arizona, Northern Iowa, Ohio, South Dakota, South Dakota State, Southern Illinois, Western Michigan<br></p><p>Taylor Siren - Highland (QB): Trine, Wisconsin-River Falls<br></p><p>Sean Sisco - Mountain Ridge (OG): Carleton, Concordia Coll. (Minn.), Hamline, Kenyon, Lake Forest, Oberlin, Occidental, Pacific, Puget Sound, Rose-Hulman, Simpson, St. Olaf<br></p><p>AJ Skaggs - Sabino (QB): Augustana, Sioux Falls, Whittier</p><p>Kenny Slade - Cienega (CB): Culver-Stockton, Whittier<br></p><p>Dante Smith - Desert Ridge (OG): Abilene Christian, New Mexico, New Mexico State, North Dakota, Northern Arizona, Northern Colorado, Sacramento State, South Dakota State, Tarleton State<br></p><p>Daylin Smith - Marana Mountain View (LB): Ripon, Western New Mexico</p><p>Thomas Smith - Ironwood Ridge (WR): Kalamazoo, Simpson</p><p>Elijah Sobas - Hamilton (LB): Concordia Coll. (Minn.), Heidelberg<br></p><p>Quintin Somerville - Saguaro (DE): Arizona, Arizona State, Auburn, Florida, Florida State, Georgia, Georgia Tech, Idaho, Kansas State, LSU, Memphis, <b>MICHIGAN</b>, Michigan State, Mississippi, Mississippi State, Nebraska, Northwestern, Ohio State, Oregon State, Stanford, UCLA, UNLV, Utah, Vanderbilt, Washington, Washington State</p><p>Tyler Speece - Skyline (SS): Arizona Christian, Concordia Coll. (Minn.), DePauw, Hamline, Kalamazoo, Kenyon, Northwestern Coll. (Iowa), Puget Sound, Rhodes, Saint John's, Simpson, St. Olaf, Trine, Wisconsin-River Falls</p><p>Kai Spencer - Marana (LB): Benedictine (Kans.), Concordia Coll. (Minn.), Millikin<br></p><p>Cameron Steele - Desert Edge (LB): Livingstone<br></p><p>Chris Stoica - Shadow Ridge (OG): Benedictine (Kans.), Carleton, Concordia Coll. (Minn.)., Culver-Stockton, Kalamazoo, Puget Sound, Sewanee, Trine</p><p>Ben Strawn - Northwest Christian (DE): Whittier<br></p><p>Garrett Sutliffe - Valley Vista (OG): Hamline, Pacific<br></p><p>Kayden Sutter - Higley (LB): Hamline, Simpson, Wisconsin-River Falls</p><p>Evan Svoboda - Red Mountain (QB): Abilene Christian, Illinois State, Morehead State, Washburn</p><p>Eli Swope - Chandler (TE): Colorado School of Mines, San Diego, Southern Utah</p><p>Tyson Tapley - Desert Mountain (WR): Loras, Puget Sound, Whittier</p><p>Myles Taylor - Williams Field (WR): Abilene Christian, Air Force, Army, Idaho, Navy, North Dakota, South Dakota State, Southern Utah</p><p>Jacob Thomas - Casa Grande (LB): Hamline<br></p><p>Justin Thomas - Casteel (OT): Abilene Christian, Air Force, Dartmouth, Idaho, Southeast Missouri State, Washburn</p><p>Donovan Thomason - Saguaro (LB): Concordia Coll. (Minn.)<br></p><p>Ty Thompson - Mesquite (QB): Arizona, Arizona State, Boise State, Boston College, California, Colorado, Duke, Iowa, Iowa State, Louisville, LSU, Miami (Fla.), Michigan State, North Carolina State, Northern Arizona, <b>OREGON</b>, Oregon State, Purdue, Utah, Wisconsin</p><p>Alex Ticala - Cactus (OT): Benedictine (Kans.)<br></p><p>Derek Torres - Mountain Ridge (DE): Simpson</p><p>Fernando Torres - Salpointe (TE): St. Olaf<br></p><p>Chris Trojan - Hamilton (FS): Olivet, Wisconsin-River Falls</p><p>Joshua Tsosie - Saguaro (DE): Concordia Coll. (Minn.)<br></p><p>Gabe Tulo - Desert Ridge (CB): Hamline<br></p><p>Jeremiah Tyler - Chandler (DT): Air Force, Army, Ball State, Brown, Furman, Georgetown, Howard, Nevada, New Mexico</p><p>Marcellous Urias - Saguaro (OT): Southwest Minnesota State</p><p>Rene Urias Jr. - Nogales (LB): Grinnell<br></p><p>Nico Vasko - Westview (QB): Mayville State</p><p>Isaiah Vega - Williams Field (OT): Livingstone<br></p><p>Andrew Vescova - Paradise Valley (DT): Culver-Stockton, Pacific, Puget Sound, Simpson, Trine</p><p>Chris Villalobos - Campo Verde (CB): Wisconsin-River Falls</p><p>Bram Walden - Saguaro (OT): Arizona, Arizona State, Arkansas, Auburn, BYU, California, Colorado, Florida State, Iowa State, LSU, Memphis, Miami (Fla.), Michigan, Michigan State, Mississippi State, Missouri, Ohio State, Oklahoma State, <b>OREGON</b>, Oregon State, Stanford, Tennessee, Texas, Texas A&amp;M, UCLA, UNLV, USC, Utah, Washington, Washington State</p><p>Christopher Walter - Florence (QB): Clarke, Graceland, Lewis &amp; Clark, Millikin, Monmouth (Ill.), Olivet<br></p><p>Tory Walters - Buena (RB): Benedictine, Carthage, Culver-Stockton, Elmhurst, Millikin, Monmouth (Ill.), Puget Sound, Whitworth, Wooster<br></p><p>Brannon Weatherby - Yuma Catholic (C): Benedictine (Kans.), Culver-Stockton, Simpson, Whittier<br></p><p>Isaiah Webb - Cienega (LB): Southwest Minnesota State, Western New Mexico</p><p>Matthew Weed - Deer Valley (WR): Carleton, Grinnell, Hamline, <b>PUGET SOUND</b><br></p><p>Xander Werner - Saguaro (TE): Air Force, Army, Bucknell, Fordham, Hawaii, Idaho, New Mexico, New Mexico State, Northern Arizona, Southern Utah, Texas State</p><p>Jaden White - Cactus Shadows (QB): Hamline, St. Olaf<br></p><p>Jack Whitten - Chaparral (SS): <b>BROWN</b>, Carnegie Mellon, Chicago</p><p>Caleb Wilkins - North Canyon (QB): Benedictine (Kans.), St. Francis, Trine, Whittier, Wisconsin-River Falls</p><p>DJ Williams - Centennial (CB): Montana State, <b>NORTHERN ARIZONA</b>, Northern Colorado, Southern Utah<br></p><p>Jared Williams - Chaparral (RB): Minot State, Northern Arizona</p><p>Kentrell Williams Jr. - Chandler (SS): <b>EASTERN WASHINGTON</b>, Furman, Northern Arizona, Northern Colorado, Southern Utah, Western New Mexico</p><p>Noah Williams - Dobson (LB): Bethel Coll. (Kans.)<br></p><p>Richie Williams - Arizona College Prep (RB): Hope, Kenyon, Livingstone, Olivet, Pacific, Saint John's, Simpson, St. Francis, Trine</p><p>Ian Williamson - Notre Dame (RB): Whittier</p><p>Mason Winkelmann - Chandler (C): Allegheny, Concordia Coll. (Minn.), Lake Forest, Mayville State, Trinity International<br></p><p>Ryan Wintermeyer - Cactus Shadows (LS): Akron<br></p><p>Alex Witt - Hamilton (DE): Olivet</p><p>Aaron Wolfcale-Holsten - Williams Field (DT): Benedictine (Kans.), Concordia Coll. (Minn.), Hamline, Livingstone, Valparaiso, Wisconsin-River Falls</p><p>Dominic Wright - Boulder Creek (RB): Simpson</p><p>Zachary Young - Casteel (LB): La Verne<br></p><p>Ashton Yurkiw - Sunnyslope (WR): Arizona Christian</p><p>Wyatt Zellner - Gilbert (LB): Concordia Coll. (Minn.)</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/qalc1xxuq3rtvtw5q1lq&#39;,&#39;https://images.rivals.com/rivals/image/upload/f_auto,q_auto/qalc1xxuq3rtvtw5q1lq&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="" alt="" src="https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/qalc1xxuq3rtvtw5q1lq" />
<div class='zoom-image'></div>
</div>
</div>
</figure>
<h3 class='article-heading'>Chandler QB Keene commits to UCF</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>UPDATED: 9/7/20</b></p><p>Over the Labor Day weekend, four more players announced their college commitments, raising the total number for State 48 seniors to.....48.</p><p>Chandler's Mikey Keene committed to UCF. It's the second straight year the Knights have reeled in a quarterback from the East Valley. Keene has been the top priority at the position for Central Florida since last spring.</p><p>Here's an <a href="https://ucf.rivals.com/news/ucf-strikes-again-in-arizona-landing-qb-target-mikey-keene">article (with quotes) from our Rivals affiliate for UCF</a>.</p><p><br>Northern Arizona picked up another player that had FBS offers as Saguaro defensive tackle Alani Ma'afu committed to the Lumberjacks. In the offseason, he has added 20 pounds to his frame as he gets ready for his senior year with the Sabercats.</p><p>Here's an <a href="https://www.sports360az.com/2020/09/saguaros-alani-maafu-commits-to-nau/">article (with quotes from Ma'afu's head coach) from Jordan Hamm of Sports360AZ</a>.</p><p><br>Another Big Sky team landing a commitment was Eastern Washington. The Eagles received a commitment from Keene's teammate, Kentrell Williams Jr. The safety selected EWU over Northern Colorado, Southern Utah, and NAU.</p><p>Here's an <a href="https://www.sports360az.com/2020/09/chandlers-kentrell-williams-jr-commits-to-eastern-washington/">article (with quotes from Williams' head coach) from Jordan Hamm of Sports360AZ</a>.</p><p><br>Finally, Safford running back Eduardo Ogaz committed to St. Olaf College in Minnesota. He rushed for 485 yards, averaging more than eight yards per carry as the Bulldogs captured their first region title in 21 years.<br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/xfyyaaw9wvsz7km2z6og&#39;,&#39;https://images.rivals.com/rivals/image/upload/f_auto,q_auto/xfyyaaw9wvsz7km2z6og&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Saguaro DT Alani Ma&#39;afu" src="https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/xfyyaaw9wvsz7km2z6og" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Saguaro DT Alani Ma&#39;afu</figcaption>
</div>
</figure>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/neu7dgtycz760i8vxwfj&#39;,&#39;https://images.rivals.com/rivals/image/upload/f_auto,q_auto/neu7dgtycz760i8vxwfj&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Chandler S Kentrell Williams  (Photo by Ralph Amsden)" src="https://images.rivals.com/rivals/image/upload/f_auto,q_auto,t_large/neu7dgtycz760i8vxwfj" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Chandler S Kentrell Williams  (Photo by Ralph Amsden)</figcaption>
</div>
</figure>
<h3 class='article-heading'>CLASS OF 2021 COMMITMENTS

</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>ARIZONA WILDCATS</b></p><p>Stevie Rocker (RB) - Canyon del Oro<b><br></b></p><p><b>ARIZONA STATE SUN DEVILS</b></p><p>John Ferlmann (LS) - Boulder Creek<br>Isaia Glass (OT) - Queen Creek<b><br></b></p><p><b>ARMY BLACK KNIGHTS</b></p><p>Daxon Lindholm (RB) - Centennial<b><br></b></p><p><b>BOISE STATE BRONCOS</b></p><p>Jalen Richmond (WR) - Chandler<b><br></b>Eli Sanders (RB) - Chandler<b><br></b></p><p><b>BROWN BEARS</b></p><p>Jack Whitten (SS) - Chaparral<b><br></b></p><p><b>CALIFORNIA GOLDEN BEARS<br></b></p><p>Hunter Barth (FS) - Queen Creek<br>Kai Millner (QB) - Higley<b><br></b></p><p><b>COLORADO STATE RAMS</b></p><p>Jack Howell (FS) - Hamilton<br>Jackson Ray (P) - Highland<b><br></b></p><p><b>DUKE BLUE DEVILS</b></p><p>Trey Brown (LB) - Arcadia<b><br></b></p><p><b>EASTERN WASHINGTON EAGLES</b></p><p>Kentrell Williams Jr. (SS) - Chandler<b><br></b></p><p><b>KANSAS STATE WILDCATS</b></p><p>Krew Jackson (FS) - Queen Creek<b><br></b></p><p><b>MARY MARAUDERS</b></p><p>Jadon Hanzal (QB) - Valley Christian<b><br></b></p><p><b>MICHIGAN WOLVERINES</b></p><p>Quintin Somerville (DE) - Saguaro<b><br></b></p><p><b>MINNESOTA GOLDEN GOPHERS</b></p><p>Steven Ortiz Jr. (CB) - Desert Edge<b><br></b></p><p><b>MONTANA STATE BOBCATS</b></p><p>Aaron Gerle (DT) - Greenway<br>Andrew Patterson (WR) - Desert Edge<b><br></b></p><p><b>NEVADA WOLF PACK</b></p><p>Zion Burns (DB/RB) - Poston Butte<b><br></b>Zachary Lewis (CB) - Hamilton<b><br></b></p><p><b>NEW MEXICO LOBOS</b></p><p>Andrell Barney (CB) - Basha<b><br></b>Bear Milacek (QB) - Boulder Creek<b><br></b>JD Roberts (LB) - Notre Dame<b><br></b></p><p><b>NORTH DAKOTA FIGHTING HAWKS</b></p><p>Damien Owens (WR) - Notre Dame<b><br></b></p><p><b>NORTHERN ARIZONA LUMBERJACKS</b></p><p>Zach Blackwood (DE) - Desert Edge<b><br></b>Richard Kwete (DT) - Sunnyslope<b><br></b>Alani Ma'afu (DT) - Saguaro<b><br></b>DJ Williams (CB) - Centennial<b><br></b></p><p><b>OHIO STATE BUCKEYES</b></p><p>Denzel Burke (CB/WR) - Saguaro<b><br></b></p><p><b>OREGON DUCKS</b></p><p>Brandon Buckner (DE) - Chandler<br>Jonah Miller (OT) - Salpointe<br>Ty Thompson (QB) - Mesquite<br>Bram Walden (OT) - Saguaro</p><p><b>PUGET SOUND LOGGERS</b></p><p>Matthew Weed (WR/DB) - Deer Valley<br></p><p><b>SAN DIEGO TOREROS</b></p><p>James Jaquint (SS) - Notre Dame<br></p><p><b>SAN DIEGO STATE AZTECS</b></p><p>Darrion Dalton (DT) - Saguaro<br>Will Haskell (QB) - Ironwood<br>Hank Pepper (LS) - Chandler<br></p><p><b>SIOUX FALLS COUGARS</b></p><p>Jayden Harrington (CB) - Verrado<br>Chase Randall (DE) - Canyon del Oro</p><p><b>ST. OLAF OLES</b></p><p>Eduardo Ogaz (RB) - Safford<br></p><p><b>TOLEDO ROCKETS</b></p><p>Benjamin Lisk (LS) - Paradise Valley</p><p><b>UCF KNIGHTS</b></p><p>Mikey Keene (QB) - Chandler<br></p><p><b>UCLA BRUINS</b></p><p>Isaiah Newcombe (WR) - Casteel<br></p><p><b>UNLV REBELS</b></p><p>Caiden Miles (OT) - Centennial</p><p><b>USC TROJANS</b></p><p>Saia Mapakaitolo (OT) - Red Mountain<br></p><p><b>UTAH UTES</b></p><p>Trey Reynolds (LB) - Queen Creek<br></p><p><b>WASHINGTON STATE COUGARS</b></p><p>Brock Dieu (OT): Casteel<br></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-9-21/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === &quot;premium&quot;'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>

<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' display-lrec1-rightrail='true' display-lrec2-rightrail='true' enrichments='[]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2020' ncaaf-schedule-year='2020' scoreboard-photos-id='15082' scoreboard-scores-id='15081' site='{&quot;id&quot;:6,&quot;legacy_id&quot;:1128,&quot;name&quot;:&quot;ArizonaVarsity&quot;,&quot;friendly_name&quot;:&quot;Arizona HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;arizonavarsity&quot;,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;arizonavarsity&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;}' twitter-feed='{&quot;id&quot;:6,&quot;site_id&quot;:6,&quot;handle&quot;:&quot;ArizonaVarsity&quot;,&quot;list_name&quot;:&quot;TeamAZV&quot;,&quot;created_at&quot;:&quot;2016-02-01T12:24:39.964-06:00&quot;,&quot;updated_at&quot;:&quot;2020-04-28T02:17:51.614-05:00&quot;,&quot;hashtags&quot;:[],&quot;usernames&quot;:[&quot;AZHSFB&quot;,&quot;ArizonaVarsity&quot;],&quot;max_number&quot;:5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-9-21/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
</div>
</div>
<script src='/javascript/ad?ad_referrer=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fgridiron-arizona-s-2021-recruiting-update-9-21&amp;space_id=2022719646' type='text/javascript'></script>

<rv-chartbeat-config-body ng-hide sections='content,content-football,content-football-free,content-article' title='Gridiron Arizona&#39;s 2021 Recruiting Update: 9/21'></rv-chartbeat-config-body>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init(null, null, null, &quot;arizonavarsity&quot;, 2199117, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if='showLRECad(&#39;footer&#39;)'>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
</div>

</div>
</main>
<footer>
<div class='flexible-links'>
<a class='link' href='/news/about-us'>About</a>
<a class='link' href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a class='link' href='/news/contact-us-5'>Contact Us</a>
<a class='link' href='/tos'>Terms of Service</a>
<a class='link' href='/news/member-services'>Help</a>
</div>
<div class='logo-container'>
<div class='footer-logo'><?xml version="1.0" encoding="UTF-8"?>
<svg width="159px" height="96px" viewbox="0 0 159 96" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 58 (84663) - https://sketch.com -->
    <title>logo_yahoo_sports_gray</title>
    <desc>Created with Sketch.</desc>
    <g id="Logos" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="logo-/-yahoo-sports-/-grayscale">
            <g id="logo-/-yahoo-sports-MASTER-/-black-on-white" transform="translate(0.000000, 36.000000)">
                <g id="yahoo-sports-logo-white">
                    <path d="M24.0702452,5.83111111 L24.0702452,7.06666667 C23.2097927,6.0367158 21.9427054,5.46606759 20.6261035,5.51555556 C17.1389101,5.51555556 14.5428883,8.69333333 14.5428883,12.4222222 C14.5428883,16.2577778 17.1259946,19.3333333 20.6261035,19.3333333 C21.9510266,19.3980812 23.2277754,18.8131965 24.0702452,17.7555556 L24.0702452,18.9911111 L28.4184741,18.9911111 L28.4184741,5.83111111 L24.0702452,5.83111111 Z M29.9209809,0 L29.9209809,18.9911111 L34.4241962,18.9911111 L34.4241962,11.9777778 C34.4241962,10.6088889 35.0613624,9.79555556 36.0773842,9.79555556 C37.093406,9.79555556 37.6315531,10.5066667 37.6315531,11.8177778 L37.6315531,18.9911111 L42.1347684,18.9911111 L42.1347684,10.7155556 C42.1347684,7.51111111 40.4557493,5.51555556 37.7564033,5.51555556 C36.4540592,5.4661141 35.2068557,6.0603675 34.3983651,7.11555556 L34.3983651,0.00444444444 L29.9209809,0 Z M71.1129155,12.4444444 C71.1129155,16.3866667 68.1897003,19.3555556 64.293515,19.3555556 C60.3973297,19.3555556 57.4741144,16.3866667 57.4741144,12.4444444 C57.4741144,8.50222222 60.4016349,5.53777778 64.293515,5.53777778 C68.1853951,5.53777778 71.1129155,8.50666667 71.1129155,12.4444444 Z M56.7120981,12.4444444 C56.7120981,16.3866667 53.7845777,19.3555556 49.8926975,19.3555556 C46.0008174,19.3555556 43.073297,16.3866667 43.073297,12.4444444 C43.073297,8.50222222 46.0008174,5.53777778 49.8926975,5.53777778 C53.7845777,5.53777778 56.7120981,8.50666667 56.7120981,12.4444444 Z M5.68434189e-14,5.85333333 L5.44174387,19.1155556 L3.48288828,23.8977778 L8.26594005,23.8977778 L15.5201635,5.85333333 L10.7844687,5.85333333 L7.83111717,13.5733333 L4.90359673,5.85333333 L5.68434189e-14,5.85333333 Z M21.5258856,15.1511111 C20.0778762,15.1511111 18.9040327,13.9392952 18.9040327,12.4444444 C18.9040327,10.9495937 20.0778762,9.73777778 21.5258856,9.73777778 C22.9738949,9.73777778 24.1477384,10.9495937 24.1477384,12.4444444 C24.1582975,13.1655836 23.8854595,13.8603865 23.3914592,14.3703671 C22.8974589,14.8803478 22.2244277,15.1620118 21.5258856,15.1511111 L21.5258856,15.1511111 Z M52.4155313,12.4444444 C52.3942095,10.9991882 51.2457931,9.84329333 49.8457334,9.85791214 C48.4456737,9.87253095 47.3201395,11.0521694 47.3271064,12.4975752 C47.3341381,13.942981 48.4710404,15.1109435 49.8711717,15.1111111 C50.5556752,15.1211114 51.2144344,14.8420408 51.6948283,14.3385545 C52.1752222,13.8350681 52.4355617,13.150859 52.4155313,12.4444444 Z M66.8163488,12.4444444 C66.795027,10.9991882 65.6466105,9.84329333 64.2465509,9.85791214 C62.8464912,9.87253095 61.720957,11.0521694 61.7279238,12.4975752 C61.7349555,13.942981 62.8718578,15.1109435 64.2719891,15.1111111 C64.9564926,15.1211114 65.6152519,14.8420408 66.0956458,14.3385545 C66.5760396,13.8350681 66.8363791,13.150859 66.8163488,12.4444444 Z M71.6510627,16.2266667 C71.6417293,17.0311249 71.9471656,17.80545 72.4982184,18.3743287 C73.0492712,18.9432074 73.7993326,19.2585242 74.5785831,19.2488889 C76.2429617,19.2488889 77.5922071,17.855997 77.5922071,16.1377778 C77.6063278,15.3326284 77.3030257,14.5560964 76.7518547,13.9862577 C76.2006837,13.416419 75.4489316,13.102163 74.6689918,13.1155556 C73.0046133,13.1155556 71.6553678,14.5084474 71.6553678,16.2266667 L71.6510627,16.2266667 Z M78.0657766,0.0222222222 L73.2999455,11.9244444 L78.6469755,11.9244444 L83.4300272,0 L78.0657766,0.0222222222 Z" id="Shape" fill="#000000"></path>
                    <path d="M134.510954,5.48444444 C134.287017,5.41042851 134.052932,5.37440508 133.81782,5.37777778 C132.285501,5.33345562 130.885901,6.2707681 130.30049,7.73333333 L130.30049,5.69333333 L125.681035,5.69333333 L125.681035,18.9466667 L130.326322,18.9466667 L130.326322,14.12 C130.326322,11.6577778 131.432752,10.28 133.382997,10.28 C133.766741,10.2725198 134.148703,10.3357311 134.510954,10.4666667 L134.510954,5.48444444 Z M157.586703,14.7066667 C157.586703,12.56 156.174605,11.3911111 153.328883,10.5688889 L152.584087,10.36 C151.529319,10.0666667 151.120327,9.96 151.120327,9.64444444 C151.120327,9.32888889 151.400163,9.08888889 152.093297,9.08888889 C153.450345,9.14730589 154.776143,9.52749663 155.967956,10.2 L157.405886,6.72888889 C155.762922,5.84513411 153.941481,5.37314042 152.088992,5.35111111 C148.778311,5.35111111 146.522398,7.07111111 146.522398,9.85333333 C146.522398,12.2133333 147.981853,13.3511111 150.883542,14.04 L151.550845,14.2 C152.52812,14.44 152.962943,14.5733333 152.962943,14.9422222 C152.962943,15.3866667 152.532425,15.5244444 151.860817,15.5244444 C150.346116,15.4741491 148.867045,15.0374509 147.55564,14.2533333 L145.911063,17.6977778 C147.686591,18.7932991 149.72378,19.3537124 151.791935,19.3155556 C155.180109,19.3155556 157.565177,17.6444444 157.565177,14.7066667 L157.586703,14.7066667 Z M99.466812,23.8755556 L99.466812,17.5422222 C100.358,18.7173685 101.741926,19.3788009 103.186485,19.32 C106.677984,19.32 109.213733,16.2088889 109.213733,12.3244444 C109.213733,8.44 106.69951,5.32888889 103.186485,5.32888889 C101.733545,5.28164108 100.348025,5.96204577 99.466812,7.15555556 L99.466812,5.69777778 L94.7913896,5.69777778 L94.7913896,23.88 L99.466812,23.8755556 Z M99.3376567,12.32 C99.3271861,11.213905 99.9645436,10.210698 100.951431,9.77990287 C101.938319,9.34910772 103.079494,9.57595163 103.84086,10.3542665 C104.602227,11.1325813 104.833158,12.3083876 104.425573,13.3313811 C104.017988,14.3543747 103.052522,15.0221694 101.981035,15.0222222 C101.279555,15.0391913 100.60157,14.760828 100.102982,14.251141 C99.6043938,13.7414539 99.3281085,13.0443046 99.3376567,12.32 L99.3376567,12.32 Z M117.380654,5.32444444 C113.351008,5.32444444 110.3503,8.34666667 110.3503,12.32 C110.3503,16.2933333 113.363924,19.3155556 117.380654,19.3155556 C121.397384,19.3155556 124.389482,16.2933333 124.389482,12.32 C124.389482,8.34666667 121.375858,5.32444444 117.380654,5.32444444 Z M119.925028,12.32 C119.926756,13.3827901 119.307948,14.3419313 118.357325,14.7498901 C117.406702,15.1578489 116.311622,14.9342208 115.583048,14.1833503 C114.854473,13.4324797 114.635998,12.3023557 115.029563,11.3202919 C115.423128,10.338228 116.351165,9.69774364 117.380654,9.69774364 C118.055765,9.6942178 118.704284,9.9692005 119.182069,10.4616073 C119.659855,10.954014 119.927319,11.6230453 119.925028,12.32 L119.925028,12.32 Z M137.378202,1.58666667 L137.378202,5.69333333 L135.656131,5.69333333 L135.656131,9.61333333 L137.378202,9.61333333 L137.378202,14.3288889 C137.378202,17.4844444 139.17346,19.3111111 142.113896,19.3111111 C143.108761,19.3245868 144.098636,19.1637885 145.041417,18.8355556 L145.041417,14.7555556 C144.601078,14.9003846 144.142996,14.9797003 143.680981,14.9911111 C142.600381,14.9911111 142.036403,14.4888889 142.036403,13.2133333 L142.036403,9.65777778 L145.050027,9.65777778 L145.050027,5.76 L142.036403,5.76 L142.036403,1.65333333 L137.378202,1.58666667 Z M93.5342779,14.7066667 C93.5342779,12.56 92.1221798,11.3911111 89.2764578,10.5688889 L88.5316621,10.36 C87.4768937,10.0666667 87.0679019,9.96 87.0679019,9.64444444 C87.0679019,9.32888889 87.3477384,9.08888889 88.0408719,9.08888889 C89.3979195,9.14730589 90.7237182,9.52749663 91.9155313,10.2 L93.3534605,6.72888889 C91.7104967,5.84513411 89.8890562,5.37314042 88.0365668,5.35111111 C84.7258856,5.35111111 82.4699728,7.07111111 82.4699728,9.85333333 C82.4699728,12.2133333 83.9294278,13.3511111 86.8311172,14.04 L87.4984196,14.2 C88.4756948,14.44 88.9105177,14.5733333 88.9105177,14.9422222 C88.9105177,15.3866667 88.48,15.5244444 87.8083924,15.5244444 C86.2936909,15.4741491 84.81462,15.0374509 83.5032153,14.2533333 L81.8586376,17.6977778 C83.6341658,18.7932991 85.6713546,19.3537124 87.7395095,19.3155556 C91.1276839,19.3155556 93.512752,17.6444444 93.512752,14.7066667 L93.5342779,14.7066667 Z" id="Shape" fill="#999999"></path>
                </g>
            </g>
        </g>
    </g>
</svg></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC</div>
<div class='copyright-notice'>© 2020 Verizon Media. All rights reserved.</div>
</footer>
<script src="https://cdn.rivals.com/production/assets/footer-42b86fa67c44b173e95b27f36d5e56aaa7be9bc31996ba0848303c63cc63e2f0.js"></script>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719646",
    c7: "https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2021-recruiting-update-9-21"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    // loading the evergreen version of cs.js so we always have the last version
    s.src = "https://s.yimg.com/cx/vzm/cs.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fgridiron-arizona-s-2021-recruiting-update-9-21&c5=2022719646&cv=2.0&cj=1&cs_ucfr=0" />
</noscript>
<!-- End comScore Tag -->

</html>
