<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"282811705,282811706","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":779,"agent":""}</script>
<script>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</script>
<script src='https://cdn.rivals.com/production/assets/window_name-426a8929f8d33048988258b1fc9ba7fa371d790b3661496339ffb6f2b1141c3f.js'></script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='stage.guce.rivals.com' name='oath:guce:consent-host'>
<meta content='true' name='oath:guce:report-only'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-81764304-1', 'auto');
</script>

<script>
dataLayer = [];
</script>
<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-17665c085dfaf620c961e1c0ddea354a20565cd5002add288461398e9f21d1eb.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansCondFonts-b7c03513f0a0ac520d56f687ede40689014ba7c54382cfa0505eb4eaaacef582.css' rel='stylesheet'>
<title>ArizonaVarsity  -  Gridiron Arizona&#39;s 2023 Recruiting Update: 12/19</title>
<meta content='ArizonaVarsity  -  Gridiron Arizona&#39;s 2023 Recruiting Update: 12/19' property='og:title'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2023 class' name='description'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-e711b13dee4b9bc2caa68e64a5977004c061ce844de11158cce2442be4b10333.css" />


<script src="https://cdn.rivals.com/production/assets/lib-00d15204fcb30534f67334e4fce0a1a9f44edf9ebabd3d87c2d49d860babf7fa.js"></script>
<script src='/javascript/config.js'></script>
<script src="https://cdn.rivals.com/production/assets/application-bc6e6a8957f681c96ae8fae15d6d1f579a27b6e6554c4fdb53f0af8280c96d06.js"></script>

<script src='/javascript/url_factory.js'></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="cvC13dK93+e5QDyCIGfNyDSwJNYjokIDJkY91iWClNviQILQH0ze4xD6/0g82C/xu2znVvMiZWGsgNRQZOQ6zA==" />
<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-fdff72b91f19d75cf51d8bdb22cf7f1c7435213329db92847ab8cd17911cc566.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-171b5725637bfa4769cee9b7c9352a74b2ba24d525be5b720e267e8adf48012c.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2023-recruiting-update-12-19' property='og:url'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/ikmyltrwhfr4rlooefih' property='og:image'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2023 class' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2022-12-19 23:45:04 -0600' property='article:published_time'>
<meta content='2022-12-20 00:47:19 -0600' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-79d2adbade85e1e68905ea1a26278770384c72769e302a0dae0424b3991cb8c0.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-fad0448de054b018c1fb496c82e4d147e36e025324f6097d939a6223773c6408.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-d83a481672df92fa565a3c3e4490fe8538a8cca8f2f6c8bc04b4e003da9c1f95.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-dde27fd6889cda35c548e8f311394eb5ad38fd060061150fb984469c56db0a8d.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-1b293697db4809dca023fcaee39f7266c5278095067b8f6c8edb1bcc1cf9029a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-160b06011cecdf794bd4037752e257bf4272d38e105b58b8b63ff4e510d25a7a.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-b53ef0fb1afaa6ee435ba26728402dd43f9f2853b6a2932fa7d9fb70fc5e35ce.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-95c2973fbaef93d4c790667ba039b95898451bb04f5b2b399071e6483347812d.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-a223232b426f12e2f04f4a3aecf49f46b9e0a79cd886e7a210e0cdf5ad5bd024.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-a217ac85d423e19cbde56dcf9b01630789a023d0509d6fa0880bd5da15cc22d1.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-894aa91cf9d624f18d121145468a0bb30395f01d70de0dbf67742b95de46cfd2.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-b0f9dfc4ee4c3780ac01665cf518b0b20ec78f58b81349f7cbcf715820137ac3.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-8ab5e15036ae6a8e5c073b018e034b9e1d8b57c0445d930c005e3bbd54bdf23e.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-c5cfe3c55f53109b71f4a7ed03d0ff07134dc883a367e64241c5c595468da9bb.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-0e1d4801a92a4feee97ecae9ec64f5af784165a723e8fa49b12047d75b5aba98.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-4bf9998442db4c04360a1612c42ca4e1aeff88b16510ab66fc9275af3e694668.json' rel='manifest'>
<rv-chartbeat-config-header ng-hide subdomain='arizonavarsity.rivals.com'></rv-chartbeat-config-header>

</head>
<body class='arizonavarsity contents-show' ng-app='rivals'>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PHNjcmlwdD4KICAoZnVuY3Rpb24odyxkLHMsbCxpKXsKICAgICAgICBpZiAo
d2luZG93Ll9kaWRBc3luY0luamVjdEdvb2dsZVRhZ01hbmFnZXIpIHJldHVy
bjsKICAgICAgICB3W2xdPXdbbF18fFtdO3dbbF0ucHVzaCh7J2d0bS5zdGFy
dCc6CiAgICAgICAgbmV3IERhdGUoKS5nZXRUaW1lKCksZXZlbnQ6J2d0bS5q
cyd9KTt2YXIgZj1kLmdldEVsZW1lbnRzQnlUYWdOYW1lKHMpWzBdLAogICAg
ICAgIGo9ZC5jcmVhdGVFbGVtZW50KHMpLGRsPWwhPSdkYXRhTGF5ZXInPycm
bD0nK2w6Jyc7ai5hc3luYz10cnVlO2ouc3JjPQogICAgICAgICdodHRwczov
L3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNvbS9ndG0uanM/aWQ9JytpK2RsKycm
Z3RtX2F1dGg9JysnS2hINmhlQ3BvV0pVSG5xVnpkRWE3dycrCiAgICAgICAg
JyZndG1fcHJldmlldz0nKydlbnYtMScrJyZndG1fY29va2llc193aW49eCc7
Zi5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLGYpOwogICAgICAgIHdpbmRv
dy5fZGlkQXN5bmNJbmplY3RHb29nbGVUYWdNYW5hZ2VyID0gdHJ1ZTsKICAg
ICAgfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCdkYXRhTGF5ZXInLCdH
VE0tTUY2UFhYQycpOwo8L3NjcmlwdD4KPG5vc2NyaXB0Pgo8aWZyYW1lIGhl
aWdodD0nMCcgc3JjPSdodHRwczovL3d3dy5nb29nbGV0YWdtYW5hZ2VyLmNv
bS9ucy5odG1sP2lkPUdUTS1NRjZQWFhDJmFtcDtndG1fYXV0aD1LaEg2aGVD
cG9XSlVIbnFWemRFYTd3JmFtcDtndG1fcHJldmlldz1lbnYtMSZhbXA7Z3Rt
X2Nvb2tpZXNfd2luPXgnIHN0eWxlPSdkaXNwbGF5Om5vbmU7dmlzaWJpbGl0
eTpoaWRkZW4nIHdpZHRoPScwJz48L2lmcmFtZT4KPC9ub3NjcmlwdD4KCgo=

</div>
</div>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
    ga('create', 'UA-81764304-1', 'auto');
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .arizonavarsity #programming > h1 {
      background-color: #000000 !important; } }
  
  .arizonavarsity .wrapper-container .team-colors-line {
    background-color: #b87333; }
  
  @media screen and (min-width: 768px) {
    .arizonavarsity .solid-team-line {
      width: 100%;
      height: 8px;
      display: flex;
      background-color: #b87333; } }
  
  .arizonavarsity .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #000000; }
    .arizonavarsity .team-colors-line .color {
      width: 33.33%; }
    .arizonavarsity .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .arizonavarsity .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .arizonavarsity .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .arizonavarsity .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .arizonavarsity .team-colors-line.header {
      height: 6px; }
  
  .arizonavarsity > header .notification-link .count-container {
    background-color: #000000 !important; }
  
  .arizonavarsity > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
  
  .arizonavarsity > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .arizonavarsity > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .arizonavarsity > header .invalid-email-banner a:hover {
      color: #b87333; }
  
  @media screen and (max-width: 767px) {
    .arizonavarsity > header .mobile-header {
      background-color: #b87333 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  
  .arizonavarsity > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  
  .arizonavarsity > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  
  .arizonavarsity > header .second-nav {
    background-color: white !important; }
  
  @media screen and (max-width: 1023px) {
    .arizonavarsity > header .nav-row > ul,
    .arizonavarsity > header .third-nav {
      background-color: white !important; }
    .arizonavarsity > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  
  .arizonavarsity > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #b87333; }
  
  .site-secondary-background-color {
    background-color: #b87333; }
  
  :root {
    --primary-color: #000000;
    --primary-color-overlay: rgba(0, 0, 0, .4);
    --secondary-color: #b87333;
    --accent-color: #000000;
    --button-color: #000000;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init("arizonavarsity")' role='navigation'>
<div class='wrapper-container'>
<a class='cta-header-banner' ng_href='{{ctrl.subscribePath}}' style='display: none;'>
Enjoying ArizonaVarsity? Get a yearly subscription for $99.95/year or $9.95/month
</a>
<div class='wrapper logo-row'>
<a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-black'></div>
</a><a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
<a alt="Arizona HS Sports" class="site-header logo-image-wrapper" href="https://arizonavarsity.rivals.com/"><img src="https://images.rivals.com/image/upload/f_auto,q_auto/jfx2ba0nx7j1blby9bv1" />
</a><div class='nav-right-controls'>
<div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
<span class='upsell-text'>
Join the team!
</span>
<div class='subscribe-button' ng-click='ctrl.subscribeEvent()'>
Subscribe
</div>
</div>
<rv-universal-search></rv-universal-search>
<rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
<rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
</div>
</div>
<div class='solid-team-line header'></div>
</div>
<div class='mobile-header'></div>
<rv-header-alert class='alert-nav'></rv-header-alert>
<hr>
<div class='nav-row-container'>
<div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="8"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<li class="touch-screens-only-subscribe-link top-nav"><a href="/sign_up">Subscribe</a></li></ul>
</div>
<div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
<ul><li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
<rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="4"></rv-forum-navigation>
<li class="search top-nav"><a href="/search">Prospect Search</a></li>
<li class="futurecast top-nav"><a href="/futurecast">FutureCast</a></li>
<rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
<li class="touch-screens-only-subscribe-link top-nav"><a href="/sign_up">Subscribe</a></li></ul>
</div>
<div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
<a ng-href='{{ctrl.userProfileEditPath}}'>
Your account has an invalid email address. Please update it here.
</a>
</div>
</div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid3.js"></script>
<script src='/javascript/ad_beacon.js?path=content&space_id=2022719646' type='text/javascript'></script>

<rv-content-title content-title='Gridiron Arizona&#39;s 2023 Recruiting Update: 12/19' ng-hide='true'></rv-content-title>
<meta content='summary_large_image' name='twitter:card'>
<meta content='ArizonaVarsity' name='twitter:site'>
<meta content='Gridiron Arizona&#39;s 2023 Recruiting Update: 12/19' name='twitter:title'>
<meta content='The Recruiting Page featuring all the offers &amp; commits for Arizona&#39;s 2023 class' name='twitter:description'>
<meta content='https://images.rivals.com/image/upload/f_auto,q_auto,t_large/ikmyltrwhfr4rlooefih' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {&quot;id&quot;:6,&quot;legacy_id&quot;:1128,&quot;name&quot;:&quot;ArizonaVarsity&quot;,&quot;friendly_name&quot;:&quot;Arizona HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;arizonavarsity&quot;,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;arizonavarsity&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;}, true, 161, nil, {&quot;id&quot;:92,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;commitment_module_football&quot;:true,&quot;rivals_module_football&quot;:true,&quot;header_name&quot;:&quot;ArizonaVarsity.com&quot;,&quot;header_logo_cloudinary&quot;:&quot;jfx2ba0nx7j1blby9bv1&quot;,&quot;mobile_header_logo_cloudinary&quot;:&quot;lt4xm3i1vhxzczdsev3e&quot;,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;,&quot;logo_background_shading&quot;:&quot;black&quot;,&quot;football_content&quot;:true,&quot;basketball_content&quot;:true,&quot;baseball_content&quot;:true,&quot;other_content&quot;:true,&quot;site_id&quot;:6,&quot;created_at&quot;:&quot;2016-11-23T13:38:43.400-06:00&quot;,&quot;updated_at&quot;:&quot;2021-12-01T12:51:04.176-06:00&quot;,&quot;max_trending_articles&quot;:6,&quot;enrichments&quot;:[{&quot;active&quot;:true,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:1},{&quot;active&quot;:false,&quot;type&quot;:&quot;Rivals&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;TeamRankings&quot;,&quot;football&quot;:true,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardScores&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Commitment&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;Schedule&quot;,&quot;football&quot;:false,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;ScoreboardPhotos&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;FanFuturecastLeaderboard&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null},{&quot;active&quot;:false,&quot;type&quot;:&quot;RecentForecasts&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:null}],&quot;footer_text&quot;:null,&quot;sections&quot;:[],&quot;supplied_domain&quot;:null,&quot;forums_link_url&quot;:&quot;https://arizonavarsity.forums.rivals.com&quot;,&quot;scoreboard_scores_id&quot;:15081,&quot;scoreboard_photos_id&quot;:15082,&quot;aol_player_id&quot;:null,&quot;aol_company_id&quot;:null,&quot;ad_frequency&quot;:5,&quot;display_twitter_follow&quot;:true,&quot;display_fb_follow&quot;:true,&quot;follow_twitter_handle&quot;:&quot;ArizonaVarsity&quot;,&quot;follow_fb_handle&quot;:&quot;arizonavarsity&quot;,&quot;forum_id&quot;:null,&quot;premium_forum_id&quot;:null,&quot;facebook_page_id&quot;:null,&quot;max_ticker_articles&quot;:12,&quot;schedule_header_on&quot;:false,&quot;promo_popup_on&quot;:false,&quot;facebook_developer_id&quot;:null,&quot;customized_tos&quot;:[],&quot;show_survey_popup&quot;:false,&quot;survey_popup_link&quot;:null,&quot;header_bottom_border_style&quot;:null,&quot;customized_upsell_banner_text&quot;:null,&quot;email_logo_cloudinary&quot;:null,&quot;target_list_on&quot;:null,&quot;gifting_banner_content&quot;:&quot;Give a Rivals gift subscription this holiday season&quot;,&quot;gifting_banner_title&quot;:&quot;The perfect gift for football recruiting fans!&quot;,&quot;gifting_banner_button_text&quot;:&quot;Give a gift subscription&quot;,&quot;navigation_key&quot;:&quot;arizonavarsity&quot;},
&quot;58e686759efa8936610b8215&quot;, &quot;58e68374c7480e728bcc385f&quot;, &quot;rivals&quot;, 15000,
false, {&quot;id&quot;:1967,&quot;user_id&quot;:2798272,&quot;site_id&quot;:6,&quot;updated_at&quot;:&quot;2018-06-24T21:51:58.853-05:00&quot;,&quot;publisher_name&quot;:&quot;Chris Eaton&quot;,&quot;first_name&quot;:&quot;Chris&quot;,&quot;last_name&quot;:&quot;Eaton&quot;,&quot;site_title&quot;:&quot;Staff&quot;,&quot;bio&quot;:null,&quot;twitter_handle&quot;:null,&quot;image_url&quot;:null,&quot;publisher_name_and_title&quot;:&quot;Chris Eaton, Staff&quot;,&quot;site_name&quot;:&quot;ArizonaVarsity&quot;,&quot;site_short_name&quot;:&quot;arizonavarsity&quot;,&quot;has_edited_profile&quot;:false}, null, nil, true)'>
<div class='ra-container'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
</div>

<div class='article-container' ng-class='{&quot;no-ad-padding&quot;: &quot;#{@display_ldrb_top}&quot;}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode' site_name='ArizonaVarsity'></rv-news-ticker>
</div>

<rv-forums ad-referer='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2023-recruiting-update-12-19' base-api-url='https://arizonavarsity.forums.rivals.com/' forums-url='https://arizonavarsity.forums.rivals.com' homepage='false' pub-ad='null' size='size' space-id='2022719646' subscribed-user='subscribedUser'></rv-forums>

<div class='distro_scale_ad'>
<div class='third_party_consent_embed' style='display: none;'>
<div class='distro_ad encoded_embed_content'>
PGRpdiBjbGFzcz0ncmEtY29udGFpbmVyIGRpc3Ryb19hZCc+CjxkaXYgY2xh
c3M9J3ZpZGVvLWFkLXdyYXBwZXInPgo8c2NyaXB0IGFzeW5jIHNyYz0nLy9j
LmpzcmRuLmNvbS9zL2NzLmpzP3A9MjI1NDYnIHR5cGU9J3RleHQvamF2YXNj
cmlwdCc+PC9zY3JpcHQ+CjxkaXYgY2xhc3M9J3ZpZGVvLWNvbnRhaW5lcicg
aWQ9J2RzX2RlZmF1bHRfYW5jaG9yJz48L2Rpdj4KPC9kaXY+CjwvZGl2PgoK

</div>
</div>
</div>

</div>
</div>
<div class='article-display-wrapper'>
<div class='mobile-ad native-ad-ccc25e1a-d33c-46c9-a14a-96144b7a8b28'></div>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2023-recruiting-update-12-19/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo(&#39;2022-12-19 23:45:04 -0600&#39;) }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2468322/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h1 class='article-title'>Gridiron Arizona&#39;s 2023 Recruiting Update: 12/19</h1>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/wbg0jaxdot6esvaglzfc&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/wbg0jaxdot6esvaglzfc&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="" alt="" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/wbg0jaxdot6esvaglzfc" />
<div class='zoom-image'></div>
</div>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<div>
<span class='author-name'>
Chris Eaton
&bull;
<span class='type-sm'>ArizonaVarsity</span>
</span>
<div>
<span class='author-name'>Staff</span>
</div>
</div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>

<div class='mobile-ad'>
<div class='native-ad-50d38545-0eeb-4c35-9393-b22cf70b9e3d'></div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><h3 class='article-heading'>NM State, Hawaii offer Desert Edge offensive tackle Jackson Carter</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>UPDATED: 12/19/22</b></p><p>Colleges across the nation continue to take notice of the prep talent in Arizona each season. More than 390 players from the Class of 2022 signed with schools to advance their football careers, and receive an education.</p><p>Times for games are given in Arizona time.</p><p>Desert Edge is coming off another playoff appearance and one of its linemen is getting some recruiting attention. <b>Kaleb Jackson Carter</b>, a 6-5, 275-pound offensive tackle, received offers from New Mexico State and Hawaii earlier this month. He was a First Team All-5A Desert West selection as the Scorpions finished 8-4 and made the quarterfinals. Jackson Carter moved to Arizona in May from Fresno and played for his uncles' (Mark and Marcus Carter) team for his senior year. He now has 10 offers. New Mexico State had nine players graduate over the weekend, including Horizon alum Justin Segura, a defensive lineman. For just the fifth time in its history, the Aggies are going to a bowl. NMSU (6-6) will play in Detroit against Bowling Green (6-6) in the Quick Lane Bowl on Dec. 26 at Ford Field. ESPN will have the game on Dec. 26 at 12:30 p.m. Hawaii announced a home-and-home series with Kansas. The Rainbow Warriors will host KU in 2028 and then go to Lawrence in 2032. Senior offensive lineman Ilm Manning, an Apollo alum, was named to the All-Mountain West Conference First Team. It's the third time he has been named to all-conference honors. UH finished 3-10 in 2022, which included a September loss at New Mexico State (45-26).<br></p><p>Red Mountain running back <a href="https://n.rivals.com/content/prospects/2023/lenox-lawson-273822">Lenox Lawson</a> has decomitted from Central Michigan and collected a new offer on Wednesday from Arizona State. Lawson took his official visit to Tempe over the weekend. Lawson, 5-11, 175, fills up the stat sheet with rushing yards (1,292), receiving yards (497), and return yards (332). Add those up and you get 2,139 all-purpose yards (194.5 per game). Lawson's film is as good as you will see from any skill-position player in the state. Arizona State announced Kenny Dillingham as its new head coach last month. The Chaparral and Arizona State alum was most recently the offensive coordinator at Oregon. The Ducks' quarterback this year, Bo Nix, ranked No. 2 in completion percentage (.715). The Sun Devils finished 3-9 in 2022.<br></p><p>Here's the rest of the offers since December 6:<br></p><p>Yuma Catholic quarterback Richard Stallworth received offers from Carroll Univ. (Wisc.) and McPherson (Kans.).<br>Dobson safety Jashawn Kinney received an offer from McPherson.<br>Peoria safety Saieed Hasan received offers from Judson (Ill.) and Western New Mexico.<br>Horizon quarterback Roman Funk received an offer from McPherson.<br>Desert Mountain defensive end Nolan Clement received offers from Bryant (R.I.), Georgetown, and UC Davis.<br>Moon Valley defensive tackle Elijah Lynn received his first offer from McPherson.<br>Moon Valley defensive tackle Sydney Lane received offers from Wisconsin-River Falls, Nebraska Wesleyan, Concordia College (Minn.), and Lake Forest (Ill.).<br>Marana Mountain View offensive guard Lucas Crawford received an offer from Doane (Neb.).<br>Marana Mountain View quarterback Josh Roman received an offer from Sterling (Kans.).<br>Centennial center Anthony Chacon received an offer from Lake Forest.<br>Prescott running back Cody Leopold received his first offer from Lake Forest.<br>Hamilton long snapper Alex Jacobo received offers from Benedictine Univ. (Ill.) and Rocky Mountain (Mont.).<br>Yuma Catholic defensive tackle Lorenzo Duran received his first offer from Concordia Univ. (Wisc.).<br>Shadow Ridge running back Anthony Garcia received an offer from Carroll Univ. (Wisc.).<br>Canyon del Oro running back Jordan Thomas received his first offers from Lake Forst and Fort Lewis (Colo.).<br>Desert Edge defensive tackle Esaias Swindle received an offer from McPherson.<br>Millennium defensive end Jax Adair received his first offer from Ottawa.<br>Gilbert linebacker Cooper Zellner received offers from Linfield (Ore.) and Arizona Christian.<br>Millennium linebacker Daniel Delponte received an offer from Ottawa.<br>Eastmark wide receiver Alex Campos received an offer from Puget Sound (Wash.).<br>Yuma Catholic linebacker Jarred Marquez received an offer from Lake Forest.<br>Millennium wide receiver Kyan Fields received offers from Ottawa and Benedictine College (Kans.).<br>Sunrise Mountain wide receiver Braden Harvey received his first offer from Puget Sound.<br>Highland defensive end Cooper Scott received his first offer from Black Hills State (S. Dak.).<br>Hamilton kicker Matthew Swink received offers from Carroll Univ. (Wisc.) and Rocky Mountain.<br>Buckeye running back Viliami Tongotea received offers from Southwestern College (Kans.) and Ripon (Wisc.).<br>Saguaro defensive end Magnum West recevied an offer from Southwestern Minnesota State.<br>Peoria quarterback Joshua Holiday received an offer from Puget Sound.<br>Mesa wide receiver Tre Brown received an offer from Rocky Mountain.<br>San Tan Charter tight end Logan Gentry received his first offers from Rocky Mountain and Arizona Christian.<br>ALA-West Foothills center Jaron Winters received offers from Presentation (S. Dak.) and Culver-Stockton (Mo.).<br>Basha offensive lineman Jack Johnson received an offer from Luther (Iowa).<br>Carl Hayden linebacker Pablo Castillo Jr. received his first offer from Crown (Minn.).<br>Highland cornerback Ezekiel Nautu received an offer from Pacific (Ore.).<br>Saguaro offensive guard William Garrett received an offer from Concordia College (Minn.).<br>Sunnyslope defensive end Preston Mosher received offers from Wabash (Ind.) and Lake Forest.<br>Apollo linebacker Brodie Chicharello received his first offer from Carthage (Wisc.).<br>Coolidge cornerback Belclem Namegabe received offers from Ottawa and Fort Lewis.<br>Florence offensive tackle Wrangler Guilliams received an offer from Lake Forest.<br>Moon Valley cornerback Jose Chavez received his first offer from Carthage.<br>Marcos de Niza wide receiver Clinton Hopkins received an offer from Crown.<br>Chaparral wide receiver Cody Judge received his first offer from Drake (Iowa).<br>Valley Christian wide receiver Ethan Heinrich received an offer from Graceland (Iowa).<br>Buckeye running back David Fresneda received an offer from Lawrence (Wisc.).<br>Desert Vista offensive guard Carson Routhier received an offer from Rocky Mountain.<br>Florence wide receiver Anthony Pistorio received his first offer from Lake Forest.<br>Valley Christian wide receiver Adam Bradford received an offer from Graceland.<br>Marcos de Niza offensive tackle Elian Ruiz received an offer from Crown.<br>Central offensive tackle Blas Guillen received his first offer from Arizona Christian.<br>Moon Valley linebacker Christopher Bryan received his first offer from Lake Forest.<br>Salpointe center Luis Arellano received an offer from Dakota Wesleyan (S. Dak.).<br>Gila Ridge wide receiver Brayden Faber received offers from Arizona Christian and Willamette (Ore.).<br>Corona del Sol long snapper Drew Nicolson received his first offer from Akron.<br>ALA-Ironwood quarterback Connor Mault received an offer from McPherson.<br>Mountain Pointe linebacker Jaxson Mack received an offer from McPherson.<br>Hamilton safety Michael Shinkle received an offer from Ottawa.<br>Camelback offensive tackle Ian Martinez Gomez received his first offer from Ottawa.<br>Liberty long snapper Tucker Allred received offers from Benedictine College (Kans.) and Lake Forest.<br>Sunnyslope running back Jackson Sriro received an offer from Ottawa.<br>Arizona College Prep center Marco Palafox received offers from Concordia Univ. (Wisc.) and Hastings (Neb.).<br>Cactus wide receiver Polo Banuelos received his first offer from Benedictine College (Kans.).<br>ALA-Gilbert North wide receiver Braeden Belanger received an offer from Concordia Univ. (Wisc.).<br>Sahuaro offensive guard Vincent Manata received his first offer from La Verne (Calif.).<br>Sunnyslope defensive tackle Matthew Kruger received an offer from Concordia College (Minn.).<br>Mountain Pointe cornerback Khalil Hayes received an offer from Lincoln (Calif.).<br>Chandler center Birdie Holloway received an offer from Black Hills State.<br>Arete Prep linebacker Aiden Wander received his first offer from Ottawa.<br>Mountain Ridge safety Lionell Clay received an offer from Jamestown (N. Dak.).<br>Valley Christian wide receiver Adam Bradford received an offer from Rocky Mountain.<br>Desert Edge cornerback Treshon Liddle received his first offer from McPherson.<br>Salpointe safety Mason Quitugua-Sanchez received an offer from McPherson.<br>Poston Butte defensive tackle Bobby Gaitan received his first offer from Ottawa.<br>Perry quarterback Jack Amer received an offer from Drake.<br>Camelback quarterback Max Martin received an offer from Benedictine College (Kans.).<br>Eastmark wide receiver Austin Johnston received his first offers from Drake and Fort Lewis.<br>Willow Canyon kicker Bryson Wilke received an offer from Rocky Mountain.<br>Basha offensive tackle Dylan Post received offers from Rocky Mountain and Lake Forest.<br>Brophy running back David Lopez received an offer from Ottawa.<br>Canyon del Oro cornerback Ethan Krominga received an offer from Nebraska Wesleyan.<br>Lake Havasu wide receiver Omare Feely received an offer from Finlandia (Mich.).<br>Hamilton offensive guard William Ralls received an offer from Rocky Mountain.<br>Lake Havasu linebacker Evan Smith received his first offers from Arizona Christian and Jamestown.<br>ALA-West Foothills defensive end Caleb Boonzaayer received an offer from Willamette.<br>Cactus Shadows running back Jaivan Swecker received his first offer from Ottawa.<br>Apollo safety Cedric Moore received his first offers from Finlandia and Carthage.<br>Cactus running back Damian Jiles received an offer from Benedictine College (Kans.).<br>Moon Valley cornerback Jose Chavez received an offer from Concordia Univ. (Wisc.).<br>ALA-Ironwood linebacker Travis Mbuya received an offer from Bluffton (Ohio).<br>Eastmark offensive tackle Jacob Trampp received an offer from Graceland.<br>Cienega wide receiver Keron Watson received offers from Adams State (Colo.) and Hastings.<br>Yuma Catholic offensive guard Seth Stoner received an offer from Concordia Univ. (Wisc.).<br>Catalina Foothills kicker Cole Revis received his first offer from Hastings.<br>San Manuel cornerback Ralphie Valencia received his first offer from Concorida Univ. (Wisc.).<br>Arizona College Prep quarterback Jayden Diaz received an offer from Hastings.<br>Red Mountain linebacker Caleb Heidrick received an offer from Mount Marty (S. Dak.).<br>Eastmark quarterback Mack Molander received his first offers from Eastern New Mexico and Lake Forest.<br>Higley wide receiver Dominic Esposito received an offer from Valparaiso (Ind.).<br>Desert Vista linebacker Antonio Delgado received offers from South Dakota School of Mines and Fort Lewis.<br>Highland safety Cole Crandall received his first offer from Benedictine College (Kans.).<br>Desert Edge offensive tackle Roman Carrasco received his first offers from Western New Mexico and Black Hills State.<br>Marcos de Niza wide receiver Jamaal Young received offers from Western New Mexico and Wasburn (Kans.).<br>Highland long snapper Thomas Lauira received his first offer from Rocky Mountain.<br>Basha linebacker Jackson Browning received an offer from Washburn.<br>Westwood wide receiver Nikita McCrimon received his first offer from Black Hills State.<br>Williams Field safety Isaac Anderson received offers from Lake Forest and Concordia Univ. (Wisc.).<br>Chandler safety Juma Kashanda received an offer from Rocky Mountain.<br>Basha linebacker Patrick Green received his first offer from South Dakota School of Mines.<br>Mountain Pointe linebacker Izaac Patterson received his first offer from Washburn.<br>Hamilton kicker Matthew Krneta received an offer from Rocky Mountain.<br>Skyline linebacker Christian Coltellaro received an offer from Crown.<br>Buckeye defensive end Brock Holt received an offer from Southwestern College (Kans.).<br>Cactus defensive tackle Jose Mora received an offer from Southwestern College (Kans.).<br>Basha defensive tackle Kaden Bancroft received an offer from Lake Forest.<br>Salpointe defensive end Damian Coley received an offer from Carthage.<br>Valley Vista wide receiver Mikel Henderson received his first offer from Westminster Coll. (Pa.).<br>Perry cornerback CJ Snowden received offers from Black Hills State, Fort Lewis, and Minot State (N. Dak.).<br>Centennial safety Jack Kaimipono Bal received an offer from Fort Lewis.<br>Kellis quarterback Darrien Campbell received his first offer from Fort Lewis.<br>Cesar Chavez cornerback Antwon Jenkins received an offer from Fort Lewis.<br>Cholla running back Malachi Eafon received his first offer from Culver-Stockton.<br>Highland safety Jace Nead received an offer from Fort Lewis.<br></p><p>This list shows four-year college offers received by seniors throughout the state. It's not limited to just 6A and 5A. It will be constantly updated as we approach the Early Signing Period from December 21-23. Those are the first days that high school seniors can sign a letter of intent to agree to attend an institution.</p><p>Verbal commitments are shown in bold.</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/mkcpstkaoq5c3duuwtbq&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/mkcpstkaoq5c3duuwtbq&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Red Mountain RB Lenox Lawson" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/mkcpstkaoq5c3duuwtbq" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Red Mountain RB Lenox Lawson</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p> <b>CLASS OF 2023 OFFERS</b></p><p>Jax Adair - Millennium (DE): Ottawa<br></p><p>Christian Aguilar - Mountain Ridge (LB): Butler, <b>DRAKE</b><br></p><p>Ryan Aguilar - Casteel (FS): Lewis &amp; Clark</p><p>Evan Aguirre - Youngker (WR): Arizona Christian, Luther, Wisconsin-River Falls<br></p><p>Brady Alfonso - Willow Canyon (OT): Crown, Ottawa<br></p><p>Cade Alisa - Poston Butte (OT): Arizona State, San Diego</p><p>Joseph Allen - Highland (SS): Arizona State (preferred walk-on)<br></p><p>Tucker Allred - Liberty (LS): Benedictine Coll. (Kans.), Carthage, Crown, Lake Forest, Lawrence, Ripon, St. Olaf, Wisconsin-River Falls</p><p>Jack Amer - Perry (QB): Augustana Univ. (S. Dak.),Drake, <b>SIOUX FALLS</b><br></p><p>Brendan Anderson - Mountain Ridge (QB): Drake, San Diego, <b>SOUTHERN UTAH</b>, St. Thomas, Yale</p><p>Isaac Anderson - Williams Field (SS): Carthage, Concordia Univ. (Wisc.), Jamestown, Knox, Lake Forest, Lawrence, Lewis &amp; Clark, Massachusetts Maritime, St. Olaf, Wisconsin-River Falls</p><p>Payden Anderson - Queen Creek (DE): Arizona Christian</p><p>Luis Arellano - Salpointe (C): Concordia Univ. (Wisc.), Dakota Wesleyan<br></p><p>Luke Arenas - Canyon del Oro (OG): Culver-Stockton<br></p><p>Coleson Arends - Pinnacle (TE): Arizona State, Black Hills State, Drake</p><p>Adrien Armstrong - Carl Hayden (WR): Arizona Christian</p><p>Christopher Arviso II - Mountain Pointe (QB): New Mexico State (preferred walk-on)<br></p><p>Strider Aston - Brophy (LB): Arizona Christian</p><p>CJ Ballard - Saguaro (OT): Arizona Christian, Knox, Lake Forest, St. Olaf, Wisconsin-River Falls</p><p>Kaden Bancroft - Basha (DT): Arizona Christian, Lake Forest, Ottawa</p><p>Polo Banuelos - Cactus (WR): Benedictine Coll. (Kans.)<br></p><p>Eli Barta - Mesa Mountain View (OG): Adams State, Central Coll. (Iowa), Concordia Coll. (Minn.), Fort Lewis, Lake Forest, Northern Arizona, Puget Sound, Wisconsin-River Falls</p><p>Kyle Bartnik - Perry (TE): Black Hills State, Drake, Ottawa<br></p><p>Matthew Bass - Chandler (OG): Adams State, Lake Forest, <b>WASHINGTON UNIV. (MO.)</b><br></p><p>Braeden Belanger - ALA-Gilbert North (WR): Concordia Coll. (Minn.), Concordia Univ. (Wisc.), Lake Forest, Puget Sound</p><p>Jorge Beltran - Cesar Chavez (QB): Crown<br></p><p>Ralph Bernard - Trevor Browne (DE): <b>COLGATE</b>, Northern Arizona</p><p>Nathan Bilski - Verrado (LB): Arizona Christian, Puget Sound<br></p><p>David Bird - O'Connor (LS): California</p><p>Jadiem Birthwright - Pinnacle (S): Lake Forest</p><p>Steven Bishopp - Sabino (K): Arizona Christian, Concordia Coll. (Minn.)<br></p><p>Matt Blau - ALA-Queen Creek (OG): Lake Forest</p><p>Jonathan Blohm - Horizon (OG): Knox<br></p><p>Ryan Blum - Basha (C): Air Force, <b>CENTRAL MICHIGAN</b>, Columbia, Georgetown, New Mexico State, Northern Arizona, Northern Colorado, San Diego</p><p>Rocco Bonini - Shadow Ridge (CB): Arizona Christian, Fort Lewis, Luther</p><p>William Bontrager - Estrella Foothills (RB): Clarke, Luther, Utah Tech (preferred walk-on)<br></p><p>Caleb Boonzaayer - ALA-West Foothills (DE): Grinnell, Kalamazoo, Rose-Hulman, Willamette<br></p><p>Caleb Botticello - Higley (DT): St. Norbert</p><p>Jackson Bowers - Mesa Mountain View (TE): Alabama, Arizona, Arizona State, Auburn, Baylor, <b>BYU</b>, California, Cincinnati, Colorado, Florida State, Georgia Tech, Louisville, LSU, Michigan State, Mississippi, Missouri, Nevada, Oregon, Oregon State, Texas, UNLV, USC, Utah, Washington, West Virginia, Yale</p><p>Adam Bradford - Valley Christian (WR): Dordt, Graceland, Rocky Mountain<br></p><p>Deyon Bradley - Moon Valley (RB): Arizona Christian</p><p>Andre Branch - Fairfax (RB): Ottawa<br></p><p>Sam Brown - Marana (WR): Jamestown, Lake Forest, Wisconsin-River Falls</p><p>Taye Brown - Hamilton (LB): Air Force, <b>ARIZONA</b>, Georgetown, Idaho, Idaho State, Kansas State, New Mexico State, Northern Arizona, San Diego State, South Dakota</p><p>Tre Brown - Mesa (WR): Adams State, Arizona Christian, Crown, Hastings, Northern State, Puget Sound, Rocky Mountain<br></p><p>Jackson Browning - Basha (LB): Adams State, Northern Arizona (preferred walk-on), Ottawa, Rocky Mountain, Washburn<br></p><p>Christopher Bryan - Moon Valley (LB): Lake Forest<br></p><p>Deshaun Buchanan - Basha (RB): Arizona, Grambling State, <b>IDAHO</b>, New Mexico State, Northern Arizona, Portland State, Utah Tech</p><p>Vincent Buckles - Chandler (WR): Lake Forest</p><p>Aidan Buggs - Casteel (OG): Arizona Christian, Clarke, Concordia Coll. (Minn.), Culver-Stockton, <b>JAMESTOWN</b>, Knox, Luther, Whittier</p><p>Jack Butler - Pusch Ridge (LB): Arizona Christian, Concordia Coll. (Minn.), Culver-Stockton, Gannon, Hastings, Jamestown, McPherson<br></p><p>John Butler - Saguaro (LB): Arizona, Arizona State (preferred walk-on), Idaho State, North Carolina Central, Northern Arizona</p><p>Carson Cagle - Campo Verde (OT): Presentation</p><p>Derek Calderon - Saguaro (LB): Arizona Christian, Luther</p><p>Enrique Calzada - ALA-Ironwood (CB): Clarke, Hastings<br></p><p>Blake Cameron - Dobson (CB): California Lutheran</p><p>Colton Campbell - Williams Field (OG): <b>SOUTHERN UTAH</b><br></p><p>Darrien Campbell - Kellis (QB): Western New Mexico<br></p><p>Alex Campos - Eastmark (WR): <b>LUTHER</b>, Ottawa (Kans.), Puget Sound<br></p><p>Andrue Cannon - St. Mary's (TE): Ottawa, Wisconsin-River Falls</p><p>Jake Carbajal - Corona del Sol (OG): <b>NORTHERN STATE</b><br></p><p>Jayden Carbajal - Sunnyslope (SS): Concordia Univ. (Wisc.)<br></p><p>Vicente Cardona - Douglas (RB): Arizona Christian, Clarke, Hastings</p><p>Roman Carrasco - Desert Edge (OT): Black Hills State, Western New Mexico<br></p><p>Tristan Carrera - Campo Verde (WR): Arizona Christian, Concordia Coll. (Minn.), Fort Lewis, Luther, Presentation</p><p>Ryan Carter - Willow Canyon (LS): Arizona Christian, Ottawa</p><p>Pablo Castillo Jr. - Carl Hayden (LB): Crown<br></p><p>Elijah Cazares - Arizona College Prep (TE): Beloit<br></p><p>Anthony Chacon - Centennial (C): Arizona Christian, Beloit, Knox, Lake Forest, Luther, Ottawa, St. Olaf, Westminster, Wisconsin-Oshkosh</p><p>Ethan Chamberlain - Marana Mountain View (RB): Crown<br></p><p>Diego Chavez - Bisbee (RB): Arizona Christian, Hastings</p><p>Jose Chavez - Moon Valley (CB): Carthage, Concordia Univ. (Wisc.)<br></p><p>Brodie Chicharello - Apollo (LB): Carthage<br></p><p>Silas Chicharello - Apollo (QB): Clarke, Concordia Univ. (Wisc.)<br></p><p>Roch Cholowsky - Hamilton (QB/P): New Mexico State, Notre Dame<br></p><p>Mason Chorak - Saguaro (OT): Idaho, Idaho State, Northern Colorado<br></p><p>Lance Christensen - Snowflake (SS): Knox<br></p><p>Omar Cisneros - Boulder Creek (CB): Fort Lewis<br></p><p>Kavaughn Clark - Centennial (RB): Nevada, Northern Arizona</p><p>Lionell Clay - Mountain Ridge (SS): Crown, Jamestown<br></p><p>Nolan Clement - Desert Mountain (DE): Arizona (preferred walk-on), Arizona State (preferred walk-on), Bryant, Georgetown, Idaho State, Lehigh, Navy, Nevada, New Mexico, Northern Arizona, Northern Iowa, St. Thomas (Minn.), UC Davis, Utah Tech, Weber State<br></p><p>Damian Coley - Salpointe (DE): Arizona Christian, Carthage, Clarke, Concordia Coll. (Minn.)</p><p>Christian Coltellaro - Skyline (LB): Crown<br></p><p>Jacob Condie - Desert Ridge (WR): Drake, Wisconsin-River Falls</p><p>Quintin Conley - Central (WR): Ottawa<br></p><p>Daniel Contreras - River Valley (OG): Arizona Christian, Wisconsin-River Falls</p><p>Zachary Cook - Cesar Chavez (OL): Arizona Christian, Hastings, Western New Mexico</p><p>Vance Cooper - Paradise Honors (RB): Bellarmine, Buena Vista, Clarke, Concordia Coll. (Minn.), Concordia Univ. (Wisc.), Crown, Denison, Graceland, Knox, Presentation, St. Olaf, Whittier<br></p><p>Zaccheus Cooper - Saguaro (RB): Alcorn State, Army, Idaho State, Montana State, Morgan State, New Mexico, Utah Tech</p><p>Christopher Cordero - Desert Edge (RB): Arizona Christian, Gannon, Westminster Coll. (Pa.), Wisconsin-River Falls</p><p>David Cordova II - Sabino (RB): Concordia Univ. (Wisc.), Cornell Coll. (Iowa), Fitchburg State, Geneva, Puget Sound<br></p><p>Peyton Cornwell - Casteel (OG): Lewis &amp; Clark</p><p>Michael Cosentino - Empire (DE): Grinnell<br></p><p>Shannon Coulter - Saguaro (WR): Arizona Christian, Wisconsin-River Falls</p><p>Bryton Cox - Williams (C): Ottawa</p><p>Cole Crandall - Highland (FS): Benedictine Coll. (Kans.)<br></p><p>Lucas Crawford - Marana Mountain View (OG): Clarke, Culver-Stockton, Doane, Lake Forest</p><p>Carter Crispin - Red Mountain (QB): Kalamazoo<br></p><p>Ben Currence - O'Connor (WR): Mary, <b>NORTHERN ARIZONA (PREFERRED WALK-ON)</b><br></p><p>Myseth Currie - Cesar Chavez (WR): Arizona Christian, Eastern New Mexico, <b>NORTHERN ARIZONA</b></p><p>Stephon Daily - Sierra Linda (WR): Army, <b>COLORADO STATE</b>, Hawaii, Nevada, Northern Arizona, Washington State</p><p>Anthony Dalisay - Mohave (DB): <b>CARTHAGE</b><br></p><p>Adam Damante - ALA-Gilbert North (QB): <b>NORTHERN ARIZONA</b></p><p>Devon Dampier - Saguaro (QB): Air Force, Alcorn State, Arizona, Army, Eastern Washington, Idaho, Idaho State, Navy, Nevada, <b>NEW MEXICO</b>, Northern Arizona, Northern Colorado, Pennsylvania, Rice, South Dakota, UTEP, Yale</p><p>Chandler Davis - Hamilton (DE): Idaho State, Northern Arizona</p><p>Ryan Davis - O'Connor (DE): Boise State, Idaho State, <b>KANSAS STATE</b>, Montana State, Nevada, North Dakota, Northern Arizona, Oregon State, San Diego State, South Dakota, Washington State</p><p>Saxon Davison - Mountain Ridge (LB): St. Norbert</p><p>Antonio Delgado - Desert Vista (LB): Arizona Christian, Black Hills State, Fort Lewis, Graceland, Lake Forest, Lewis &amp; Clark, South Dakota School of Mines, Southwest Baptist, Wisconsin-River Falls</p><p>Michael Delligatti - Dobson (LB): McPherson<br></p><p>Daniel Delponte - Millennium (LB): Arizona Christian, Crown, Ottawa<br></p><p>Jayden Diaz - Arizona College Prep (QB): Beloit, Central Coll. (Iowa), Concordia Coll. (Minn.), Hastings, Jamestown, Knox, Lake Forest, Presentation, Simpson, St. Norbert, Wisconsin-River Falls</p><p>Tysson Donnell - Cesar Chavez (DT): Arizona Christian</p><p>Alex Doost - Mountain Ridge (OT): Arizona, Arizona State, BYU, California, Colorado, Colorado State, Indiana, Massachusetts, Michigan State, Nevada, Northern Arizona, <b>NORTHWESTERN</b>, Oregon State, San Diego State, Utah, Utah State, Washington, Washington State, West Virginia</p><p>Dameon Draper - Millennium (SS): Arizona Christian</p><p>David Drinen - Saguaro (CB): Luther, Wisconsin-River Falls</p><p>Layton Duncan - Brophy (WR): Arizona State (preferred walk-on), Idaho State, Montana State, Morgan State, Nevada, North Dakota, Northern Arizona, Northern Colorado</p><p>Lorenzo Duran - Yuma Catholic (DT): Concordia Univ. (Wisc.)<br></p><p>James Durand - Basha (OG): Arizona, BYU, California, Colorado, Harvard, Indiana, Iowa State, New Mexico, New Mexico State, Oregon State, Pennsylvania, Princeton, San Diego State, Utah, Utah State, <b>WISCONSIN</b>, Yale</p><p>AJ Dutchover - Highland (OG): Concordia Coll. (Minn.), Fort Lewis, Grinnell, <b>SOUTHERN UTAH</b>, Wisconsin-River Falls</p><p>Josh Dweh - Trevor Browne (DT): Ottawa<br></p><p>Joshua Dye - Williams Field (RB): Northern Arizona</p><p>Josiah Dye - Williams Field (CB): Air Force, Army, New Mexico, North Dakota, Northern Arizona, Southern Utah, Utah State</p><p>Malachi Eafon - Cholla (RB): Culver-Stockton<br></p><p>Lashown Ealim - Chandler (OG): Arizona Christian, Black Hills State, Luther</p><p>Keire Earl - Basha (CB): Arizona Christian, Culver-Stockton<br></p><p>Emyson Edmonds - Hamilton (CB): Presentation, Wisconsin-River Falls</p><p>Tanner Emery - Safford (OT): <b>SOUTHERN UTAH</b><br></p><p>Jack Endean - Tanque Verde (OT): Arizona, California, <b>OKLAHOMA STATE</b></p><p>Deric English - Saguaro (WR): Arizona, Arizona State, Colorado State, Florida State, Louisville, Michigan State, Missouri, Morgan State, Northern Arizona, Oregon, Utah, Washington</p><p>Charles Ennis Jr. - Chandler (RB): Arizona Christian, Wisconsin-River Falls</p><p>Sean Esparza - Boulder Creek (OG): Central Coll. (Iowa), Concordia Coll. (Minn.), Puget Sound</p><p>Ethan Espinosa - Valley Vista (WR): Graceland, Knox<br></p><p>Elijah Espinoza - McClintock (CB): Arizona Christian</p><p>Valentine Espinoza - Casa Grande (C): Presentation</p><p>Dominic Esposito - Higley (WR): Central Coll. (Iowa), Lake Forest, Valparaiso, Wisconsin-River Falls</p><p>Moses Everest - Carl Hayden (DE): Arizona Christian, Crown</p><p>Brayden Faber - Gila Ridge (WR): Arizona Christian, Dean, Finlandia, Willamette<br></p><p>Trey Fanene - Corona del Sol (OT): Arizona Christian, Lewis &amp; Clark, Puget Sound<br></p><p>Chris Fasano - Mesquite (WR): Luther</p><p>Omare Feely - Lake Havasu (WR): Arizona Christian, Finlandia<br></p><p>Gage Felix - Salpointe (WR): Hastings</p><p>Brady Ferris - Willow Canyon (RB): Jamestown, Lake Forest</p><p>Dane Fidler - Apache Junction (CB): Knox, Lake Forest, McPherson, Tabor, Villanova (preferred walk-on)</p><p>Charlie Fiedler - Sunnyslope (WR): <b>LAKE FOREST</b><br></p><p>Kyan Fields - Millennium (WR): Benedictine Coll. (Kans.), Ottawa, Taylor<br></p><p>Jasiah Flores - Shadow Ridge (DT): Arizona Christian</p><p>Jonah Flowers - Valley Vista (LB): Ottawa</p><p>Xander Flowers - Lake Havasu (C): Ottawa<br></p><p>Kolten Ford - Queen Creek (K): Centenary</p><p>Aaron Francis - Central (LB): Arizona Christian, Lewis &amp; Clark, Ottawa<br></p><p>Shea Freibaum - Saguaro (LS): Marshall, <b>OKLAHOMA STATE</b>, Oregon, Oregon State, San Jose State</p><p>David Fresneda - Buckeye (RB): Arizona Christian, Lawrence, Lewis &amp; Clark</p><p>Ethan Fritz - Basha (OT): Wisconsin-River Falls</p><p>Roman Funk - Horizon (QB): Concordia Univ. (Wisc.)., Hendrix, Knox, McPherson, Ottawa (Kans.), Rose-Hulman, Southwestern Coll. (Kans.)</p><p>Bobby Gaitan - Poston Butte (DT): Ottawa<br></p><p>David Galindo - St. Mary's (LB): Jamestown</p><p>Will Galvan - Cactus (ATH): Arizona Christian, Benedictine Coll. (Kans.), Jamestown</p><p>Anthony Garcia - Shadow Ridge (RB): Arizona Christian, Carroll Univ. (Wisc.)</p><p>Juan Pablo Garcia - Douglas (DE): <b>ARIZONA CHRISTIAN</b><br></p><p>Brysen Gardner - Centennial (K): Lake Forest, Ottawa, Presentation, Ripon, Wisconsin-River Falls</p><p>My'Keil Gardner - Liberty (DE): Arizona, Arizona State, California, Colorado, Colorado State, Fresno State, Iowa, Iowa State, Michigan, Nebraska, Nevada, Northern Arizona, <b>OREGON</b>, Oregon State, San Diego State, Texas, UCLA, USC, Utah State, Washington State, Wisconsin</p><p>William Garrett - Saguaro (OG): Adams State, Arizona Christian, Bethel Univ. (Minn.), Concordia Coll. (Minn.), Knox, Lake Forest, Presentation, St. Olaf, Wisconsin-River Falls</p><p>Mekhi Gaskin - Sunnyside (FS): Doane</p><p>Luis Gastelum-Contreras - Brophy (OT): Clarke, Hastings, Jamestown, Luther</p><p>Logan Gentry - San Tan Charter (TE): Arizona Christian, Rocky Mountain<br></p><p>Logan Getejanc - Shadow Ridge (OG): Arizona Christian, Concordia Coll. (Minn.), Crown, Fort Lewis, Graceland, Lake Forest, Ottawa, Saint John's (Minn.), Wisconsin-River Falls</p><p>Gavin Geweniger - Chaparral (DE): Air Force, Arizona, Boise State, Colorado, Colorado State, Iowa State, Kansas State, Nevada, Northwestern, Oregon, Oregon State, San Diego State, <b>STANFORD</b>, UNLV, Washington, Washington State</p><p>Connor Gingg - Verrado (LB): Arizona Christian</p><p>Austin Glimpse - Sunrise Mountain (QB): Grinnell, Rose-Hulman, Rensselaer Polytechnic Institute, <b>SOUTH DAKOTA SCHOOL OF MINES</b>, Washington Univ. (Mo.), Wesleyan, Wisconsin-River Falls</p><p>Mekhi Godlove - Tolleson (OG): Arizona Christian</p><p>Nate Godoy - Thunderbird (FS): Bethany Coll. (Kans.), Willamette<br></p><p>Nate Gomez - Campo Verde (CB): Central Coll. (Iowa), Dordt, Knox, Lewis &amp; Clark, Luther, Presentation, St. Norbert</p><p>Rudy Gonzales - Cactus (QB): Graceland<br></p><p>Dailan Goodman - Salpointe (RB): Arizona Christian, Culver-Stockton, Hastings, Presentation</p><p>Max Grady - Desert Vista (CB): Arizona Christian</p><p>Abraham Grajeda - Pusch Ridge (RB): George Fox</p><p>Patrick Green - Basha (LB): South Dakota School of Mines<br></p><p>CJ Greer - Trevor Browne (RB): Arizona Christian, Ottawa<br></p><p>Carlos Griffin - Saguaro (CB): <b>ARMY</b>, Syracuse</p><p>Rodrigo Guerrero - Trevor Browne (C): Willamette</p><p>Blas Guillen - Central (OT): Arizona Christian<br></p><p>Wrangler Guilliams - Florence (OT): Lake Forest, Ottawa<br></p><p>Austin Hall - Sunrise Mountain (LS): Crown<br></p><p>Terrance Hall - Mountain Ridge (WR): Morgan State</p><p>Landon Halle - Cienega (C): Arizona Christian<br></p><p>Daunte Hamblin - Chandler (RB): Luther</p><p>Donnovan Hamblin - Chandler (LB): Knox, Luther</p><p>Carter Hancock - Higley (WR): Air Force, Columbia, Michigan (preferred walk-on)</p><p>Dominic Hanger - Chandler (LB): Adams State, Augustana Univ. (S. Dak.)</p><p>Braden Harvey - Sunrise Mountain (WR): Puget Sound<br></p><p>Saieed Hasan - Peoria (SS): Judson, McPherson, Western New Mexico, Wisconsin-River Falls<br></p><p>Drayson Hatch - ALA-Queen Creek (K): Arizona Christian, Lake Forest</p><p>Khalil Hayes - Mountain Pointe (CB): Arizona Christian, Lincoln, McPherson, Wisconsin-River Falls</p><p>Jaxon Haynes - Hamilton (WR): <b>AUGUSTANA UNIV. (S.DAK.)</b>, Drake, Lake Forest, Northern State, South Dakota School of Mines, Wisconsin-River Falls</p><p>Hunter Heeringa - Valley Christian (QB): Northwestern Coll. (Iowa)<br></p><p>Kaleb Hefner - Canyon View (OT): Arizona Christian, Luther</p><p>Caleb Heidrick - Red Mountain (LB): Culver-Stockton, Knox, Lawrence, Luther, Mount Marty<br></p><p>Harrison Heimuli - Highland (LB): Concordia Coll. (Minn.)<br></p><p>Ethan Heinrich - Valley Christian (WR): Cal Lutheran, Concordia Coll. (Minn.), Dordt, Graceland, Northwestern Coll. (Iowa), Ottawa</p><p>Mikel Henderson - Valley Vista (WR): Westminster Coll. (Pa.)<br></p><p>Vernon Henderson - Paradise Honors (DE): Fontbonne<br></p><p>Liam Henry - Estrella Foothills (RB): Arizona Christian, Lewis &amp; Clark, <b>LUTHER</b></p><p>Aiden Herring - Perry (DE): <b>AIR FORCE</b>, Army, Colgate, Columbia, Idaho, Idaho State, Lehigh, Montana, Nevada, North Dakota, Northern Arizona, Yale</p><p>David Hicks - Queen Creek (WR): Arizona Christian, Concordia Coll. (Minn.), Lake Forest, Lewis &amp; Clark, St. Norbert</p><p>Brennen Hills - Casteel (RB): Arizona Christian, Clarke, Concordia Coll. (Minn.), Gustavus Adolphus, Jamestown, Lawrence, Luther, Knox, Nebraska Wesleyan, Presentation, Ripon</p><p>Jake Hilton - Prescott (WR): Concordia Univ. (Wisc.), Luther, Simpson, <b>WISCONSIN-RIVER FALLS</b><br></p><p>Jake Hoel - Arizona College Prep (WR): Arizona Christian, Jamestown, Knox, Lake Forest, Luther, Ottawa, Rose-Hulman<br></p><p>Gavin Hogencamp - River Valley (QB): Arizona Christian, Graceland, Hastings<br></p><p>Joshua Holiday - Peoria (QB): Crown, Lawrence, Luther, Puget Sound<br></p><p>Birdie Holloway - Chandler (C): Black Hills State, Luther</p><p>Brock Holt - Buckeye (DE): Arizona Christian, Southwestern Coll. (Kans.)<br></p><p>Clinton Hopkins - Marcos de Niza (WR): Crown, Presentation<br></p><p>Jase Hudson - Campo Verde (K): Crown, Luther</p><p>Clayton Hughes - Campo Verde (DT): Arizona Christian, Crown, Knox, Luther, Ripon, St. Norbert, Whittier<br></p><p>Jaden Humphrey - Desert Vista (DE): Arizona Christian</p><p>Kaleb Jackson Carter - Desert Edge (OT): Hawaii, Idaho, Idaho State, Montana, Montana State, New Mexico State, Northern Arizona, Northern Colorado, Northern Iowa, San Diego State</p><p>Alex Jacobo - Hamilton (LS): Arizona Christian, Benedictine Univ. (Ill.), Carthage, Culver-Stockton, Ottawa, Rocky Mountain<br></p><p>Jesus Jacobo - Tolleson (OL): Arizona Christian<br></p><p>Logan James - Wickenburg (QB): <b>MONTANA STATE-NORTHERN</b><br></p><p>Antwon Jenkins - Cesar Chavez (CB): Arizona Christian, Concordia Coll. (Minn.), Crown, Eastern New Mexico, Fort Lewis, Ottawa, Rocky Mountain, St. Norbert, Western New Mexico</p><p>Mitch Jensen - ALA-Queen Creek (RB/LB): Colorado School of Mines, Northern State</p><p>Bryce Jewell - Pusch Ridge (CB): Rose-Hulman, Southwestern Univ. (Tex.)<br></p><p>Dominic Jewell - Willow Canyon (LB): Arizona Christian, Lake Forest, Presentation</p><p>Damian Jiles - Cactus (RB): Arizona Christian, Benedictine Coll. (Kans.), Montana Tech, Wisconsin-River Falls</p><p>Amare Johnson - Casteel (CB): Concordia Coll. (Minn.)</p><p>Grant Johnson - Casa Grande (DE): Arizona Christian, Clarke, Presbyterian, Presentation</p><p>Isaac Johnson - Casa Grande (WR): Culver-Stockton</p><p>Jack Johnson - Basha (OL): Luther, Whittier<br></p><p>Jaylen Johnson - Mountain Pointe (WR): Bethany Coll. (Kans.), Graceland<br></p><p>Korey Johnson - Mountain Ridge (CB): Colorado School of Mines, Lake Forest, Sioux Falls, South Dakota School of Mines, St. Thomas, Utah Tech</p><p>Mark Johnson - Paradise Honors (K): Puget Sound, Wooster<br></p><p>Micah Johnson - Sunrise Mountain (WR): Grambling State, Montana, Northern Arizona, Northern Colorado, San Jose State</p><p>Zacary Johnson - Centennial (OT): Lake Forest, Norwich</p><p>Austin Johnston - Eastmark (WR): Drake, Fort Lewis<br></p><p>Marcus Jones - Marcos de Niza (LB): Mayville State, McPherson<br></p><p>Elijah Joplin - Marana (QB): Arizona Christian, Jamestown</p><p>Cody Judge - Chaparral (WR): Drake<br></p><p>Braeden Kaczmarek - Red Mountain (DE): Air Force, Idaho State, <b>NORTHERN ARIZONA</b><br></p><p>Jack Kaimipono Bal - Centennial (FS): Fort Lewis, Tuskegee<br></p><p>Ashton Kamp - Northwestern Christian (QB): Crown, Lewis &amp; Clark </p><p>Sirri Kandiyeli - Mesa Mountain View (OT): Air Force, <b>ARIZONA STATE</b>, Army, Cornell, Eastern Washington, Harvard, Idaho State, Lehigh, Montana, New Mexico State, Northern Arizona, Pennsylvania, Princeton, South Dakota, Weber State</p><p>Juma Kashanda - Chandler (SS): Arizona Christian, Concordia Coll. (Minn.), Fort Lewis, Lake Forest, Ottawa, Rocky Mountain, Taylor, Westminster (Pa.), Wisconsin-River Falls</p><p>Carston Kieffer - Corona del Sol (K): Arizona State, Tulane (preferred walk-on)<br></p><p>Jashawn Kinney - Dobson (SS): Greenville, McPherson<br></p><p>Jason Kirkland - Mountain Ridge (DE): Brown, Butler, Colorado School of Mines, <b>CORNELL</b>, Morehead State, Rose-Hulman, San Diego, Sioux Falls, South Dakota School of Mines, St. Thomas (Minn.), Valparaiso</p><p>Drew Klingman - Pusch Ridge (LB): Arizona Christian</p><p>Matthew Klopfenstein - Horizon (TE): Arizona, Arizona State, <b>BAYLOR</b>, Buffalo, California, Colorado, Houston, Indiana, Iowa State, Kansas, Louisville, Massachusetts, Michigan, Michigan State, Nevada, Oregon State, Pittsburgh, San Diego State, Tennessee, Utah State, Washington, Washington State, West Virginia, Wisconsin</p><p>Salehe Koonooka - Centennial (DE): Arizona Christian, Taylor, Wisconsin-River Falls</p><p>Dallas Kroh - Marana Mountain View (C): Knox, Puget Sound</p><p>Matthew Krneta - Hamilton (K): Arizona Christian, Rocky Mountain<br></p><p>Ethan Krominga - Canyon del Oro (CB): Arizona Christian, Concordia Coll. (Minn.), Concordia Univ. (Wisc.), Hastings, Knox, Lake Forest, Nebraska Wesleyan, St. Norbert</p><p>Asher Kroschel - Hamilton (FS): Presentation, Wisconsin-River Falls<br></p><p>Matthew Kruger - Sunnyslope (DT): Arizona Christian, Concordia Coll. (Minn.), Culver-Stockton, Graceland<br></p><p>Jonathan Kubat - Corona del Sol (RB): Arizona Christian</p><p>Cole Lalama - Queen Creek (LB): Arizona Christian, Black Hills State<br></p><p>Dionte Lamaide - Saguaro (DE): Idaho</p><p>Cole Lancaster - Gila Ridge (TE): Graceland<br></p><p>Ethan Lane - Basha (QB): Lake Forest, Luther, Ottawa, Rocky Mountain<br></p><p>Ja'Kobi Lane - Red Mountain (WR): Arizona, Arizona State, Auburn, Colorado, Colorado State, Fresno State, Hawaii, Iowa State, Kansas State, Massachusetts, Nevada, Northern Arizona, Northern Iowa, Oregon, San Jose State, Texas, Texas A&amp;M, <b>USC</b>, Utah</p><p>Sydney Lane - Moon Valley (DT): Arizona Christian, Concordia Coll. (Minn.), Concordia Univ. (Wisc.), John Melvin, Lake Forest, Lewis &amp; Clark, Nebraska Wesleyan, Willamette, Wisconsin-River Falls<br></p><p>Zurian Lapsley - Glendale (LB/RB): Eastern Washington, Sioux Falls, Southern Utah, St. Norbert</p><p>Trey Largo - Mesquite (CB): Luther</p><p>Filemani Lauina - Shadow Ridge (LB): Arizona Christian</p><p>Thomas Lauria - Highland (LS): Rocky Mountain<br></p><p>Sire LaVallee - Mesquite (SS): Lewis &amp; Clark, Luther</p><p>Lenox Lawson - Red Mountain (WR): Arizona State, Central Michigan, Idaho State, Montana State, New Mexico State, North Dakota, Northern Colorado, Northern Iowa, South Dakota State, Southern Utah, Washington State</p><p>Cooper LeDuc - Hamilton (CB): Albion, Butler, Lake Forest, New Mexico State, Sioux Falls, <b>SOUTHERN UTAH</b>, St. Norbert</p><p>Cody Leopold - Prescott (RB): Lake Forest<br></p><p>Jordan Legg - Dobson (QB/K): Lawrence<br></p><p>Na'Jai Lewis - Desert Edge (OT): Arizona Christian, Hastings</p><p>PJ Lewis - St. Mary's (FS): Lewis &amp; Clark</p><p>Myles Libman - Pinnacle (WR): Air Force, Arizona, Arizona State, Columbia, Dartmouth, Georgetown, Idaho, Idaho State, Lehigh, Montana State, Northern Arizona, Northern Colorado, Pennsylvania, Portland State, Princeton, Utah Tech</p><p>Treshon Liddle - Desert Edge (CB): McPherson<br></p><p>Gavin Limongello - Apache Junction (QB): Knox, Lake Forest</p><p>Cole Linyard - Horizon (WR): Jamestown</p><p>Noah Locke - Paradise Honors (LB): Rose-Hulman</p><p>Caleb Lomu - Highland (OT): Arizona, Arizona State, Auburn, BYU, California, Colorado, Florida, Indiana, Michigan, Mississippi, Missouri, Nevada, Northern Arizona, Oregon, Oregon State, San Diego State, Tennessee, UCLA, UNLV, USC, <b>UTAH</b>, Utah State, Washington, Washington State</p><p>David Lopez - Brophy (RB): Arizona Christian, Clarke, Jamestown, Ottawa<br></p><p>Aaron Loughran - Hamilton (LB): Albion, Presentation, Wisconsin-River Falls</p><p>James Lujan Jr. - Williams Field (OT): Concordia Coll. (Minn.), Knox, Lewis &amp; Clark</p><p>Luke Luna - Casa Grande (DT): Clarke, Concordia Univ. (Wisc.), Knox</p><p>Michael Luna - Sequoia Pathway (K): Crown</p><p>Elijah Lynn - Moon Valley (DT): McPherson<br></p><p>Jaxson Mack - Mountain Pointe (LB): Arizona Christian, McPherson<br></p><p>Joshua Macon - Willow Canyon (DT): Anna Maria, Arizona Christian, Culver-Stockton, Graceland, Whittier<br></p><p>Sean Madrid - Salpointe (LB): Arizona Christian, Clarke, Concordia Univ. (Wisc.), Dakota Wesleyan, Knox, McPherson, Presentation, Ripon, St. Norbert</p><p>Vincent Manta - Sahuaro (OG): La Verne<br></p><p>Vinny Mansfield - Desert Edge (WR): Gannon, Wisconsin-River Falls</p><p>Braxton Manusina - Centennial (LS): McPherson, Ottawa<br></p><p>Nathan Manzanarez - Desert Edge (FS): Southern Utah (preferred walk-on)<br></p><p>Gage Maras - Boulder Creek (C): Arizona Christian, Concordia Coll. (Minn.), Fort Lewis, Keiser, Puget Sound, Southwestern Coll. (Kans.)<br></p><p>Ignacio Marquez - St. Mary's (OT): Jamestown, Knox, Lewis &amp; Clark, Ottawa</p><p>Jarred Marquez - Yuma Catholic (LB): Arizona Christian, Lake Forest, Ottawa, Westminster Coll. (Pa.)<br></p><p>Cole Marszalek - Millennium (LS): Arizona Christian, <b>TEXAS STATE</b><br></p><p>Cole Martin - Basha (CB): Alabama, Arizona, Arizona State, Arkansas, California, Colorado, Duke, Florida, Florida Atlantic, Florida State, Georgia, Idaho, Iowa State, Kansas, Louisville, LSU, Michigan State, Mississippi, Nebraska, Nevada, Northern Arizona, Notre Dame, <b>OREGON</b>, San Jose State, Stanford, Tennessee, Texas, Texas A&amp;M, UCLA, USC, Washington, West Virginia, Wisconsin</p><p>Max Martin - Camelback (QB): Arizona Christian, Benedictine Coll. (Kans.), Ottawa<br></p><p>Nicolas Martin - Chandler (OG): Adams State, Arizona Christian, Colorado Mesa, Concordia Coll. (Minn.), Graceland, Knox, <b>LAKE FOREST</b>, Presentation, St. Olaf, Wisconsin-River Falls</p><p>Ian Martinez Gomez - Camelback (OT): Ottawa<br></p><p>Juan Martinez - La Joya (DT): Arizona Christian<br></p><p>Philip Maschue - St. Mary's (OT) - Jamestown, Ottawa<br></p><p>Gianni Mascolino - Coolidge (QB): Washington</p><p>Kelton Mason - Mesa (WR): La Verne<br></p><p>Sean Mathews - Thunderbird (LB): Arizona Christian, Grinnell, Knox, Lewis &amp; Clark, McPherson, Presentation, Puget Sound, Rose-Hulman, Whittier</p><p>Connor Mault - ALA-Ironwood (QB): Clarke, McPherson<br></p><p>Dylan Maza - Marcos de Niza (WR): Presentation</p><p>Travis Mbuya - ALA-Ironwood (LB): Arizona Christian, Bluffton, Clarke, Hastings<br></p><p>Kaiden McCarty - Eastmark (FS): Ottawa</p><p>Nikita McCrimon - Westwood (WR): Black Hills State<br></p><p>Alex McLaughlin - Hamilton (LB): Air Force, Arizona, Army, Colorado, Idaho, Idaho State, Illinois State, Montana State, Navy, New Mexico State, Northern Arizona, Ohio, Southern Utah, St. Thomas, UNLV, Utah Tech, Washington State, Weber State, Western Illinois</p><p>Ryder McMillon - Liberty (CB): Arizona Christian<br></p><p>Joseph Mickelson - Sunnyslope (WR): Knox<br></p><p>Wyatt Milkovic - Basha (LB): Army, <b>BOISE STATE</b>, California, Colorado, Colorado State, Iowa State, Nevada, New Mexico, New Mexico State, Northern Arizona, Utah State</p><p>Clinton Moindi - Tolleson (WR): Arizona Christian</p><p>Mack Molander - Eastmark (QB): Eastern New Mexico, Lake Forest<br></p><p>Jager Monongye - Horizon (OT): Ottawa<br></p><p>George Monreal - Saguaro (DT): Luther</p><p>Aaron Monroe Jr. - Centennial (CB): Arizona Christian</p><p>Maddox Montoya - Mesquite (LB): Arizona Christian, <b>PUGET SOUND</b><br></p><p>Cedric Moore - Apollo (SS): Carthage, Finlandia<br></p><p>Jose Mora - Cactus (DT): Ottawa, Southwestern (Kans.)<br></p><p>Josh Morin - Heritage Academy Mesa (DE): Idaho State, <b>SOUTHERN UTAH</b><br></p><p>Majel Morones - Campo Verde (DE): Presentation</p><p>Preston Mosher - Sunnyslope (DE): Dordt, Knox, Lake Forest, Wabash<br></p><p>Hudson Muller - Horizon (LB): Knox, St. Norbert</p><p>Breck Mullins - Williams Field (LB): <b>SOUTHERN UTAH</b><br></p><p>Tyler Mustain - Pusch Ridge (LB): Idaho State, Northern Arizona</p><p>Alex Nabavi - Desert Mountain (LB): Ottawa<br></p><p>Belclem Namegabe - Coolidge (CB): Arizona Christian, Crown, Fort Lewis, Jamestown, Knox, Northern Arizona (preferred walk-on), Ottawa, Rocky Mountain, South Dakota School of Mines, Southern Utah (preferred walk-on)<br></p><p>Noah Narain - Gilbert (CB): Lewis &amp; Clark</p><p>Ezekiel Nautu - Highland (CB): Bowdoin, Grinnell, Pacific, Presentation, Wisconsin-River Falls</p><p>Jace Nead - Highland (FS): Concordia Coll. (Minn.), Fort Lewis, Knox, Lake Forest, Presentation, Southern Virginia, St. Norbert</p><p>Blaise Nelson - Valley Vista (WR): Arizona Christian, Lake Forest, North Dakota, <b>NORTHERN ARIZONA</b>, South Dakota School of Mines, St. Thomas (Minn.), Wisconsin-River Falls</p><p>Kyle Nelson - Heritage Academy Mesa (TE): Idaho State</p><p>Raquain Nichols - Fairfax (CB): Ottawa</p><p>Drew Nicolson - Corona del Sol (LS): Akron<br></p><p>Chris Nimcheski - Saguaro (WR): Colorado School of Mines, South Dakota School of Mines</p><p>Andereya Nsubuga Jr. - Chandler (CB): Portland State</p><p>Marc O'Bannon - Perry (OG): Arizona Christian, Northern State, Wisconsin-River Falls</p><p>Marcus Oberriter - Holbrook (QB): Quincy</p><p>Tyreeq-Styles Obichere (WR): Lake Forest<br></p><p>Adrian Oceguera - Mohave (DE): Whittier<br></p><p>Aidan Olsen - Chandler (CB): Wisconsin-River Falls</p><p>Matthew Orthmann - Corona del Sol (DE): Arizona Christian, Concordia Coll. (Minn.), Lake Forest, Lewis &amp; Clark, South Dakota School of Mines, Wisconsin-River Falls</p><p>Elijah Paige - Pinnacle (OT): Arizona, Arizona State, Auburn, Baylor, BYU, California, Cincinnati, Colorado, Colorado State, Duke, Indiana, Kansas, Miami (Fla.), Michigan, Michigan State, Mississippi, Missouri, Nebraska, Northwestern, Notre Dame, Oregon, Oregon State, Penn State, San Diego State, Stanford, Tennessee, UCLA, <b>USC</b>, Utah, Utah State, Washington, Washington State, West Virginia, Wisconsin</p><p>Marco Palafox - Arizona College Prep (C): Arizona Christian, Beloit, Concordia Univ. (Wisc.), Hastings, Jamestown, Lewis &amp; Clark, Knox, Luther, Ottawa, Presentation, Rose-Hulman, Simpson, St. Norbert</p><p>Cristian Pando - Willcox (RB): Arizona Christian, Clarke, Hastings, Knox<br></p><p>Gavin Parks - Desert Edge (WR): Presentation, Wisconsin-River Falls</p><p>Johnny Parrish - Chino Valley (RB): Luther</p><p>Izaac Patterson - Mountain Pointe (LB): Washburn<br></p><p>Keona Peat - Corona del Sol (OG): Fort Valley State, Johnson C. Smith, Lincoln (Calif.)</p><p>Sebastian Perez - Desert Vista (DE): Arizona Christian</p><p>Gavin Peterson - Cienega (WR): Calumet<br></p><p>Dylan Petrick - Tanque Verde (OT): Adams State</p><p>Anthony Pistorio - Florence (WR): Lake Forest<br></p><p>Vincent Plancarte - Mohave (LS): Beloit, Knox, St. Andrews, William Penn<br></p><p>Hunter Pletka - San Tan Charter (DE): Knox</p><p>Dylan Post - Basha (OT): Adams State, Arizona Christian, Black Hills State, Ellsworth, Lake Forest, Ottawa, Rocky Mountain<br></p><p>Demarion Postell - Tolleson (WR): Arizona Christian</p><p>Makua Pule - Highland (OT): Arizona (preferred walk-on), Arizona State (preferred walk-on)</p><p>Jake Purdy - River Valley (DE): <b>HASTINGS</b><br></p><p>Jaden Pyrah - Desert Edge (LB): Albion, Wisconsin-River Falls</p><p>Dion Quintana - Yuma Catholic (WR): Black Hills State, La Verne</p><p>Mason Quitugua-Sanchez - Salpointe (FS): Clarke, Concordia Univ. (Wisc.), McPherson, Puget Sound, Ripon, St. Norbert, Whittier</p><p>Conner Raetzman - Salpointe (LB): Minot State<br></p><p>William Ralls - Hamilton (OG): Drake, Presentation, Wisconsin-River Falls</p><p>Jacob Rasmussen - Thatcher (DE): Jamestown, Ottawa (Kans.)<br></p><p>Daniel Rea - Hamilton (OG): Presentation</p><p>Cornell Reed Jr. - Sequoia Pathway (WR): Crown</p><p>Cole Revis - Catalina Foothills (K): Hastings<br></p><p>Jacob Reynolds - Mountain Ridge (DE): Crown<br></p><p>Porter Reynolds - Queen Creek (LB): Colorado, Eastern Washington, Idaho State, <b>NORTHERN ARIZONA</b>, Washington State, Weber State</p><p>Travis Rich - Salpointe (K): Arizona Christian<br></p><p>Jose Rivera - Cesar Chavez (WR): Arizona Christian, Knox</p><p>Sylvestre Rivera - Fairfax (LB): Ottawa<br></p><p>Prince Roberson - Cesar Chavez (WR): Arizona Christian</p><p>Brett Roberts - Marana Mountain View (LB): Arizona Christian, Concordia Coll. (Minn.)<br></p><p>Dylan Roberts - Centennial (DT): Arizona, California, Colorado, Northern Arizona, <b>NORTHWESTERN</b>, Washington State</p><p>Levi Robins - Saguaro (CB): <b>COLUMBIA</b>, Michigan (preferred walk-on), Yale</p><p>Duce Robinson - Pinnacle (TE): Arizona, Arizona State, Arkansas, Clemson, Florida Atlantic, Florida State, Georgia, Iowa State, LSU, Michigan, Michigan State, Nevada, New Mexico, Notre Dame, Ohio State, Oklahoma, Oregon, Pittsburgh, San Jose State, Texas A&amp;M, UCLA, UNLV, USC, Utah, Washington</p><p>Izaac Robles - Mohave (WR): Whittier<br></p><p>Jayden Rogers - Mountain Ridge (P): Arizona Christian, <b>SOUTHERN UTAH</b><br></p><p>Zack Rogowski - Canyon del Oro (WR): Arizona Christian, Concordia Coll. (Minn.), Hastings</p><p>Josh Roman - Marana Mountain View (QB): Clarke, Concordia Coll. (Minn.), Lake Forest, Sterling<br></p><p>Jett Roufus - O'Connor (DE): Arizona Christian, Central Coll. (Iowa), Knox<br></p><p>Carson Routhier - Desert Vista (OG): Arizona Christian, Rocky Mountain<br></p><p>Jacobie Rucker - Pinnacle (RB): Lake Forest</p><p>Trevor Rudolph - Buena (OT): Hastings<br></p><p>Ty'ree Rudulph - Cesar Chavez (DE): Arizona Christian</p><p>Anthony Ruiz - Liberty (LB): Arizona State (preferred walk-on)<br></p><p>Elian Ruiz - Marcos de Niza (OT): Crown, Presentation, Wisconsin-River Falls</p><p>Jaylen Rushing - Mountain Pointe (RB): New Mexico State (preferred walk-on), Western Illinois<br></p><p>Landon Sabetta - Perry (OT): Luther, Wisconsin-River Falls</p><p>Jerron Salazar - Arizona College Prep (FS): Arizona Christian, Beloit, Knox, Luther, Presentation, St. Norbert</p><p>Oscar Saldana - Trevor Browne (OT): Ottawa</p><p>Xavier Sanchez - Millennium (FS): Taylor<br></p><p>Xavier Sanchez - Red Mountain (CB): Luther, Presentation</p><p>Jackson Sander - Higley (LB): Luther</p><p>Erick Santiago - Verrado (QB): Arizona Christian</p><p>Max Sawyer - Desert Edge (LB): Black Hills State<br></p><p>Sinjin Schmitt - Boulder Creek (RB): Air Force</p><p>Griffin Schureman - Queen Creek (OT): Arizona State (preferred walk-on)<br></p><p>Brayden Scott - Tanque Verde (LB): Carthage, Clarke</p><p>Cooper Scott - Highland (DE): Black Hills State<br></p><p>Dorae Scott - Basha (WR): New Mexico State</p><p>Ryker Scott - ALA-Queen Creek (DE): Knox<br></p><p>Sione Sekona - ALA-Queen Creek (OG): Lake Forest</p><p>Tristan Shafer - Corona del Sol (LB): Arizona Christian, Crown, Graceland, Lake Forest, Lewis &amp; Clark</p><p>Mason Shea - Campo Verde (WR): Knox, Luther</p><p>Michael Shinkle - Hamilton (FS): Arizona Christian, Ottawa, Presentation, Wisconsin-River Falls</p><p>Cole Shivers - Saguaro (CB): Arizona, Boise State, Buffalo, Colorado, Florida State, Fresno State, Iowa State, Kansas, Nevada, <b>NORTHWESTERN</b>, UNLV, Utah State, Washington State, Wisconsin</p><p>Will Short - Hamilton (LB): Presentation</p><p>JJ Silver - Queen Creek (RB): Arizona Christian, Eastern New Mexico, St. Norbert, Wisconsin-River Falls</p><p>Tyson Simmons - Basha (DE): Air Force, Colgate, <b>NAVY</b>, Nevada</p><p>Jibril Singhateh - Desert Mountain (OT): Lake Forest, Ottawa<br></p><p>Preston Slaton - Hamilton (TE): Air Force, New Mexico State, San Diego</p><p>Evan Smith - Lake Havasu (LB): Arizona Christian, Jamestown<br></p><p>Genesis Smith - Hamilton (FS): Air Force, <b>ARIZONA</b>, Arizona State, Army, Cal, Colorado State, Florida A&amp;M, Iowa State, New Mexico State, Northern Arizona, Ohio, Oregon State, Rice, San Diego State, Tulane, UNLV, Utah State, Washington, Washington State, Yale</p><p>Rovelle Smith - O'Connor (WR): Concordia Coll. (Minn.)</p><p>CJ Snowden - Perry (CB): Black Hills State, Fort Lewis, Minot State, South Dakota School of Mines, St. Norbert, Taylor<br></p><p>Dom Solano - Cactus (DE): Idaho State, Lake Forest, <b>MONTANA STATE</b><br></p><p>Samuel Sollars - Shadow Ridge (WR): Hastings<br></p><p>Fredo Sotelo - Salpointe (QB): Concordia Coll. (Minn.), Jamestown, Lake Forest, Puget Sound</p><p>Tre' Spivey - Hamilton (WR): Arizona, Arizona State, BYU, Colorado State, Kansas, Kansas State, Massachusetts, Nevada, New Mexico, New Mexico State, Northern Arizona, Oklahoma State, Portland State, San Diego State, UNLV, Utah State, Washington, Washington State, Wisconsin</p><p>Matt Spurlin - Willow Canyon (OG): Arizona Christian, Jamestown, Ottawa<br></p><p>Jackson Sriro - Sunnyslope (RB): Knox, Lake Forest, Ottawa, Presentation, Puget Sound</p><p>Hank Stabler - Paradise Honors (LB): Arizona Christian, Crown</p><p>Griffin Stalfort - Hamilton (C): <b>AIR FORCE</b>, New Mexico State</p><p>Richard Stallworth - Yuma Catholic (QB): Adams State, Arizona Christian, Carroll Univ. (Wisc.), Lake Forest, McPherson, Ottawa, Westminster<br></p><p>Briton Stanton - Williams Field (WR): Alma, Knox, Lewis &amp; Clark, Presentation</p><p>Derek Staples - Desert Vista (OG): Arizona Christian</p><p>Tanner Steffa - Casteel (DT): Concordia Coll. (Minn.), Lewis &amp; Clark, Wisconsin-River Falls</p><p>Biruk Stephens - Arizona College Prep (RB): Beloit, Crown, Knox, Lewis &amp; Clark, Luther</p><p>Seth Stoner - Yuma Catholic (OG): Carroll Univ. (Wisc.), Concordia Univ. (Wisc.), Knox, Westminster<br></p><p>Isaac Stopke - Lake Havasu (RB): Arizona Christian, <b>DRAKE</b><br></p><p>Mason Stromstad - Marcos de Niza (LB/WR): Lake Forest, Montana Tech, South Dakota School of Mines, <b>SOUTHERN UTAH</b>, Whittier</p><p>Bryan Stroughter - Tempe (CB): Wisconsin-River Falls</p><p>Ayden Suba - Queen Creek (DE): Arizona Christian, Puget Sound</p><p>Jaivon Swecker - Cactus Shadows (RB): Ottawa<br></p><p>David Sweetman - Brophy (DT): Jamestown</p><p>Esaias Swindle - Desert Edge (DT): Albion, Arizona Christian, Lewis &amp; Clark, McPherson<br></p><p>Matthew Swink - Hamilton (K): Arizona Christian, Carroll Univ. (Wisc.), Concordia Coll. (Minn.), Lewis &amp; Clark, Ottawa (Ariz.), Ottawa (Kans.), Puget Sound, Rocky Mountain<br></p><p>Nick Switzer - Hamilton (RB): Lewis &amp; Clark, New Mexico State</p><p>Hyrum Tanner - Empire (WR): Clarke, Concordia Coll. (Minn.), Culver-Stockton, Hastings, Rose-Hulman<br></p><p>Rune Tepolt - Liberty (LB): Arizona Christian, Black Hills State</p><p>Jordan Thomas - Canyon del Oro (RB): Fort Lewis, Lake Forest<br></p><p>Colin Tibbs - Verrado (CB): Arizona Christian, Colorado School of Mines, Sioux Falls</p><p>Viliami Tongotea - Buckeye (RB): Arizona Christian, Crown, Ripon, Rocky Mountain, Southwestern Coll. (Kans.)</p><p>Jacob Trampp - Eastmark (OT): Arizona State (preferred walk-on), Graceland, Southern Utah (preferred walk-on)<br></p><p>Matthew Tran - Arizona College Prep (LB): Knox, Luther</p><p>Gary Tucker - Mountain Pointe (DE): Wisconsin-River Falls</p><p>Brody Turner - Chandler (OG/DT): Concordia Coll. (Minn.), Wisconsin-River Falls</p><p>Ralphie Valencia - San Manuel (CB): Concordia Univ. (Wisc.)<br></p><p>Drew Vanderah - Arizona College Prep (CB): Grinnell, Lake Forest, St. Norbert</p><p>Mason VanDerToorn - Horizon (SS): Crown, St. Norbert, Wisconsin-River Falls</p><p>Levi VanDyke - Prescott (FS): Concordia Univ. (Wisc.)<br></p><p>Traven Vigenser - Desert Vista (WR): North Dakota, Northern Arizona (preferred walk-on)<br></p><p>Issac Villalobos - Tombstone (DT): Ottawa<br></p><p>Layton Vining - Liberty (OT): <b>IDAHO</b></p><p>Juan Virgen Jr. - Verrado (SS): Arizona Christian, Crown, Whittier</p><p>Julien Virgen - Verrado (RB): Arizona Christian, Crown<br></p><p>Kaden Wagner - Chino Valley (LB): Jamestown, Northern Arizona, Western New Mexico</p><p>Aiden Wander - Arete Prep (LB): Ottawa<br></p><p>Blake Ware - O'Connor (LB): Central Coll. (Iowa), Crown, Fort Lewis, Lake Forest, Pacific (Ore.), Puget Sound, Westminster</p><p>Jacob Ware - Centennial (SS): Ottawa<br></p><p>A'Mauri Washington - Chandler (DT): Arizona, Arizona State, Arkansas, Auburn, Florida, Florida State, Iowa State, LSU, Michigan, Michigan State, Nebraska, Northern Arizona, Ohio State, Oklahoma, <b>OREGON</b>, Oregon State, Penn State, Syracuse, Tennessee, Texas, Texas A&amp;M, USC, Utah, Washington, Washington State</p><p>Demari Washington - Centennial (FS): Army, Colorado, Sioux Falls</p><p>Keron Watson - Cienega (WR): Adams State, Culver-Stockton, Hastings, Southwestern Coll. (Kans.)<br></p><p>Pierson Watson - Coconino (LB): Air Force, <b>BYU</b>, Nevada, Northern Arizona, South Dakota, Weber State</p><p>Will Way - Pusch Ridge (OT/DE): Arizona State (preferred walk-on), <b>IDAHO STATE</b>, Northern Arizona, South Dakota, Washington State, Weber State<br></p><p>Jonathan Webb - Paradise Honors (LB): Crown</p><p>Jake Weidinger - Flagstaff (WR): Arizona Christian, Hastings, Wisconsin-River Falls</p><p>Zarius Wells - Chandler (OT): Adams State, Black Hills State, Colorado Mesa, Fort Lewis, South Dakota School of Mines</p><p>Magnum West - Saguaro (DE): Arizona Christian, Black Hills State, Carnegie Mellon, Lake Forest, South Dakota School of Mines, Southwestern Minnesota State, St. Thomas (Minn.), Wisconsin-River Falls</p><p>Doran Wetzel - Ironwood (LB): Arizona Christian, Crown, Lewis &amp; Clark, Wisconsin-River Falls</p><p>Mason Whitener - Verrado (OT): Arizona Christian</p><p>Bryson Wilke - Willow Canyon (K): Arizona Christian, Rocky Mountain<br></p><p>Mason Williams - Eastmark (OT): Arizona State (preferred walk-on)<br></p><p>Sam Williams - Brophy (FS): Arizona Christian</p><p>Shahid Wilson - Millennium (CB): Adams State, Montana State, North Dakota</p><p>Jaron Winters - ALA-West Foothills (C): Arizona Christian, Culver-Stockton, Fort Lewis, Mayville State, Presentation<br></p><p>Jamaal Young - Marcos de Niza (WR): Arizona Christian, Black Hills State, Jamestown, Mayville State, Montana Tech, Ottawa, Presentation, Rocky Mountain, Washburn, Western New Mexico, Wisconsin-River Falls</p><p>Mikey Young - Paradise Honors (CB): Arizona Christian, Clarke, Crown, Presentation, Ripon<br></p><p>Manuel Zamorano - Canyon del Oro (LB): Wisconsin-River Falls</p><p>Cooper Zellner - Gilbert (LB): Arizona Christian, Linfield, Rocky Mountain</p><p>Prince Zombo - Liberty (WR): Arizona State (preferred walk-on)<br></p><p>Kaden Zordani - Horizon (QB): Ottawa<br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/gllgsgge545kkoprpcsn&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/gllgsgge545kkoprpcsn&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="" alt="" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/gllgsgge545kkoprpcsn" />
<div class='zoom-image'></div>
</div>
</div>
</figure>
<h3 class='article-heading'>Mountain Ridge quarterback Brendan Anderson commits to Southern Utah</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>UPDATED: 12/19/22</b></p><p>Mountain Ridge made it back-to-back trips to the playoffs for the first time since 2009-10 and its three-year starter at quarterback had a lot to do with it.<br></p><p><a href="https://n.rivals.com/content/prospects/2023/brendan-anderson-270611">Brendan Anderson</a> threw 90 TD passes for the Mountain Lions in his time on varsity and announced on Dec. 11 that he has committed to Southern Utah following a visit to the Cedar City campus.<br></p><p>"The culture that has been established there is something that I'm excited to be a part of," Anderson said in a text message. "The people that I have met there really make it feel like home."<br></p><p>Southern Utah was one of five FCS programs to offer the 6-1, 185-pound signal caller. Anderson also held offers from Yale, Drake, St. Thomas (Minn.), and San Diego.<br></p><p>This year, Anderson completed 212 of his 363 passes for 2,527 yards and threw 32 touchdown passes. While his last game ended up as a playoff loss (42-41), Anderson went out with a bang as he had a season-high 386 yards and five TD passes at Mountain Pointe. He is one of nine SUU commits from Arizona (so far).<br></p><p>One of the recruits from the '22 class made a quick impact to Southern Utah. Kohner Cullimore, a Highland alum, made Second Team-All Western Athletic Conference at linebacker as a freshman. SUU improved from a 1-10 season in 2021 to 5-6 this year. This was the first season for head coach DeLane Fitzgerald with the Thunderbirds.<br></p><p><br>Some of the Phoenix Union schools had seasons to celebrate in 2022. At Trevor Browne, the Bruins are also proud to have one of their players go Division I.<br></p><p>On Dec. 7, defensive end <b>Ralph Bernard</b> committed to Colgate University in Upstate New York. He was a dominant force in the trenches for the Bruins.<br></p><p>Bernard (6-3, 270) started his second year for the Bruins in 2022 and tallied 57 tackles to tie for the team lead. Over the past two seasons, he had 20 sacks.<br></p><p>Bernard also held an FCS offer from Northern Arizona. He received his offer from Colgate last May after spring ball.<br></p><p>Colgate, which plays in the Patriot League (FCS), finished 3-8 this year. The Raiders dropped their last three games.<br></p><p><br>One of the local NAIA schools, Arizona Christian, received its first in-state commit for this class last Tuesday when <b>Juan Pablo Garcia</b> announced his college decision.</p><p>Garcia, a defensive end at Douglas, received his offer from ACU back in September during the Bulldogs' season.<br></p><p>"Everyone has that winning mentality," Garcia said of Arizona Christian in a text message. "It's just about everyone being on the same page."<br></p><p>Garcia (6-3, 190) had a two-sack game against Empire in October. Douglas improved two games in the standings this year to finish 4-6, its most victories since 2018. Garcia will be taking part in the Gametime Senior Bowl in Mesa next month. It is an all-star game featuring seniors from throughout the state.<br></p><p>Arizona Christian not only made the playoffs in 2022, but one of its local players, Nestor Higuera, was voted to the Associated Press NAIA Second Team. Higuera, a Paradise Valley alum, connected on 15-of-18 field goals with a long of 52 yards. During his four years, Higuera made 35 field goals. The Firestorm finished 8-3 and gave a great fight on a snowy day in Iowa against Morningside in the playoffs. ACU trailed the top seed by just 21-18 after three quarters before falling 35-18. Arizona Christian finished as co-champions of the Sooner Athletic Conference with Texas Wesleyan and Ottawa (all 7-2 in league play).<br><br></p><p>Washington University in St. Louis is ranked in the top 15 academically by U.S. News &amp; World Report. <b>Matthew Bass</b>, an offensive guard at Chandler, has been interested in the school and visited earlier this year. He received an offer from the Bears over the summer and last Tuesday, committed to go to Wash U.<br></p><p>"I love the school and how hard they push you in the classroom and on the field," Bass said in a text message. I really enjoyed taking a visit out there and the culture of the university. I believe it's a great fit for me."<br></p><p>Bass (6-4, 290), spent all four of his high school years in the CHS program with two of those on varsity. The Wolves made the Open Division playoffs in each of those seasons. Bass was part of a line that opened up holes for Ca'lil Valentine (1,347 yards, 18 TDs) and gave time for quarterback Dylan Raiola to throw (2,435 yards, 22 TDs).<br></p><p>Washington University was rewarded following an 8-2 season with a spot in the Culver's Isthmus Bowl. The Bears were defeated by Wisconsin-River Falls (31-24) on Nov. 19 in Wisconsin. The Bears play in the College Conference of Illinois &amp; Wisconsin (Div. III). <br></p><p><br>Here's the rest of the commitments since Dec. 6:</p><p>Mohave defensive back Anthony Dalisay committed to Carthage (Wisc.).<br>Casteel offensive guard Aidan Buggs committed to Jamestown (N. Dak.).<br>Estrella Foothills running back Liam Henry committed to Luther (Iowa).<br>Valley Vista wide receiver Blaise Nelson committed to Northern Arizona.<br>Mountain Ridge punter Jayden Rogers committed to Southern Utah.<br>River Valley defensive end Jake Purdy committed to Hastings (Neb.).<br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/xpmhqveytkoq4kargmut&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/xpmhqveytkoq4kargmut&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Trevor Browne DE Ralph Bernard" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/xpmhqveytkoq4kargmut" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Trevor Browne DE Ralph Bernard</figcaption>
</div>
</figure>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/roltrrrmnkxmspbewmcw&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/roltrrrmnkxmspbewmcw&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Douglas DE Juan Pablo Garcia  (Photo Courtesy of Juan Pablo Garcia)" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/roltrrrmnkxmspbewmcw" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Douglas DE Juan Pablo Garcia  (Photo Courtesy of Juan Pablo Garcia)</figcaption>
</div>
</figure>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init='ctrl.init(&#39;https://images.rivals.com/image/upload/f_auto,q_auto,t_large/smo0uztcduywh7hgkfkh&#39;,&#39;https://images.rivals.com/image/upload/f_auto,q_auto/smo0uztcduywh7hgkfkh&#39;)'>
<div class='image-container'>
<div ng-class='{&quot;clickable-image&quot;: ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" alt="Chandler OG Matthew Bass" src="https://images.rivals.com/image/upload/f_auto,q_auto,t_large/smo0uztcduywh7hgkfkh" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Chandler OG Matthew Bass</figcaption>
</div>
</figure>
<h3 class='article-heading'>CLASS OF 2023 COMMITMENTS



</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>AIR FORCE FALCONS</b></p><p>Aiden Herring (DE) - Perry<b><br></b>Griffin Stalfort (C) - Hamilton<b><br></b></p><p><b>ARIZONA WILDCATS</b></p><p>Taye Brown (LB) - Hamilton<br>Genesis Smith (FS) - Hamilton<b><br></b></p><p><b>ARIZONA CHRISTIAN FIREBIRDS</b></p><p>Juan Pablo Garcia (DE) - Douglas<b><br></b></p><p><b>ARIZONA STATE SUN DEVILS</b></p><p>Sirri Kandiyeli (OT) - Mesa Mountain View<b><br></b></p><p><b>ARMY BLACK KNIGHTS<br></b></p><p>Carlos Griffin (CB) - Saguaro<b><br></b></p><p><b>AUGUSTANA (S. DAK.) VIKINGS</b></p><p>Jaxon Haynes (WR) - Hamilton<b><br></b></p><p><b>BAYLOR BEARS</b></p><p>Matthew Klopfenstein (TE) - Horizon<b><br></b></p><p><b>BOISE STATE BRONCOS</b></p><p>Wyatt Milkovic (LB) - Basha<b><br></b></p><p><b>BYU COUGARS</b></p><p>Jackson Bowers (TE) - Mesa Mountain View<br>Pierson Watson (LB) - Coconino<b><br></b></p><p><b>CARTHAGE FIREBIRDS</b></p><p>Anthony Dalisay (DB) - Mohave<b><br></b></p><p><b>CENTRAL MICHIGAN CHIPPEWAS</b></p><p>Ryan Blum (C) - Basha<b><br></b></p><p><b>COLGATE RAIDERS</b></p><p>Ralph Bernard (DE) - Trevor Browne<b><br></b></p><p><b>COLORADO STATE RAMS</b></p><p>Stephon Daily (WR) - Sierra Linda<b><br></b></p><p><b>COLUMBIA LIONS</b></p><p>Levi Robins (CB) - Saguaro<b><br></b></p><p><b>CORNELL BIG RED</b></p><p>Jason Kirkland (DE) - Mountain Ridge<b><br></b></p><p><b>DRAKE BULLDOGS</b></p><p>Christian Aguilar (LB) - Mountain Ridge<b><br></b>Isaac Stopke (RB) - Lake Havasu<b><br></b></p><p><b>HASTINGS BRONCOS</b></p><p>Jake Purdy (DE) - River Valley<b><br></b></p><p><b>IDAHO VANDALS</b></p><p>Deshaun Buchanan (RB) - Basha<b><br></b>Layton Vining (OT) - Liberty<b><br></b></p><p><b>IDAHO STATE BENGALS</b></p><p>Will Way (OT/DE) - Pusch Ridge<b><br></b></p><p><b>JAMESTOWN JIMMIES</b></p><p>Aidan Buggs (OG) - Casteel<b><br></b></p><p><b>KANSAS STATE WILDCATS</b></p><p>Ryan Davis (DE) - O'Connor<b><br></b></p><p><b>LAKE FOREST FORESTERS</b></p><p>Charlie Fiedler (WR) - Sunnyslope<br>Nicolas Martin (OG) - Chandler<b><br></b></p><p><b>LUTHER NORSE</b></p><p>Alex Campos (WR) - Eastmark<b><br></b>Liam Henry (RB) - Estrella Foothills<b><br></b></p><p><b>MONTANA STATE BOBCATS</b></p><p>Dom Solano (DE) - Cactus<b><br></b></p><p><b>MONTANA STATE NORTHERN LIGHTS</b></p><p>Logan James (QB) - Wickenburg<b><br></b></p><p><b>NAVY MIDSHIPMEN</b></p><p>Tyson Simmons (DE) - Basha<b><br></b></p><p><b>NEW MEXICO LOBOS</b></p><p>Devon Dampier (QB) - Saguaro<b><br></b></p><p><b>NORTHERN ARIZONA LUMBERJACKS</b></p><p>Ben Currence (WR) - O'Connor (walk-on)<br>Myseth Currie (WR) - Cesar Chavez<br>Adam Damante (QB) - ALA-Gilbert North<b><br></b>Braeden Kaczmarek (DE) - Red Mountain<b><br></b>Blaise Nelson (WR) - Valley Vista<b><br></b>Porter Reynolds (LB) - Queen Creek<b><br></b></p><p><b>NORTHERN STATE WOLVES</b></p><p>Jake Carbajal (OG) - Corona del Sol<b><br></b></p><p><b>NORTHWESTERN WILDCATS</b></p><p>Alex Doost (OT) - Mountain Ridge<br>Dylan Roberts (DT) - Centennial<b><br></b>Cole Shivers (CB) - Saguaro<b><br></b></p><p><b>OKLAHOMA STATE COWBOYS<br></b></p><p>Jack Endean (OT) - Tanque Verde<br>Shea Freibaum (LS) -Saguaro<br></p><p><b>OREGON DUCKS<br></b></p><p>My'Keil Gardner (DE) - Liberty<br>Cole Martin (CB) - Basha<br>A'Mauri Washington (DT) - Chandler<br></p><p><b>PUGET SOUND LOGGERS</b></p><p>Maddox Montoya (LB) - Mesquite</p><p><b>SIOUX FALLS COUGARS</b></p><p>Jack Amer (QB) - Perry<br></p><p><b>SOUTH DAKOTA SCHOOL OF MINES HARDROCKERS</b></p><p>Austin Glimpse (QB) - Sunrise Mountain<br></p><p><b>SOUTHERN UTAH THUNDERBIRDS</b></p><p>Brendan Anderson (QB) - Mountain Ridge<br>Colton Campbell (OG) - Williams Field<br>AJ Dutchover (OG) - Highland<br>Tanner Emery (OT) - Safford<br>Cooper LeDuc (CB) - Hamilton<br>Josh Morin (DE) - Heritage Academy Mesa<br>Breck Mullins (LB) - Williams Field<br>Jayden Rogers (P) - Mountain Ridge<br>Mason Stromstad (LB) - Marcos de Niza<br></p><p><b>STANFORD CARDINAL</b></p><p>Gavin Geweniger (DE) - Chaparral</p><p><b>TEXAS STATE BOBCATS</b></p><p>Cole Marszalek (LS) - Millennium<br></p><p><b>USC TROJANS</b></p><p>Ja'Kobi Lane (WR) - Red Mountain<br>Elijah Paige (OT) - Pinnacle</p><p><b>UTAH UTES</b></p><p>Caleb Lomu (OT) - Highland</p><p><b>WASHINGTON UNIV. (MO.) BEARS</b></p><p>Matthew Bass (OG) - Chandler<br></p><p><b>WISCONSIN BADGERS</b></p><p>James Durand (OG) - Basha</p><p><b>WISCONSIN-RIVER FALLS FALCONS</b></p><p>Jake Hilton (WR) - Prescott<br></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2023-recruiting-update-12-19/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === &quot;premium&quot;'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>

<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' display-lrec1-rightrail='true' display-lrec2-rightrail='true' display-lrec3-rightrail='true' enrichments='[{&quot;active&quot;:true,&quot;type&quot;:&quot;Twitter&quot;,&quot;football&quot;:null,&quot;list_id&quot;:null,&quot;list_title&quot;:null,&quot;position&quot;:1}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2022' ncaaf-schedule-year='2022' scoreboard-photos-id='15082' scoreboard-scores-id='15081' site='{&quot;id&quot;:6,&quot;legacy_id&quot;:1128,&quot;name&quot;:&quot;ArizonaVarsity&quot;,&quot;friendly_name&quot;:&quot;Arizona HS Sports&quot;,&quot;annual_discount&quot;:null,&quot;subdomain&quot;:&quot;arizonavarsity&quot;,&quot;primary_color&quot;:&quot;000000&quot;,&quot;secondary_color&quot;:&quot;b87333&quot;,&quot;font_color&quot;:&quot;ffffff&quot;,&quot;short_name&quot;:&quot;arizonavarsity&quot;,&quot;maple_ncaaf_team_id&quot;:null,&quot;maple_ncaaf_endpoint&quot;:null,&quot;maple_ncaab_team_id&quot;:null,&quot;maple_ncaab_endpoint&quot;:null,&quot;maple_college_id&quot;:null,&quot;google_analytics_id&quot;:&quot;UA-81764304-1&quot;}' twitter-feed='{&quot;id&quot;:6,&quot;site_id&quot;:6,&quot;handle&quot;:&quot;ArizonaVarsity&quot;,&quot;list_name&quot;:&quot;TeamAZV&quot;,&quot;created_at&quot;:&quot;2016-02-01T12:24:39.964-06:00&quot;,&quot;updated_at&quot;:&quot;2020-04-28T02:17:51.614-05:00&quot;,&quot;hashtags&quot;:[],&quot;usernames&quot;:[&quot;AZHSFB&quot;,&quot;ArizonaVarsity&quot;],&quot;max_number&quot;:5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://arizonavarsity.rivals.com/news/gridiron-arizona-s-2023-recruiting-update-12-19/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
</div>
</div>
<script src='/javascript/ad?ad_referrer=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fgridiron-arizona-s-2023-recruiting-update-12-19&amp;space_id=2022719646' type='text/javascript'></script>

<rv-chartbeat-config-body ng-hide sections='content,content-football,content-football-free,content-article' title='Gridiron Arizona&#39;s 2023 Recruiting Update: 12/19'></rv-chartbeat-config-body>

<script>
dataLayer = [{"u15":"arizonavarsity","u16":2468322}];

</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='ra-container'>
<div class='side-rail-meta lrec-ad' ng-if='showLRECad(&#39;footer&#39;)'>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
</div>
</div>

</div>
</main>
<script src='/javascript/pencil_ad.js'></script>
<script src='/javascript/stream_ad.js'></script>
<script src='/javascript/moments_ad.js'></script>
<footer>
<div class='flexible-links'>
<a class='link' href='/news/about-us'>About</a>
<a class='link' href='/news/member-services'>Help</a>
<a class='link' href='/news/contact-us-5'>Contact Us</a>
<a class='link' href='/tos'>Terms of Service</a>
</div>
<div class='flexible-links'>
<a class='link' href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
</div>
<div class='logo-container'>
<div class='footer-logo'><?xml version="1.0" encoding="UTF-8"?>
<svg width="159px" height="96px" viewbox="0 0 159 96" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <!-- Generator: Sketch 58 (84663) - https://sketch.com -->
    <title>logo_yahoo_sports_gray</title>
    <desc>Created with Sketch.</desc>
    <g id="Logos" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="logo-/-yahoo-sports-/-grayscale">
            <g id="logo-/-yahoo-sports-MASTER-/-black-on-white" transform="translate(0.000000, 36.000000)">
                <g id="yahoo-sports-logo-white">
                    <path d="M24.0702452,5.83111111 L24.0702452,7.06666667 C23.2097927,6.0367158 21.9427054,5.46606759 20.6261035,5.51555556 C17.1389101,5.51555556 14.5428883,8.69333333 14.5428883,12.4222222 C14.5428883,16.2577778 17.1259946,19.3333333 20.6261035,19.3333333 C21.9510266,19.3980812 23.2277754,18.8131965 24.0702452,17.7555556 L24.0702452,18.9911111 L28.4184741,18.9911111 L28.4184741,5.83111111 L24.0702452,5.83111111 Z M29.9209809,0 L29.9209809,18.9911111 L34.4241962,18.9911111 L34.4241962,11.9777778 C34.4241962,10.6088889 35.0613624,9.79555556 36.0773842,9.79555556 C37.093406,9.79555556 37.6315531,10.5066667 37.6315531,11.8177778 L37.6315531,18.9911111 L42.1347684,18.9911111 L42.1347684,10.7155556 C42.1347684,7.51111111 40.4557493,5.51555556 37.7564033,5.51555556 C36.4540592,5.4661141 35.2068557,6.0603675 34.3983651,7.11555556 L34.3983651,0.00444444444 L29.9209809,0 Z M71.1129155,12.4444444 C71.1129155,16.3866667 68.1897003,19.3555556 64.293515,19.3555556 C60.3973297,19.3555556 57.4741144,16.3866667 57.4741144,12.4444444 C57.4741144,8.50222222 60.4016349,5.53777778 64.293515,5.53777778 C68.1853951,5.53777778 71.1129155,8.50666667 71.1129155,12.4444444 Z M56.7120981,12.4444444 C56.7120981,16.3866667 53.7845777,19.3555556 49.8926975,19.3555556 C46.0008174,19.3555556 43.073297,16.3866667 43.073297,12.4444444 C43.073297,8.50222222 46.0008174,5.53777778 49.8926975,5.53777778 C53.7845777,5.53777778 56.7120981,8.50666667 56.7120981,12.4444444 Z M5.68434189e-14,5.85333333 L5.44174387,19.1155556 L3.48288828,23.8977778 L8.26594005,23.8977778 L15.5201635,5.85333333 L10.7844687,5.85333333 L7.83111717,13.5733333 L4.90359673,5.85333333 L5.68434189e-14,5.85333333 Z M21.5258856,15.1511111 C20.0778762,15.1511111 18.9040327,13.9392952 18.9040327,12.4444444 C18.9040327,10.9495937 20.0778762,9.73777778 21.5258856,9.73777778 C22.9738949,9.73777778 24.1477384,10.9495937 24.1477384,12.4444444 C24.1582975,13.1655836 23.8854595,13.8603865 23.3914592,14.3703671 C22.8974589,14.8803478 22.2244277,15.1620118 21.5258856,15.1511111 L21.5258856,15.1511111 Z M52.4155313,12.4444444 C52.3942095,10.9991882 51.2457931,9.84329333 49.8457334,9.85791214 C48.4456737,9.87253095 47.3201395,11.0521694 47.3271064,12.4975752 C47.3341381,13.942981 48.4710404,15.1109435 49.8711717,15.1111111 C50.5556752,15.1211114 51.2144344,14.8420408 51.6948283,14.3385545 C52.1752222,13.8350681 52.4355617,13.150859 52.4155313,12.4444444 Z M66.8163488,12.4444444 C66.795027,10.9991882 65.6466105,9.84329333 64.2465509,9.85791214 C62.8464912,9.87253095 61.720957,11.0521694 61.7279238,12.4975752 C61.7349555,13.942981 62.8718578,15.1109435 64.2719891,15.1111111 C64.9564926,15.1211114 65.6152519,14.8420408 66.0956458,14.3385545 C66.5760396,13.8350681 66.8363791,13.150859 66.8163488,12.4444444 Z M71.6510627,16.2266667 C71.6417293,17.0311249 71.9471656,17.80545 72.4982184,18.3743287 C73.0492712,18.9432074 73.7993326,19.2585242 74.5785831,19.2488889 C76.2429617,19.2488889 77.5922071,17.855997 77.5922071,16.1377778 C77.6063278,15.3326284 77.3030257,14.5560964 76.7518547,13.9862577 C76.2006837,13.416419 75.4489316,13.102163 74.6689918,13.1155556 C73.0046133,13.1155556 71.6553678,14.5084474 71.6553678,16.2266667 L71.6510627,16.2266667 Z M78.0657766,0.0222222222 L73.2999455,11.9244444 L78.6469755,11.9244444 L83.4300272,0 L78.0657766,0.0222222222 Z" id="Shape" fill="#000000"></path>
                    <path d="M134.510954,5.48444444 C134.287017,5.41042851 134.052932,5.37440508 133.81782,5.37777778 C132.285501,5.33345562 130.885901,6.2707681 130.30049,7.73333333 L130.30049,5.69333333 L125.681035,5.69333333 L125.681035,18.9466667 L130.326322,18.9466667 L130.326322,14.12 C130.326322,11.6577778 131.432752,10.28 133.382997,10.28 C133.766741,10.2725198 134.148703,10.3357311 134.510954,10.4666667 L134.510954,5.48444444 Z M157.586703,14.7066667 C157.586703,12.56 156.174605,11.3911111 153.328883,10.5688889 L152.584087,10.36 C151.529319,10.0666667 151.120327,9.96 151.120327,9.64444444 C151.120327,9.32888889 151.400163,9.08888889 152.093297,9.08888889 C153.450345,9.14730589 154.776143,9.52749663 155.967956,10.2 L157.405886,6.72888889 C155.762922,5.84513411 153.941481,5.37314042 152.088992,5.35111111 C148.778311,5.35111111 146.522398,7.07111111 146.522398,9.85333333 C146.522398,12.2133333 147.981853,13.3511111 150.883542,14.04 L151.550845,14.2 C152.52812,14.44 152.962943,14.5733333 152.962943,14.9422222 C152.962943,15.3866667 152.532425,15.5244444 151.860817,15.5244444 C150.346116,15.4741491 148.867045,15.0374509 147.55564,14.2533333 L145.911063,17.6977778 C147.686591,18.7932991 149.72378,19.3537124 151.791935,19.3155556 C155.180109,19.3155556 157.565177,17.6444444 157.565177,14.7066667 L157.586703,14.7066667 Z M99.466812,23.8755556 L99.466812,17.5422222 C100.358,18.7173685 101.741926,19.3788009 103.186485,19.32 C106.677984,19.32 109.213733,16.2088889 109.213733,12.3244444 C109.213733,8.44 106.69951,5.32888889 103.186485,5.32888889 C101.733545,5.28164108 100.348025,5.96204577 99.466812,7.15555556 L99.466812,5.69777778 L94.7913896,5.69777778 L94.7913896,23.88 L99.466812,23.8755556 Z M99.3376567,12.32 C99.3271861,11.213905 99.9645436,10.210698 100.951431,9.77990287 C101.938319,9.34910772 103.079494,9.57595163 103.84086,10.3542665 C104.602227,11.1325813 104.833158,12.3083876 104.425573,13.3313811 C104.017988,14.3543747 103.052522,15.0221694 101.981035,15.0222222 C101.279555,15.0391913 100.60157,14.760828 100.102982,14.251141 C99.6043938,13.7414539 99.3281085,13.0443046 99.3376567,12.32 L99.3376567,12.32 Z M117.380654,5.32444444 C113.351008,5.32444444 110.3503,8.34666667 110.3503,12.32 C110.3503,16.2933333 113.363924,19.3155556 117.380654,19.3155556 C121.397384,19.3155556 124.389482,16.2933333 124.389482,12.32 C124.389482,8.34666667 121.375858,5.32444444 117.380654,5.32444444 Z M119.925028,12.32 C119.926756,13.3827901 119.307948,14.3419313 118.357325,14.7498901 C117.406702,15.1578489 116.311622,14.9342208 115.583048,14.1833503 C114.854473,13.4324797 114.635998,12.3023557 115.029563,11.3202919 C115.423128,10.338228 116.351165,9.69774364 117.380654,9.69774364 C118.055765,9.6942178 118.704284,9.9692005 119.182069,10.4616073 C119.659855,10.954014 119.927319,11.6230453 119.925028,12.32 L119.925028,12.32 Z M137.378202,1.58666667 L137.378202,5.69333333 L135.656131,5.69333333 L135.656131,9.61333333 L137.378202,9.61333333 L137.378202,14.3288889 C137.378202,17.4844444 139.17346,19.3111111 142.113896,19.3111111 C143.108761,19.3245868 144.098636,19.1637885 145.041417,18.8355556 L145.041417,14.7555556 C144.601078,14.9003846 144.142996,14.9797003 143.680981,14.9911111 C142.600381,14.9911111 142.036403,14.4888889 142.036403,13.2133333 L142.036403,9.65777778 L145.050027,9.65777778 L145.050027,5.76 L142.036403,5.76 L142.036403,1.65333333 L137.378202,1.58666667 Z M93.5342779,14.7066667 C93.5342779,12.56 92.1221798,11.3911111 89.2764578,10.5688889 L88.5316621,10.36 C87.4768937,10.0666667 87.0679019,9.96 87.0679019,9.64444444 C87.0679019,9.32888889 87.3477384,9.08888889 88.0408719,9.08888889 C89.3979195,9.14730589 90.7237182,9.52749663 91.9155313,10.2 L93.3534605,6.72888889 C91.7104967,5.84513411 89.8890562,5.37314042 88.0365668,5.35111111 C84.7258856,5.35111111 82.4699728,7.07111111 82.4699728,9.85333333 C82.4699728,12.2133333 83.9294278,13.3511111 86.8311172,14.04 L87.4984196,14.2 C88.4756948,14.44 88.9105177,14.5733333 88.9105177,14.9422222 C88.9105177,15.3866667 88.48,15.5244444 87.8083924,15.5244444 C86.2936909,15.4741491 84.81462,15.0374509 83.5032153,14.2533333 L81.8586376,17.6977778 C83.6341658,18.7932991 85.6713546,19.3537124 87.7395095,19.3155556 C91.1276839,19.3155556 93.512752,17.6444444 93.512752,14.7066667 L93.5342779,14.7066667 Z" id="Shape" fill="#999999"></path>
                </g>
            </g>
        </g>
    </g>
</svg></div>
</div>
<div class='copyright-notice' data-philter='angular-data-footer'>Certain data provided by STATS, LLC</div>
<div class='copyright-notice' data-philter='angular-copyright-footer'>© 2022 Yahoo. All rights reserved.</div>
</footer>
<script src="https://cdn.rivals.com/production/assets/basicFooter-4ebdabf837c34b6074ea6f2f1d10e21ea4318e41e37eef5a4cf6640aea934c75.js"></script>

</body>
<div class='third_party_consent_embed' style='display: none;'>
<div class='encoded_embed_content'>
PCEtLSBCZWdpbiBjb21TY29yZSBUYWcgLS0+Cgo8c2NyaXB0PgogIHZhciBf
Y29tc2NvcmUgPSBfY29tc2NvcmUgfHwgW107CiAgX2NvbXNjb3JlLnB1c2go
ewogICAgYzE6ICIyIiwKICAgIGMyOiAiNzI0MTQ2OSIsCiAgICBjNTogIjIw
MjI3MTk2NDYiLAogICAgYzc6ICJodHRwczovL2FyaXpvbmF2YXJzaXR5LnJp
dmFscy5jb20vbmV3cy9ncmlkaXJvbi1hcml6b25hLXMtMjAyMy1yZWNydWl0
aW5nLXVwZGF0ZS0xMi0xOSIKICB9KTsKICAoZnVuY3Rpb24oKSB7CiAgICB2
YXIgcyA9IGRvY3VtZW50LmNyZWF0ZUVsZW1lbnQoInNjcmlwdCIpLCBlbCA9
IGRvY3VtZW50LmdldEVsZW1lbnRzQnlUYWdOYW1lKCJzY3JpcHQiKVswXTsg
cy5hc3luYyA9IHRydWU7CiAgICAvLyBsb2FkaW5nIHRoZSBldmVyZ3JlZW4g
dmVyc2lvbiBvZiBjcy5qcyBzbyB3ZSBhbHdheXMgaGF2ZSB0aGUgbGFzdCB2
ZXJzaW9uCiAgICBzLnNyYyA9ICJodHRwczovL3MueWltZy5jb20vY3gvdnpt
L2NzLmpzIjsKICAgIGVsLnBhcmVudE5vZGUuaW5zZXJ0QmVmb3JlKHMsIGVs
KTsKICB9KSgpOwo8L3NjcmlwdD4KCjxub3NjcmlwdD4KICA8aW1nIHNyYz0i
aHR0cHM6Ly9zYi5zY29yZWNhcmRyZXNlYXJjaC5jb20vcD9jMT0yJmMyPTcy
NDE0NjkmYzc9aHR0cHMlM0ElMkYlMkZhcml6b25hdmFyc2l0eS5yaXZhbHMu
Y29tJTJGbmV3cyUyRmdyaWRpcm9uLWFyaXpvbmEtcy0yMDIzLXJlY3J1aXRp
bmctdXBkYXRlLTEyLTE5JmM1PTIwMjI3MTk2NDYmY3Y9Mi4wJmNqPTEmY3Nf
dWNmcj0wIiAvPgo8L25vc2NyaXB0Pgo8IS0tIEVuZCBjb21TY29yZSBUYWcg
LS0+CgoK

</div>
</div>
</html>
