<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":1,"applicationTime":147,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81764304-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>ArizonaVarsity.com  -  Here's Every Arizona High School Alum on a 2018 NCAA DII Football Roster </title>
<meta content="ArizonaVarsity.com  -  Here's Every Arizona High School Alum on a 2018 NCAA DII Football Roster " property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-148d62b8b40bde34ee136b619dc631e4e3fe9462342e84ae99d593e22b40b4ec.css" />


<script src="https://cdn.rivals.com/production/assets/lib-2c218050dad198426f2e9ad50588b8e7f779d699e9bbbd1fde5e701df92e3866.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-8fbd5e10bd18bb8518ef0c5b3e138fb6daa5a4a0eb87a02b30006de83a56419f.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="fHpcLqSbIRWvbI8ig6INPb7k8GLni7XZlQxFzhqi/3YWHMFLYw6G61cK92p9iKKhzQGdcstQgHF/4rW4hg27Pg==" />
<script>
  (function () {
    'use strict';
  
    angular.module('rivals').factory('userPaths', function () {
      var basePath = "rivals.com";
  
      var siteUrl = function(subdomain) {
        if(subdomain === 'rivals') {
          return window.location.protocol + '//' + basePath;
        } else {
          return window.location.protocol + '//' + subdomain + '.' + basePath;
        }
      };
  
      var trendingThreads = function(baseUrl, forum) {
        return baseUrl + 'api/threads/' + forum + '/trending';
      };
  
      var publishingDashboardUrl = function(subdomain) {
        return siteUrl(subdomain) + '/publishing/contents';
      };
  
      var commitmentsRelativePath = function (page, year) {
        var url;
        if (!page || (page != 'rivals150' && page != 'basketball')) {
          url = "/commitments/football"
        } else {
          url = "/commitments/basketball"
        }
  
        return url + (year ? '/' + year : '');
      };
  
      var commitmentsPath = function (page, year) {
        return basePath + commitmentsRelativePath(page, year);
      };
  
  
      var apiV1RanksProspectsPath = function (rank_id) {
        return "/api/v1/ranks/:rank_id/prospects".replace(/\:rank_id/i, rank_id);
      };
  
      var editContentsPath = function (content_id) {
        return "/publishing/contents/:content_id/edit".replace(/\:content_id/i, content_id);
      };
  
      var apiV1RankPeoplePath = function (rank_id) {
        return "/api/v1/people/rank/:rank_id".replace(/\:rank_id/i, rank_id);
      };
  
      var apiV1ForecastGraphPath = function (prospect_id) {
        return "/api/v1/content/forecast_graph/:prospect_id".replace(/\:prospect_id/i, prospect_id);
      };
  
      return {
        adminHomePath: "/admin/home",
        highschoolApiPath: "/api/v1/content/highschools",
        apiV1BreakingNewsPath: "/api/v1/breaking_news",
        apiV1ContentCollegesPath: "/api/v1/content/colleges",
        apiV1ContentContentsPath: "/api/v1/content/contents",
        apiV1ContentHighschoolsPath: "/api/v1/content/highschools",
        apiV1CustomModules: "/api/v1/custom_modules",
        apiV1CustomModulesPath: "/api/v1/custom_modules/id",
        apiV1EventsPath: "/api/v1/events",
        apiV1FavoriteBlocksPath: "/api/v1/publishing/favorite_blocks",
        apiV1FlipperShowPath: "/api/v1/flipper?key=key",
        apiV1ForecastGraphPath: apiV1ForecastGraphPath,
        apiV1ContentForecastsPath: "/api/v1/content/forecasts",
        apiV1GalleriesPath: "/api/v1/galleries",
        apiV1HpCustomModules: "/api/v1/hp_custom_modules",
        apiV1HpEnrichments: "/api/v1/hp_enrichments",
        apiV1ImagesPath: "/api/v1/images",
        apiV1ProspectRankingsPath: "/api/v1/prospect_rankings",
        apiV1RankPeoplePath: apiV1RankPeoplePath,
        apiV1RanksProspectsPath: apiV1RanksProspectsPath,
        apiV1TrendingContentsPath: "/api/v1/trending_contents",
        apiV1UsersPath: "/api/v1/users",
        basePath: basePath,
        commitmentsPath: commitmentsPath,
        commitmentsRelativePath: commitmentsRelativePath,
        contentsPath: "/news/slug",
        editContentsPath: editContentsPath,
        forumsPath: "https://arizonavarsity.forums.rivals.com/",
        forumsStatisticsPath: "",
        galleriesPath: "/galleries",
        homepagePath: "/content/sport",
        newUserRegistrationPath: "/sign_up",
        newSiteSubscriptionPath: "/subscriptions/new",
        prospectApiPath: "/api/content/prospects",
        prospectCardPath: "/content/prospect_cards/id",
        prospectsPath: "/content/prospects/id",
        publishingDashboardUrl: publishingDashboardUrl,
        registerPath:  "/sign_up",
        rivals250Path: "/prospect_rankings?sport=rivals250",
        signInPath:  "/users/sign_in",
        signOutPath:  "/users/sign_out",
        siteUrl: siteUrl,
        subscribePath: "/users/subscriptions",
        trendingThreads: trendingThreads,
        userProfileEditPath: "/users/profile",
        userProfilePath: "/users/profile"
      };
    });
  }).call(this);
</script>
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://arizonavarsity.rivals.com/news/here-s-every-arizona-high-school-alum-on-a-2017-ncaa-dii-football-roster' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/cqxamjaokib1hef6fb5a' property='og:image'>
<meta content='A directory of all of the Arizona high school football alumni playing NCAA D2 football' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-08-23 02:41:19 -0500' property='article:published_time'>
<meta content='2018-08-23 02:41:20 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "arizonavarsity.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='arizonavarsity contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .arizonavarsity #programming > h1 {
      background-color: #000000 !important; } }
  .arizonavarsity > header .notification-link .count-container {
    background-color: #000000 !important; }
  .arizonavarsity > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .arizonavarsity > header .wrapper-container {
        border-bottom: 5px solid #edbe00 !important; } }
  .arizonavarsity > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .arizonavarsity > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .arizonavarsity > header .invalid-email-banner a:hover {
      color: #edbe00; }
  @media screen and (max-width: 767px) {
    .arizonavarsity > header .mobile-header {
      background-color: #edbe00 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .arizonavarsity > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .arizonavarsity > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .arizonavarsity > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .arizonavarsity > header .nav-row > ul,
    .arizonavarsity > header .third-nav {
      background-color: white !important; }
    .arizonavarsity > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .arizonavarsity > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #edbe00; }
  
  .site-secondary-background-color {
    background-color: #edbe00; }
  
  :root {
    --outbrain-primary-color: #000000;
    --outbrain-secondary-color: #edbe00; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Arizona HS Sports" class="school-header" href="https://arizonavarsity.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/zcfxozfifkhrsxmluop3" alt="Zcfxozfifkhrsxmluop3" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;arizonavarsity&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;arizonavarsity&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719646,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Here's Every Arizona High School Alum on a 2018 NCAA DII Football Roster "
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='azhsfb' name='twitter:site'>
<meta content="Here's Every Arizona High School Alum on a 2018 NCAA DII Football Roster " name='twitter:title'>
<meta content='A directory of all of the Arizona high school football alumni playing NCAA D2 football' name='twitter:description'>
<meta content='https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/cqxamjaokib1hef6fb5a' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":6,"legacy_id":1128,"name":"ArizonaVarsity.com","friendly_name":"Arizona HS Sports","annual_discount":null,"subdomain":"arizonavarsity","primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","short_name":"arizonavarsity","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81764304-1"}, true, 161, nil, {"id":92,"primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"ArizonaVarsity.com","header_logo_cloudinary":"zcfxozfifkhrsxmluop3","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81764304-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":false,"other_content":true,"site_id":6,"created_at":"2016-11-23T13:38:43.400-06:00","updated_at":"2018-08-16T01:54:06.669-05:00","max_trending_articles":6,"enrichments":[{"active":false,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://arizonavarsity.forums.rivals.com","scoreboard_scores_id":15081,"scoreboard_photos_id":15082,"aol_player_id":null,"aol_company_id":null,"ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":10,"schedule_header_on":true},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #000000'>
Ticker
</div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://arizonavarsity.rivals.com/news/here-s-every-arizona-high-school-alum-on-a-2017-ncaa-dii-football-roster' background-color='#000000' base-api-url='https://arizonavarsity.forums.rivals.com/' homepage='false' message-board-url='https://arizonavarsity.forums.rivals.com' pub-ad='null' size='size' space-id='2022719646' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://arizonavarsity.rivals.com/news/here-s-every-arizona-high-school-alum-on-a-2017-ncaa-dii-football-roster/printable' site-name='ArizonaVarsity.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-08-23 02:41:19 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1838235/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Here's Every Arizona High School Alum on a 2018 NCAA DII Football Roster </h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/ykuzcgqgvhm2m1hqwlop'>
<span>
<span class='title-sm'>
Ralph Amsden
&bull;
</span>
<span class='type-sm'>ArizonaVarsity.com</span>
<div class='type-sm'>
<a href='//twitter.com/azhsfb' target='_blank'>@azhsfb</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Publisher</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/azhsfb'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>
Publisher of ArizonaVarsity.com
</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>ArizonaVarsity.com's database of all of the players who are from Arizona and currently listed on NCAA D2 Football rosters. Hopefully this is a helpful reference to track and root on the local alumni who are pursuing their athletic and academic goals out of state at less heralded, but equally important institutions.</p>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p><b>Make sure you're following ArizonaVarsity.com on, <a href="https://twitter.com/AZHSFB">Twitter</a>, <a href="http://instagram.com/azhsrivals">Instagram</a> and <a href="https://www.facebook.com/arizonavarsity/">Facebook</a>.</b></p>
</div>
<h3 class='article-heading'>Adams State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://asugrizzlies.com/roster.aspx?rp_id=4559&amp;path=football">Jordan Larson</a>, TE, Sophomore (Valley Christian)<br></p><p><a href="http://www.asugrizzlies.com/roster.aspx?rp_id=3674&amp;path=football">Rebecca <i></i>Longo</a>, K, RS Freshman (Basha)</p><p><a href="http://www.asugrizzlies.com/roster.aspx?rp_id=3546&amp;path=football">Casey <i></i>Carnaghi</a>, WR, RS Sophomore (Sahuaro)</p><p><a href="https://asugrizzlies.com/roster.aspx?rp_id=4518&amp;path=football">Sean Benke,</a> OL, Freshman (Marana Mountain View)</p>
</div>
<h3 class='article-heading'>Albany State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.asugoldenrams.com/roster.aspx?rp_id=1583&amp;path=football">Gabriel Ballinas</a>, K/P, Sophomore (Hamilton)</p>
</div>
<h3 class='article-heading'>Arkansas Monticello</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://www.uamsports.com/roster.aspx?rp_id=2820&amp;path=football">Jake Wagner</a>, OL, Freshman (Sunrise Mountain)</p>
</div>
<h3 class='article-heading'>Arkansas Tech</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://arkansastechsports.com/roster.aspx?rp_id=2757&amp;path=football">Angel <i></i>Silva</a>, LB, Senior (St. Mary's)</p>
</div>
<h3 class='article-heading'>Augustana</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.goaugie.com/roster.aspx?rp_id=6906">Jake Welsheimer</a>, WR, Sophomore (Shadow Mountain)</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/krllrcvx44uld6ws0ehx)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/krllrcvx44uld6ws0ehx" alt="Krllrcvx44uld6ws0ehx" />
</div>
<figcaption class='image-caption'>Jake Welsheimer</figcaption>
<div class='image-credit'>GoAugie.com</div>
</figure>
<h3 class='article-heading'>Bemidji State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.bsubeavers.com/football/roster/2017/11127/zach-southwick/">Zach Southwick</a>, OL, Sophomore (Moon Valley)</p><p><a href="http://www.bsubeavers.com/football/roster/2017/11024/jeff-harris/">Jeff Harris</a>, DE, RS Senior (Valley Vista)</p><p><a href="http://www.bsubeavers.com/football/roster/2018/14588/nate-woods/">Nate Woods</a>, DB, Junior (Skyline)</p>
</div>
<h3 class='article-heading'>Black Hills State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://bhsuathletics.com/roster.aspx?rp_id=2342">Jacob Parks</a>, K/P, Sophomore (Centennial)</p><p><a href="http://bhsuathletics.com/roster.aspx?rp_id=2331">Tyler Hammons</a>, QB, RS Freshman (Cienega)</p><p><a href="http://bhsuathletics.com/roster.aspx?rp_id=2263">Austin Goddard</a>, LB, Senior (Ironwood Ridge)</p><p><a href="http://bhsuathletics.com/roster.aspx?rp_id=2285">Keith Marson</a>, OL, RS Junior (Vista Grande)</p><p><a href="http://bhsuathletics.com/roster.aspx?rp_id=2320">Clayton Dry,</a> OL, Senior (Mountain Pointe)</p><p><a href="http://bhsuathletics.com/roster.aspx?rp_id=2341">Jordan Pace,</a> WR, RS Freshman (Shadow Mountain)</p><p><a href="https://bhsuathletics.com/roster.aspx?rp_id=2903">Nolan Susel</a>, RB, Freshman (Florence)</p><p><a href="https://bhsuathletics.com/roster.aspx?rp_id=2908">Khiry Keith</a>, OL, Junior (Marcos de Niza)</p><p><a href="https://bhsuathletics.com/roster.aspx?rp_id=2918">Nikolas Arnold</a>, DL, Freshman (Florence)</p><p><br></p>
</div>
<h3 class='article-heading'>Chadron State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://chadroneagles.com/roster.aspx?rp_id=2949">Coy Colgate</a>, RB, RS Sophomore (Nogales)</p><p><a href="https://chadroneagles.com/roster.aspx?rp_id=3475">Jordan Watt</a>, DL, Sophomore (Mountain Pointe)</p><p><a href="https://chadroneagles.com/roster.aspx?rp_id=3449">Ethan Zimmerman</a>, DB, Freshman (Apache Junction)</p><p><a href="https://chadroneagles.com/roster.aspx?rp_id=3442">Kael Juelfs</a>, LB, Freshman (Lee Williams)</p>
</div>
<h3 class='article-heading'>Colorado Mesa</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.cmumavericks.com/roster.aspx?rp_id=11062&amp;path=football">Aaron <i></i>Howard</a>, QB, Freshman (Chandler)</p><p><a href="http://www.cmumavericks.com/roster.aspx?rp_id=12191">Tre Hart</a>, WR, Freshman (Chandler)</p><p><a href="http://www.cmumavericks.com/roster.aspx?rp_id=10946&amp;path=football">Logan <i></i>Bayus</a>, DL, RS Freshman (O'Connor)</p>
</div>
<h3 class='article-heading'>Colorado School of Mines</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://minesathletics.com/roster.aspx?rp_id=4694">Travis Lockhart,</a> QB, RS Sophomore (Hamilton)</p><p><a href="http://minesathletics.com/roster.aspx?rp_id=4692">Adam Leonard,</a> DB, RS Senior (Centennial)</p><p><a href="http://minesathletics.com/roster.aspx?rp_id=4672">Grant Gale,</a> LB, RS Senior (Highland)<br></p><p><a href="http://minesathletics.com/roster.aspx?rp_id=4660">Zach Budzik,</a> OL, RS Sophomore (Desert Vista)</p><p><a href="http://minesathletics.com/roster.aspx?rp_id=4771">Edwin Lovett,</a> DB, RS Freshman (Pusch Ridge)</p>
</div>
<h3 class='article-heading'>CSU-Pueblo</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/williams_darius_3y1d">Darius Williams</a>, DB, Senior (Williams Field)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/dennard_marche_msqv">Marché Dennard</a>, RB, Senior (Brophy)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/Malachi_Wilkins">Malachi Wilkins</a>, LB, RS Freshman (Estrella Foothills)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/alderson_hunter_e4hh">Hunter Alderson</a>, OL, RS Sophomore (Ironwood Ridge)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/campbell_tre_xowv">Tre Campbell</a>, WR, RS Sophomore (Shadow Ridge)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/Max_Fine">Max Fine</a>, WR, RS Freshman (Williams Field)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/reaves_anthony_id0x">Anthony Reaves</a>, TE, RS Junior (Desert Vista)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/forsgren_cole_6pkc">Cole Forsgren</a>, WR, Senior (Williams Field)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/guerra_preston_zpuk">Preston Guerra</a>, TE, RS Sophomore (Cactus)</p><p><a href="http://gothunderwolves.com/sports/fball/2017-18/bios/sears_jamaal_xpts">Jamaal Sears</a>, DB, Junior (Valley Vista)</p><p><a href="http://www.gothunderwolves.com/sports/fball/2018-19/bios/Keith_Wesley">Keith Wesley</a>, LB, Freshman (Higley)</p><p><a href="http://www.gothunderwolves.com/sports/fball/2018-19/bios/Tavian_Robey">Tavian Robey</a>, DL, Freshman (Marana Mountain View)</p><p><a href="http://www.gothunderwolves.com/sports/fball/2018-19/bios/pearson_josh_p8pb">Josh Pearson</a>, K, Freshman (Marana)</p><p><a href="http://www.gothunderwolves.com/sports/fball/2018-19/bios/Darius_Holton">Darius Holton</a>, DB, Freshman (Perry)</p><p><a href="http://www.gothunderwolves.com/sports/fball/2018-19/bios/Kyle_Carriker">Kyle Carriker</a>, DL, Freshman (Pinnacle)</p><p><a href="http://www.gothunderwolves.com/sports/fball/2018-19/bios/powell_marcus_3hcj">Marcus Powell</a>, DL, Sophomore (Perry)</p>
</div>
<h3 class='article-heading'>Concordia- St. Paul</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://cspbears.com/roster.aspx?rp_id=5319">Mark Rivera</a>, OL, Junior (Mesquite)</p><p><a href="http://cspbears.com/roster.aspx?rp_id=5341">Cole Marmor</a>, DL, Junior(Ironwood Ridge)</p>
</div>
<h3 class='article-heading'>Dixie State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://dixiestateathletics.com/roster.aspx?rp_id=5368&amp;path=football">Anthony <i></i>Reyes</a>, K, Senior (Dobson)</p><p><a href="https://dixiestateathletics.com/roster.aspx?rp_id=5758&amp;path=football">Michael Sanders</a>, QB, RS Senior (Pinnacle)</p><p><a href="https://dixiestateathletics.com/roster.aspx?rp_id=5689&amp;path=football">Josh Carlson</a>, P, Freshman (Gilbert)</p><p><br></p>
</div>
<h3 class='article-heading'>East Central</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.ecutigers.com/roster.aspx?rp_id=1623">Wyatt Galante</a>, OL, RS Junior (Red Mountain)</p>
</div>
<h3 class='article-heading'>Eastern New Mexico</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.goeasternathletics.com/roster.aspx?rp_id=13832&amp;path=football">Tyler <i></i>Lynch</a>, TE, RS Junior (Williams Field)</p><p><a href="http://www.goeasternathletics.com/roster.aspx?rp_id=13788&amp;path=football">Troy <i></i>Bethsold</a>, LB, RS Junior (Liberty)</p><p><a href="https://goeasternathletics.com/roster.aspx?rp_id=14955&amp;path=football">Vavrix Owens</a>, LB, Junior (Mountain Pointe)</p><p><a href="https://goeasternathletics.com/roster.aspx?rp_id=14964&amp;path=football">Emilio Rodriguez</a>, DB Junior (Verrado)</p><p><a href="https://goeasternathletics.com/roster.aspx?rp_id=14967&amp;path=football">Deon Lee</a>, DB, Junior (Mountain Pointe)</p><p><a href="https://goeasternathletics.com/roster.aspx?rp_id=15020&amp;path=football">Davin <i></i>Williams-Mumin</a>, DB, Freshman (Liberty)</p><p><a href="https://goeasternathletics.com/roster.aspx?rp_id=15021&amp;path=football">Qadeer <i></i>Williams-Mumin</a>, LB, Freshman (Liberty)</p>
</div>
<h3 class='article-heading'>Fort Hays State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://fhsuathletics.com/roster.aspx?rp_id=4870">Nick Courinos</a>, OL, Junior (Shadow Mountain)</p>
</div>
<h3 class='article-heading'>Fort Lewis</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.goskyhawks.com/roster.aspx?rp_id=4330">Mason Hatton</a>, WR, RS Senior (Pinnacle)</p><p><a href="http://www.hillsdalechargers.com/sports/fball/2018-19/bios/lowery_scott_0rjk">Jacob McCabe</a>, OL, Freshman (Page)</p><p><a href="https://goskyhawks.com/roster.aspx?rp_id=6609">Chad Myron</a>, WR, Freshman (Window Rock)</p><p>Colton Petersen, DL, RS Sophomore (Mesquite)</p>
</div>
<h3 class='article-heading'>Grand Valley State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://gvsulakers.com/roster.aspx?rp_id=5786&amp;path=football">Ethan <i></i>Cortazzo</a>, WR, RS Senior (Red Mountain)</p>
</div>
<h3 class='article-heading'>Harding</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://hardingsports.com/roster.aspx?rp_id=5643">Dylan Hendricks</a>, LB, RS Sophomore (Mesa)</p>
</div>
<h3 class='article-heading'>Henderson State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://hsusports.com/roster.aspx?rp_id=3098&amp;path=football">Bowen <i></i>Sweeney</a>, DB, Senior (Payson)</p>
</div>
<h3 class='article-heading'>Hillsdale</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.hillsdalechargers.com/sports/fball/2018-19/bios/tobin_kendall_duzn">Kendall Tobin</a>, DL, Freshman (Pusch Ridge)</p><p><a href="http://www.hillsdalechargers.com/sports/fball/2018-19/bios/lowery_scott_0rjk">Scott Lowery</a>, WR, RS Freshman (Homeschooled)</p>
</div>
<h3 class='article-heading'>Lenoir-Rhyne University</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://lrbears.com/roster.aspx?rp_id=1755">Jonathan Nolan,</a> OL, Junior (Horizon)</p>
</div>
<h3 class='article-heading'>Lindenwood</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.lindenwoodlions.com/roster.aspx?rp_id=8760&amp;path=football">Koby <i></i>Charles</a>, DB, RS Freshman (Casa Grande)</p>
</div>
<h3 class='article-heading'>Long Island-Post</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://liupostpioneers.com/roster.aspx?rp_id=7135&amp;path=football">Austin <i></i>Nuessle</a>, QB, RS Freshman (Desert Mountain)</p>
</div>
<h3 class='article-heading'>University of Mary</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://goumary.com/roster.aspx?rp_id=3955&amp;path=football">Antonio Cuevas</a>, DB, Freshman (Saguaro)</p><p><a href="http://www.goumary.com/roster.aspx?rp_id=3064&amp;path=football">Garrett <i></i>Weissinger</a>, QB, Sophomore (Sunrise Mountain)</p><p><a href="https://goumary.com/roster.aspx?rp_id=3977&amp;path=football">Dallas Pena</a>, OL, Freshman (Valley Vista)</p><p><a href="https://goumary.com/roster.aspx?rp_id=3973&amp;path=football">Vincent Meloy</a>, OL, Freshman (Williams Field)</p><p><a href="https://goumary.com/roster.aspx?rp_id=3966&amp;path=football">Danny Kittner</a>, WR, Freshman (Higley)</p><p><a href="https://goumary.com/roster.aspx?rp_id=3978&amp;path=football">Brody Riggs</a>, K, Sophomore (Cactus)</p><p><br></p>
</div>
<h3 class='article-heading'>Minnesota-Crookston</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.goldeneaglesports.com/roster.aspx?rp_id=2502&amp;path=football">Reyes <i></i>Lara III</a>, QB, RS Freshman (Valley Vista)</p><p><a href="https://goldeneaglesports.com/roster.aspx?rp_id=2790&amp;path=football">Joey Sanchez</a>, DB, Freshman (Red Mountain)</p><p><a href="https://goldeneaglesports.com/roster.aspx?rp_id=2888&amp;path=football">Wyatt Shedrick</a> III, WR, Freshman (Saguaro)</p><p><a href="http://www.goldeneaglesports.com/roster.aspx?rp_id=2485&amp;path=football">Jordan <i></i>Frieberg</a>, DL, RS Freshman (Willow Canyon)</p><p><a href="http://www.goldeneaglesports.com/roster.aspx?rp_id=2478&amp;path=football">Elizsha <i></i>Bear-Encinas</a>, OL, RS Freshman (Casa Grande)</p>
</div>
<h3 class='article-heading'>Minot State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://msubeavers.com/roster.aspx?rp_id=4320">Justin Coleman</a>, DB, Freshman (Red Mountain)</p><p><a href="https://msubeavers.com/roster.aspx?rp_id=4324">Scott Fallers</a>, QB, Freshman (Westview)</p><p><a href="https://msubeavers.com/roster.aspx?rp_id=4317">Kamryn Bradley</a>, RB, Freshman (Copper Canyon)</p>
</div>
<h3 class='article-heading'>Missouri Science and Tech</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.minerathletics.com/roster.aspx?rp_id=4506&amp;path=football">Zach <i></i>Glaess</a>, K, RS Sophomore (Queen Creek)</p><p><a href="https://minerathletics.com/roster.aspx?rp_id=5030&amp;path=football">Ryan Langford</a>, TE, Freshman (O'Connor)</p>
</div>
<h3 class='article-heading'>Nebraska-Kearney</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.lopers.com/roster.aspx?rp_id=4991">Luke Quinn</a>, RB, Senior (Horizon)</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/crnaerjsfzhz0hlsvqyf)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/crnaerjsfzhz0hlsvqyf" alt="Crnaerjsfzhz0hlsvqyf" />
</div>
<figcaption class='image-caption'>Luke Quinn</figcaption>
<div class='image-credit'>via Kearney Hub</div>
</figure>
<h3 class='article-heading'>New Mexico Highlands</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://nmhucowboys.com/roster.aspx?rp_id=4567&amp;path=football">Luke Verbalaitis</a>, OL, Freshman (Pinnacle)</p>
</div>
<h3 class='article-heading'>North Alabama</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.roarlions.com/roster.aspx?rp_id=1470&amp;path=football">Jordan Robinson</a>, DB, RS Junior (Mesquite)</p>
</div>
<h3 class='article-heading'>Northern Michigan</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><br></p><p><a href="http://www.nmuwildcats.com/sports/fball/2017-18/bios/cook_abram_fofs">Abram Cook</a>, DL, Senior (Valley Vista)</p><p><a href="http://www.nmuwildcats.com/sports/fball/2017-18/bios/dixon_dallas_l833">Dallas Dixon</a>, WR, Sophomore (Tolleson)</p>
</div>
<h3 class='article-heading'>Northern State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><br></p><p><a href="http://nsuwolves.com/roster.aspx?rp_id=4506&amp;path=football">K.C. <i></i>Yeargain</a>, DB, Senior (Chandler)</p><p><a href="http://nsuwolves.com/roster.aspx?rp_id=4621&amp;path=football">Zach <i></i>Bohnenkamp</a>, DB, Sophomore (Canyon del Oro)</p><p><a href="http://nsuwolves.com/roster.aspx?rp_id=4445&amp;path=football">Zech <i></i>Culbreath</a>, WR, RS Senior (Chandler)</p><p><a href="http://nsuwolves.com/roster.aspx?rp_id=4444&amp;path=football">Jacob <i></i>Cross</a>, DL, RS Sophomore (Perry)</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/kvpcuoe6ug3ybjy7649t)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/kvpcuoe6ug3ybjy7649t" alt="Kvpcuoe6ug3ybjy7649t" />
</div>
<figcaption class='image-caption'>Zech Culbreath</figcaption>
<div class='image-credit'>Aberdeen American News</div>
</figure>
<h3 class='article-heading'>Northwest Missouri State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://bearcatsports.com/roster.aspx?rp_id=7102&amp;path=football">Jerrell Green</a>, DB, Junior (Millennium)</p>
</div>
<h3 class='article-heading'>Pittsburg State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.pittstategorillas.com/roster.aspx?rp_id=3789&amp;path=football">Elijah <i></i>Jeffcoat</a>, DE, RS Junior (Williams Field)</p><p><a href="http://www.pittstategorillas.com/roster.aspx?rp_id=3788&amp;path=football">Marcus <i></i>Brantley</a>, DB, Senior (Red Mountain)</p>
</div>
<h3 class='article-heading'>Sioux Falls</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://usfcougars.com/roster.aspx?rp_id=3939">Ja'Tai Jenkins</a>, RB, Freshman (Verrado)</p><p><a href="http://usfcougars.com/roster.aspx?rp_id=3946">Christian Medieros</a>, DL, Freshman (Desert Ridge)</p>
</div>
<h3 class='article-heading'>South Dakota School of Mines</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://gorockers.com/roster.aspx?rp_id=5958">Kendahl Johnson</a>, DB, Freshman (O'Connor)</p><p><a href="https://gorockers.com/roster.aspx?rp_id=5953">Adrian Eastman</a>, DB, Freshman (Higley)</p><p><a href="https://gorockers.com/roster.aspx?rp_id=5957">Gavin Chaddocck</a>, LB, Freshman (Sunrise Mountain)</p><p><a href="https://gorockers.com/roster.aspx?rp_id=5955">Hunter Jaskey</a>, DL Freshman (Boulder Creek)</p><p><a href="http://gorockers.com/roster.aspx?rp_id=554">Christian Singleton</a>, QB, RS Freshman (Flagstaff)</p><p><a href="http://gorockers.com/roster.aspx?rp_id=488">Chris Counce</a>, LB, Senior (Saguaro)</p><p><a href="http://gorockers.com/roster.aspx?rp_id=522">Adrian Perez</a>, DL, Junior (Desert Vista)</p><p><a href="http://gorockers.com/roster.aspx?rp_id=495">Griffin Facciano</a>, OL, Sophomore (Ironwood Ridge)</p><p><a href="http://gorockers.com/roster.aspx?rp_id=475">Ian Anderson</a>, WR, Junior (Hamilton)</p><p><a href="http://gorockers.com/roster.aspx?rp_id=527">Robert Schrock</a>, OL, Senior (Mesa)<br></p><p><a href="https://gorockers.com/roster.aspx?rp_id=7061">Francisco Dicochea</a> III, LB, Junior (Cienega)</p>
</div>
<h3 class='article-heading'>Southwest Baptist</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://www.sbubearcats.com/roster.aspx?rp_id=4575&amp;path=football">DeMarco Grayson</a>, RB, Junior (Catalina)</p>
</div>
<h3 class='article-heading'>Southwest Minnesota State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><br></p><p><a href="http://www.smsumustangs.com/roster.aspx?rp_id=5315">Austin Wells,</a> P/K, Senior (Campo Verde)</p><p><a href="https://smsumustangs.com/roster.aspx?rp_id=6899">Shavez Hawkins</a>, RB, Sophomore (Williams Field)</p><p><a href="https://smsumustangs.com/roster.aspx?rp_id=6900">Shaun'dell Hawkins</a>, LB, Freshman (Williams Field)</p><p><br></p>
</div>
<h3 class='article-heading'>Southwestern Oklahoma State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://swosuathletics.com/roster.aspx?rp_id=2515">CJ Jennings</a>, DB, Junior (O'Connor)</p>
</div>
<h3 class='article-heading'>Tartleton State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://tarletonsports.com/roster.aspx?rp_id=8198">Thomas Warren</a>, DB, Senior (Mountain Pointe)</p>
</div>
<h3 class='article-heading'>Texas A&amp;M Kingsville</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://javelinaathletics.com/roster.aspx?rp_id=2352">Donovan Moore</a>, WR, RS Junior (Tucson)</p>
</div>
<h3 class='article-heading'>Texas-Permian Basin</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://utpbfalcons.com/roster.aspx?rp_id=2206&amp;path=football">Quinn Tinley</a>, DB, RS Freshman (Perry/Palastine)</p>
</div>
<h3 class='article-heading'>Truman State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://trumanbulldogs.com/roster.aspx?rp_id=3878">Sam Reeves</a>, DL, RS Junior (Vista Grande)</p>
</div>
<h3 class='article-heading'>Tusculum</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.tusculumpioneers.com/sports/fball/2017-18/bios/pistone_tommy_bj9y">Tommy Pistone</a>, QB, RS Senior (Yuma Catholic)</p>
</div>
<h3 class='article-heading'>Virginia Union</h3>
<div class='st__content-block st__content-block--text article-text'>
<p>Jaeren Burch, WR, Senior (Perry)</p>
</div>
<h3 class='article-heading'>Washburn</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><br></p><p><a href="http://wusports.com/roster.aspx?rp_id=4531&amp;path=football">Colton <i></i>Dunkle</a>, OL, Junior (Basha)</p><p><a href="http://wusports.com/roster.aspx?rp_id=4543&amp;path=football">Kyle <i></i>Hinton</a>, OL, Junior (Liberty)</p><p><a href="http://wusports.com/roster.aspx?rp_id=4702&amp;path=football">Jaaron <i></i>Taylor</a>, DL, RS Freshman (Chandler)</p><p><a href="https://wusports.com/roster.aspx?rp_id=5221&amp;path=football">Mason Honne</a>, OL, Freshman (Mountain Pointe)</p><p><a href="https://wusports.com/roster.aspx?rp_id=5287&amp;path=football">Alex Ward</a>, OL, Junior (Hamilton)</p><p><br></p>
</div>
<h3 class='article-heading'>Wayne State College </h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.wscwildcats.com/roster.aspx?rp_id=3597&amp;path=football">Dallan <i></i>Taylor</a>, OL, RS Freshman (Liberty)<br></p><p><a href="https://wscwildcats.com/roster.aspx?rp_id=3981&amp;path=football">Billy Rone</a>, OL, Senior (Marcos de Niza)</p><p><br></p>
</div>
<h3 class='article-heading'>West Texas A&amp;M</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.gobuffsgo.com/roster.aspx?rp_id=6968&amp;path=football">Joseph Radke</a>, LB, RS Sophomore (Miami)</p><p><br></p>
</div>
<h3 class='article-heading'>Western New Mexico</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.wnmumustangs.com/roster.aspx?rp_id=3016&amp;path=football">Gabriel <i></i>Tomaszewski</a>, QB, Junior (Perry)</p><p><a href="http://www.wnmumustangs.com/roster.aspx?rp_id=3021&amp;path=football">DeAndre <i></i>Williams</a>, RB/DB, Junior (Tucson)</p><p><a href="http://www.wnmumustangs.com/roster.aspx?rp_id=3121&amp;path=football">Laruni <i></i>Witty</a>, DB, Sophomore (Westview)</p><p><a href="http://www.wnmumustangs.com/roster.aspx?rp_id=3020&amp;path=football">Jacob <i></i>Valdez</a>, LB, RS Sophomore (Buena)</p><p><a href="http://www.wnmumustangs.com/roster.aspx?rp_id=3106&amp;path=football">Clay <i></i>Branton</a>, LB, RS Sophomore (Tucson)</p><p><a href="http://www.wnmumustangs.com/roster.aspx?rp_id=3134&amp;path=football">James <i></i>Vaifale</a>, LB, Senior (Corona del Sol)</p><p><a href="http://www.wnmumustangs.com/roster.aspx?rp_id=2996&amp;path=football">Elijah <i></i>Jones</a>, WR/DB, RS Sophomore (Campo Verde)</p><p><a href="https://wnmumustangs.com/roster.aspx?rp_id=3318&amp;path=football">Peyton Kendrick</a>, QB, Junior (Santa Rita)</p><p><a href="https://wnmumustangs.com/roster.aspx?rp_id=3318&amp;path=football">Adrian Leos</a>, LB, Freshman (Vista Grande)</p><p><a href="https://wnmumustangs.com/roster.aspx?rp_id=3302&amp;path=football">Nico Flores</a>, WR, Freshman (Santa Cruz)</p><p><a href="https://wnmumustangs.com/roster.aspx?rp_id=3322&amp;path=football">Cameron Vega</a>, OL, Freshman (Rincon)</p><p><a href="https://wnmumustangs.com/roster.aspx?rp_id=3323&amp;path=football">Mac Rothschild-Potterf</a>, OL, Freshman (Desert Vista)</p><p><a href="https://wnmumustangs.com/roster.aspx?rp_id=3329&amp;path=football">Khalil Gardley</a>, TE, Freshman (Buena)</p>
</div>
<h3 class='article-heading'>Western Oregon</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.wouwolves.com/roster.aspx?rp_id=4076&amp;path=football">Gabe <i></i>Avila</a>, LB, RS Sophomore (Greenway)<br></p><p><br></p>
</div>
<h3 class='article-heading'>Western State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.gomountaineers.com/roster.aspx?rp_id=4729&amp;path=football">David <i></i>Velazquez</a>, DB, RS Senior(Horizon)</p><p><a href="http://www.gomountaineers.com/roster.aspx?rp_id=4657&amp;path=football">Garrett <i></i>Boyd</a>, P, Junior (Seton Catholic)</p><p><a href="http://www.gomountaineers.com/roster.aspx?rp_id=4664&amp;path=football">Joey <i></i>Dill</a>, LB, RS Junior (Casa Grande)</p>
</div>
<h3 class='article-heading'>William Jewell</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://jewellcardinals.com/roster.aspx?rp_id=3708&amp;path=football">Connor Carpenter</a>, LB, RS Sophomore (Willow Canyon)<br></p>
</div>
<h3 class='article-heading'>Winona State</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="http://www.winonastatewarriors.com/roster.aspx?rp_id=8827&amp;path=football">Javian <i></i>Roebuck</a>, RB, Junior (La Joya)</p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://arizonavarsity.rivals.com/news/here-s-every-arizona-high-school-alum-on-a-2017-ncaa-dii-football-roster/printable' site-name='ArizonaVarsity.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' scoreboard-photos-id='15082' scoreboard-scores-id='15081' site='{"id":6,"legacy_id":1128,"name":"ArizonaVarsity.com","friendly_name":"Arizona HS Sports","annual_discount":null,"subdomain":"arizonavarsity","primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","short_name":"arizonavarsity","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81764304-1"}' twitter-feed='{"id":6,"site_id":6,"handle":"azhsfb","list_name":"Arizona-Varsity","created_at":"2016-02-01T12:24:39.964-06:00","updated_at":"2018-08-16T01:52:12.473-05:00","hashtags":[],"usernames":["AZHSFB","ArizonaVarsity","GreggRosenberg1"],"max_number":5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://arizonavarsity.rivals.com/news/here-s-every-arizona-high-school-alum-on-a-2017-ncaa-dii-football-roster/printable' site-name='ArizonaVarsity.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719646', 'https://arizonavarsity.rivals.com/news/here-s-every-arizona-high-school-alum-on-a-2017-ncaa-dii-football-roster');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Here's Every Arizona High School Alum on a 2018 NCAA DII Football Roster ";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://arizonavarsity.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Oath Inc</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719646",
    c7: "https://arizonavarsity.rivals.com/news/here-s-every-arizona-high-school-alum-on-a-2017-ncaa-dii-football-roster"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fhere-s-every-arizona-high-school-alum-on-a-2017-ncaa-dii-football-roster&c5=2022719646&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
