<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":1,"applicationTime":209,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81764304-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<title>ArizonaVarsity  -  Physical Lions bring experience at QB &amp; OL</title>
<meta content='ArizonaVarsity  -  Physical Lions bring experience at QB &amp; OL' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-ec039dd1f9bbe68e8484a56baba05958de90bd9a849bc759465637cfd3d5439a.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-eca3759404f3364c7823b72370ec43a86e249d9b2ea73918d92982142a888ad1.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="Dvjnsb08fMMCDfaMF/Iwpw0Tsmv6U6yPqMDeKYNAmJ4rEj3BmydZwW8Lrs/4q552psK3bEjpIKopZIiqarXJ+Q==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      var singleSiteApp = function() {
        return "false";
      };
  
      return {
        getPremiumIcon: getPremiumIcon,
        singleSiteApp: singleSiteApp
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://arizonavarsity.rivals.com/news/physical-lions-bring-experience-in-trenches' property='og:url'>
<meta content='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_headline_primary/fheidalegfgzi3s8s7d5' property='og:image'>
<meta content='QB Jonah Guevara leads Liberty and can hurt defenses throwing it or running it' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-08-11 13:47:03 -0500' property='article:published_time'>
<meta content='2019-08-11 14:05:30 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='apple-touch-icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "arizonavarsity.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='arizonavarsity contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .arizonavarsity #programming > h1 {
      background-color: #000000 !important; } }
  .arizonavarsity .wrapper-container .team-colors-line {
    background-color: #edbe00; }
  .arizonavarsity img.custom-premium-icon, .arizonavarsity .custom-premium-icon, .arizonavarsity img.custom-premium-white-icon, .arizonavarsity .custom-premium-white-icon,
  .arizonavarsity img.custom-premium-gallery-icon, .arizonavarsity .custom-premium-gallery-icon, .arizonavarsity .premium-icon-container {
    display: none; }
  .arizonavarsity .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #000000; }
    .arizonavarsity .team-colors-line .color {
      width: 33.33%; }
    .arizonavarsity .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .arizonavarsity .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .arizonavarsity .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .arizonavarsity .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .arizonavarsity .team-colors-line.header {
      height: 6px; }
  .arizonavarsity > header .notification-link .count-container {
    background-color: #000000 !important; }
  .arizonavarsity > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .arizonavarsity > header .wrapper-container {
        border-bottom: 6px solid #edbe00 !important; } }
  .arizonavarsity > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .arizonavarsity > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .arizonavarsity > header .invalid-email-banner a:hover {
      color: #edbe00; }
  @media screen and (max-width: 767px) {
    .arizonavarsity > header .mobile-header {
      background-color: #edbe00 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .arizonavarsity > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .arizonavarsity > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .arizonavarsity > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .arizonavarsity > header .nav-row > ul,
    .arizonavarsity > header .third-nav {
      background-color: white !important; }
    .arizonavarsity > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .arizonavarsity > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #edbe00; }
  
  .site-secondary-background-color {
    background-color: #edbe00; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(0, 0, 0, 0.4), rgba(0, 0, 0, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #000000;
    --secondary-color: #edbe00;
    --accent-color: #000000;
    --button-color: #000000;
    --subscription-button-color: #0A4EA3; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false,"arizonavarsity")' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Arizona HS Sports" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://arizonavarsity.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/zcfxozfifkhrsxmluop3" alt="Zcfxozfifkhrsxmluop3" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath + ctrl.utmParams }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://arizonavarsity.rivals.com/">Home</a></li>
        <rv-forum-navigation site-identifier="&#39;arizonavarsity&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719646,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Physical Lions bring experience at QB & OL"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='azhsfb' name='twitter:site'>
<meta content='Physical Lions bring experience at QB &amp; OL' name='twitter:title'>
<meta content='QB Jonah Guevara leads Liberty and can hurt defenses throwing it or running it' name='twitter:description'>
<meta content='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/fheidalegfgzi3s8s7d5' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":6,"legacy_id":1128,"name":"ArizonaVarsity","friendly_name":"Arizona HS Sports","annual_discount":null,"subdomain":"arizonavarsity","primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","short_name":"arizonavarsity","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81764304-1"}, true, 161, nil, {"id":92,"primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"ArizonaVarsity.com","header_logo_cloudinary":"zcfxozfifkhrsxmluop3","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81764304-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":false,"other_content":true,"site_id":6,"created_at":"2016-11-23T13:38:43.400-06:00","updated_at":"2019-01-14T18:59:58.121-06:00","max_trending_articles":6,"enrichments":[{"active":false,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"forums_link_url":"https://arizonavarsity.forums.rivals.com","scoreboard_scores_id":15081,"scoreboard_photos_id":15082,"aol_player_id":null,"aol_company_id":null,"ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":10,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null,"custom_premium_icon_enabled":null,"email_logo_cloudinary":null},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000, false, {"id":1967,"user_id":2798272,"site_id":6,"updated_at":"2018-06-24T21:51:58.853-05:00","publisher_name":"Chris Eaton","first_name":"Chris","last_name":"Eaton","site_title":"Staff","bio":null,"twitter_handle":null,"image_url":null,"publisher_name_and_title":"Chris Eaton, Staff","site_name":"ArizonaVarsity","site_short_name":"arizonavarsity","has_edited_profile":false})'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-forums ad-referer='https://arizonavarsity.rivals.com/news/physical-lions-bring-experience-in-trenches' base-api-url='https://arizonavarsity.forums.rivals.com/' forums-url='https://arizonavarsity.forums.rivals.com' homepage='false' pub-ad='null' size='size' space-id='2022719646' subscribed-user='subscribedUser'></rv-forums>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://arizonavarsity.rivals.com/news/physical-lions-bring-experience-in-trenches/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-08-11 13:47:03 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2067782/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Physical Lions bring experience at QB &amp; OL</h2>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/wvd3hbnd6a6wnbsyetee','https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto/wvd3hbnd6a6wnbsyetee')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/wvd3hbnd6a6wnbsyetee" alt="Wvd3hbnd6a6wnbsyetee" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Liberty offensive guard Vincente Maestas checks the play call with his fellow linemen before getting into position during a home game last year.  He has already won one title in 2019 as he was a member of the Lions' wrestling team which took state last February.</figcaption>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='author-name'>
Chris Eaton
&bull;
</span>
<span class='type-sm'>ArizonaVarsity</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>Staff</span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><h3 class='article-heading'>Guard Maestas part of Liberty O-Line returning all 5 starters</h3>
<div class='st__content-block st__content-block--text article-text'>
<p> <b>WEEKLY BLOG: 8/11/19</b> </p><p>Quick question: As it relates to scoring, which big-school team (6A, 5A, and 4A) was the closest to a perfect season in 2018?</p><p>Three-time 6A champion Chandler lost just once, but it was by 22 points to Corona Centennial out of California in its opener. Centennial ran the table en route to the 5A title, but was blanked in the GEICO Bowl by 17 points to Eastside Catholic out of Washington. Some may call it an exhibition, but postseason games count on your record. Saguaro claimed its sixth straight state title and like the previous two, only lost to an out-of-state team. In the Sabercats' case, it was in Week 2 against Liberty HS out of Henderson, Nev.</p><p>Which leads us to another Liberty, this one out of Peoria. The Lions (10-2) took a 7-0 mark into Pinnacle in October and led the Pioneers, 33-14 midway through the third quarter. Spencer Rattler led PHS back with the game's last three touchdowns, and a 34-33 victory. Fast forward to the quarterfinal round of the 6A playoffs, where the Lions were in a slugfest with Highland. Liberty was holding on to a 12-7 advantage with six minutes to play before the Hawks rallied with the go-ahead score. A long field goal at the end would have knotted the score, but the Lions' season ended with a 15-12 defeat.</p><p>Yes, they would have had two (maybe three) more games to play to cap "perfection", but the fact remains - Two losses by a total of four points.<br></p><p>They were similar results to the 2017 season, when Liberty was in 5A and went 11-2 losing by just three and five points to city rivals Sunrise Mountain and Centennial, respectively.</p><p>There's a lot of programs in the state that would be thrilled with winning records (which Liberty has had in nine of the past 10 seasons) and playoff wins (of which the Lions have 10 during that span). But, that's not what Mark Smith wants his team to settle for.</p><p>The mantra for this year is L.N.D. It stands for Leave No Doubt. The heartbreaking November losses the past two seasons are motivation for Liberty's second year in 6A. It's also a team that should remember them well, because they were there. A photo of the Lions' seniors at Camp Tontozona in Payson last month shows 40 seniors.</p><p>"I like that we have a lot of seniors," Smith, who is starting his fifth year at the helm, said. "There's some good senior leadership. Anytime you can start a returning quarterback and an offensive line that returns all five, that's a good reason to be excited."</p><p><b>Jonah Guevara</b> returns at the QB position, where he passed for 1,557 yards and 11 touchdowns in nine games. A 6-2, 165-pound senior dual threat, he rushed for 466 yards (7.6 yards per carry) and nine touchdowns.</p><p>"He's electric with his legs," Smith said. "He's a strider. He can make all the throws we need him to make."</p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/he2edhr1rnxmko7zpdk3','https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto/he2edhr1rnxmko7zpdk3')">
<div class='image-container'>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img class="image-with-caption" src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/he2edhr1rnxmko7zpdk3" alt="He2edhr1rnxmko7zpdk3" />
<div class='zoom-image'></div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>Liberty QB Jonah Guevara gets ready to take the snap out of shotgun in a road game from last year.  He was busy during track season last spring competing in the 200, 400, 4x100 relay, and 4x400 relay.  (Photo by Ralph Amsden)</figcaption>
</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Liberty's offense was as balanced as you could possibly have last year. The Lions amassed 2,351 yards on the ground and 2,336 through the air (390 total yards/game).</p><p>And the Lions don't just return one QB, they bring back two. Junior <b>Brock Mast</b> threw passes in seven games, including three starts late in the year when Guevara was injured. In those three games, Mast completed 76 percent of his passes for 648 yards and eight TDs. LHS also took the W in each of them.</p><p>It's at the other skill positions that newcomers will have to emerge for the Lions to pile up points like they did last year (38.5 ppg). The top three running backs have graduated along with the top four receivers.</p><p>Liberty runs a multiple spread offense and the stable of running backs includes <b>Jace Accurso</b>, <b>Joe Forney</b>, and <b>Isaiah Pittman</b>. At wide receiver, <b>Jaiden Pina</b> and <b>Gavin Guy</b> are both seniors and should see many more opportunities than last year, when they were backups.</p><p>In the NFL, offensive lines that stay together develop a consistency from working together. It's rare for it to happen in high school, but the Lions bring back all five starters from last year and they're all seniors. Tackles <b>Temoc Sandoval</b> and <b>Jared Crean</b> combine with guards <a href="https://n.rivals.com/content/prospects/2020/frank-thompson-211825">Frank Thompson</a> (an Arizona State commit) and <b>Vincente Maestas</b> along with center <b>Brian Dean</b> to make an experienced formidable unit.</p><p>That group, along with the defensive linemen, flexed their muscles in May and June bringing home first place trophies in all five competitions against fellow schools. Liberty took the Corey Peters lineman challenge, plus big man competitions at Arizona Christian, Arizona State, and Northern Arizona, along with the 30-team West Side Universal Athletic big man.</p><p>"Our offensive line coach (Shawn Gloden) has been in our program for a full year," Smith said. "These kids have bought in. Our strength coach and defensive line coach (Brian Cherry) does an excellent job in the weight room. Our kids are physical and strong."</p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Business trip with the boys 🥇 <a href="https://t.co/8XRfB6BgtD">pic.twitter.com/8XRfB6BgtD</a></p>&mdash; Frank Thompson #57 (@57FrankThompson) <a href="https://twitter.com/57FrankThompson/status/1129958859898904576?ref_src=twsrc%5Etfw">May 19, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>The Lions use an odd front with a 3-4 defense. Liberty has returning players at all three levels of the D.</p><p>Senior nose guard <b>Grant Collins</b> had five sacks last season. Pittman and Accurso are also defensive players at linebacker. Accurso had 60 tackles for the Lions with 3.5 sacks. <b>Jax Stam</b> had tackles in 11 games as a freshman last year. In addition to his 59 tackles, the safety had three interceptions.</p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">The FROSH tries to steal the show on Senior Night for the <a href="https://twitter.com/LibertyFBLions?ref_src=twsrc%5Etfw">@LibertyFBLions</a> 🏈! An INT and part of the game-winning sack for <a href="https://twitter.com/JaxStam?ref_src=twsrc%5Etfw">@JaxStam</a> in the 24-21 win over Sandra Day O&#39;Connor! <a href="https://twitter.com/hashtag/AZHSFB?src=hash&amp;ref_src=twsrc%5Etfw">#AZHSFB</a> <a href="https://twitter.com/hashtag/PeoriaLibertyLions?src=hash&amp;ref_src=twsrc%5Etfw">#PeoriaLibertyLions</a> 🦁 <a href="https://t.co/EIPp4PF1Se">pic.twitter.com/EIPp4PF1Se</a></p>&mdash; Devon Henry (@devonhenry77) <a href="https://twitter.com/devonhenry77/status/1053712753049784320?ref_src=twsrc%5Etfw">October 20, 2018</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Last Friday brought Liberty's annual Black and Red scrimmage. That will be followed this Thursday night with a scrimmage at home against Basha (7 pm).</p><p>Much like NFL exhibitions, it's a chance to provide reps for players, evaluate position battles, and see how they react before the lights get brighter.</p><p>"When you play your own team, you want to see execution and everybody get out of there healthy," Smith said. "This week (against Basha), it's to see how we match up physically."</p><p>The schedule includes seven playoff teams, including a trip to Las Vegas to face Liberty (the one that beat Saguaro last year). It starts with Brophy on Aug. 23 at Phoenix College, and continues with games against Sunrise Mountain, Desert Ridge, Boulder Creek, Pinnacle, and Chaparral. The season-ender against Chaparral will be broadcasted by YurView Arizona on Nov. 1.</p><p>It's a lot to contend with, but Smith said he is solely focused on "the next game", which is against Brophy. Last year, calling it a defensive battle would be an understatement. Liberty defeated the Broncos, 7-0.</p><p>One area the Lions would like to duplicate is in the turnover battle. Liberty was +16 overall with 28 takeaways (20 interceptions and eight fumbles). It is along those lines that Smith said the team needs to execute to have both offensive and defensive success in 2019.</p><p>"You've got to take care of the football and you've got to get the drive started," Smith said. "On defense, you want to take the ball away and get off the field."</p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Healthy looking program <a href="https://t.co/bBJgNK37Nf">pic.twitter.com/bBJgNK37Nf</a></p>&mdash; LibertyLionsFootball (@LibertyFBLions) <a href="https://twitter.com/LibertyFBLions/status/1156757347902976000?ref_src=twsrc%5Etfw">August 1, 2019</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://arizonavarsity.rivals.com/news/physical-lions-bring-experience-in-trenches/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' scoreboard-photos-id='15082' scoreboard-scores-id='15081' site='{"id":6,"legacy_id":1128,"name":"ArizonaVarsity","friendly_name":"Arizona HS Sports","annual_discount":null,"subdomain":"arizonavarsity","primary_color":"000000","secondary_color":"edbe00","font_color":"ffffff","short_name":"arizonavarsity","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81764304-1"}' twitter-feed='{"id":6,"site_id":6,"handle":"azhsfb","list_name":"Arizona-Varsity","created_at":"2016-02-01T12:24:39.964-06:00","updated_at":"2018-08-16T01:52:12.473-05:00","hashtags":[],"usernames":["AZHSFB","ArizonaVarsity","GreggRosenberg1"],"max_number":5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://arizonavarsity.rivals.com/news/physical-lions-bring-experience-in-trenches/printable' site-name='ArizonaVarsity'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719646', 'https://arizonavarsity.rivals.com/news/physical-lions-bring-experience-in-trenches');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Physical Lions bring experience at QB & OL";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("arizonavarsity", 2067782, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
</div>

</div>
</main>
<footer>
<!-- t('footer.about_link', primary_host: primary_host) -->
<ul class='footer-links list-inline'>
<li>
<a href='/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='/news/member-services'>Help</a>
</li>
</ul>
<div class='logo-container'>
<div class='footer-logo'></div>
</div>
<div class='copyright-notice'>Certain data provided by STATS, LLC<br/>© 2019 Verizon Media. All rights reserved.</div>
</footer>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719646",
    c7: "https://arizonavarsity.rivals.com/news/physical-lions-bring-experience-in-trenches"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Farizonavarsity.rivals.com%2Fnews%2Fphysical-lions-bring-experience-in-trenches&c5=2022719646&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
